Funções e fórmulas

Função SOMA

Função SOMA

Observação: Desejamos fornecer o conteúdo da Ajuda mais recente no seu idioma da forma mais rápida possível. Esta página foi traduzida de forma automatizada e pode conter imprecisões ou erros gramaticais. Nosso objetivo é que este conteúdo seja útil para você. As informações foram úteis? Dê sua opinião no final desta página. Aqui está o artigo em inglês para facilitar a referência.

A função SOMA, uma das funções de matemática e trigonometria, adiciona valores. É possível adicionar valores individuais, referências de célula ou intervalos, ou uma mistura dos três.

Por exemplo:

  • =SOMA(A2:A10)

  • =SOMA(A2:A10;C2:C10)

Seu navegador não oferece suporte a vídeo. Instale o Microsoft Silverlight, o Adobe Flash Player ou o Internet Explorer 9.

SOMA(número1;[número2];...)

Nome do argumento

Descrição

número1    (Obrigatório)

O primeiro número que você deseja somar. O número pode ser como “4”, uma referência de célula, como B6, ou um intervalo de células, como B2:B8.

número2-255    (opcional)

Este é o segundo número que você deseja somar. Você pode especificar até 255 números adicionais dessa maneira.

Esta seção abordará algumas práticas recomendadas para trabalhar com a função soma. Grande parte disso pode ser aplicada ao trabalho com outras funções também.

Método =1+2 ou =A+B – Embora seja possível inserir =1+2+3 ou =A1+B1+C2 e obter resultados totalmente precisos, esses métodos estão sujeitos a erros por vários motivos:

  1. Erros de digitação – Imagine tentar inserir mais valores e/ou valores maiores, desta forma:

    • =14598,93+65437,90+78496,23

    Em seguida, tente validar se as suas entradas estão corretas. É muito mais fácil colocar esses valores em células individuais e usar uma fórmula de soma. Além disso, você pode formatar os valores quando eles estiverem nas células, tornando-os muito mais legíveis quando estiverem em uma fórmula.

    Use a função SOMA em vez de embutir valores em fórmulas.  A fórmula na célula D5 é =SOMA(D2:D4)
  2. Erros #VALOR! de referência de texto em vez de números

    Se você usar uma fórmula como:

    • =A1+B1+C1 ou =A1+A2+A3

    Exemplo de uma construção de fórmula ruim.  A fórmula na célula D2 é =A2+B2+C2

    Sua fórmula pode quebrar se houver qualquer valor não numérico (texto) nas células referidas, o que retornará um #VALUE! Error. SOMA ignorará valores de texto e oferecerá a soma dos valores numéricos apenas.

    Construção de fórmula adequada.  Em vez de =A2+B2+C2, a fórmula da célula D2 fórmula é =SOMA(A2:C2)
  3. Erro #REF! de exclusão de linhas ou colunas

    Erro #REF! causado pela exclusão de uma coluna  A fórmula mudou para =A2+#REF!+B2

    Se você excluir uma linha ou coluna, a fórmula não será atualizada para excluir a linha excluída e retornará um erro #REF!, em que uma função SOMA será atualizada automaticamente.

    A função SOMA se ajusta automaticamente a colunas e linhas inseridas ou excluídas
  4. As fórmulas não atualizarão referências ao inserir linhas ou colunas

    As fórmulas =A+B+C não serão atualizadas se você adicionar linhas

    Se você inserir uma linha ou coluna, a fórmula não será atualizada para incluir a linha adicionada, onde uma função soma será atualizada automaticamente (desde que você não esteja fora do intervalo referenciado na fórmula). Isso é especialmente importante se você espera que sua fórmula atualize e ela não, pois ela deixará você com resultados incompletos que você não consiga capturar.

    O exemplo retrata uma fórmula de SOMA expandindo automaticamente de =SOMA(A2:C2) para =SOMA(A2:D2) quando uma coluna foi inserida
  5. SOMA com Referências de célula individuais versus Intervalos

    Usando uma fórmula como:

    • =SOMA(A1;A2;A3;B1;B2;B3)

    É igualmente vulnerável ao inserir ou excluir linhas dentro do intervalo referenciado pelas mesmas razões. É muito melhor usar intervalos individuais, como:

    • =SOMA(A1:A3;B1:B3)

    Que serão atualizados ao adicionar ou excluir linhas.

Problema

O que deu errado

Minha função SOMA mostra #####, mas não o resultado.

Verifique as larguras de coluna. # # # # normalmente significa que a coluna é muito estreita para exibir o resultado da fórmula.

Minha função SOMA mostra a fórmula em si como texto, mas não o resultado.

Verifique se a célula não está formatada como texto. Selecione a célula ou intervalo em questão e use Ctrl + 1 para exibir a caixa de diálogo Formatar células , clique na guia número e selecione o formato desejado. Se a célula tiver sido formatada como texto e não mudar depois que você alterar o formato, talvez seja necessário usar F2 _GT_ Enter para forçar a alteração da formatação.

Minha função SOMA não atualiza.

Certifique-se de que o cálculo esteja definido como automático. Na guia fórmula , acesse Opções de cálculo. Você também pode usar F9 para forçar a cálculo da planilha.

Verifique se definiu o cálculo como Automático.  Na guia Fórmulas, vá para Opções de Cálculo.

Alguns valores não são adicionados.

Somente os valores numéricos no intervalo ou na referência são adicionados. Células vazias e valores lógicos, como VERDADEIRO, ou texto são ignorados.

O erro #NOME? em vez do resultado previsto.

Normalmente, isso significa que a fórmula foi digitada incorretamente, como =soma(A1:A10), em vez de =SOMA(A1:A10).

Minha função SOMA mostra um número inteiro, mas deveria mostrar decimais

Verifique a formatação da célula para garantir que está exibindo decimais. Escolha a célula ou o intervalo em questão e use o comando Ctrl+1 para exibir a caixa de diálogo Formatar Células. Em seguida, clique na guia Número, escolha o formato desejado e lembre-se de indicar o número de casas decimais que deseja.

  1. Eu quero somar/subtrair/multiplicar/dividir números. Assista a esta série de vídeos sobre Matemática básica no Excel ou Usar o Excel como calculadora.

  2. Como faço para exibir mais ou menos casas decimais? Você pode mudar a formatação do número. Escolha a célula ou o intervalo em questão e use o comando Ctrl+1 para exibir a caixa de diálogo Formatar Células. Em seguida, clique na guia Número, escolha o formato desejado e lembre-se de indicar o número de casas decimais que deseja.

  3. Como faço para adicionar ou subtrair horas? Você pode adicionar e subtrair horas de modos diferentes. Por exemplo, para obter a diferença entre 8:00 e 12:00 para motivos de pagamentos, você usaria: =("12:00 PM"-"8:00 AM")*24, fazendo a subtração da hora de início da hora de término. Observe que o Excel calcula as horas como uma fração do dia, portanto, é preciso multiplicar por 24 para obter o total de horas. No primeiro exemplo, usamos =((B2-A2)+(D2-C2))*24 para obter a soma das horas do início ao fim, menos uma pausa para o almoço (8h50 no total).

    Se você está somente adicionando horas e minutos e gostaria de exibi-los dessa forma, pode somar e não precisa multiplicar por 24. Assim, no segundo exemplo, usamos =SUM(A6:C6), já que precisamos apenas do número total de horas e minutos para tarefas atribuídas (5:36 ou 5 horas e 36 minutos).

    Calculando horas

    Para obter mais informações, consulte: Adicionar ou subtrair horários.

  4. Como obtenho a diferença entre as datas? Como com horas, você pode adicionar e subtrair datas. Aqui está um exemplo muito comum de contar o número de dias entre duas datas. É tão simples quanto = B2-a2. A chave para trabalhar com datas e horas é que você começa com a data/hora de término e subtraia a data/hora de início.

    Calculando as diferenças entre datas

    Para obter mais formas de trabalhar com datas, consulte: calcular a diferença entre duas datas.

  5. Como faço para somar somente células visíveis? Às vezes, quando você oculta linhas manualmente ou usa o Filtro Automático para exibir somente determinados dados, também recomendamos somar as células visíveis. Você pode usar a função SUBTOTAL Se você está usando uma linha de totais na tabela do Excel, qualquer função que selecionar da lista suspensa Total será inserida automaticamente como um subtotal. Veja mais sobre como obter o Total dos dados de uma tabela do Excel.

Precisa de mais ajuda?

Você pode sempre consultar um especialista na Excel Tech Community, obter suporte na Comunidade de respostas ou sugerir um novo recurso ou melhoria no User Voice do Excel.

Confira também

Saiba mais sobre a soma

A função SOMASE soma apenas os valores que atendem a um único critério

A função SOMASES soma apenas os valores que atendem a vários critérios

A função CONT.SE conta apenas os valores que atendem a um único critério

A função CONT.SES conta apenas os valores que atendem a vários critérios

Visão geral de fórmulas no Excel

Como evitar fórmulas quebradas

Localizar e corrigir erros em fórmulas

Atalhos de teclado no Excel para Windows

Atalhos de teclado no Excel para Mac

Funções de Matemática e Trigonometria

Funções do Excel (ordem alfabética)

Funções do Excel (por Categoria)

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×