Funções e fórmulas

Função SE

Função SE

Observação: Desejamos fornecer o conteúdo da Ajuda mais recente no seu idioma da forma mais rápida possível. Esta página foi traduzida de forma automatizada e pode conter imprecisões ou erros gramaticais. Nosso objetivo é que este conteúdo seja útil para você. As informações foram úteis? Dê sua opinião no final desta página. Aqui está o artigo em inglês para facilitar a referência.

A função se é uma das funções mais populares no Excel e permite fazer comparações lógicas entre um valor e o que você espera.

Portanto, uma instrução se pode ter dois resultados. O primeiro resultado é se a comparação for verdadeira, a segunda se sua comparação for falsa.

Por exemplo, =SE(C2="Sim";1;2) descreve SE(C2 = Sim retornar 1, caso contrário retornar 2).

Seu navegador não oferece suporte a vídeo. Instale o Microsoft Silverlight, o Adobe Flash Player ou o Internet Explorer 9.

Use a função SE, uma das funções lógicas, para retornar um valor se uma condição for verdadeira e um outro valor se for falsa.

SE(teste_lógico, valor_se_verdadeiro, [valor_se_falso])

Por exemplo:

  • =SE(A2>B2,"Acima do orçamento","OK")

  • =SE(A2=B2;B4-A4;"")

Nome do argumento

Descrição

teste_lógico    (obrigatório)

A condição que você deseja testar.

valor_se_verdadeiro    (obrigatório)

O valor que você deseja retornar se o resultado do teste_lógico for VERDADEIRO.

valor_se_falso    (opcional)

O valor que você deseja retornar se o resultado do teste_lógico for FALSO.

Exemplos de SE simples

A célula D2 contém a fórmula =SE(C2="Sim";1;2)
  • =SE(C2="Sim";1,2)

No exemplo acima, a célula D2 diz: SE(C2 = Sim, a fórmula retorna um 1 ou um 2)

A célula D2 contém a fórmula =SE(C2=1;"SIM";"NÃO")
  • =SE(C2=1;"Sim";"Não")

Neste exemplo, a fórmula na célula D2 diz: se (C2 = 1, em seguida, Return Sim; caso contrário, retornando não)como você vê, a função se pode ser usada para avaliar o texto e os valores. Ele também pode ser usado para avaliar erros. Você não está limitado a verificar apenas se uma coisa é igual a outro e retornando um único resultado, você também pode usar operadores matemáticos e executar cálculos adicionais dependendo dos seus critérios. Você também pode aninhar várias funções se juntas para realizar várias comparações.

A fórmula na célula D2 é =SE(C2>B2;"Acima do orçamento";"Dentro do orçamento")
  • =SE(C2>B2;"Acima do orçamento";"Dentro do orçamento")

No exemplo acima, a função SE em D2 está dizendo SE(C2 é maior que B2, retorne "Acima do orçamento", caso contrário, retorne "Dentro do orçamento")

A fórmula na célula E2 é =SE(C2>B2;C2-B2;"")
  • =SE(C2>B2;C2-B2;0)

Na ilustração acima, em vez de retornar um resultado de texto, vamos retornar um cálculo matemático. Para que a fórmula em E2 esteja dizendo se (real é maior do que o orçado, subtraia o valor orçado do valor real; caso contrário, retorne Nothing).

A fórmula na célula F7 é SE(E7="Sim";F5*0,0825;0)
  • =SE(E7="Sim";F5*0,0825;0)

Neste exemplo, a fórmula em F7 está dizendo SE(E7="Sim", calcule o Valor Total em F5 * 8,25%, caso contrário, nenhum Imposto sobre Vendas é cobrado, retorne 0)

Observação: Se você pretende usar texto em fórmulas, será necessário encapsular o texto entre aspas (por exemplo, "texto"). A única exceção que está usando verdadeiro ou falso, que o Excel reconhece automaticamente.

Problemas comuns

Problema

O que aconteceu de errado

0 (zero) na célula

Não havia um argumento para os argumentos valor_se_verdadeiro ou valor_se_falso. Para receber o valor correto, adicione um texto de argumento aos dois argumentos, ou adicione VERDADEIRO ou FALSO ao argumento.

#NOME? na célula

Isso geralmente significa que a fórmula está incorreta.

Precisa de mais ajuda?

Você pode sempre consultar um especialista na Excel Tech Community, obter suporte na Comunidade de respostas ou sugerir um novo recurso ou melhoria no User Voice do Excel.

Consulte Também

Operadores de cálculo e precedência no Excel

Usar funções aninhadas em uma fórmula

Usando se para verificar se uma célula está em branco

Usando se para verificar se uma célula está em branco

Vídeo: funções se avançadas

Função IFS (Office 365, Excel 2016 e posterior)

Funções se avançadas – trabalhando com fórmulas aninhadas e evitando armadilhas

Vídeos de treinamento: funções se avançadas

A função CONT.se irá contar valores com base em um único critério

A função CONT. ses irá contar valores com base em vários critérios

A função SOMASE soma valores com base em um único critério

A função SOMASES somará valores com base em vários critérios

Função e

Função or

Função PROCV

Visão geral de fórmulas no Excel

Como evitar fórmulas quebradas

Usar a verificação de erros para detectar erros em fórmulas

Funções lógicas

Funções do Excel (ordem alfabética)

Funções do Excel (por categoria)

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×