Definir e resolver um problema usando o Solver

Observação: Desejamos fornecer o conteúdo da Ajuda mais recente no seu idioma da forma mais rápida possível. Esta página foi traduzida de forma automatizada e pode conter imprecisões ou erros gramaticais. Nosso objetivo é que este conteúdo seja útil para você. As informações foram úteis? Dê sua opinião no final desta página. Aqui está o artigo em inglês para facilitar a referência.

O Solver é um suplemento do Microsoft Excel que você pode usar para teste de hipóteses. Use o Solver para encontrar um valor ideal (máximo ou mínimo) para uma fórmula em uma célula — conforme restrições, ou limites, sobre os valores de outras células de fórmula em uma planilha. O Solver trabalha com um grupo de células, chamadas variáveis de decisão ou simplesmente de células variáveis, usadas no cálculo das fórmulas nas células de objetivo e de restrição. O Solver ajusta os valores nas células variáveis de decisão para satisfazer aos limites sobre células de restrição e produzir o resultado que você deseja para a célula objetiva. 

Resumindo, você pode usar o Solver para determinar o valor máximo ou mínimo de uma célula alterando outras células. Por exemplo, você pode alterar a quantia do seu orçamento publicitário projetado e ver o efeito sobre a quantia de lucro projetado.

Observação: As versões do Solver anteriores ao Excel 2007 se referiam à célula de objetivo como a "célula de destino" e às células variáveis de decisão como "células variáveis" ou "células ajustáveis". Muitos aprimoramentos foram feitos no suplemento Solver para o Excel 2010, portanto, se você estiver usando o Excel 2007, sua experiência será um pouco diferente.

No exemplo a seguir, o nível de publicidade em cada trimestre afeta o número de unidades vendidas, determinando indiretamente o valor da receita de vendas, as despesas associadas e o lucro. O Solver pode alterar os orçamentos trimestrais para publicidade (células variáveis de decisão B5:C5), até uma restrição total de R$ 20.000,00 (célula F5), até que o lucro total (célula de objetivo F7) alcance o valor máximo possível. Os valores nas células variáveis são usados para calcular o lucro de cada trimestre, de modo que eles sejam relatados na célula de objetivo de fórmula F7, =SOMA (Lucro T1:Lucro T2).

Antes da avaliação do Solver

1. Células variáveis

2. Célula restrita

3. Célula de objetivo

Após a execução do Solver, os novos valores serão os seguintes.

Depois da avaliação do Solver

  1. Na guia Dados, no grupo Análise, clique em Solver.
    Imagem da Faixa de Opções do Excel

    Observação: Se o comando Solver ou o grupo Análise não estiver disponível, será necessário ativar o Solversuplemento. Consulte: Como ativar o suplemento Solver.

    Imagem da caixa de diálogo Excel 2010+ Solver
  2. Na caixa Definir Objetivo, digite uma referência de célula ou um nome para a célula de objetivo, a qual deve conter uma fórmula.

  3. Siga um destes procedimentos:

    • Se você deseja que o valor da célula de objetivo seja o maior possível, clique em Máx.

    • Se você deseja que o valor da célula de objetivo seja o menor possível, clique em Mín.

    • Se você deseja a célula de objetivo tenha um determinado valor, clique em Valor de e digite o valor na caixa.

    • Na caixa Alterando Células Variáveis, insira um nome ou uma referência para cada intervalo de células variáveis de decisão. Separe as referências não adjacentes por vírgula. As células variáveis devem estar relacionadas direta ou indiretamente à célula de objetivo. Você pode especificar até 200 células variáveis.

  4. Na caixa Sujeito às Restrições, insira as restrições que você deseja aplicar, procedendo da seguinte forma:

    1. Na caixa de diálogo Parâmetros do Solver, clique em Adicionar.

    2. Na caixa Referência de Célula, insira a referência de célula ou o nome do intervalo de células cujo valor você deseja restringir.

    3. Clique na relação ( <=, =, >=, int, bin ou dif ) desejada entre a célula referenciada e a restrição. Se você clicar em int, inteiro aparecerá na caixa Restrição. Se você clicar em bin, binário aparecerá na caixa Restrição. Se você clicar em dif, tudodiferente aparecerá na caixa Restrição.

    4. Se você escolher <=, = ou >= para a relação na caixa Restrição, digite um número, uma referência ou um nome de célula ou uma fórmula.

    5. Siga um destes procedimentos:

      • Para aceitar a restrição e adicionar uma outra, clique em Adicionar.

      • Para aceitar a restrição e retornar à caixa de diálogo parâmetro do Solver, clique em OK.
        Observação    você pode aplicar as relações int, bin e dif somente em restrições em células variáveis de decisão.

        Você pode alterar ou excluir uma restrição existente da seguinte forma:

    6. Na caixa de diálogo Parâmetros do Solver, clique na restrição que deseja alterar ou excluir.

    7. Clique em Alterar e, em seguida, faça as alterações ou clique em Excluir.

  5. Clique em Solucionar e siga um destes procedimentos:

    • Para que os valores das soluções sejam mantidos na planilha, na caixa de diálogo Resultados do Solver, clique em Manter Solução do Solver.

    • Para restaurar os valores originais antes de ter clicado em Resolver, clique em Restaurar Valores Originais.

    • Você pode interromper o processo de solução pressionando Esc. O Excel recalculará a planilha com os últimos valores encontrados para as células das variáveis de decisão.

    • Para criar um relatório baseado na sua solução depois que o Solver identificar uma solução, clique no tipo de relatório na caixa Relatórios e clique em OK. O relatório será criado em uma nova planilha em sua pasta de trabalho. Se o Solver não encontrar uma solução, somente alguns relatórios ou nenhum estarão disponíveis.

    • Para salvar os valores de células variáveis de decisão como um cenário que você poderá exibir mais tarde, clique em Salvar Cenário na caixa de diálogo Resultados do Solver e digite um nome para o cenário na caixa Nome do Cenário.

  1. Após definir um problema, clique em Opções na caixa de diálogo Parâmetros do Solver.

  2. Na caixa de diálogo Opções, marque a caixa de seleção Mostrar Resultados de Iteração para exibir os valores de cada tentativa de solução e clique em OK.

  3. Na caixa de diálogo Parâmetros do Solver, clique em Solucionar.

  4. Na caixa de diálogo Mostrar Solução de Avaliação, siga um destes procedimentos:

    • Para interromper o processo de solução e exibir a caixa de diálogo Resultados do Solver, clique em Parar.

    • Para continuar com o processo de solução e exibir a próxima tentativa de solução, clique em Continuar.

  1. Na caixa de diálogo Parâmetros do Solver, clique em Opções.

  2. Escolha ou insira valores para qualquer opção nas guias Todos os Métodos, GRG Não Linear e Evolucionário na caixa de diálogo.

  1. Na caixa de diálogo Parâmetros do Solver, clique em Carregar/Salvar.

  2. Insira um intervalo de células para a área de modelo e clique em Salvar ou Carregar.

    Ao salvar um modelo, insira a referência para a primeira célula de um intervalo vertical de células vazias no qual você deseja colocar o modelo de problema. Ao carregar um modelo, insira a referência do intervalo inteiro de células que contém o modelo do problema.

    Dica: Você pode salvar as últimas seleções na caixa de diálogo parâmetros do Solver com uma planilha salvando a pasta de trabalho. Cada planilha em uma pasta de trabalho pode ter suas próprias seleções do Solver, e todas elas são salvas. Você também pode definir mais de um problema para uma planilha clicando em carregar/salvar para salvar problemas individualmente.

Você pode escolher qualquer um dos três seguintes algoritmos ou métodos de solução na caixa de diálogo Parâmetros do Solver:

  • Gradiente Reduzido Generalizado (GRG) Não Linear    Use para problemas simples não lineares.

  • LP Simplex    Use para problemas lineares.

  • Evolucionário    Use para problemas complexos.

Importante: Você deve habilitar o suplemento Solver primeiro. Para obter mais informações, consulte carregar o suplemento Solver.

No exemplo a seguir, o nível de publicidade em cada trimestre afeta o número de unidades vendidas, determinando indiretamente o valor da receita das vendas, das despesas associadas e do lucro. O Solver pode alterar os orçamentos trimestrais para anúncios (células variáveis de decisão B5: C5), até uma restrição de orçamento total de $20000 (célula D5), até que o lucro total (célula do objetivo D7) atinja o valor máximo possível. Os valores nas células variáveis são usados para calcular o lucro de cada trimestre, para que eles sejam relacionados à célula de objetivo da fórmula D7, = soma (lucro de T1: lucro do T2).

Avaliação do Solver de exemplo

Texto explicativo 1 Células variáveis

Texto explicativo 2 Célula restrita

Texto explicativo 3  Célula de objetivo

Após a execução do Solver, os novos valores serão os seguintes.

Avaliação do Exemplo de Resolução com novos valores

  1. No Excel 2016 para Mac: clique em Data > Solver.

    Solver

    No Excel para Mac 2011: clique na guia dados, em análise, clique em Solver.

    Guia Dados, grupo Análise, Suplemento Solver

  2. Em definir objetivo, insira um referência de célula ou um nome para a célula do objetivo.

    Observação: A célula do objetivo deve conter uma fórmula.

  3. Siga um destes procedimentos:

    Para

    Faça isto

    Tornar o valor da célula de objetivo o mais grande possível

    Clique em Max.

    Tornar o valor da célula de objetivo o menor possível

    Clique em mínimo.

    Definir a célula de objetivo como um determinado valor

    Clique em valor de e digite o valor na caixa.

  4. Na caixa alteraNdo células variáveis, insira um nome ou referência para cada intervalo de células variáveis de decisão. Separe as referências não adjacentes com vírgulas.

    As células variáveis devem estar relacionadas direta ou indiretamente à célula do objetivo. Você pode especificar até 200 células variáveis.

  5. Na caixa sujeito às restrições, adicione as restrições que você deseja aplicar.

    Para adicionar uma restrição, siga estas etapas:

    1. Na caixa de diálogo Parâmetros do Solver, clique em Adicionar.

    2. Na caixa Referência de Célula, insira a referência de célula ou o nome do intervalo de células cujo valor você deseja restringir.

    3. No menu pop-up de < = relação, selecione a relação desejada entre a célula referenciada e a restrição. Se você escolher < =, = ou > =, na caixa restrição, digite um número, uma referência de célula ou um nome ou uma fórmula.

      Observação: Você só pode aplicar as relações int, bin e dif em restrições às células variáveis de decisão.

    4. Siga um destes procedimentos:

    Para

    Faça isto

    Aceitar a restrição e adicionar outra

    Clique em Adicionar.

    Aceitar a restrição e retornar à caixa de diálogo parâmetros do Solver

    Clique em OK.

  6. Clique em resolver e siga um destes procedimentos:

    Para

    Faça isto

    Manter os valores da solução na planilha

    Clique em manter solução do Solver na caixa de diálogo resultados do Solver.

    Restaurar os dados originais

    Clique em restaurar valores originais.

Observações: 

  1. Para interromper o processo de solução, pressione ESC. O Excel recalcula a planilha com os últimos valores encontrados para as células ajustáveis.

  2. Para criar um relatório com base em sua solução após o Solver encontrar uma solução, você pode clicar em um tipo de relatório na caixa relatórios e, em seguida, clicar em OK. O relatório é criado em uma nova planilha na pasta de trabalho. Se o Solver não encontrar uma solução, a opção para criar um relatório ficará indisponível.

  3. Para salvar os valores de células de ajuste como um cenário que você pode exibir posteriormente, clique em salvar cenário na caixa de diálogo resultados do Solver e digite um nome para o cenário na caixa nome do cenário.

  1. No Excel 2016 para Mac: clique em Data > Solver.

    Solver

    No Excel para Mac 2011: clique na guia dados, em análise, clique em Solver.

    Guia Dados, grupo Análise, Suplemento Solver

  2. Depois de definir um problema, na caixa de diálogo parâmetros do Solver, clique em Opções.

  3. Marque a caixa de seleção Mostrar resultados de iteração para ver os valores de cada solução de avaliação e clique em OK.

  4. Na caixa de diálogo Parâmetros do Solver, clique em Solucionar.

  5. Na caixa de diálogo Mostrar solução de avaliação, siga um destes procedimentos:

    Para

    Faça isto

    Parar o processo de solução e exibir a caixa de diálogo resultados do Solver

    Clique em parar.

    Continuar o processo de solução e exibir a próxima solução de avaliação

    Clique em Continuar.

  1. No Excel 2016 para Mac: clique em Data > Solver.

    Solver

    No Excel para Mac 2011: clique na guia dados, em análise, clique em Solver.

    Guia Dados, grupo Análise, Suplemento Solver

  2. Clique em Opções e, na caixa de diálogo Opções ou Opções do Solver, escolha uma ou mais das seguintes opções:

    Para

    Faça isto

    Definir o tempo e as iterações da solução

    Na guia todos os métodos, em solucionar limites, na caixa tempo máximo (segundos), digite o número de segundos que você deseja permitir para o tempo de solução. Em seguida, na caixa iterações, digite o número máximo de iterações que você deseja permitir.

    Observação: Se o processo da solução atingir o tempo máximo ou o número de iterações antes de o Solver encontrar uma solução, o Solver exibirá a caixa de diálogo Mostrar solução de avaliação.

    Definir o grau de precisão

    Na guia todos os métodos, na caixa precisão da restrição, digite o grau de precisão desejado. Quanto menor for o número, maior será a precisão.

    Definir o grau de convergência

    Na guia não linear ou evolucionário, na caixa convergência, digite a quantidade de alterações relativas que você deseja permitir nas cinco últimas iterações antes de o Solver parar com uma solução. Quanto menor o número, menor alteração relativa é permitida.

  3. Clique em OK.

  4. Na caixa de diálogo parâmetros do Solver, clique em resolução ou Fechar.

  1. No Excel 2016 para Mac: clique em Data > Solver.

    Solver

    No Excel para Mac 2011: clique na guia dados, em análise, clique em Solver.

    Guia Dados, grupo Análise, Suplemento Solver

  2. Clique em carregar/salvar, insira um intervalo de células para a área do modelo e clique em salvar ou carregar.

    Ao salvar um modelo, insira a referência para a primeira célula de um intervalo vertical de células vazias no qual você deseja colocar o modelo de problema. Ao carregar um modelo, insira a referência do intervalo inteiro de células que contém o modelo do problema.

    Dica: Você pode salvar as últimas seleções na caixa de diálogo parâmetros do Solver com uma planilha salvando a pasta de trabalho. Cada planilha em uma pasta de trabalho pode ter suas próprias seleções do Solver, e todas elas são salvas. Você também pode definir mais de um problema para uma planilha clicando em carregar/salvar para salvar problemas individualmente.

  1. No Excel 2016 para Mac: clique em Data > Solver.

    Solver

    No Excel para Mac 2011: clique na guia dados, em análise, clique em Solver.

    Guia Dados, grupo Análise, Suplemento Solver

  2. No menu pop-up selecionar um método de solução, selecione uma das seguintes opções:

Método de solução

Descrição

GRG (gradiente reduzido generalizado) não linear

A opção padrão, para modelos que usam a maioria das funções do Excel, exceto se, pesquisa e outras funções de "etapa".

LP do simplex

Use esse método para problemas de programação linear. Seu modelo deve usar soma, SOMARPRODUTO, + e * em fórmulas que dependem das células variáveis.

Evolucionário

Esse método, com base em algoritmos genéticos, é melhor quando seu modelo usa se, escolhe ou pesquisa com argumentos que dependem das células variáveis.

Observação: Partes do código do programa Solver são direitos autorais 1990-2010 pela Frontline Systems, Inc. as partes são direitos autorais 1989 por métodos ideais, Inc.

Mais ajuda sobre como usar o Solver

Para obter ajuda mais detalhada sobre o Solver, entre em contato com:

Frontline Systems, Inc.
Caixa postal 4288
Inclinar Village, NV 89450-4288
(775) 831-0300
Site da Web:
http://www.Solver.com email: ajuda
do info@solver.comsolver em www.solver.com.

Partes do código do programa Solver tiveram seus direitos autorais registrados em 1990 a 2009 pela Frontline Systems, Inc. Outras partes foram registradas em 1989 pela Optimal Methods, Inc.

Precisa de mais ajuda?

Você pode sempre consultar um especialista na Excel Tech Community, obter suporte na Comunidade de respostas ou sugerir um novo recurso ou melhoria no User Voice do Excel.

Confira também

Usando o Solver para orçamentos de capital

Usando o Solver para determinar a combinação de produtos ideal

Introdução ao análise de hipóteses

Visão geral de fórmulas no Excel

Como evitar fórmulas quebradas

Detectar erros em fórmulas

Atalhos de teclado no Excel 2016 para Windows

Atalhos de teclado no Excel 2016 para Mac

Funções do Excel (ordem alfabética)

Funções do Excel (por categoria)

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×