Criar um Modelo de banco de dados (também conhecido como diagrama de Relacionamento entre Entidades)

Criar um Modelo de banco de dados (também conhecido como diagrama de Relacionamento entre Entidades)

Com o exemplo de Diagrama de modelo de banco de dados, é possível criar um novo modelo ou fazer a engenharia reversa de um banco de dados existente para torná-lo um modelo usando os conceitos de modelagem Relacional ou Objeto Relacional. Use o estêncil Relacionamento entre Entidades para modelar os bancos de dados com base em SQL92 e padrões anteriores. Use o estêncil Objeto Relacional, que tem outras formas para trabalho com tipos, para modelar bancos de dados com base em SQL99 e padrões posteriores.

Exemplo de modelo de banco de dados

Com o exemplo de Diagrama de modelo de banco de dados, é possível criar um novo modelo ou fazer a engenharia reversa de um banco de dados existente para torná-lo um modelo usando os conceitos de modelagem Relacional ou Objeto Relacional. Use o estêncil Relacionamento entre Entidades para modelar os bancos de dados com base em SQL92 e padrões anteriores. Use o estêncil Objeto Relacional, que tem outras formas para trabalho com tipos, para modelar bancos de dados com base em SQL99 e padrões posteriores.

Este artigo descreve como criar um modelo de banco de dados e o que fazer com ele após a criação.

Não consegue encontrar os recursos do modelo de banco de dados?

Nem todas as edições do Microsoft Visio têm o recurso de modelo de banco de dados. Se não encontrar os recursos descritos nos procedimentos deste artigo, é provável que sua edição do Visio não os inclua.

  • O Microsoft Visio Standard não inclui o exemplo de Diagrama de modelo de banco de dados.

  • As edições Microsoft Office Visio Professional e Premium são compatíveis com os recursos de engenharia reversa para o exemplo de Diagrama de modelo de banco de dados (ou seja, usando um banco de dados existente para criar um modelo do Visio), mas não é compatível com a engenharia avançada (ou seja, usando um modelo de banco de dados do Visio para gerar um código SQL).

  1. Para iniciar o diagrama do modelo de banco de dados, siga um destes procedimentos:

    Crie um novo diagrama de modelo do zero

    Se você não tiver um banco de dados existente que deseja usar como ponto de partida, pode começar com um Modelo de banco de dados em branco e adicionar suas próprias tabelas e relacionamentos.

    1. Clique na guia Arquivo.

    2. Clique em Novo, em Software e Banco de Dados e clique duas vezes em Diagrama de Modelo de Banco de Dados.

    3. Na guia Banco de Dados, no grupo Gerenciar, clique em Exibir Opções.

    4. Na caixa de diálogo Opções de Banco de Dados de Documentos, selecione o conjunto de símbolos que deseja usar e outras opções de tabela e relacionamentos e clique em OK.

    Use um banco de dados existente como ponto de partida

    Se você tiver um banco de dados que deseja modelar para entendê-lo melhor ou para usá-lo como ponto de partida de um novo modelo, é possível usar o Assistente de Engenharia Reversa para extrair o esquema, ou estrutura, do banco de dados e criar um novo modelo.

    Antes de iniciar o assistente:

    1. Se estiver fazendo a engenharia reversa de uma pasta de trabalho do Microsoft Excel, antes de iniciar o assistente é preciso abri-la e nomear o grupo (ou intervalo) de células que contém os títulos de coluna. Se quiser usar mais de uma planilha, basta dar um nome ao grupo de células da coluna em cada planilha. Esses intervalos são tratados como tabelas no assistente. Consulte mais informações sobre como nomear um intervalo de células no tópico da Ajuda do Excel "Definir intervalos ou referências de células nomeadas".

    2. Para melhores resultados, defina como driver padrão o banco de dados de destino em que deseja fazer a engenharia reversa antes de executar o Assistente de Engenharia Reversa. Esta etapa garante que o assistente mapeará corretamente os tipos de dados nativos e que todos os códigos extraídos pelo assistente serão exibidos corretamente na Janela de Código.

    3. Clique na guia Arquivo.

    4. Clique em Novo, em Software e Banco de Dados e clique duas vezes em Diagrama de Modelo de Banco de Dados.

    5. Na guia Banco de Dados, no grupo Modelo, clique em Engenharia Reversa.

    6. Na primeira tela do Assistente de Engenharia Reversa, faça o seguinte:

      1. Selecione o driver de banco de dados para seu sistema de gerenciamento de banco de dados (DBMS). Se ainda não tiver associado o driver de banco de dados do Visio a uma determinada fonte de dados ODBC, clique em Configuração.

        Observação: Se estiver fazendo a engenharia reversa de uma planilha do Excel, escolha o Driver Genérico ODBC.

      2. Selecione a fonte de dados do banco de dados que você está atualizando. Se ainda não tiver criado uma fonte de dados para o banco de dados existente, clique em Novo para fazer isso agora.

        Ao criar uma nova fonte, o nome será adicionado à lista de Fontes de Dados.

      3. Quando estiver satisfeito com as configurações, clique em Próximo.

    7. Siga as instruções das caixas de diálogo específicas do driver.

      Por exemplo, na caixa de diálogo Conectar Fonte de Dados, digite o nome de usuário e senha e clique em OK.

      Observação: Se você usa um Driver Genérico ODBC, pode ver uma mensagem de erro indicando que as informações de engenharia reversa podem estar incompletas. Na maioria dos casos, isso não é um problema, basta clicar em OK e continuar com o assistente.

    8. Marque as caixas de seleção para o tipo de informação que deseja extrair e depois clique em Próximo.

      Observação: Alguns itens podem não estar disponíveis (aparecendo esmaecidos) porque nem todos os sistemas de gerenciamento de banco de dados são compatíveis com todos os tipos de elementos que o assistente pode extrair.

    9. Marque as caixas de seleção para as tabelas (e modos de exibição, se houver) que deseja extrair ou clique em Selecionar Tudo para extrair todos e depois clique em Próximo.

      Observação: Se estiver fazendo a engenharia reversa de uma planilha do Excel e não aparecer nada na lista, é provável que precise nomear o intervalo de células que contém os títulos de coluna na planilha.

    10. Se tiver marcado a caixa de seleção Procedimentos Armazenados, selecione os procedimentos que deseja extrair ou clique em Selecionar Tudo para extrair todos e depois clique em Próximo.

    11. Selecione se deseja que os itens que passaram por engenharia reversa sejam adicionados automaticamente à página atual.

      Observação: É possível optar para que o assistente crie automaticamente o desenho, além de listar os itens que passaram por engenharia reversa na janela de Tabelas e Exibições. Se decidir por não criar o desenho automaticamente, pode arrastar os itens da janela de Tabelas e Exibições para sua página de desenho para reunir manualmente o modelo de banco de dados.

    12. Examine as seleções para confirmar que está extraindo as informações desejadas e clique em Terminar.

      O assistente extrairá as informações selecionadas e exibir as anotações sobre o processo de extração na janela Saída.

    Importe e refine um modelo existente

    Se você tiver um modelo VisioModeler ou PLATINUM ERwin existente, pode ser possível importá-lo para criar um diagrama de modelo de banco de dados do Visio. Esse recurso se limita apenas aos arquivos de modelo de dicionário VisioModeler 2.0 (.imd) ou posteriores e arquivos .erx PLATINUM ERwin 2.6, 3.0 e 3.52.

    1. Clique na guia Arquivo.

    2. Clique em Novo, em Software e Banco de Dados e clique duas vezes em Diagrama de Modelo de Banco de Dados.

    3. Na guia Banco de Dados, no grupo Modelo, clique em Importare depois no tipo de modelo.

    4. Digite o nome do caminho e do arquivo do modelo que deseja importar ou clique no botão Navegar, para localizar o arquivo de modelo e clique em Abrir.

    5. Na caixa de diálogo Importar, clique em OK.

      O Visio importará o arquivo e exibirá o andamento na janela Saída. As tabelas importadas são exibidas na janela de Tabelas e Exibições.

    6. Na janela de Tabelas e Exibições, selecione as tabelas que deseja modelar e depois arraste-as para a página de desenho.

  2. Após criar um diagrama de modelo de banco de dados, começa o trabalho de refinar o diagrama. É possível adicionar e personalizar as tabelas e exibições, criar relacionamentos e personalizar os tipos de dados e colunas.

    Tabelas

    Use a formaEntidade para criar uma tabela no diagrama.

    1. No estêncil Relacionamento entre Entidades ou Objeto Relacional, arraste uma forma Entidade para o desenho.

    2. Clique duas vezes na forma para abrir a janela Propriedades do Banco de Dados.

    3. Em Categorias, clique em Definição e digite um nome para a tabela.

    4. Em Categorias, clique em Colunas, digite um nome e escolha um tipo de dados.

    5. Selecione a caixa de seleção Necessário para as colunas que não podem ter valores nulos.

    6. Selecione a caixa de seleção PK (chave primária) para colunas que identificam exclusivamente cada linha na tabela de banco de dados.

    7. Em Categorias, clique em Índices, Gatilhos, Verificação ou Estendida para criar esses elementos opcionais.

    Colunas

    Use a janela Propriedades do Banco de Dados para adicionar ou alterar as propriedades das colunas, incluindo tipos de dados e chaves primárias.

    1. Clique duas vezes na tabela do seu diagrama.

    2. Na janela Propriedades do Banco de Dados, em Categorias, clique em Colunas.

    3. Clique na primeira célula vazia Nome Físico e digite um nome.

    4. Para alterar o tipo dos dados de uma coluna, clique no campo Tipo de Dados da coluna e selecione um tipo de dados ou digite na lista. Por exemplo, você pode digitar decimal(8,2) ou char(30).

    5. Para evitar valores nulos, marque a caixa de seleção Necessário.

    6. Para especificar que a coluna é uma chave primária, marque a caixa de seleção PK.

    7. Para ver mais propriedades da coluna, além das que aparecem ao clicar na categoria Colunas, selecione a coluna e clique em Editar.

    Relacionamentos

    Os relacionamentos usam chaves primárias e estrangeiras para que os bancos de dados façam a correspondência de uma linha de uma tabela com uma linha de outra tabela relacionada. Você pode exibir esses relacionamentos no diagrama. Além disso, você pode definir a cardinalidade deles (por exemplo, um para muitos) e usar as notações Pé de galinha, Relacional ou IDEF1X para mostrar a cardinalidade. Não é possível exibir relacionamentos do tipo muitos para muitos com nenhuma dessas notações no exemplo de Diagrama de Modelo de Banco de Dados.

    1. Crie um relacionamento entre tabelas:

      1. Ambas as tabelas devem estar visíveis no diagrama. Se você fez a engenharia reversa do modelo de um banco de dados existente, talvez seja necessário arrastar uma ou ambas da janela de Tabelas e Exibições para a página de desenho.

      2. Clique duas vezes na tabela desejada para o lado da chave primária do relacionamento.

      3. Na janela Propriedades do Banco de Dados, em Categorias, clique em Colunas.

      4. Na grade, clique na coluna que deseja usar para identificar exclusivamente cada linha na tabela e selecione a caixa de seleção PK para defini-la como a chave primária.

      5. Do estêncil Objeto Relacional ou Relacionamento entre Entidades, arraste uma forma Relacionamento e solte-a em um espaço em branco na página.

      6. Conecte a extremidade superior à tabela com a tabela pai.

      7. Conecte a outra extremidade à tabela filha.

        Se a segunda tabela não contiver já uma coluna com o mesmo nome da chave primária, o modelador a adicionará à segunda tabela como uma chave estrangeira.

        Observação: Se as linhas de relacionamento desaparecerem, na guia Banco de Dados, no grupo Gerenciar, clique em Opções de Exibição. Na guia Relacionamentos, em Mostrar, selecione a caixa de seleção Relacionamentos.

    2. Defina a cardinalidade do relacionamento:

      1. Clique duas vezes no relacionamento.

      2. Na janela Propriedades do Banco de Dados, em Categorias, clique em Diversos.

      3. Em Cardinalidade, escolha a que melhor atende ao relacionamento. Para relacionamentos do tipo um para muitos, a melhor opção é Zero ou mais ou Um ou mais. Para relacionamentos do tipo um para um, a melhor opção é Zero ou um ou Exatamente um.

  3. Para fazer outros ajustes ao diagrama (como criar índices, cláusulas de verificação e gatilhos) faça o seguinte:

    Criar índices

    Os índices melhoram o desempenho ou a velocidade do banco de dados durante a execução de uma consulta.

    1. Abra o diagrama de modelo de banco de dados.

    2. Clique duas vezes na tabela em que deseja adicionar um índice e, na janela Propriedades do Banco de Dados, na lista de Categorias, clique em Índices.

    3. Clique em Novo.

    4. Na caixa de diálogo Criar Índice, digite um nome para o índice e clique em OK.

    5. Na lista Tipo de Índice , selecione uma opção para criar um índice exclusivo ou não exclusivo.

    6. Na lista Colunas Disponíveis, selecione o nome de cada coluna que deseja incluir nesse índice e clique em Adicionar >.

    7. Na lista Colunas Indexadas, selecione a caixa de seleção Cresc. para criar um índice com uma ordem de classificação crescente, ou desmarque a caixa de seleção para criar um índice com uma ordem de classificação decrescente.

      O diagrama de modelo de banco de dados será atualizado.

    Criar modos de exibição

    Você pode encarar um modo de exibição como uma consulta salva. Os modos de exibição são especialmente úteis quando você precisa acessar várias vezes as mesmas informações de várias tabelas ou quando deseja expor os dados para os usuários sem deixar que eles alterem as tabelas reais.

    No estêncil Relacionamento entre Entidades ou Objeto Relacional, arraste para o desenho uma forma Modo de Exibição.

    Definir propriedades estendidas para tabelas e modos de exibição

    Dependendo do seu sistema de gerenciamento de banco de dados (DBMS), pode ser possível definir propriedades estendidas para tabelas ou modos de exibição a fim de determinar onde serão armazenadas.

    Clique duas vezes na tabela ou modo de exibição cujas propriedades estendidas deseja definir e, na janela Propriedades do Banco de Dados, na lista Categorias, clique em Estendido.

    Criar cláusulas de verificação

    Use cláusulas de verificação para garantir que os dados inseridos em uma coluna estejam dentro de um determinado intervalo de valores. Por exemplo, é possível criar uma cláusula de verificação que exija que os dados em uma coluna chamada "Idade" sejam mais que 65.

    1. Clique duas vezes na tabela para abrir a janela Propriedades do Banco de Dados.

    2. Em Categorias, clique em Colunas e depois clique na coluna em que deseja adicionar uma cláusula de verificação.

    3. Clique em Editar.

    4. Na guia Verificar da caixa de diálogo Propriedades da Coluna, insira as restrições desejadas.

      A cláusula de verificação será adicionada à Janela de Código em Código local.

    Criar procedimentos armazenados e funções definidas pelo usuário

    Use os procedimentos armazenados e as funções definidas pelo usuário para criar pacotes de código que podem ser reusados na execução das mesmas ações várias vezes. A principal diferença entre os dois é que uma função definida pelo usuário retorna um valor, enquanto o procedimento armazenado executa um código sem retornar um valor.

    1. Na guia Banco de Dados, no grupo Mostrar/Ocultar, selecione a caixa de seleção Código para abrir a janela de Código.

    2. Clique em Código global e em Novo.

    3. Na guia Propriedades do Editor de Códigos, clique no tipo de código que deseja criar e digite um nome para ele.

    4. Na guia Corpo, digite o código e clique em OK.

    Criar gatilhos

    Os gatilhos fazem com que um código SQL especificado no gatilho seja executado na ocorrência de um evento específico no banco de dados.

    1. Clique duas vezes na tabela para abrir a janela Propriedades do Banco de Dados.

    2. Em Categorias, clique em Gatilhose em Adicionar.

    3. Na guia Propriedades, digite um nome para o gatilho.

    4. Na guia Corpo, digite o código e clique em OK.

      O gatilho será adicionado à Janela de Código em Código local.

Este artigo descreve como criar um modelo de banco de dados e o que fazer com ele após a criação. Para um início rápido, no menu Arquivo, aponte para Novo, e depois para Software e Banco de Dadose clique em Diagrama de Modelo de Banco de Dados.

Não consegue encontrar os recursos do modelo de banco de dados?

É provável que sua edição do Microsoft Office Visio não inclua os recursos que você está procurando. Para saber qual é sua edição do Visio, clique em Sobre o Microsoft Office Visio no menu Ajuda. O nome da edição fica na linha superior do texto da caixa de diálogo.

  • O Microsoft Office Visio Standard não inclui o exemplo de Diagrama de modelo de banco de dados.

  • O Microsoft Office Visio Professional é compatível com os recursos de engenharia reversa para o exemplo de Diagrama de modelo de banco de dados (ou seja, usando um banco de dados existente para criar um modelo do Visio), mas não é compatível com engenharia avançada (ou seja, usando um modelo de banco de dados do Visio para gerar código SQL).

  • O pacote completo de recursos de modelagem de banco de dados pode ser encontrado no Visio for Enterprise Architects, incluindo a engenharia reversa e a avançada. O Visio for Enterprise Architects está incluído na assinatura Premium do MSDN, que está disponível com as edições baseadas em funções do Microsoft Visual Studio Professional e Visual Studio Team System.

  1. Para iniciar o diagrama do modelo de banco de dados, siga um destes procedimentos:

    Crie um novo diagrama de modelo do zero

    Se você não tiver um banco de dados existente que deseja usar como ponto de partida, pode começar com um Modelo de banco de dados em branco e adicionar suas próprias tabelas e relacionamentos.

    1. No menu Arquivo, aponte para Novo e depois para Software e Banco de Dadose clique em Diagrama de Modelo de Banco de Dados.

    2. No menu Banco de Dados, aponte para Opçõese clique em Documento.

    3. Na caixa de diálogo Opções de Banco de Dados de Documentos, selecione o conjunto de símbolos que deseja usar e outras opções de tabela e relacionamentos e clique em OK.

    Use um banco de dados existente como ponto de partida

    Se você tiver um banco de dados que deseja modelar para entendê-lo melhor ou para usá-lo como ponto de partida de um novo modelo, é possível usar o Assistente de Engenharia Reversa para extrair o esquema, ou estrutura, do banco de dados e criar um novo modelo.

    Observação: Antes de iniciar o assistente:

    1. Se estiver fazendo a engenharia reversa de uma pasta de trabalho do Microsoft Office Excel, antes de iniciar o assistente é preciso abri-la e nomear o grupo (ou intervalo) de células que contém os títulos de coluna. Se quiser usar mais de uma planilha, basta dar um nome ao grupo de células da coluna em cada planilha. Esses intervalos são tratados como tabelas no assistente. Consulte mais informações sobre como nomear um intervalo de células no tópico da Ajuda do Microsoft Office Excel "Definir intervalos ou referências de células nomeadas".

    2. Para melhores resultados, defina como driver padrão o banco de dados de destino em que deseja fazer a engenharia reversa antes de executar o Assistente de Engenharia Reversa. Esta etapa garante que o assistente mapeará corretamente os tipos de dados nativos e que todos os códigos extraídos pelo assistente serão exibidos corretamente na Janela de Código.

    3. No menu Arquivo, aponte para Novo e depois para Software e Banco de Dadose clique em Diagrama de Modelo de Banco de Dados.

    4. No menu Banco de Dados, clique em Engenharia Reversa.

    5. Na primeira tela do Assistente de Engenharia Reversa, faça o seguinte:

      1. Selecione o driver de banco de dados do Microsoft Office Visio para seu sistema de gerenciamento de banco de dados (DBMS). Se ainda não tiver associado o driver de banco de dados do Visio a uma determinada fonte de dados ODBC, clique em Configuração.

        Observação: Se estiver fazendo a engenharia reversa de uma planilha do Excel, escolha o Driver Genérico ODBC.

      2. Selecione a fonte de dados do banco de dados que você está atualizando. Se ainda não tiver criado uma fonte de dados para o banco de dados existente, clique em Novo para fazer isso agora.

        Ao criar uma nova fonte, o nome será adicionado à lista de Fontes de Dados.

      3. Quando estiver satisfeito com as configurações, clique em Próximo.

    6. Siga as instruções das caixas de diálogo específicas do driver.

      Por exemplo, na caixa de diálogo Conectar Fonte de Dados, digite um nome de usuário e senha e clique em OK. Se sua fonte de dados não for protegida por senha, basta clicar em OK.

      Observação: Se você usa um Driver Genérico ODBC, pode ver uma mensagem de erro indicando que as informações de engenharia reversa podem estar incompletas. Na maioria dos casos, isso não é um problema, basta clicar em OK e continuar com o assistente.

    7. Marque as caixas de seleção para o tipo de informação que deseja extrair e depois clique em Próximo.

      Observação: Alguns itens podem não estar disponíveis (aparecendo esmaecidos) porque nem todos os sistemas de gerenciamento de banco de dados são compatíveis com todos os tipos de elementos que o assistente pode extrair.

    8. Marque as caixas de seleção para as tabelas (e modos de exibição, se houver) que deseja extrair ou clique em Selecionar Tudo para extrair todos e depois clique em Próximo.

      Observação: Se estiver fazendo a engenharia reversa de uma planilha do Excel e não aparecer nada na lista, é provável que precise nomear o intervalo de células que contém os títulos de coluna na planilha.

    9. Se tiver selecionado a caixa de seleção Procedimentos Armazenados na etapa 5, selecione os procedimentos que deseja extrair ou clique em Selecionar Tudo para extrair todos e clique em Próximo.

    10. Selecione se deseja que os itens que passaram por engenharia reversa sejam adicionados automaticamente à página atual.

      Observação: É possível optar para que o assistente crie automaticamente o desenho, além de listar os itens que passaram por engenharia reversa na janela de Tabelas e Exibições. Se decidir por não criar o desenho automaticamente, pode arrastar os itens da janela de Tabelas e Exibições para sua página de desenho para reunir manualmente o modelo de banco de dados.

    11. Examine as seleções para confirmar que está extraindo as informações desejadas e clique em Terminar.

      O assistente extrairá as informações selecionadas e exibir as anotações sobre o processo de extração na janela Saída.

    Importe e refine um modelo existente

    Se você tiver um modelo VisioModeler ou PLATINUM ERwin existente, pode ser possível importá-lo para criar um diagrama de modelo de banco de dados do Visio. Esse recurso se limita apenas aos arquivos de modelo de dicionário VisioModeler 2.0 (.imd) ou posteriores e arquivos .erx PLATINUM ERwin 2.6, 3.0 e 3.52.

    1. No menu Arquivo, aponte para Novo e depois para Software e Banco de Dadose clique em Diagrama de Modelo de Banco de Dados.

    2. No menu Banco de Dados, aponte para Importação e clique em Importar <tipo de modelo>.

    3. Digite o nome do caminho e do arquivo do modelo que deseja importar ou clique no botão Navegar, para localizar o arquivo de modelo e clique em Abrir.

    4. Na caixa de diálogo Importar, clique em OK.

      O Visio importará o arquivo e exibirá o andamento na janela Saída. As tabelas importadas são exibidas na janela de Tabelas e Exibições.

    5. Na janela de Tabelas e Exibições, selecione as tabelas que deseja modelar e depois arraste-as para a página de desenho.

  2. Após criar um diagrama de modelo de banco de dados, começa o trabalho de refinar o diagrama. É possível adicionar e personalizar as tabelas e exibições, criar relacionamentos e personalizar os tipos de dados e colunas.

    Tabelas

    Use a formaEntidade para criar uma tabela no diagrama.

    1. No estêncil Relacionamento entre Entidades ou Objeto Relacional, arraste uma forma Entidade para o desenho.

    2. Clique duas vezes na forma para abrir a janela Propriedades do Banco de Dados.

    3. Em Categorias, clique em Definição e digite um nome para a tabela.

    4. Em Categorias, clique em Colunas, digite um nome e escolha um tipo de dados.

    5. Selecione a caixa de seleção Necessário para as colunas que não podem ter valores nulos.

    6. Selecione a caixa de seleção PK (chave primária) para colunas que identificam exclusivamente cada linha na tabela de banco de dados.

    7. Em Categorias, clique em Índices, Gatilhos, Verificação ou Estendida para criar esses elementos opcionais.

    Colunas

    Use a janela Propriedades do Banco de Dados para adicionar ou alterar as propriedades das colunas, incluindo tipos de dados e chaves primárias.

    1. Clique duas vezes na tabela do seu diagrama.

    2. Na janela Propriedades do Banco de Dados, em Categorias, clique em Colunas.

    3. Clique na primeira célula vazia Nome físico e digite um nome.

    4. Para alterar o tipo dos dados de uma coluna, clique no campo Tipo de Dados da coluna e selecione um tipo de dados ou digite na lista. Por exemplo, você pode digitar decimal(8,2) ou char(30).

    5. Para evitar valores nulos, marque a caixa de seleção Necessário.

    6. Para especificar que a coluna é uma chave primária, marque a caixa de seleção PK.

    7. Para ver mais propriedades da coluna, além das que aparecem ao clicar na categoria Colunas, selecione a coluna e clique em Editar.

    Relacionamentos

    Os relacionamentos usam chaves primárias e estrangeiras para que os bancos de dados façam a correspondência de uma linha de uma tabela com uma linha de outra tabela relacionada. Você pode exibir esses relacionamentos no diagrama. Além disso, você pode definir a cardinalidade deles (por exemplo, um para muitos) e usar as notações Pé de galinha, Relacional ou IDEF1X para mostrar a cardinalidade. Não é possível exibir relacionamentos do tipo muitos para muitos com nenhuma dessas notações no exemplo de Diagrama de Modelo de Banco de Dados.

    1. Crie um relacionamento entre tabelas:

      1. Ambas as tabelas devem estar visíveis no diagrama. Se você fez a engenharia reversa do modelo de um banco de dados existente, talvez seja necessário arrastar uma ou ambas da janela de Tabelas e Exibições para a página de desenho.

      2. Clique duas vezes na tabela desejada para o lado da chave primária do relacionamento.

      3. Na janela Propriedades do Banco de Dados, em Categorias, clique em Colunas.

      4. Na grade, clique na coluna que deseja usar para identificar exclusivamente cada linha na tabela e selecione a caixa de seleção PK para defini-la como a chave primária.

      5. Do estêncil Objeto Relacional ou Relacionamento entre Entidades, arraste uma forma Relacionamento e solte-a em um espaço em branco na página.

      6. Conecte a extremidade superior à tabela com a tabela pai.

      7. Conecte a outra extremidade à tabela filha.

        Se a segunda tabela não contiver já uma coluna com o mesmo nome da chave primária, o modelador a adicionará à segunda tabela como uma chave estrangeira.

        Observação: Se as linhas de relacionamento desaparecerem, no menu Banco de Dados, aponte para Opções e clique em Documento. Na guia Relacionamentos, em Mostrar, selecione a caixa de seleção Relacionamentos.

    2. Defina a cardinalidade do relacionamento:

      1. Clique duas vezes no relacionamento.

      2. Na janela Propriedades do Banco de Dados, em Categorias, clique em Diversos.

      3. Em Cardinalidade, escolha a que melhor atende ao relacionamento. Para relacionamentos do tipo um para muitos, a melhor opção é Zero ou mais ou Um ou mais. Para relacionamentos do tipo um para um, a melhor opção é Zero ou um ou Exatamente um.

  3. Para fazer outros ajustes ao diagrama (como criar índices, cláusulas de verificação e gatilhos) faça o seguinte:

    Criar índices

    Os índices melhoram o desempenho ou a velocidade do banco de dados durante a execução de uma consulta.

    1. Abra o diagrama de modelo de banco de dados.

    2. Clique duas vezes na tabela em que deseja adicionar um índice e, na janela Propriedades do Banco de Dados, na lista de Categorias, clique em Índices.

    3. Clique em Novo.

    4. Na caixa de diálogo Criar Índice, digite um nome para o índice e clique em OK.

    5. Na lista Tipo de Índice , selecione uma opção para criar um índice exclusivo ou não exclusivo.

    6. Na lista Colunas Disponíveis, selecione o nome de cada coluna que deseja incluir nesse índice e clique em Adicionar >.

    7. Na lista Colunas Indexadas, selecione a caixa de seleção Cresc. para criar um índice com uma ordem de classificação crescente, ou desmarque a caixa de seleção para criar um índice com uma ordem de classificação decrescente.

      O diagrama de modelo de banco de dados será atualizado.

    Criar modos de exibição

    Você pode encarar um modo de exibição como uma consulta salva. Os modos de exibição são especialmente úteis quando você precisa acessar várias vezes as mesmas informações de várias tabelas ou quando deseja expor os dados para os usuários sem deixar que eles alterem as tabelas reais.

    No estêncil Relacionamento entre Entidades ou Objeto Relacional, arraste para o desenho uma forma Modo de Exibição.

    Definir propriedades estendidas para tabelas e modos de exibição

    Dependendo do seu sistema de gerenciamento de banco de dados (DBMS), pode ser possível definir propriedades estendidas para tabelas ou modos de exibição a fim de determinar onde serão armazenadas.

    Clique duas vezes na tabela ou modo de exibição cujas propriedades estendidas deseja definir e, na janela Propriedades do Banco de Dados, na lista Categorias, clique em Estendido.

    Criar cláusulas de verificação

    Use cláusulas de verificação para garantir que os dados inseridos em uma coluna estejam dentro de um determinado intervalo de valores. Por exemplo, é possível criar uma cláusula de verificação que exija que os dados em uma coluna chamada "Idade" sejam mais que 65.

    1. Clique duas vezes na tabela para abrir a janela Propriedades do Banco de Dados.

    2. Em Categorias, clique em Colunas e depois clique na coluna em que deseja adicionar uma cláusula de verificação.

    3. Clique em Editar.

    4. Na guia Verificar da caixa de diálogo Propriedades da Coluna, insira as restrições desejadas. Confira mais informações sobre suas escolhas em Caixa de diálogo Propriedades do Campo e da Coluna (guia de verificação).

      A cláusula de verificação será adicionada à janela de Código em Código local.

    Criar procedimentos armazenados e funções definidas pelo usuário

    Use os procedimentos armazenados e as funções definidas pelo usuário para criar pacotes de código que podem ser reusados na execução das mesmas ações várias vezes. A principal diferença entre os dois é que uma função definida pelo usuário retorna um valor, enquanto o procedimento armazenado executa um código sem retornar um valor.

    1. No menu Banco de Dados, aponte para Modo de Exibição e clique em Código para abrir a Janela de Código.

    2. Clique em Código global e em Novo.

    3. Na guia Propriedades do Editor de Códigos, clique no tipo de código que deseja criar e digite um nome para ele.

    4. Na guia Corpo, digite o código e clique em OK.

    Criar gatilhos

    Os gatilhos fazem com que um código SQL especificado no gatilho seja executado na ocorrência de um evento específico no banco de dados.

    1. Clique duas vezes na tabela para abrir a janela Propriedades do Banco de Dados.

    2. Em Categorias, clique em Gatilhose em Adicionar.

    3. Na guia Propriedades, digite um nome para o gatilho.

    4. Na guia Corpo, digite o código e clique em OK.

      O gatilho será adicionado à Janela de Código em Código local.

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×