Criar um Modelo de Banco de Dados (também conhecido como diagrama de Relacionamento de Entidade) no Visio

Criar um Modelo de Banco de Dados (também conhecido como diagrama de Relacionamento de Entidade) no Visio

No Visio, com o modelo Diagrama de Modelo de Banco de Dados, você pode criar um novo modelo ou fazer engenharia reversa de um banco de dados existente em um modelo.

Ícone do banco de dados, seta, diagrama do Visio representando o banco de dados

Este artigo descreve como criar um modelo de banco de dados e o que você pode fazer com o modelo depois de criá-lo.

Observação: O diagrama do Modelo de Banco de Dados só está disponível em algumas versões do Visio. Confira Não consegue encontrar os recursos de modelagem de bancos de dados? para saber mais.

1: Iniciar um diagrama de modelo de banco de dados

Se você não tiver um banco de dados existente que deseja usar como ponto de partida, pode começar com um Modelo de banco de dados em branco e adicionar suas próprias tabelas e relacionamentos.

  1. Selecione Arquivo > Novo.

  2. Na caixa de Pesquisa, digite modelo de banco de dados e pressione Enter.

  3. Nos resultados da pesquisa, clique duas vezes no Diagrama de Modelo de Banco de Dados.

    Modelo do diagrama do Modelo de banco de dados.
  4. Selecione Unidades Métricas ou Unidades dos EUA e, em seguida, selecione Criar.

    O Assistente de Engenharia Reversa geralmente é aberto automaticamente.

  5. Selecione Cancelar para fechar o assistente.

  6. Na guia Banco de Dados, no grupo Gerenciar, selecione Exibir Opções.

  7. Na caixa de diálogo Opções de Banco de Dados de Documentos, selecione o conjunto de símbolos que deseja usar e outras opções de tabela e relacionamentos e, em seguida, selecione OK. Clique no botão Ajuda, na caixa de diálogo para obter mais informações sobre as várias opções.

Se você possui um banco de dados que deseja modelar para poder entendê-lo melhor ou usá-lo como ponto de partida para um novo modelo, use o Assistente de Engenharia Reversa para extrair o esquema ou estrutura do banco de dados e criar um novo modelo.

Antes de iniciar o assistente:

  • Se você pretende fazer engenharia reversa de uma pasta de trabalho Excel, primeiro abra a pasta de trabalho e nomeie o grupo (ou intervalo) de células que contém os títulos de coluna. Se quiser usar mais de uma planilha, basta dar um nome ao grupo de células da coluna em cada planilha. Esses intervalos são tratados como tabelas no Assistente de Engenharia Reversa. Para obter mais informações sobre como nomear um intervalo de células, confira Definir e usar nomes em fórmulas.

  • Para melhores resultados, defina como driver padrão o banco de dados de destino em que deseja fazer a engenharia reversa antes de executar o Assistente de Engenharia Reversa. Esta etapa garante que o assistente mapeará corretamente os tipos de dados nativos e que todos os códigos extraídos pelo assistente serão exibidos corretamente na Janela de Código.

Iniciar o assistente:

  1. Selecione Arquivo > Novo.

  2. Na caixa de Pesquisa, digite modelo de banco de dados e pressione Enter.

  3. Nos resultados da pesquisa, clique duas vezes no Diagrama de Modelo de Banco de Dados. Selecione Criar.

    O Assistente de Engenharia Reversa deve abrir automaticamente.

    Se o assistente não abrir: Na guia Banco deDados da faixa de opções da barra de ferramentas, no grupo Modelo, selecione Engenharia Reversa.

  4. Na primeira tela do Assistente de Engenharia Reversa, faça o seguinte:

    1. Selecione o driver de banco de dados para seu sistema de gerenciamento de banco de dados (DBMS). Se ainda não tiver associado o driver de banco de dados do Visio a uma determinada fonte de dados ODBC, clique em Configurar.

      Observação: Se estiver fazendo a engenharia reversa de uma planilha do Excel, escolha o Driver Genérico ODBC.

    2. Selecione a fonte de dados do banco de dados que você está atualizando. Se ainda não tiver criado uma fonte de dados para o banco de dados existente, clique em Novo para fazer isso agora.

      Ao criar uma nova fonte, o nome será adicionado à lista de Fontes de Dados.

    3. Quando estiver satisfeito com as configurações, clique em Próximo.

  5. Siga as instruções das caixas de diálogo específicas do driver.

    Por exemplo, na caixa de diálogo Conectar Fonte de Dados, digite o nome de usuário e senha e clique em OK.

    Observação: Se você usa um Driver Genérico ODBC, pode ver uma mensagem de erro indicando que as informações de engenharia reversa podem estar incompletas. Na maioria dos casos, isso não é um problema, basta clicar em OK e continuar com o assistente.

  6. Marque as caixas de seleção para o tipo de informação que deseja extrair e depois clique em Próximo.

    Observação: Alguns itens podem não estar disponíveis (aparecendo esmaecidos) porque nem todos os sistemas de gerenciamento de banco de dados são compatíveis com todos os tipos de elementos que o assistente pode extrair.

  7. Marque as caixas de seleção para as tabelas (e modos de exibição, se houver) que deseja extrair ou clique em Selecionar Tudo para extrair todos e depois clique em Próximo.

    Observação: Se estiver fazendo a engenharia reversa de uma planilha do Excel e não aparecer nada na lista, é provável que precise nomear o intervalo de células que contém os títulos de coluna na planilha. Para obter mais informações, confira Definir e usar nomes em fórmulas.

  8. Se tiver marcado a caixa de seleção Procedimentos Armazenados, selecione os procedimentos que deseja extrair ou clique em Selecionar Tudo para extrair todos e depois clique em Próximo.

  9. Selecione se deseja que os itens que passaram por engenharia reversa sejam adicionados automaticamente à página atual.

    Observação: É possível optar para que o assistente crie automaticamente o desenho, além de listar os itens que passaram por engenharia reversa na janela de Tabelas e Exibições. Se decidir por não criar o desenho automaticamente, pode arrastar os itens da janela de Tabelas e Exibições para sua página de desenho para reunir manualmente o modelo de banco de dados.

  10. Examine as seleções para confirmar que está extraindo as informações desejadas e clique em Terminar.

    O assistente extrairá as informações selecionadas e exibir as anotações sobre o processo de extração na janela Saída.

Se você tiver um modelo VisioModeler ou PLATINUM ERwin existente, pode ser possível importá-lo para criar um diagrama de modelo de banco de dados doVisio. Esse recurso se limita apenas aos arquivos de modelo de dicionário VisioModeler 2.0 (.imd) ou posteriores e arquivos .erx PLATINUM ERwin 2.6, 3.0 e 3.52.

  1. Selecione Arquivo > Novo.

  2. Na caixa de Pesquisa, digite modelo de banco de dados e pressione Enter.

  3. Nos resultados da pesquisa, clique duas vezes no Diagrama de Modelo de Banco de Dados. Selecione Criar.

    O Assistente de Engenharia Reversa será aberto automaticamente. Selecione Cancelar para fechar o assistente.

  4. Na guia Banco de Dados, no grupo Modelo, selecione Importar e, em seguida, selecione o tipo de modelo.

  5. Digite o nome do caminho e do arquivo do modelo que deseja importar ou selecione o botão Navegar, para localizar o arquivo de modelo e, em seguida, selecione Abrir.

  6. Na caixa de diálogo Importar, selecione OK.

    O Visio importa o arquivo e exibe o andamento na janela Saída. As tabelas importadas são exibidas na janela de Tabelas e Exibições.

  7. Na janela de Tabelas e Exibições, selecione as tabelas que deseja modelar e depois arraste-as para a página de desenho.

Este artigo descreve como você pode criar um modelo de banco de dados e o que você pode fazer com o modelo depois de criá-lo. Para obter um início rápido, selecione Arquivo > Novo > Software e Banco de Dados e, em seguida, selecione Diagrama de Modelo de Banco de Dados.

Observação: O diagrama do Modelo de Banco de Dados só está disponível em algumas versões do Visio. Confira Não consegue encontrar os recursos de modelagem de bancos de dados? para saber mais.

1: Iniciar um diagrama de modelo de banco de dados

Se você não tiver um banco de dados existente que deseja usar como ponto de partida, pode começar com um Modelo de banco de dados em branco e adicionar suas próprias tabelas e relacionamentos.

  1. Selecione Arquivo > Novo.

  2. Em Categorias de Modelos, selecione Software e Banco de Dados e, em seguida, selecione Diagrama de Modelo de Banco de Dados.

    Modelo de Diagrama de Modelo de Banco de Dados.

  3. No lado direito, selecione Unidades Métricas ou Unidades dos EUA e, em seguida, selecione Criar.

  4. Na guia Banco de Dados da faixa de opções, no grupo Gerenciar, selecione Exibir Opções.

  5. Na caixa de diálogo Opções de Banco de Dados de Documentos, selecione o conjunto de símbolos que deseja usar e outras opções de tabela e relacionamentos e clique em OK.

Se você tiver um banco de dados que deseja modelar para entendê-lo melhor ou para usá-lo como ponto de partida de um novo modelo, é possível usar o Assistente de Engenharia Reversa para extrair o esquema, ou estrutura, do banco de dados e criar um novo modelo.

Antes de iniciar o assistente:

  • Se você pretende fazer engenharia reversa de uma pasta de trabalho Excel, primeiro abra a pasta de trabalho e nomeie o grupo (ou intervalo) de células que contém os títulos de coluna. Se quiser usar mais de uma planilha, basta dar um nome ao grupo de células da coluna em cada planilha. Esses intervalos são tratados como tabelas no assistente. Para obter mais informações sobre como nomear um intervalo de células, confira Definir e usar nomes em fórmulas.

  • Para melhores resultados, defina como driver padrão o banco de dados de destino em que deseja fazer a engenharia reversa antes de executar o Assistente de Engenharia Reversa. Esta etapa garante que o assistente mapeará corretamente os tipos de dados nativos e que todos os códigos extraídos pelo assistente serão exibidos corretamente na Janela de Código.

Iniciar o assistente:

  1. Selecione Arquivo > Novo.

  2. Em Categorias de Modelos, selecione Software e Banco de Dados e, em seguida, selecione Diagrama de Modelo de Banco de Dados.

  3. No lado direito, selecione Unidades Métricas ou Unidades dos EUA e, em seguida, selecione Criar.

  4. Na guia Banco de Dados da faixa de opções, no grupo Modelo, selecione Engenharia Reversa.

  5. Na primeira tela do Assistente de Engenharia Reversa, faça o seguinte:

    1. Selecione o driver de banco de dados do Microsoft Office Visio para seu sistema de gerenciamento de banco de dados (DBMS). Se ainda não tiver associado o driver de banco de dados do Visio a uma determinada fonte de dados ODBC, clique em Configurar.

      Observação: Se estiver fazendo a engenharia reversa de uma planilha do Excel, escolha o Driver Genérico ODBC.

    2. Selecione a fonte de dados do banco de dados que você está atualizando. Se ainda não tiver criado uma fonte de dados para o banco de dados existente, clique em Novo para fazer isso agora.

      Ao criar uma nova fonte, o nome será adicionado à lista de Fontes de Dados.

    3. Quando estiver satisfeito com as configurações, clique em Próximo.

  6. Siga as instruções das caixas de diálogo específicas do driver.

    Por exemplo, na caixa de diálogo Conectar Fonte de Dados, digite um nome de usuário e senha e clique em OK. Se sua fonte de dados não for protegida por senha, basta clicar em OK.

    Observação: Se você usa um Driver Genérico ODBC, pode ver uma mensagem de erro indicando que as informações de engenharia reversa podem estar incompletas. Na maioria dos casos, isso não é um problema, basta clicar em OK e continuar com o assistente.

  7. Marque as caixas de seleção para o tipo de informação que deseja extrair e depois clique em Próximo.

    Observação: Alguns itens podem não estar disponíveis (aparecendo esmaecidos) porque nem todos os sistemas de gerenciamento de banco de dados são compatíveis com todos os tipos de elementos que o assistente pode extrair.

  8. Marque as caixas de seleção para as tabelas (e modos de exibição, se houver) que deseja extrair ou clique em Selecionar Tudo para extrair todos e depois clique em Próximo.

    Observação: Se estiver fazendo a engenharia reversa de uma planilha do Excel e não aparecer nada na lista, é provável que precise nomear o intervalo de células que contém os títulos de coluna na planilha. Para obter mais informações, confira Definir e usar nomes em fórmulas.

  9. Se tiver selecionado a caixa de seleção Procedimentos Armazenados na etapa 5, selecione os procedimentos que deseja extrair ou clique em Selecionar Tudo para extrair todos e clique em Próximo.

  10. Selecione se deseja que os itens que passaram por engenharia reversa sejam adicionados automaticamente à página atual.

    Observação: É possível optar para que o assistente crie automaticamente o desenho, além de listar os itens que passaram por engenharia reversa na janela de Tabelas e Exibições. Se decidir por não criar o desenho automaticamente, pode arrastar os itens da janela de Tabelas e Exibições para sua página de desenho para reunir manualmente o modelo de banco de dados.

  11. Examine as seleções para confirmar que está extraindo as informações desejadas e clique em Terminar.

    O assistente extrairá as informações selecionadas e exibir as anotações sobre o processo de extração na janela Saída.

Se você tiver um modelo VisioModeler ou PLATINUM ERwin existente, pode ser possível importá-lo para criar um diagrama de modelo de banco de dados do Visio. Esse recurso se limita apenas aos arquivos de modelo de dicionário VisioModeler 2.0 (.imd) ou posteriores e arquivos .erx PLATINUM ERwin 2.6, 3.0 e 3.52.

  1. Selecione Arquivo > Novo.

  2. Em Categorias de Modelos, selecione Software e Banco de Dados e, em seguida, selecione Diagrama de Modelo de Banco de Dados.

  3. No lado direito, selecione Unidades Métricas ou Unidades dos EUA e, em seguida, selecione Criar.

  4. Na guia Banco de Dados da faixa de opções, no grupo Modelo, selecione Importar e, em seguida, selecione o tipo de arquivo do qual você deseja importar.

  5. Digite o nome do caminho e do arquivo do modelo que deseja importar ou clique no botão Navegar, para localizar o arquivo de modelo e clique em Abrir.

  6. Na caixa de diálogo Importar, clique em OK.

    O Visio importa o arquivo e exibe o andamento na janela Saída. As tabelas importadas são exibidas na janela de Tabelas e Exibições.

  7. Na janela de Tabelas e Exibições, selecione as tabelas que deseja modelar e depois arraste-as para a página de desenho.

Este artigo descreve como você pode criar um modelo de banco de dados e o que você pode fazer com o modelo depois de criá-lo. Para obter um início rápido, selecione Arquivo > Novo > Software e Banco de Dados e, em seguida, selecione Diagrama de Modelo de Banco de Dados.

Observação: O diagrama do Modelo de Banco de Dados só está disponível em algumas versões do Visio. Confira Não consegue encontrar os recursos de modelagem de bancos de dados? para saber mais.

1: Iniciar um diagrama de modelo de banco de dados

Se você não tiver um banco de dados existente que deseja usar como ponto de partida, pode começar com um Modelo de banco de dados em branco e adicionar suas próprias tabelas e relacionamentos.

  1. Selecione Arquivo > Novo > Software e Banco de Dados e, em seguida, selecione uma das duas opções do Diagrama de Modelo de Banco de Dados.

  2. No menu Banco de Dados, aponte para Opções e clique em Documento.

  3. Na caixa de diálogo Opções de Banco de Dados de Documentos, selecione o conjunto de símbolos que deseja usar e outras opções de tabela e relacionamentos e clique em OK.

Se você tiver um banco de dados que deseja modelar para entendê-lo melhor ou para usá-lo como ponto de partida de um novo modelo, é possível usar o Assistente de Engenharia Reversa para extrair o esquema, ou estrutura, do banco de dados e criar um novo modelo.

Antes de iniciar o assistente:

  • Se você pretende fazer engenharia reversa de uma pasta de trabalho Excel, primeiro abra a pasta de trabalho e nomeie o grupo (ou intervalo) de células que contém os títulos de coluna. Se quiser usar mais de uma planilha, basta dar um nome ao grupo de células da coluna em cada planilha. Esses intervalos são tratados como tabelas no assistente. Para obter mais informações sobre como nomear um intervalo de células, confira Definir e usar nomes em fórmulas.

  • Para melhores resultados, defina como driver padrão o banco de dados de destino em que deseja fazer a engenharia reversa antes de executar o Assistente de Engenharia Reversa. Esta etapa garante que o assistente mapeará corretamente os tipos de dados nativos e que todos os códigos extraídos pelo assistente serão exibidos corretamente na Janela de Código.

Iniciar o assistente:

  1. No menu Arquivo, aponte para Novo e depois para Software e Banco de Dados e, em seguida, selecione uma das duas opções do Diagrama de Modelo de Banco de Dados.

  2. No menu Banco de Dados, clique em Engenharia Reversa para abrir o assistente.

  3. Na primeira tela do Assistente de Engenharia Reversa, faça o seguinte:

    1. Selecione o driver de banco de dados do Visio para o seu sistema de gerenciamento de banco de dados (DBMS). Se ainda não tiver associado o driver de banco de dados do Visio a uma determinada fonte de dados ODBC, clique em Configuração.

      Observação: Se estiver fazendo a engenharia reversa de uma planilha do Excel, escolha o Driver Genérico ODBC.

    2. Selecione a fonte de dados do banco de dados que você está atualizando. Se ainda não tiver criado uma fonte de dados para o banco de dados existente, clique em Novo para fazer isso agora.

      Ao criar uma nova fonte, o nome será adicionado à lista de Fontes de Dados.

    3. Quando estiver satisfeito com as configurações, clique em Próximo.

  4. Siga as instruções das caixas de diálogo específicas do driver.

    Por exemplo, na caixa de diálogo Conectar Fonte de Dados, digite um nome de usuário e senha e clique em OK. Se sua fonte de dados não for protegida por senha, basta clicar em OK.

    Observação: Se você usa um Driver Genérico ODBC, pode ver uma mensagem de erro indicando que as informações de engenharia reversa podem estar incompletas. Na maioria dos casos, isso não é um problema, basta clicar em OK e continuar com o assistente.

  5. Marque as caixas de seleção para o tipo de informação que deseja extrair e depois clique em Próximo.

    Observação: Alguns itens podem não estar disponíveis (aparecendo esmaecidos) porque nem todos os sistemas de gerenciamento de banco de dados são compatíveis com todos os tipos de elementos que o assistente pode extrair.

  6. Marque as caixas de seleção para as tabelas (e modos de exibição, se houver) que deseja extrair ou clique em Selecionar Tudo para extrair todos e depois clique em Próximo.

    Observação: Se estiver fazendo a engenharia reversa de uma planilha do Excel e não aparecer nada na lista, é provável que precise nomear o intervalo de células que contém os títulos de coluna na planilha. Para obter mais informações, confira Definir e usar nomes em fórmulas.

  7. Se tiver selecionado a caixa de seleção Procedimentos Armazenados na etapa 5, selecione os procedimentos que deseja extrair ou clique em Selecionar Tudo para extrair todos e clique em Próximo.

  8. Selecione se deseja que os itens que passaram por engenharia reversa sejam adicionados automaticamente à página atual.

    Observação: É possível optar para que o assistente crie automaticamente o desenho, além de listar os itens que passaram por engenharia reversa na janela de Tabelas e Exibições. Se decidir por não criar o desenho automaticamente, pode arrastar os itens da janela de Tabelas e Exibições para sua página de desenho para reunir manualmente o modelo de banco de dados.

  9. Examine as seleções para confirmar que está extraindo as informações desejadas e clique em Terminar.

    O assistente extrairá as informações selecionadas e exibir as anotações sobre o processo de extração na janela Saída.

Se você tiver um modelo VisioModeler ou PLATINUM ERwin existente, pode ser possível importá-lo para criar um diagrama de modelo de banco de dados do Visio. Esse recurso se limita apenas aos arquivos de modelo de dicionário VisioModeler 2.0 (.imd) ou posteriores e arquivos .erx PLATINUM ERwin 2.6, 3.0 e 3.52.

  1. No menu Arquivo, aponte para Novo e depois para Software e Banco de Dadose clique em Diagrama de Modelo de Banco de Dados.

  2. No menu Banco de Dados, aponte para Importação e clique em Importar <tipo de modelo>.

  3. Digite o nome do caminho e do arquivo do modelo que deseja importar ou clique no botão Navegar, para localizar o arquivo de modelo e clique em Abrir.

  4. Na caixa de diálogo Importar, selecione OK.

    O Visio importa o arquivo e exibe o andamento na janela Saída. As tabelas importadas são exibidas na janela de Tabelas e Exibições.

  5. Na janela de Tabelas e Exibições, selecione as tabelas que deseja modelar e depois arraste-as para a página de desenho.

2: Refinar a estrutura do diagrama

Após criar um diagrama de modelo de banco de dados, começa o trabalho de refinar o diagrama. Você pode adicionar e personalizar os três principais componentes de um modelo:

  • Entidades (ou tabelas),

  • Colunas (que descrevem os fatos sobre uma tabela) e

  • Relações (associações entre as tabelas). Os relacionamentos podem ser de um para um, um para muitos ou muitos para muitos.

Selecione um título abaixo para abrir instruções sobre como adicionar o recurso ao seu modelo.

Existem dois estênceis que acompanham o modelo de Diagrama de Modelo de Banco de Dados. À medida que você começa a refinar a estrutura do diagrama, trabalhe a partir do estêncil ideal para você:

  • Use o estêncil Relacionamento entre Entidades para modelar os bancos de dados com base em SQL92 e padrões anteriores.

  • Use o estêncil Objeto Relacional, que tem outras formas para trabalhar com tipos, para modelar bancos de dados com base em SQL99 e padrões posteriores.

Use a formaEntidade para criar uma tabela no diagrama:

  1. No estêncil Relacionamento entre Entidades ou Objeto Relacional, arraste uma forma Entidade para o desenho.

  2. Clique duas vezes na forma para abrir a janela Propriedades do Banco de Dados.

  3. Em Categorias, clique em Definição e digite um nome para a tabela.

  4. Em Categorias, clique em Colunas, digite um nome e escolha um tipo de dados.

  5. Selecione a caixa de seleção Necessário para as colunas que não podem ter valores nulos.

  6. Selecione a caixa de seleção PK (chave primária) para colunas que identificam exclusivamente cada linha na tabela de banco de dados.

  7. Em Categorias, clique em Índices, Gatilhos, Verificação ou Estendida para criar esses elementos opcionais.

Use a janela Propriedades do Banco de Dados para adicionar ou alterar as propriedades das colunas, incluindo tipos de dados e chaves primárias:

  1. Clique duas vezes na tabela do seu diagrama.

  2. Na janela Propriedades do Banco de Dados, em Categorias, clique em Colunas.

  3. Clique na primeira célula vazia Nome Físico e digite um nome.

  4. Para alterar o tipo dos dados de uma coluna, clique no campo Tipo de Dados da coluna e selecione um tipo de dados ou digite na lista. Por exemplo, você pode digitar decimal(8,2) ou char(30).

  5. Para evitar valores nulos, marque a caixa de seleção Necessário.

  6. Para especificar que a coluna é uma chave primária, marque a caixa de seleção PK.

  7. Para ver mais propriedades da coluna, além das que aparecem ao clicar na categoria Colunas, selecione a coluna e clique em Editar.

Os relacionamentos usam chaves primárias e estrangeiras para que os bancos de dados façam a correspondência de uma linha de uma tabela com uma linha de outra tabela relacionada. Você pode exibir esses relacionamentos no diagrama. Além disso, você pode definir a cardinalidade deles (por exemplo, um para muitos) e usar as notações Pé de galinha, Relacional ou IDEF1X para mostrar a cardinalidade. Não é possível exibir relacionamentos do tipo muitos para muitos com nenhuma dessas notações no exemplo de Diagrama de Modelo de Banco de Dados.

Crie um relacionamento entre tabelas:

  1. Ambas as tabelas devem estar visíveis no diagrama. Se você fez a engenharia reversa do modelo de um banco de dados existente, talvez seja necessário arrastar uma ou ambas da janela de Tabelas e Exibições para a página de desenho.

  2. Clique duas vezes na tabela desejada para o lado da chave primária do relacionamento.

  3. Na janela Propriedades do Banco de Dados, em Categorias, clique em Colunas.

  4. Na grade, clique na coluna que deseja usar para identificar exclusivamente cada linha na tabela e selecione a caixa de seleção PK para defini-la como a chave primária.

  5. Do estêncil Objeto Relacional ou Relacionamento entre Entidades, arraste uma forma Relacionamento e solte-a em um espaço em branco na página.

  6. Conecte a extremidade superior à tabela com a tabela pai.

  7. Conecte a outra extremidade à tabela filha.

    Se a segunda tabela não contiver já uma coluna com o mesmo nome da chave primária, o modelador a adicionará à segunda tabela como uma chave estrangeira.

    Observação: Se as linhas de relacionamento desaparecerem, na guia Banco de Dados, no grupo Gerenciar, clique em Opções de Exibição. Na guia Relacionamentos, em Mostrar, selecione a caixa de seleção Relacionamentos.

Defina a cardinalidade do relacionamento:

  1. Clique duas vezes no relacionamento.

  2. Na janela Propriedades do Banco de Dados, em Categorias, clique em Diversos.

  3. Em Cardinalidade, escolha a que melhor atende ao relacionamento. Para relacionamentos do tipo um para muitos, a melhor opção é Zero ou mais ou Um ou mais. Para relacionamentos do tipo um para um, a melhor opção é Zero ou um ou Exatamente um.

3: Adicionar recursos de pesquisa e atualização de dados

Para fazer outros refinamentos no diagrama (como criar índices, cláusulas de verificação e acionadores), selecione um cabeçalho abaixo para abrir instruções sobre como adicionar um dos seguintes procedimentos:

Os índices melhoram o desempenho ou a velocidade do banco de dados durante a execução de uma consulta.

  1. Abra o diagrama de modelo de banco de dados.

  2. Clique duas vezes na tabela em que deseja adicionar um índice e, na janela Propriedades do Banco de Dados, na lista de Categorias, clique em Índices.

  3. Clique em Novo.

  4. Na caixa de diálogo Criar Índice, digite um nome para o índice e clique em OK.

  5. Na lista Tipo de Índice , selecione uma opção para criar um índice exclusivo ou não exclusivo.

  6. Na lista Colunas Disponíveis, selecione o nome de cada coluna que deseja incluir nesse índice e clique em Adicionar >.

  7. Na lista Colunas Indexadas, selecione a caixa de seleção Cresc. para criar um índice com uma ordem de classificação crescente, ou desmarque a caixa de seleção para criar um índice com uma ordem de classificação decrescente.

    O diagrama de modelo de banco de dados será atualizado.

Você pode encarar um modo de exibição como uma consulta salva. Os modos de exibição são especialmente úteis quando você precisa acessar várias vezes as mesmas informações de várias tabelas ou quando deseja expor os dados para os usuários sem deixar que eles alterem as tabelas reais.

No estêncil Relacionamento entre Entidades ou Objeto Relacional, arraste para o desenho uma forma Modo de Exibição.

Dependendo do seu sistema de gerenciamento de banco de dados (DBMS), pode ser possível definir propriedades estendidas para tabelas ou modos de exibição a fim de determinar onde serão armazenadas.

Clique duas vezes na tabela ou modo de exibição cujas propriedades estendidas deseja definir e, na janela Propriedades do Banco de Dados, na lista Categorias, clique em Estendido.

Use cláusulas de verificação para garantir que os dados inseridos em uma coluna estejam dentro de um determinado intervalo de valores. Por exemplo, é possível criar uma cláusula de verificação que exija que os dados em uma coluna chamada "Idade" sejam mais que 65.

  1. Clique duas vezes na tabela para abrir a janela Propriedades do Banco de Dados.

  2. Em Categorias, clique em Colunas e depois clique na coluna em que deseja adicionar uma cláusula de verificação.

  3. Clique em Editar.

  4. Na guia Verificar da caixa de diálogo Propriedades da Coluna, insira as restrições desejadas. Confira mais informações sobre suas escolhas em Caixa de diálogo Propriedades do Campo e da Coluna (guia de verificação).

    A cláusula de verificação será adicionada à Janela de Código em Código local.

Use os procedimentos armazenados e as funções definidas pelo usuário para criar pacotes de código que podem ser reusados na execução das mesmas ações várias vezes. A principal diferença entre os dois é que uma função definida pelo usuário retorna um valor, enquanto o procedimento armazenado executa um código sem retornar um valor.

  1. Na guia Banco de Dados, no grupo Mostrar/Ocultar, selecione a caixa de seleção Código para abrir a janela de Código.

  2. Clique em Código global e em Novo.

  3. Na guia Propriedades do Editor de Códigos, clique no tipo de código que deseja criar e digite um nome para ele.

  4. Na guia Corpo, digite o código e clique em OK.

Os gatilhos fazem com que um código SQL especificado no gatilho seja executado na ocorrência de um evento específico no banco de dados.

  1. Clique duas vezes na tabela para abrir a janela Propriedades do Banco de Dados.

  2. Em Categorias, clique em Gatilhose em Adicionar.

  3. Na guia Propriedades, digite um nome para o gatilho.

  4. Na guia Corpo, digite o código e clique em OK.

    O gatilho será adicionado à Janela de Código em Código local.

Não consegue encontrar os recursos de modelagem do banco de dados?

Algumas edições de Visio não têm alguns ou todos os recursos de modelagem de banco de dados:

  • O Visio Standard não inclui o modelo Diagrama de Modelo do Banco de Dados.

  • As edições Visio Professional e Premium são compatíveis com os recursos de engenharia reversa para o exemplo de Diagrama de Modelo de Banco de Dados (ou seja, usar um banco de dados existente para criar um modelo do Visio), mas não é compatível com a engenharia direta (isto é, usar um modelo de banco de dados do Visio para gerar um código SQL).

  • O conjunto completo de recursos de modelagem de banco de dados, incluindo engenharia reversa e engenharia direta, está no Visio for Enterprise Architects. Visio para Enterprise Architects está incluído no MSDN assinatura Premium, o que está disponível com o Visual Studio Professional e o Visual Studio Team System edições baseado na função.

Para saber qual é sua edição do Visio, clique em Sobre o Microsoft Office Visio no menu Ajuda. O nome da edição fica na linha superior de texto na caixa de diálogo.

Se você estiver usando Plano do Visio 2 e quiser saber mais sobre como fazer a engenharia de um banco de dados existente para um modelo de banco de dados, confira, engenharia reversa de um banco de dados existente.

Confira também

Definir uma relação em um diagrama de modelo de banco de dados

Criar ou editar exibições em diagramas de modelo de banco de dados

Adicionar tabelas e colunas a diagramas de modelos de banco de dados

Definir e editar tipos de dados em diagramas de modelos de banco de dados

Exibir notação de Pé de Galinha em um diagrama de modelo de banco de dados

Criar ou editar um índice em um diagrama de modelo de banco de dados

Preservar a integridade referencial em diagramas de modelo de banco de dados

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×