Criar um modelo de banco de dados (também conhecido como diagrama de Relação de Entidade)

Criar um modelo de banco de dados (também conhecido como diagrama de Relação de Entidade)

Observação:  Desejamos fornecer o conteúdo da Ajuda mais recente no seu idioma da forma mais rápida possível. Esta página foi traduzida de forma automatizada e pode conter imprecisões ou erros gramaticais. Nosso objetivo é que este conteúdo seja útil para você. As informações foram úteis? Dê sua opinião no final desta página. Aqui está o artigo em inglês para facilitar a referência.

Com o modelo de diagrama de modelo de banco de dados, você pode criar um novo modelo ou fazer engenharia reversa de um banco de dados existente para um modelo usando qualquer um do relacional ou conceitos de modelagem relacional do objeto. Use o estêncil de relação de entidade para bancos de dados de modelo que são baseados no SQL92 e padrões anteriores. Use o estêncil relacional do objeto, que tem formas adicionais para trabalhar com tipos de bancos de dados de modelo que são baseados em padrões posteriores e SQL99.

Exemplo de modelo de banco de dados

Com o modelo de diagrama de modelo de banco de dados, você pode criar um novo modelo ou fazer engenharia reversa de um banco de dados existente para um modelo usando qualquer um do relacional ou conceitos de modelagem relacional do objeto. Use o estêncil de relação de entidade para bancos de dados de modelo que são baseados no SQL92 e padrões anteriores. Use o estêncil relacional do objeto, que tem formas adicionais para trabalhar com tipos de bancos de dados de modelo que são baseados em padrões posteriores e SQL99.

Este artigo descreve como você pode criar um modelo de banco de dados e o que você pode fazer com o modelo depois de criá-lo.

Não consegue encontrar o banco de dados recursos de modelo?

Não todas as edições do Microsoft Visio tem o recurso de modelo de banco de dados. Se você não conseguir encontrar os recursos descritos os procedimentos neste artigo, provavelmente você possui uma edição do Visio que não inclui-los.

  • Microsoft Visio Standard não inclui o modelo de diagrama de modelo de banco de dados.

  • Edições do Microsoft Visio Professional e Premium permitem recursos de engenharia reversa para o modelo de diagrama de modelo de banco de dados (ou seja, usando um banco de dados existente para criar um modelo no Visio), mas não suporta engenharia avançada (ou seja, usando um arquivo do Visio modelo de banco de dados para gerar o código SQL).

  1. Para iniciar o diagrama de modelo de banco de dados, siga um destes procedimentos:

    Criar um novo diagrama de modelo do zero

    Se você não tiver um banco de dados existente que você deseja usar como um ponto de partida, você pode começar com um modelo de banco de dados em branco e adicionar suas próprias tabelas e relações.

    1. Clique na guia Arquivo.

    2. Clique em novo, clique em Software e banco de dados e, em seguida, clique duas vezes no Diagrama de modelo de banco de dados.

    3. Na guia banco de dados, no grupo Gerenciar, clique em Opções de exibição.

    4. Na caixa de diálogo Opções de documento de banco de dados, selecione o conjunto de símbolos que você deseja usar e outras opções de tabela e de relação e clique em Okey.

    Usar um banco de dados existente como ponto de partida

    Se você tiver um banco de dados que você deseja para que você possa compreendê-lo melhor ou usá-lo como um ponto de partida para um novo modelo de modelo, você pode usar o Assistente de engenharia reversa para extrair o esquema, ou estrutura, do banco de dados e criar um novo modelo.

    Antes de iniciar o Assistente:

    1. Se você estiver inversa antes de iniciar o Assistente de engenharia uma pasta de trabalho do Microsoft Excel, é necessário abrir a pasta de trabalho e o nome do grupo (ou intervalo) de células que contém os títulos de coluna. Se você quiser usar mais de uma planilha, basta Nomeie o grupo de células de coluna em cada planilha. Esses intervalos são tratados como tabelas do assistente. Para obter mais informações sobre como nomear um intervalo de células, consulte o tópico na sua Ajuda do Excel intitulado defina nomeados referências de células ou intervalos.

    2. Para obter melhores resultados, defina o driver padrão para o banco de dados de destino que você deseja fazer engenharia reversa antes de executar o Assistente de engenharia reversa. Esta etapa garante que o assistente mapeia os tipos de dados nativos corretamente e que todo o código extraído pelo assistente corretamente é exibido na janela de código.

    3. Clique na guia Arquivo.

    4. Clique em novo, clique em Software e banco de dados e, em seguida, clique duas vezes no Diagrama de modelo de banco de dados.

    5. Na guia banco de dados, no grupo de modelo, clique em Engenharia reversa.

    6. Na primeira tela do Assistente de engenharia reversa, faça o seguinte:

      1. Selecione o driver de banco de dados para o seu sistema de gerenciamento de banco de dados (DBMS). Se você já não associado o driver de banco de dados do Visio com uma fonte de dados ODBC específica, clique em Configurar.

        Observação: Se você for uma planilha do Excel de engenharia reversa, escolha o Driver genérico ODBC.

      2. Selecione a fonte de dados do banco de dados que você está atualizando. Se você já não tiver criado uma fonte de dados para o banco de dados existente, clique em novo para fazer isso agora.

        Quando você cria uma nova fonte, seu nome é adicionado à lista de Fontes de dados.

      3. Quando você estiver satisfeito com as configurações, clique em Avançar.

    7. Siga as instruções em qualquer caixa de diálogo específica do driver.

      Por exemplo, na caixa de diálogo Conectar fonte de dados, digite o nome de usuário e senha e clique em Okey.

      Observação: Se você usa o Driver genérico ODBC, você pode receber uma mensagem de erro que indica que as informações de engenharia reversa podem estar incompletas. Na maioria dos casos, isso não é um problema — basta clicar Okey e continuar com o assistente.

    8. Marque as caixas de seleção para o tipo de informação que você deseja extrair e clique em Avançar.

      Observação: Alguns itens podem estar indisponíveis (aparecem esmaecidas) porque nem todos os sistemas de gerenciamento de banco de dados oferece suporte a todos os tipos de elementos que o assistente pode extrair.

    9. Selecione as caixas de seleção para as tabelas (e modos de exibição, se houver) que você deseja extrair, ou clique em Selecionar tudo para extrair todos e, em seguida, clique em Avançar.

      Observação: Se você for uma planilha do Excel de engenharia reversa e não ver nada nesta lista, é provável que você precise nomear o intervalo de células que contém os títulos de coluna em sua planilha.

    10. Se você selecionou a caixa de seleção de Procedimentos armazenados, selecione os procedimentos que você deseja extrair, ou clique em Selecionar tudo para extrai-los todos e, em seguida, clique em Avançar.

    11. Selecione se deseja que os itens com engenharia reversa a ser adicionado automaticamente à página atual.

      Observação: Você pode optar por que o assistente crie automaticamente o desenho, além para listar itens com engenharia reversa na janela tabelas e exibições. Se você decidir não tiver criado automaticamente o desenho, você pode arrastar os itens da janela tabelas e modos de exibição para sua página de desenho para reunir manualmente o modelo de banco de dados.

    12. Examine as seleções para verificar se você está extraindo as informações que você deseja e clique em Concluir.

      O assistente extrai as informações selecionadas e exibe observações sobre o processo de extração na janela de saída.

    Importar e refinar um modelo existente

    Se você tiver um modelo de VisioModeler ou PLATINUM ERwin existente, você poderá importá-lo para criar um diagrama de modelo de banco de dados do Visio. Essa capacidade está limitada aos somente VisioModeler 2.0 ou posteriores arquivos de modelo (. IMD) do dicionário e arquivos de erx PLATINUM ERwin 2.6, 3.0 e 3.52.

    1. Clique na guia Arquivo.

    2. Clique em novo, clique em Software e banco de dados e, em seguida, clique duas vezes no Diagrama de modelo de banco de dados.

    3. Na guia banco de dados, no grupo de modelo, clique em Importar e clique no tipo de modelo.

    4. Digite o caminho e o nome para o modelo que você deseja importar ou clique no botão Procurar para localizar o arquivo de modelo e clique em Abrir.

    5. Na caixa de diálogo Importar, clique em Okey.

      Visio importa o arquivo e exibe o seu progresso na janela de saída. As tabelas importadas são exibidas na janela tabelas e exibições.

    6. Na janela tabelas e exibições, selecione as tabelas que você deseja modelar e arraste-os para a página de desenho.

  2. Depois de criar um diagrama de modelo de banco de dados, o trabalho de refinamento diagrama começa. Você pode adicionar e personalizar tabelas e exibições, criar relações e personalizar colunas e tipos de dados.

    Tabelas

    Use a forma de entidade para criar uma tabela no seu diagrama.

    1. No estêncil Relação de entidade tanto na Relacional do objeto, arraste uma forma de entidade para o desenho.

    2. Clique duas vezes na forma para abrir a janela Propriedades de banco de dados.

    3. Em categorias, clique em definição e digite um nome para a tabela.

    4. Em categorias, clique em colunas, digite um nome e escolha um tipo de dados.

    5. Marque a caixa de seleção necessário para colunas que não podem ter valores nulos.

    6. Marque a caixa de seleção CP (chave primária) para colunas que identificam exclusivamente cada linha na tabela de banco de dados.

    7. Em categorias, clique em índices, disparadores, Verifique ou estendido para criar esses elementos opcionais.

    Colunas

    Use a janela Propriedades de banco de dados para adicionar ou alterar as propriedades de colunas, incluindo tipos de dados e chaves primárias.

    1. Clique duas vezes na tabela no seu diagrama.

    2. Na janela Propriedades de banco de dados, em categorias, clique em colunas.

    3. Clique na primeira célula Nome físico vazia e digite um nome.

    4. Para alterar o tipo de dados de uma coluna, clique em campo de Tipo de dados da coluna e selecione um tipo de dados na lista ou digite-a na lista. Por exemplo, você pode digitar decimal(8,2) ou char(30).

    5. Para evitar valores nulos, marque a caixa de seleção necessário .

    6. Para especificar que a coluna é uma chave primária, marque a caixa de seleção CP.

    7. Para ver mais propriedades da coluna além das que aparecem quando você clicar na categoria de colunas, selecione a coluna e clique em Editar.

    Relações

    Relações usam chaves primárias e estrangeiras para permitir bancos de dados para que correspondam a uma linha em uma tabela com uma linha em uma tabela relacionada. Você pode mostrar essas relações no diagrama. Além disso, você pode definir seu cardinalidade (por exemplo, um-para-muitos) e usar pés de galinha, relacional ou IDEF1X notação para mostrar a cardinalidade. Você não pode mostrar relações de muitos-para-muitos com qualquer um destas notações no modelo de diagrama de modelo de banco de dados.

    1. Crie uma relação entre tabelas:

      1. Certifique-se de que ambas as tabelas são visíveis no diagrama. Se você inversa engenharia o modelo de banco de dados existente, você talvez precise arraste um ou ambos da janela tabelas e modos de exibição para a página de desenho.

      2. Clique duas vezes na tabela que você deseja para o lado de chave primária da relação.

      3. Na janela Propriedades de banco de dados, em categorias, clique em colunas.

      4. Na grade, clique na coluna que você deseja usar para identificar exclusivamente cada linha na tabela e selecione a caixa de seleção CP defini-la como a chave primária.

      5. No estêncil Relacional do objeto ou Relação de entidade, arraste uma forma de relação e solte-um espaço em branco na página.

      6. Conecte a extremidade superior para a tabela com a tabela pai.

      7. Conecte a outra extremidade à tabela filho.

        Se a segunda tabela já não contém uma coluna com o mesmo nome que a chave primária, o Modelador adiciona-lo para a segunda tabela como uma chave estrangeira.

        Observação: Se as linhas de relação desaparecem, na guia banco de dados, no grupo Gerenciar, clique em Opções de exibição. Na guia relações, em Mostrar, marque a caixa de seleção de relações.

    2. Defina cardinalidade da relação:

      1. Clique duas vezes na relação.

      2. Na janela Propriedades de banco de dados, em categorias, clique em diversos.

      3. Em Cardinalidade, escolha a cardinalidade que melhor se adapte a relação. Para obter uma relação um-para-muitos, a melhor opção é Zero ou mais ou um ou mais. Para relações individual, a melhor opção é Zero ou um ou exatamente um.

  3. Para fazer outros ajustes ao seu diagrama (como a criação de índices, cláusulas de verificação e disparadores), você pode fazer o seguinte:

    Criar índices

    Índices de melhoram o desempenho ou a velocidade de seu banco de dados quando você executa uma consulta.

    1. Abra o diagrama de modelo de banco de dados.

    2. Clique duas vezes na tabela à qual você deseja adicionar um índice e na janela Propriedades de banco de dados, na lista categorias, clique em índices.

    3. Clique em Novo.

    4. Na caixa de diálogo Criar índice, digite um nome para o índice e clique em Okey.

    5. Na lista Tipo de índice, selecione uma opção para criar um índice exclusivo ou não exclusivo.

    6. Na lista Colunas disponíveis, selecione o nome de cada coluna que você deseja incluir nesse índice e clique Adicionar >.

    7. Na lista de Colunas indexadas, marque a caixa de seleção Asc para criar um índice com uma ordem de classificação crescente ou desmarque a caixa de seleção para criar um índice com uma ordem de classificação decrescente.

      O diagrama de modelo de banco de dados é atualizado.

    Criar modos de exibição

    Você pode pensar um modo de exibição como uma consulta salva. Modos de exibição são particularmente úteis se você precisar repetidamente acessar as mesmas informações de várias tabelas ou se você quiser expor os dados aos usuários sem permitindo que eles alterar as tabelas reais.

    No estêncil Relação de entidade ou Relacional do objeto, arraste uma forma de Exibir a página de desenho.

    Definir as propriedades estendidas para tabelas e exibições

    Dependendo do seu sistema de gerenciamento de banco de dados (DBMS), você poderá definir as propriedades estendidas para tabelas ou exibições para determinar onde eles estão armazenados.

    Clique duas vezes na tabela ou exibir cujas propriedades estendidas você deseja definir e, na janela Propriedades de banco de dados, na lista categorias, clique em estendidas.

    Criar cláusulas de verificação

    Use cláusulas de verificação para garantir que os dados inseridos em uma coluna estão em um determinado intervalo de valores. Por exemplo, você pode criar uma cláusula de verificação que requer os dados em uma coluna chamada "Idade" para ser mais 65.

    1. Clique duas vezes na tabela para abrir a janela Propriedades de banco de dados.

    2. Em categorias, clique em colunas e, em seguida, clique na coluna que você deseja adicionar uma cláusula de verificação para.

    3. Clique em Editar.

    4. Na guia Verificar da caixa de diálogo Propriedades da coluna, insira as restrições que desejar.

      A cláusula de verificação é adicionada à janela de código em código Local.

    Criar procedimentos armazenados e funções definidas pelo usuário

    Use procedimentos armazenados e funções definidas pelo usuário para criar pacotes do código que você pode reutilizar para executar as mesmas ações repetidamente. A principal diferença entre os dois é que uma função definida pelo usuário retorna um valor, enquanto o procedimento armazenado executa código sem retornar um valor.

    1. Na guia banco de dados, no grupo Mostrar/ocultar, marque a caixa de seleção de código para abrir a janela de código.

    2. Clique em Código Global e, em seguida, clique em novo.

    3. Na guia Propriedades do Editor de código, clique no tipo de código que você deseja criar e digite um nome para o código.

    4. Na guia corpo, digite o código e clique em Okey.

    Criar disparadores

    Disparadores causam código SQL que você especificar no disparador para ser executada quando ocorre um evento particular no banco de dados.

    1. Clique duas vezes na tabela para abrir a janela Propriedades de banco de dados.

    2. Em categorias, clique em disparadores e clique em Adicionar.

    3. Na guia Propriedades, digite um nome para o disparador.

    4. Na guia corpo, digite o código e clique em Okey.

      O disparador é adicionado à janela de código em código Local.

Este artigo descreve como você pode criar um modelo de banco de dados e o que você pode fazer com o modelo depois de criá-lo. Para o início rápido, no menu arquivo, aponte para novo, aponte para o banco de dados e Software e clique em Diagrama de modelo de banco de dados.

Não consegue encontrar o banco de dados recursos de modelo?

Provavelmente, a edição do Microsoft Office Visio não inclui os recursos que você está procurando. Para descobrir qual edição do Visio, clique em Sobre o Microsoft Office Visio no menu Ajuda. O nome da edição é na linha superior do texto na caixa de diálogo.

  • Microsoft Office Visio Standard não inclui o modelo de diagrama de modelo de banco de dados.

  • Microsoft Office Visio Professional oferece suporte a recursos de engenharia reversa para o modelo de diagrama de modelo de banco de dados (ou seja, usando um banco de dados existente para criar um modelo no Visio), mas não suporta engenharia avançada (ou seja, usando um banco de dados do Visio modelo para gerar código SQL).

  • Você pode encontrar os recursos de modelagem, incluindo engenharia reversa e encaminhar engenharia, no Visio for Enterprise Architects para o pacote completo de banco de dados. O Visio for Enterprise Architects está incluído no MSDN inscrição Premium, que está disponível com o Visual Studio Professional e edições baseadas em função do Visual Studio Team System.

  1. Para iniciar o diagrama de modelo de banco de dados, siga um destes procedimentos:

    Criar um novo diagrama de modelo do zero

    Se você não tiver um banco de dados existente que você deseja usar como um ponto de partida, você pode começar com um modelo de banco de dados em branco e adicionar suas próprias tabelas e relações.

    1. No menu arquivo, aponte para novo, aponte para o banco de dados e Software e clique em Diagrama de modelo de banco de dados.

    2. No menu banco de dados, aponte para Opções e clique em documento.

    3. Na caixa de diálogo Opções de documento de banco de dados, selecione o conjunto de símbolos que você deseja usar e outras opções de tabela e de relação e clique em Okey.

    Usar um banco de dados existente como ponto de partida

    Se você tiver um banco de dados que você deseja para que você possa compreendê-lo melhor ou usá-lo como um ponto de partida para um novo modelo de modelo, você pode usar o Assistente de engenharia reversa para extrair o esquema, ou estrutura, do banco de dados e criar um novo modelo.

    Observação: Antes de iniciar o Assistente:

    1. Se você estiver inversa antes de iniciar o Assistente de engenharia uma pasta de trabalho do Microsoft Office Excel, é necessário abrir a pasta de trabalho e o nome do grupo (ou intervalo) de células que contém os títulos de coluna. Se você quiser usar mais de uma planilha, basta Nomeie o grupo de células de coluna em cada planilha. Esses intervalos são tratados como tabelas do assistente. Para obter mais informações sobre como nomear um intervalo de células, consulte o tópico no seu Microsoft Office Excel ajuda intitulada defina nomeados referências de células ou intervalos.

    2. Para obter melhores resultados, defina o driver padrão para o banco de dados de destino que você deseja fazer engenharia reversa antes de executar o Assistente de engenharia reversa. Esta etapa garante que o assistente mapeia os tipos de dados nativos corretamente e que todo o código extraído pelo assistente corretamente é exibido na janela de código.

    3. No menu arquivo, aponte para novo, aponte para o banco de dados e Software e clique em Diagrama de modelo de banco de dados.

    4. No menu banco de dados, clique em Engenharia reversa.

    5. Na primeira tela do Assistente de engenharia reversa, faça o seguinte:

      1. Selecione o driver de banco de dados do Microsoft Office Visio para seu sistema de gerenciamento de banco de dados (DBMS). Se você já não associado o driver de banco de dados do Visio com uma fonte de dados ODBC específica, clique em Configurar.

        Observação: Se você for uma planilha do Excel de engenharia reversa, escolha o Driver genérico ODBC.

      2. Selecione a fonte de dados do banco de dados que você está atualizando. Se você já não tiver criado uma fonte de dados para o banco de dados existente, clique em novo para fazer isso agora.

        Quando você cria uma nova fonte, seu nome é adicionado à lista de Fontes de dados.

      3. Quando você estiver satisfeito com as configurações, clique em Avançar.

    6. Siga as instruções em qualquer caixa de diálogo específica do driver.

      Por exemplo, na caixa de diálogo Conectar fonte de dados, digite um nome de usuário e senha e clique em Okey. Se sua fonte de dados não estiver protegido por senha, basta clicar em Okey.

      Observação: Se você usa o Driver genérico ODBC, você pode receber uma mensagem de erro que indica que as informações de engenharia reversa podem estar incompletas. Na maioria dos casos, isso não é um problema — basta clicar Okey e continuar com o assistente.

    7. Marque as caixas de seleção para o tipo de informação que você deseja extrair e clique em Avançar.

      Observação: Alguns itens podem estar indisponíveis (aparecem esmaecidas) porque nem todos os sistemas de gerenciamento de banco de dados oferece suporte a todos os tipos de elementos que o assistente pode extrair.

    8. Selecione as caixas de seleção para as tabelas (e modos de exibição, se houver) que você deseja extrair, ou clique em Selecionar tudo para extrair todos e, em seguida, clique em Avançar.

      Observação: Se você for uma planilha do Excel de engenharia reversa e não ver nada nesta lista, é provável que você precise nomear o intervalo de células que contém os títulos de coluna em sua planilha.

    9. Se você selecionou a caixa de seleção Procedimentos armazenados na etapa 5, selecione os procedimentos que você deseja extrair, ou clique em Selecionar tudo para extrai-los todos e, em seguida, clique em Avançar.

    10. Selecione se deseja que os itens com engenharia reversa a ser adicionado automaticamente à página atual.

      Observação: Você pode optar por que o assistente crie automaticamente o desenho, além para listar itens com engenharia reversa na janela tabelas e exibições. Se você decidir não tiver criado automaticamente o desenho, você pode arrastar os itens da janela tabelas e modos de exibição para sua página de desenho para reunir manualmente o modelo de banco de dados.

    11. Examine as seleções para verificar se você está extraindo as informações que você deseja e clique em Concluir.

      O assistente extrai as informações selecionadas e exibe observações sobre o processo de extração na janela de saída.

    Importar e refinar um modelo existente

    Se você tiver um modelo de VisioModeler ou PLATINUM ERwin existente, você poderá importá-lo para criar um diagrama de modelo de banco de dados do Visio. Essa capacidade está limitada aos somente VisioModeler 2.0 ou posteriores arquivos de modelo (. IMD) do dicionário e arquivos de erx PLATINUM ERwin 2.6, 3.0 e 3.52.

    1. No menu arquivo, aponte para novo, aponte para o banco de dados e Software e clique em Diagrama de modelo de banco de dados.

    2. No menu banco de dados, aponte para Importar e clique em Importar < tipo de modelo >.

    3. Digite o caminho e o nome para o modelo que você deseja importar ou clique no botão Procurar para localizar o arquivo de modelo e clique em Abrir.

    4. Na caixa de diálogo Importar, clique em Okey.

      Visio importa o arquivo e exibe o seu progresso na janela de saída. As tabelas importadas são exibidas na janela tabelas e exibições.

    5. Na janela tabelas e exibições, selecione as tabelas que você deseja modelar e arraste-os para a página de desenho.

  2. Depois de criar um diagrama de modelo de banco de dados, o trabalho de refinamento diagrama começa. Você pode adicionar e personalizar tabelas e exibições, criar relações e personalizar colunas e tipos de dados.

    Tabelas

    Use a forma de entidade para criar uma tabela no seu diagrama.

    1. No estêncil Relação de entidade tanto na Relacional do objeto, arraste uma forma de entidade para o desenho.

    2. Clique duas vezes na forma para abrir a janela Propriedades de banco de dados.

    3. Em categorias, clique em definição e digite um nome para a tabela.

    4. Em categorias, clique em colunas, digite um nome e escolha um tipo de dados.

    5. Marque a caixa de seleção necessário para colunas que não podem ter valores nulos.

    6. Marque a caixa de seleção CP (chave primária) para colunas que identificam exclusivamente cada linha na tabela de banco de dados.

    7. Em categorias, clique em índices, disparadores, Verifique ou estendido para criar esses elementos opcionais.

    Colunas

    Use a janela Propriedades de banco de dados para adicionar ou alterar as propriedades de colunas, incluindo tipos de dados e chaves primárias.

    1. Clique duas vezes na tabela no seu diagrama.

    2. Na janela Propriedades de banco de dados, em categorias, clique em colunas.

    3. Clique no primeiro nome físico vazia da célula e digite um nome.

    4. Para alterar o tipo de dados de uma coluna, clique em campo de Tipo de dados da coluna e selecione um tipo de dados na lista ou digite-a na lista. Por exemplo, você pode digitar decimal(8,2) ou char(30).

    5. Para evitar valores nulos, marque a caixa de seleção necessário .

    6. Para especificar que a coluna é uma chave primária, marque a caixa de seleção CP.

    7. Para ver mais propriedades da coluna além das que aparecem quando você clicar na categoria de colunas, selecione a coluna e clique em Editar.

    Relações

    Relações usam chaves primárias e estrangeiras para permitir bancos de dados para que correspondam a uma linha em uma tabela com uma linha em uma tabela relacionada. Você pode mostrar essas relações no diagrama. Além disso, você pode definir seu cardinalidade (por exemplo, um-para-muitos) e usar pés de galinha, relacional ou IDEF1X notação para mostrar a cardinalidade. Você não pode mostrar relações de muitos-para-muitos com qualquer um destas notações no modelo de diagrama de modelo de banco de dados.

    1. Crie uma relação entre tabelas:

      1. Certifique-se de que ambas as tabelas são visíveis no diagrama. Se você inversa engenharia o modelo de banco de dados existente, você talvez precise arraste um ou ambos da janela tabelas e modos de exibição para a página de desenho.

      2. Clique duas vezes na tabela que você deseja para o lado de chave primária da relação.

      3. Na janela Propriedades de banco de dados, em categorias, clique em colunas.

      4. Na grade, clique na coluna que você deseja usar para identificar exclusivamente cada linha na tabela e selecione a caixa de seleção CP defini-la como a chave primária.

      5. No estêncil Relacional do objeto ou Relação de entidade, arraste uma forma de relação e solte-um espaço em branco na página.

      6. Conecte a extremidade superior para a tabela com a tabela pai.

      7. Conecte a outra extremidade à tabela filho.

        Se a segunda tabela já não contém uma coluna com o mesmo nome que a chave primária, o Modelador adiciona-lo para a segunda tabela como uma chave estrangeira.

        Observação: Se as linhas de relação desaparecem, no menu banco de dados, aponte para Opções e clique em documento. Na guia relações, em Mostrar, marque a caixa de seleção de relações.

    2. Defina cardinalidade da relação:

      1. Clique duas vezes na relação.

      2. Na janela Propriedades de banco de dados, em categorias, clique em diversos.

      3. Em Cardinalidade, escolha a cardinalidade que melhor se adapte a relação. Para obter uma relação um-para-muitos, a melhor opção é Zero ou mais ou um ou mais. Para relações individual, a melhor opção é Zero ou um ou exatamente um.

  3. Para fazer outros ajustes ao seu diagrama (como a criação de índices, cláusulas de verificação e disparadores), você pode fazer o seguinte:

    Criar índices

    Índices de melhoram o desempenho ou a velocidade de seu banco de dados quando você executa uma consulta.

    1. Abra o diagrama de modelo de banco de dados.

    2. Clique duas vezes na tabela à qual você deseja adicionar um índice e na janela Propriedades de banco de dados, na lista categorias, clique em índices.

    3. Clique em Novo.

    4. Na caixa de diálogo Criar índice, digite um nome para o índice e clique em Okey.

    5. Na lista Tipo de índice, selecione uma opção para criar um índice exclusivo ou não exclusivo.

    6. Na lista Colunas disponíveis, selecione o nome de cada coluna que você deseja incluir nesse índice e clique Adicionar >.

    7. Na lista de Colunas indexadas, marque a caixa de seleção Asc para criar um índice com uma ordem de classificação crescente ou desmarque a caixa de seleção para criar um índice com uma ordem de classificação decrescente.

      O diagrama de modelo de banco de dados é atualizado.

    Criar modos de exibição

    Você pode pensar um modo de exibição como uma consulta salva. Modos de exibição são particularmente úteis se você precisar repetidamente acessar as mesmas informações de várias tabelas ou se você quiser expor os dados aos usuários sem permitindo que eles alterar as tabelas reais.

    No estêncil Relação de entidade ou Relacional do objeto, arraste uma forma de Exibir a página de desenho.

    Definir as propriedades estendidas para tabelas e exibições

    Dependendo do seu sistema de gerenciamento de banco de dados (DBMS), você poderá definir as propriedades estendidas para tabelas ou exibições para determinar onde eles estão armazenados.

    Clique duas vezes na tabela ou exibir cujas propriedades estendidas você deseja definir e, na janela Propriedades de banco de dados, na lista categorias, clique em estendidas.

    Criar cláusulas de verificação

    Use cláusulas de verificação para garantir que os dados inseridos em uma coluna estão em um determinado intervalo de valores. Por exemplo, você pode criar uma cláusula de verificação que requer os dados em uma coluna chamada "Idade" para ser mais 65.

    1. Clique duas vezes na tabela para abrir a janela Propriedades de banco de dados.

    2. Em categorias, clique em colunas e, em seguida, clique na coluna que você deseja adicionar uma cláusula de verificação para.

    3. Clique em Editar.

    4. Na guia Verificar da caixa de diálogo Propriedades da coluna, insira as restrições que desejar. Para saber mais sobre as opções, consulte caixa de diálogo coluna e propriedades de campo (guia verificar).

      A cláusula de verificação são adicionados à janela de código em código Local.

    Criar procedimentos armazenados e funções definidas pelo usuário

    Use procedimentos armazenados e funções definidas pelo usuário para criar pacotes do código que você pode reutilizar para executar as mesmas ações repetidamente. A principal diferença entre os dois é que uma função definida pelo usuário retorna um valor, enquanto o procedimento armazenado executa código sem retornar um valor.

    1. No menu banco de dados, aponte para Exibir e clique em código para abrir a janela de código.

    2. Clique em Código Global e, em seguida, clique em novo.

    3. Na guia Propriedades do Editor de código, clique no tipo de código que você deseja criar e digite um nome para o código.

    4. Na guia corpo, digite o código e clique em Okey.

    Criar disparadores

    Disparadores causam código SQL que você especificar no disparador para ser executada quando ocorre um evento particular no banco de dados.

    1. Clique duas vezes na tabela para abrir a janela Propriedades de banco de dados.

    2. Em categorias, clique em disparadores e clique em Adicionar.

    3. Na guia Propriedades, digite um nome para o disparador.

    4. Na guia corpo, digite o código e clique em Okey.

      O disparador é adicionado à janela de código em código Local.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×