Criar um diagrama do Visualizador de Dados

Observação:  Desejamos fornecer o conteúdo da Ajuda mais recente no seu idioma da forma mais rápida possível. Esta página foi traduzida de forma automatizada e pode conter imprecisões ou erros gramaticais. Nosso objetivo é que este conteúdo seja útil para você. As informações foram úteis? Dê sua opinião no final desta página. Aqui está o artigo em inglês para facilitar a referência.

Você gostaria de criar um fluxograma do Visio detalhado e requintado automaticamente a partir de uma pasta de trabalho do Excel? Você pode fazer isso usando os modelos de Visualizador de Dados. Cada modelo tem uma pasta de trabalho do Excel associada usada para converter os dados do processo em um fluxograma do Visio. Você também pode usar seu próprio modelo personalizado do Excel, mapear dados do Excel para formas em Criar Diagrama do assistente de Dados e criar automaticamente o diagrama. Você pode ainda adicionar colunas adicionais de dados no Excel que são convertidas em dados no formato do Visio.

O Visio também oferece suporte à sincronização bilateral entre o diagrama do Visio e a pasta de trabalho do Excel. Além de criar o fluxograma, editando dados no Excel e atualizando o diagrama do Visio, você também pode fazer alterações no Diagrama do Visio e atualizar os dados do Excel no diagrama. 

Visão geral do Visualizador de Dados

A capacidade de usar os modelos do Visualizador de Dados está disponível somente com o Visio Online Plan 2 no Canal de lançamento atual. Se não tem certeza de qual versão do Visio está usando, selecione Arquivo > Conta > Sobre o Visio. Confira Visio Online Plan 2 para saber mais sobre a versão de assinatura do Visio.

Caso você não encontre os modelos do Visualizador de Dados ou tenha outras dúvidas sobre como começar, acesse a página Perguntas frequentes do Visualizador de Dados.

Observação: Para usá-lo, você deve ter uma assinatura do Office 365. Se você é um assinante do Office 365, certifique-se de ter a versão mais recente do Office. Se você é um profissional de TI que gerencia o processo de atualização do Office 365, confira a página de lançamentos para canais, para saber quais atualizações são fornecidas em cada canal.

Neste artigo

Criar um diagrama do Visualizador de Dados

Antes de começar

Reúna suas ideias e elabore-as em formato de rascunho usando uma folha de papel ou a escrita à tinta. Esse rascunho inicial pode ajudá-lo a colocar seu trabalho em movimento e a facilitar as etapas seguintes.

Para criar um diagrama do Visualizador de Dados, você pode trabalhar simultaneamente no Excel e no Visio. Talvez você ache mais fácil trabalhar em duas janelas no seu dispositivo Windows ou em um ambiente com vários monitores. A comparação visual do seu trabalho entre o Excel e o Visio ajuda a confirmar que você está realmente fazendo o que pretende fazer.

Recomendado    Assista a este vídeo do Microsoft Office para vê-lo em ação: Visualizador de Dados: Demonstração.

Estágio 1: escolher um modelo do Visualizador de Dados

  1. Abra o Visio ou escolha Arquivo > Novo se você estiver editando um diagrama.

  2. Selecione MODELOS.

    O comando MODELOS
  3. Escolha Fluxograma.

    O comando Fluxograma
  4. Selecione fluxograma básico - Visualizador de dados, fluxograma multifuncional - Visualizador de dados ou diagrama de auditoria - Visualizador de dados.

    Os modelos do Visualizador de Dados

    Um modelo do Visualizador de dados tem um ícone do Excel no canto superior esquerdo.

Para obter mais informações sobre fluxogramas e suas formas, confira Criar um fluxograma básico e Criar um fluxograma multifuncional.

Estágio 2: criar uma pasta de trabalho do Excel

  1. Na visualização do modelo, selecione Modelo de dados do Excel.

    Como escolher o link do Modelo de Dados do Excel

    Observação    Se você quiser usar os mesmos modelos de amostra do Excel usados para referência neste artigo, baixe-os nos links a seguir:

  2. Escolha Arquivo > Salvar, especifique um computador, um servidor de rede ou uma biblioteca de documentos do SharePoint, insira um nome de arquivo e escolha Salvar.

  3. Para adicionar uma nova planilha, na parte inferior da pasta de trabalho, selecione Nova planilha Botão Nova Planilha .

  4. Crie uma tabela do Excel. Para obter mais informações sobre como usar tabelas do Excel, confira Visão geral de tabelas do Excel, Criar ou excluir uma tabela do Excel e Redimensionar uma tabela adicionando ou removendo linhas e colunas.

  5. Adicione linhas e colunas para a tabela que são usados para criar o diagrama do Visio. Há requisitos específicos para os cabeçalhos de coluna de tabela do Excel e os valores. Use a seção, colunas do Excel como interagem com componentes de fluxograma do Visio como um guia visual.

Estágio 3: adicionar mais dados de forma à tabela do Excel (opcional)

  1. Examine a guia Mapa de Processos no modelo do Excel. As colunas na tabela do Excel são verdes e azuis. A cor fornece uma pista visual sobre a diferença entre as colunas.

    As colunas azuis são usadas para criar o fluxograma no diagrama do Visio. Todas as colunas também são adicionadas como dados de forma.

  2. Para adicionar mais dados de forma, adicione uma ou mais colunas à sua tabela do Excel.

    As colunas verdes indicam outros dados de forma que você pode adicionar a cada forma. É possível acrescentar qualquer número de colunas adicionais. Por padrão, esses dados não ficam visíveis no diagrama, a menos que você adicione elementos gráficos de dados. Para ver os dados de forma no diagrama do Visio, selecione Dados > Janela Dados da Forma. Para obter mais informações sobre dados de forma e gráficos de dados, confira Adicionar dados a formas e Visão geral: gráficos de dados.

Estágio 4: criar um diagrama do Visio com o assistente

  1. Retorne ao Visio. Na visualização do modelo, selecione sua unidade de medida e clique em Criar.

  2. Na primeira página do assistente Criar Diagrama a partir de Dados, faça o seguinte:

    1. Em Que diagrama você deseja criar dos dados?, selecione um modelo: Fluxograma Básico, Fluxograma Multifuncional (horizontal) ou Fluxograma Multifuncional (vertical).

    2. Em Selecionar a pasta de trabalho do Excel, selecione uma pasta de trabalho na lista das pastas de trabalho usadas mais recentemente ou selecione Procurar para localizar a pasta de trabalho que você criou no Estágio 2.

    3. Em Selecione uma tabela ou um intervalo personalizado na pasta de trabalho, selecione a tabela que contém seus dados de processos do Excel.

    4. Selecione Concluir. Essa ação aceita todos os valores padrão preenchidos pelo Visio para as outras páginas do assistente.

Como resultado, o diagrama é criado automaticamente dentro de um contêiner. Páginas adicionais do Visio são adicionadas dependendo do tamanho do fluxograma.

Estágio 5: salvar o diagrama do Visio

  • Selecione Arquivo > Salvar, encontre uma localização, insira um nome de arquivo e selecione Salvar.

É uma boa ideia manter os arquivos do Excel e do Visio no mesmo local, porque eles trabalham lado a lado.

Estágio 6: sincronizar os dados e o diagrama

Depois de criar um diagrama com o Visualizador de Dados, você pode querer fazer alterações nele. O Visio oferece suporte à sincronização bidirecional entre os dados de origem e o diagrama.

Dica    Mantenha ambos os arquivos sincronizados e atualizados depois de terminar de trabalhar com eles. Quando você alterar os dados do Excel, atualize o diagrama; quando alterar o conteúdo do diagrama, atualize os dados do Excel.

Para modificar os dados no Excel e atualizar o diagrama

  1. Faça alterações nos dados da tabela do Excel. Você pode adicionar, atualizar ou excluir linhas.

  2. Salve a pasta de trabalho do Excel.

  3. No Visio, clique no contêiner do diagrama para habilitar a guia Design de Ferramentas de Dados na faixa de opções e, em seguida, selecione Atualizar o Diagrama.

Como resultado, as alterações feitas na pasta de trabalho do Excel serão exibidas no diagrama do Visio. Observe o seguinte:

  • Se você tiver feito alguma alteração no diagrama que pode se perder após a atualização, o Visio exibe uma caixa de diálogo Atualizar Conflito de Diagrama.

  • A ação de atualizar apenas fará alterações nas formas e conexões dentro do contêiner.

  • Todas as alterações de formatação feitas nas formas ou nos conectores dentro do contêiner serão preservadas.

  • Mantenha todas as formas e linhas conectoras do diagrama dentro do contêiner. Nenhum outro objeto na página, mas fora do contêiner, será afetado. Para saber mais sobre contêineres, confira Esclarecer a estrutura de diagramas usando contêineres e listas.

Para modificar o conteúdo no diagrama e atualizar os dados no Excel

  1. Faça alterações no diagrama do Visio. Adicione, atualize ou exclua formas e conectores.

  2. Se a pasta de trabalho do Excel estiver em um computador desktop ou servidor de arquivo de rede, ele deve ser salvo e fechado.

  3. Clique no contêiner do diagrama para habilitar a guia Design de Ferramentas de Dados na faixa de opções e, em seguida, selecione Atualizar Fonte de Dados.

Como resultado, as alterações feitas no diagrama do Visio serão exibidas na pasta de trabalho do Excel. Em caso de perda de dados no Excel, o Visio exibirá a caixa de diálogo Atualizar Conflito de Fonte de Dados. Para evitar problemas, use as seguintes práticas recomendadas:

  • Salve um backup dos dados do Excel antes de substituir as alterações.

  • Na pasta de trabalho do Excel, use uma Tabela do Excel como fonte de dados, não um intervalo personalizado. Depois de selecionar Substituir na caixa de diálogo Atualizar Fonte de Dados, o Visio converte o intervalo personalizado em uma tabela do Excel.

  • Não use fórmulas na fonte de dados do Excel. Depois de selecionar Substituir na caixa de diálogo Atualizar Fonte de Dados, o Visio converte a fórmula no resultado da fórmula.

  • Você criou o diagrama usando a seguinte opção em Criar Diagrama no assistente de Dados em que as colunas de dados estão mapeadas para funções e fases: Mapeamento > Mais Opções > Manter a ordem dos valores da coluna dos dados a criar > Selecionar Função ou Raia ou Selecionar a Fase ou Linha do Tempo. Neste caso, o Visio requer uma coluna adicional nos seus dados para representar a conexão entre formas. Depois de selecionar Substituir na caixa de diálogo Atualizar Fonte de Dados, a coluna adicional será inserida.

  • Você criou um diagrama de fluxograma multifuncional com duas raias e fases com base na ordem dos valores dos dados no Excel. Você criou o diagrama usando a seguinte opção em Criar Diagrama no assistente de Dados em que as colunas de dados estão conectadas a etapas do processo e atividades: Mapeamento > Especifique como conectar as etapas/atividades do processo > Conectar em sequência. Neste caso, o Visio requer uma coluna adicional nos seus dados para representar a conexão entre formas. Se você alterar a ordem das raias ou fases no diagrama, a ordem será alterada na fonte de dados. Depois de selecionar Substituir na caixa de diálogo Atualizar Fonte de Dados, as raias e fases do diagrama não seguem mais a ordem dos dados na pasta de trabalho do Excel.

Estágio 7: personalizar a interação entre a tabela do Excel e o diagrama do Visio (opcional)

Há momentos em que você pode querer personalizar a criação dos seus diagramas do Visualizador de Dados. Por exemplo, talvez você queira usar formas diferentes para manter a conformidade com os padrões da sua organização ou mapear para nomes de colunas diferentes na tabela do Excel.

  1. Quando você selecionar Criar para entrar no assistente Criar Diagrama a partir de Dados e depois de inserir valores na primeira página (consulte o Estagio 4), selecione Avançar ou Voltar para exibir cada página do assistente.

  2. Selecione Ajuda (?) para obter mais informações sobre como personalizar cada opção na página. Para obter mais informações, confira Usar o assistente Criar Diagrama a partir de Dados.

Início da página

Como colunas do Excel interagem com componentes de fluxograma do Visio

Use o seguinte passo a passo com imagens para entender como cada coluna do Excel é usada para criar o fluxograma do Visio.

ID da Etapa do Processo    Um número que identifica cada forma do fluxograma. Essa coluna é necessária, e cada valor na tabela do Excel deve ser exclusivo e não estar em branco. Esse valor não aparece no fluxograma.

Interação do Mapa de Processos do Excel com o fluxograma do Visio: ID da Etapa do Processo

Descrição da Etapa do Processo   Texto adicionado a cada forma do fluxograma.

Interação do Mapa de Processos do Excel com o fluxograma do Visio: Descrição da Etapa do Processo

ID da Próxima Etapa   A ID da Etapa do Processo da próxima forma da sequência. Uma forma de ramificação tem duas próximas etapas e é representada por números separados por vírgulas, como 4,5. Você pode ter mais de duas próximas etapas.

Interação do Mapa de Processos do Excel com o fluxograma do Visio: ID da Próxima Etapa

Rótulo do Conector   Para formas de ramificação, rótulos de conector são representados como texto separado por vírgula, como Sim, Não. No exemplo, Sim corresponde a 4 e Não, a 5.

Interação do Mapa de Processos do Excel com o fluxograma do Visio: Rótulo do Conector

Tipo de Forma   O tipo da forma que você deseja representar no diagrama do Visio, como Processo ou Decisão. A Microsoft recomenda usar as listas suspensas para ajudar a validar suas escolhas.

Interação do Mapa de Processos do Excel com o fluxograma do Visio: Tipo de Forma

Função e Fase    A função (ou raia) e a fase (a linha do tempo) as quais cada forma pertence. Essa coluna somente é aplicável a um diagrama de Fluxograma Multifuncional, sendo ignorada por um diagrama de Fluxograma Básico.

Interação do Mapa de Processos do Excel com o fluxograma do Visio: Função e Fase

Início da página

Usar outros estênceis para criar um diagrama de Visualizador de Dados

Além de usar os modelos de Visualizador de dados, você também pode usar estênceis de outros modelos quando você criar um diagrama de Visualizador de dados. Por exemplo, crie diagramas de processo para transações financeiras ou gerenciamento de estoque. Há outros estênceis orientados a processos, incluindo modelos BPMN básicos e objetos de fluxo de trabalho. Você mesmo pode adicionar formas personalizadas usando o estêncil Minhas formas. Para obter mais informações, consulte criar, salvar e compartilhar estênceis personalizados.

  1. Abra um diagrama do Visualizador de Dados (Fluxograma Básico ou Fluxograma Multifuncional) que você criou.

  2. Selecione Criar para entrar no assistente Criar Diagrama a partir de Dados e depois de inserir valores na primeira página, selecione Avançar até exibir a página Mapeamento de Forma no assistente.

  3. Adicione um ou mais estênceis usando a opção Mais Formas.

  4. Selecione qualquer forma e mapeie-a para os valores de dados da coluna Tipo de Forma arrastando-os.

Início da página

Aplicar Gráficos de Dados ao seu diagrama

É possível melhorar ainda mais seu diagrama adicionando gráficos de dados, que ajudam a visualizar dados de forma no diagrama. Na verdade, é possível transformar seu diagrama em um painel de processos em que os gráficos de dados mostram informações sobre KPIs (indicadores chave de desempenho) usando os ícones de gráficos de dados com base nos seus dados de forma.

  1. Abra o diagrama do Visualizador de Dados.

    Selecione o contêiner ao qual você deseja aplicar os Gráficos de Dados.

  2. Selecione Dados > Campos de Gráficos de Dados.

  3. Selecione os campos de gráficos de dados que você deseja adicionar ao seu diagrama.

    Aplicar Gráficos de Dados para o Diagrama do Visualizador de Dados do Visio

    Os gráficos de dados são aplicados ao diagrama inteiro. Para ocultar gráficos de dados para certas formas, mantenha os valores da coluna de dados em branco na pasta de trabalho do Excel para essas linhas.

  4. Se desejar, será possível definir opções adicionais na guia Dados. Para saber mais, confira Visão geral: gráficos de dados.

Início da página

Próximas etapas

Veja a seguir algumas tarefas que você pode querer fazer depois de criar um diagrama do Visualizador de Dados.

  • Temas    Um tema no Visio é um conjunto de cores e efeitos que você pode aplicar a um desenho com um único clique. Temas são uma maneira rápida de dar uma aparência profissional aos seus desenhos. Para obter mais informações, confira Aplicar uma aparência profissional aos seus desenhos com temas.

  • Layout    O Visio tem guias manuais e ferramentas automáticas para ajudar a garantir o bom alinhamento e espaçamento das formas no seu diagrama. Isso ajuda a dar a maior clareza possível para o seu desenho, além de deixá-lo com uma aparência bem organizada. Para obter mais informações, consulte Alinhar e posicionar formas em um diagrama.

  • Exportar    Exporte um diagrama de Visualizador de Dados e uma pasta de trabalho do Excel associada para um pacote de modelos do Visio (.vtpx). Um pacote de modelos do Visio salva as configurações do diagrama, estênceis e dados para que outras pessoas as utilizem como um ponto de partida rápido para criar seu próprio diagrama de Visualizador de Dados. Outros usuários podem instalar e personalizar o pacote de modelos em seus computadores. Confira mais informações em Exportar e instalar um pacote de modelos de Visualizador de Dados.

Início da página

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×