Criar, executar, editar ou excluir uma macro no Office para Mac

Observação: Desejamos fornecer o conteúdo da Ajuda mais recente no seu idioma da forma mais rápida possível. Esta página foi traduzida de forma automatizada e pode conter imprecisões ou erros gramaticais. Nosso objetivo é que este conteúdo seja útil para você. No final da página, deixe sua opinião se estas informações foram úteis para você. Aqui está o artigo em inglês para facilitar a referência.

Para poupar tempo em tarefas que você executa com frequência, você pode gravar as etapas dessas tarefas como uma macro. Em seguida, quando desejar executar uma dessas tarefas gravadas, você poderá ativar a macro para executar as etapas para você.

Word

No Word 2016 para Mac, você pode criar uma macro com um atalho de teclado, executar uma macro e excluir uma macro que não seja mais necessária.

  1. Clique em Exibir > Macros > Gravar Macro.

    Na guia Exibir, clique em Macro e em Gravar Macro para começar a criar uma macro.
  2. Digite um nome para a macro ou aceite o padrão que o Word fornece.

    Insira um nome para a macro no nome da Macro ou aceite o nome genérico fornecido pelo Word.
  3. Para usar essa macro em qualquer novo documento que você criar, verifique se todos os documentos (normal) estão selecionados na lista armazenar macro em .

  4. Clique em teclado para atribuir uma combinação de teclas à sua macro.

    o Word exibe a caixa de diálogo Personalizar teclado .

  5. Digite uma combinação de teclas na caixa pressione o novo atalho de teclado .

    O Word exibe o comando ou a macro já atribuída a uma combinação de teclas, caso exista, depois que você pressionar a combinação.

    Quando você pressiona uma combinação de teclas, o Word exibe o comando ou a ação atualmente atribuída a essa combinação de teclas, se houver.

  6. Se a combinação de teclas que você escolheu já estiver atribuída, exclua-a na caixa pressione novo atalho de teclado e escolha uma nova combinação de teclas.

    Vá para a próxima etapa depois de encontrar uma combinação de teclas não atribuída.

    O Word identifica quando você pressiona uma combinação de tecla que não está atribuída a um comando ou a uma macro.
  7. Para usar esse atalho de teclado em qualquer documento novo, certifique-se de que normal. dotm, o modelo global, esteja selecionado na lista salvar alterações em .

    Selecione Normal.dotm para disponibilizar uma macro para uso em novos documentos que você criar.
  8. Clique em Atribuir.

  9. Quando estiver pronto para gravar a macro, clique em OK.

  10. Clique nos comandos ou pressione as teclas para cada etapa na tarefa.

    o Word grava seus cliques e pressionamentos de teclas, mas não grava o texto que você selecionar com o mouse. Para selecionar o texto durante a gravação de uma macro, use o teclado.

  11. Para parar de gravar, clique em Exibir > Macros > Parar Gravação.

    Clique em Parar Gravação no menu Macros para parar de gravar uma macro.

Para executar uma macro, pressione o atalho de teclado atribuído a ela ou execute a macro na lista macros .

  1. Clique em Exibir > Macros > Exibir Macros.

    Clique em Exibir Macros para exibir e editar as macros associadas ao documento atual.
  2. Na lista em nome da macro, selecione a macro que você deseja executar.

  3. Clique em Executar.

    Após selecionar uma macro em Nome da Macro, clique em Executar para executá-la.

  1. Clique em Exibir > Macros > Exibir Macros.

    Clique em Exibir Macros para exibir e editar as macros associadas ao documento atual.
  2. Verifique se o local especificado por macros inclui o local da macro que você deseja excluir.

    Selecione o local das macros que você deseja exibir a partir das Macros da lista.

    A lista incluirá o documento que está aberto na janela atual, bem como os comandos de modelo global e Word.

  3. Em nome da macro, selecione a macro que você deseja excluir e, em seguida, clique no sinal de subtração abaixo da lista.

    Selecione a macro que deseja excluir e, em seguida, clique no sinal de subtração abaixo da lista.
  4. Quando o Word pede para confirmar que você deseja excluir a macro, clique em Sim.

Excel

No Excel 2016 para Mac, você pode criar uma macro com um atalho de teclado, executar uma macro e excluir uma macro que não seja mais necessária.

Quando você grava uma macro, o gravador de macros grava todas as etapas necessárias para concluir as ações que você quer que a macro execute. Essas etapas podem incluir digitar texto ou números, clicar em células ou comandos na faixa de opções ou nos menus, formatar, selecionar células, linhas ou colunas e arrastar o mouse para selecionar células na sua planilha.

Observação: Os comandos para gravar, criar e excluir macros, bem como outros recursos avançados, também estão disponíveis na guia desenvolvedor na faixa de opções. Para obter mais informações sobre como usar a guia desenvolvedor, consulte usar a guia desenvolvedor para criar ou excluir uma macro no Excel 2016 para Mac.

  1. Selecione ferramentas > macro > gravar novo.

    Selecione Ferramentas, macro e, em seguida, gravar nova macro

  2. Na caixa Nome da macro, digite um nome para a macro.

    Digite um nome de macro, um local e uma tecla de atalho

  3. Para criar um atalho de teclado para a macro, digite uma letra na caixa option + cmd .

  4. Selecione um local para a macro na lista suspensa.

    Para salvar a macro

    Clique em

    No documento em que você está criando macro

    Esta Pasta de Trabalho

    Em todos os documentos

    Nova Pasta de Trabalho

    Para estar disponível sempre que você usar o Excel

    Pasta de Trabalho Pessoal de Macros

  5. Adicionais Adicione uma descrição da macro.

  6. Quando estiver pronto para gravar, clique em OK.

  7. Clique nos comandos ou pressione as teclas para cada etapa na tarefa.

  8. Para parar a gravação, selecione ferramentas > macro > parar gravação. (Esta etapa não será gravada na sua macro.)

    Selecione Parar gravação

Para executar uma macro, pressione o atalho de teclado atribuído a ela ou execute a macro na caixa de diálogo macros.

  1. Na guia Exibição, clique em Exibir Macros.

  2. Clique em macros no menu pop-up e selecione esta pasta de trabalho.

  3. Escolha sua macro na lista e clique em Executar.

    Adicionar uma conexão para receber dados externos

  1. Selecione ferramentas > macro > macros.

    Selecionar macro e selecionar macros

  2. Selecione a macro a ser excluída e, em seguida, pressione o sinal de subtração.

    Selecione o nome da macro e, em seguida, selecione sinal de subtração

  3. Uma mensagem de confirmação será exibida. Clique em Sim para confirmar a exclusão.

    Confirmar exclusão

Você também pode excluir uma macro da guia desenvolvedor .

  1. Na guia Desenvolvedor, clique em Macros.

  2. Na lista, clique na macro que deseja excluir e clique no botão Excluir.

    Selecione uma macro e clique no sinal de subtração para excluí-la

Word

Para automatizar uma tarefa repetitiva, você pode criar rapidamente uma macro no Word. Você também pode usar o Editor do Visual Basic no Microsoft Visual Basic for Applications para gravar seu próprio script de macro ou copiar toda ou parte de uma macro em uma nova macro.

Quando você grava uma macro, todas as etapas necessárias para concluir as ações que você deseja que a macro execute são gravadas. No entanto, a navegação de volta à guia para interromper a gravação não está incluída nas etapas gravadas.

  1. Na guia Desenvolvedor, em Visual Basic, clique em Registro.

    Guia Desenvolvedor do Word, grupo do Visual Basic

    Se a guia Desenvolvedor não estiver disponível

    1. No lado direito da faixa de opções, clique em Menu pop-up de ação e em Preferências da Faixa de Opções.

    2. Em Personalizar, marque a caixa de seleção Desenvolvedor.

  2. Na caixa Nome da macro, digite um nome para a macro.

  3. No menu pop-up Armazenar macro em, siga um destes procedimentos:

    Para salvar a macro

    Clique em

    No documento no qual você está criando a macro

    [nome do documento] (documento)

    Em todos os documentos

    Todos os Documentos (Normal)

  4. Clique em OK e execute as ações que deseja gravar.

  5. Na guia Desenvolvedor, em Visual Basic, clique em Parar.

Você pode usar o Editor do Visual Basic interno para criar uma macro.

  1. Na guia Desenvolvedor, em Visual Basic, clique em Editor.

    Guia Desenvolvedor do Word, grupo do Visual Basic

    Se a guia Desenvolvedor não estiver disponível

    1. No lado direito da faixa de opções, clique em Menu pop-up de ação e em Preferências da Faixa de Opções.

    2. Em Personalizar, marque a caixa de seleção Desenvolvedor.

  2. Se for necessário inserir um módulo, no Editor do Visual Basic, no menu Inserir, clique em Módulo.

  3. Na janela de código do módulo, digite ou cole o código da macro que você deseja usar.

  4. Quando tiver terminado, no menu Word, clique em Fechar e Retornar ao Microsoft Word.

  1. Na guia Desenvolvedor, em Visual Basic, clique em Macros.

    Guia Desenvolvedor do Word, grupo do Visual Basic

    Se a guia Desenvolvedor não estiver disponível

    1. No lado direito da faixa de opções, clique em Menu pop-up de ação e em Preferências da Faixa de Opções.

    2. Em Personalizar, marque a caixa de seleção Desenvolvedor.

  2. Na lista, clique na macro que você deseja executar e, em seguida, clique em Executar.

Para editar uma macro, use o Editor do Visual Basic.

  1. Na guia Desenvolvedor, em Visual Basic, clique em Macros.

    Guia Desenvolvedor do Word, grupo do Visual Basic

    Se a guia Desenvolvedor não estiver disponível

    1. No lado direito da faixa de opções, clique em Menu pop-up de ação e em Preferências da Faixa de Opções.

    2. Em Personalizar, marque a caixa de seleção Desenvolvedor.

  2. Na lista, clique na macro que você deseja editar e, em seguida, clique em Editar.

    O Editor do Visual Basic é aberto.

  3. Faça as alterações desejadas.

  4. Quando tiver terminado, no menu Word, clique em Fechar e Retornar ao Microsoft Word.

  1. Na guia Desenvolvedor, em Visual Basic, clique em Macros.

    Guia Desenvolvedor do Word, grupo do Visual Basic

    Se a guia Desenvolvedor não estiver disponível

    1. No lado direito da faixa de opções, clique em Menu pop-up de ação e em Preferências da Faixa de Opções.

    2. Em Personalizar, marque a caixa de seleção Desenvolvedor.

  2. Na lista, clique na macro que você deseja copiar e, em seguida, clique em Editar.

    O Editor do Visual Basic é aberto.

  3. Na janela de código do Editor do Visual Basic, selecione as linhas da macro a serem copiadas.

    Dica: Para copiar toda a macro, inclua as linhas Sub e End Sub na seleção.

  4. No menu Editar, clique em Copiar.

  5. Na caixa Projeto da janela de código, clique no módulo no qual o código será inserido.

  6. No menu Editar, clique em Colar.

  1. Na guia Desenvolvedor, em Visual Basic, clique em Macros.

    Guia Desenvolvedor do Word, grupo do Visual Basic

    Se a guia Desenvolvedor não estiver disponível

    1. No lado direito da faixa de opções, clique em Menu pop-up de ação e em Preferências da Faixa de Opções.

    2. Em Personalizar, marque a caixa de seleção Desenvolvedor.

  2. Na lista, clique na macro que você deseja excluir e clique em Excluir.

PowerPoint

Para automatizar uma tarefa repetitiva, você pode usar o Visual Basic for Applications para criar uma macro no PowerPoint.

Você pode usar o Editor do Visual Basic interno para criar uma macro.

  1. Na guia Desenvolvedor, em Visual Basic, clique em Editor.

    Guia Desenvolvedor do PowerPoint, grupo do Visual Basic

    Se a guia Desenvolvedor não estiver disponível

    1. No lado direito da faixa de opções, clique em Menu pop-up de ação e em Preferências da Faixa de Opções.

    2. Em Personalizar, marque a caixa de seleção Desenvolvedor.

  2. Se for necessário inserir um módulo, no Editor do Visual Basic, no menu Inserir, clique em Módulo.

  3. Na janela de código do módulo, digite ou cole o código da macro que você deseja usar.

  4. Quando tiver terminado, no menu PowerPoint, clique em Fechar e Retornar ao Microsoft PowerPoint.

  1. Na guia Desenvolvedor, em Visual Basic, clique em Macros.

    Guia Desenvolvedor do PowerPoint, grupo do Visual Basic

    Se a guia Desenvolvedor não estiver disponível

    1. No lado direito da faixa de opções, clique em Menu pop-up de ação e em Preferências da Faixa de Opções.

    2. Em Personalizar, marque a caixa de seleção Desenvolvedor.

  2. Na lista, clique na macro que você deseja executar e, em seguida, clique em Executar.

Para editar uma macro, use o Editor do Visual Basic.

  1. Na guia Desenvolvedor, em Visual Basic, clique em Macros.

    Guia Desenvolvedor do PowerPoint, grupo do Visual Basic

    Se a guia Desenvolvedor não estiver disponível

    1. No lado direito da faixa de opções, clique em Menu pop-up de ação e em Preferências da Faixa de Opções.

    2. Em Personalizar, marque a caixa de seleção Desenvolvedor.

  2. Na lista, clique na macro que você deseja editar e, em seguida, clique em Editar.

    O Editor do Visual Basic é aberto.

  3. Faça as alterações desejadas.

  4. Quando tiver terminado, no menu PowerPoint, clique em Fechar e Retornar ao Microsoft PowerPoint.

  1. Na guia Desenvolvedor, em Visual Basic, clique em Macros.

    Guia Desenvolvedor do PowerPoint, grupo do Visual Basic

    Se a guia Desenvolvedor não estiver disponível

    1. No lado direito da faixa de opções, clique em Menu pop-up de ação e em Preferências da Faixa de Opções.

    2. Em Personalizar, marque a caixa de seleção Desenvolvedor.

  2. Na lista, clique na macro que você deseja copiar e, em seguida, clique em Editar.

    O Editor do Visual Basic é aberto.

  3. Na janela de código do Editor do Visual Basic, selecione as linhas da macro a serem copiadas.

    Dica: Para copiar toda a macro, inclua as linhas Sub e End Sub na seleção.

  4. No menu Editar, clique em Copiar.

  5. Na caixa Projeto da janela de código, clique no módulo no qual o código será inserido.

  6. No menu Editar, clique em Colar.

  1. Na guia Desenvolvedor, em Visual Basic, clique em Macros.

    Guia Desenvolvedor do PowerPoint, grupo do Visual Basic

    Se a guia Desenvolvedor não estiver disponível

    1. No lado direito da faixa de opções, clique em Menu pop-up de ação e em Preferências da Faixa de Opções.

    2. Em Personalizar, marque a caixa de seleção Desenvolvedor.

  2. Na lista, clique na macro que você deseja excluir e clique em Excluir.

Excel

Para automatizar uma tarefa repetitiva, você pode criar rapidamente uma macro no Excel. Você também pode usar o Editor do Visual Basic no Microsoft Visual Basic for Applications para gravar seu próprio script de macro ou copiar toda ou parte de uma macro em uma nova macro.

Todas as etapas necessárias para completar as ações que você deseja que a macro execute são gravadas. No entanto, a navegação de volta à guia para interromper a gravação não está incluída nas etapas gravadas.

  1. Na guia Desenvolvedor, em Visual Basic, clique em Registro.

    Guia Desenvolvedor do Excel, grupo Visual Basic

    Se a guia Desenvolvedor não estiver disponível

    1. No lado direito da faixa de opções, clique em Menu pop-up de ação e em Preferências da Faixa de Opções.

    2. Em Personalizar, marque a caixa de seleção Desenvolvedor.

  2. Na caixa Nome da macro, digite um nome para a macro.

    Dica: Para criar um atalho de teclado para a macro, digite uma letra na caixa Option+Cmd+.

  3. No menu pop-up Armazenar macro em, siga um destes procedimentos:

    Para salvar a macro

    Clique em

    No documento no qual você está criando a macro

    Esta Pasta de Trabalho

    Em todos os documentos

    Nova Pasta de Trabalho

    Para estar disponível sempre que você usar o Excel

    Pasta de Trabalho Pessoal de Macros

    A pasta de trabalho pessoal de macros está localizada em usuários/ nome de usuário/library/Application Support suporte/Microsoft/Office/Excel.

  4. Clique em OK e execute as ações que deseja gravar.

  5. Na guia Desenvolvedor, em Visual Basic, clique em Registro novamente.

Você pode usar o Editor do Visual Basic interno para criar uma macro.

  1. Na guia Desenvolvedor, em Visual Basic, clique em Editor.

    Guia Desenvolvedor do Excel, grupo Visual Basic

    Se a guia Desenvolvedor não estiver disponível

    1. No lado direito da faixa de opções, clique em Menu pop-up de ação e em Preferências da Faixa de Opções.

    2. Em Personalizar, marque a caixa de seleção Desenvolvedor.

  2. Se for necessário inserir um módulo, no Editor do Visual Basic, no menu Inserir, clique em Módulo.

  3. Na janela de código do módulo, digite ou cole o código da macro que você deseja usar.

  4. Quando tiver terminado, no menu Excel, clique em Fechar e Retornar ao Microsoft Excel.

  1. Na guia Desenvolvedor, em Visual Basic, clique em Macros.

    Guia Desenvolvedor do Excel, grupo Visual Basic

    Se a guia Desenvolvedor não estiver disponível

    1. No lado direito da faixa de opções, clique em Menu pop-up de ação e em Preferências da Faixa de Opções.

    2. Em Personalizar, marque a caixa de seleção Desenvolvedor.

  2. Na lista, clique na macro que você deseja executar e, em seguida, clique em Executar.

    Dica: Para executar uma macro usando um atalho do teclado, pressione OPTION + COMANDO + a letra digitada quando você criou o atalho de teclado.

Para editar uma macro, use o Editor do Visual Basic.

  1. Na guia Desenvolvedor, em Visual Basic, clique em Macros.

    Guia Desenvolvedor do Excel, grupo Visual Basic

    Se a guia Desenvolvedor não estiver disponível

    1. No lado direito da faixa de opções, clique em Menu pop-up de ação e em Preferências da Faixa de Opções.

    2. Em Personalizar, marque a caixa de seleção Desenvolvedor.

  2. Na lista, clique na macro que você deseja editar e, em seguida, clique em Editar.

    O Editor do Visual Basic é aberto.

  3. Faça as alterações desejadas.

  4. Quando tiver terminado, no menu Excel, clique em Fechar e Retornar ao Microsoft Excel.

Depois de concluir esse procedimento, a macro será executada sempre que você abrir a pasta de trabalho que contém a macro.

  1. Na guia Desenvolvedor, em Visual Basic, clique em Registro.

    Guia Desenvolvedor do Excel, grupo Visual Basic

    Se a guia Desenvolvedor não estiver disponível

    1. No lado direito da faixa de opções, clique em Menu pop-up de ação e em Preferências da Faixa de Opções.

    2. Em Personalizar, marque a caixa de seleção Desenvolvedor.

  2. Na caixa Nome da macro, digite Abrir_Auto.

  3. No menu pop-up Armazenar macro em, siga um destes procedimentos:

    Para salvar a macro

    Clique em

    No documento no qual você está criando a macro

    Esta Pasta de Trabalho

    Em todos os documentos

    Nova Pasta de Trabalho

    Para estar disponível sempre que você usar o Excel

    Pasta de Trabalho Pessoal de Macros

  4. Clique em OK e execute as ações que deseja gravar.

  5. Na guia Desenvolvedor, em Visual Basic, clique em Registro novamente.

  6. No menu Arquivo, clique em Salvar como.

  7. No menu pop-up Formatar, clique em Pasta de trabalho habilitada para macro do Excel (.xlsm) e, em seguida, clique em Salvar.

  1. Na guia Desenvolvedor, em Visual Basic, clique em Macros.

    Guia Desenvolvedor do Excel, grupo Visual Basic

    Se a guia Desenvolvedor não estiver disponível

    1. No lado direito da faixa de opções, clique em Menu pop-up de ação e em Preferências da Faixa de Opções.

    2. Em Personalizar, marque a caixa de seleção Desenvolvedor.

  2. Na lista, clique na macro que você deseja copiar e, em seguida, clique em Editar.

    O Editor do Visual Basic é aberto.

  3. Na janela de código do Editor do Visual Basic, selecione as linhas da macro a serem copiadas.

    Dica: Para copiar toda a macro, inclua as linhas Sub e End Sub na seleção.

  4. No menu Editar, clique em Copiar.

  5. Na caixa Projeto da janela de código, clique no módulo no qual o código será inserido.

  6. No menu Editar, clique em Colar.

  1. Na guia Desenvolvedor, em Visual Basic, clique em Macros.

    Guia Desenvolvedor do Excel, grupo Visual Basic

    Se a guia Desenvolvedor não estiver disponível

    1. No lado direito da faixa de opções, clique em Menu pop-up de ação e em Preferências da Faixa de Opções.

    2. Em Personalizar, marque a caixa de seleção Desenvolvedor.

  2. Na lista, clique na macro que você deseja excluir e clique em Excluir.

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×