Contar caracteres em células

Observação:  Desejamos fornecer o conteúdo da Ajuda mais recente no seu idioma da forma mais rápida possível. Esta página foi traduzida de forma automatizada e pode conter imprecisões ou erros gramaticais. Nosso objetivo é que este conteúdo seja útil para você. As informações foram úteis? Dê sua opinião no final desta página. Aqui está o artigo em inglês para facilitar a referência.

Quando você precisa contar os caracteres em células, use a função LEN— que calcula as letras, números, caracteres e todos os espaços. Por exemplo, o comprimento do "É graus 98 hoje, para que eu será vá nadando" (excluindo as aspas) é 42 caracteres — 31 letras, 2 números, 8 espaços, uma vírgula e 2 apóstrofos.

Para usar a função, digite = CARACT (célula) na barra de fórmulas, pressione Enter no teclado.

Várias células: Para aplicar a mesma fórmula em várias células, insira a fórmula na primeira célula e arraste na alça de preenchimento para baixo (ou entre) o intervalo de células.

Inserindo várias funções NÚM.CARACT em uma planilha

Para obter a uma contagem total de todos os caracteres em várias células é usar as funções soma juntamente com LEN. Neste exemplo, a função LEN conta os caracteres em cada célula e a função SOMA adiciona as contagens:

= Soma ((LEN ( cell1 ), CARACT ( cell2 ), (LEN ( cell3 )) )).

Experimente

Aqui estão alguns exemplos que demonstram como usar a função NÚM.

Copie a tabela abaixo e cole-a na célula A1 em uma planilha do Excel. Arraste a fórmula de B2 para B4 para ver o comprimento do texto em todas as células na coluna A.

Cadeias de caracteres de texto

Fórmulas

A rápida raposa marrom.

=NÚM.CARACT(A2)

A rápida raposa marrom saltou.

A raposa marrom rápida saltou sobre o cachorro preguiçoso.

Contar caracteres em uma célula

  1. Clique na célula B2.

  2. Insira CARACT (a2).

A fórmula conta os caracteres na célula A2, que totaliza para 27 — que inclui todos os espaços e o período no final da sentença.

Observação: LEN conta espaços depois do último caractere.

Contar caracteres em várias células

  1. Clique na célula B2.

  2. Pressione Ctrl + C para copiar a célula B2, e em seguida, selecione as células B3 e B4 e pressione Ctrl + V para colar sua fórmula nas células B3: B4.

Isso copia a fórmula para células B3 e B4 e a função conta os caracteres em cada célula (20, 27 e 45).

Contar o número total de caracteres

  1. Na pasta de trabalho de exemplo, clique na célula B6.

  2. Na célula, insira =SOMA(NÚM.CARACT(A2),NÚM.CARACT(A3),NÚM.CARACT(A4)) e pressione Enter.

Isso conta os caracteres em cada uma das três células e os totaliza dar (92).

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×