Como corrigir um erro #VALOR! na função CONCATENAR

Observação: Desejamos fornecer o conteúdo da Ajuda mais recente no seu idioma da forma mais rápida possível. Esta página foi traduzida de forma automatizada e pode conter imprecisões ou erros gramaticais. Nosso objetivo é que este conteúdo seja útil para você. As informações foram úteis? Dê sua opinião no final desta página. Aqui está o artigo em inglês para facilitar a referência.

Importante: No Excel 2016, Excel Mobile e Excel Online, CONCATENAR foi substituído pela função CONCAT. Embora CONCATENAR ainda esteja disponível para compatibilidade com versões anteriores, recomenda-se usar CONCAT por ela ser uma função mais robusta.

Um dos cenários mais comuns onde você encontra o erro #VALOR! com CONCATENAR é quando você tenta criar uma cadeia de caracteres que inclui uma referência de célula que contém um erro, como #VALOR!.

No exemplo a seguir, queremos concatenar D2, E2 e F2, onde E2 tem um erro #VALOR!.

Erro #VALOR! em CONCATENAR

O erro em E2 faz com que a função exiba o #VALUE! Error. Para que ele funcione com êxito, você precisará substituir o erro por um valor diferente do erro. Você pode criar uma fórmula que verifica um erro na referência da célula e, se tiver, exibir a cadeia de caracteres de texto em que um 0 aparece em vez do erro (ou pode substituir seu próprio texto por 0, mas precisará quebrar o texto entre aspas: "seu texto").

Uma fórmula como esta funciona:

=SE(ÉERROS(E2);CONCATENAR(D2;" ",0," ",F2))

As funções SE e ÉERROS usaram como uma solução alternativa para concatenar uma cadeia de caracteres com o erro #VALOR!

Como isso funciona? A função se usa a função SEERRO para determinar se há um erro no E2, e se houver, a função CONCATENAr combina os valores em D2, E2 e F2 (a função substitui o erro por 0) e exibe a cadeia de texto resultante. Observação a fórmula também usa espaços ("") para ajudar a separar os valores.

Corrigir o erro #VALOR! com CONCATENAR no Excel 2003 e em versões mais antigas

Se você estiver obtendo a #VALUE! erro no Office Excel 2003 ou versões mais antigas, será necessário desmarcar a opção avaliação de fórmulas de transição (TFE) no Excel. Siga as etapas descritas em #VALUE! erro ao concatenar células para resolver o problema.

Você tem dúvida sobre uma função específica?

Postar uma pergunta no fórum da comunidade do Excel

Ajude-nos a melhorar o Excel

Você tem sugestões sobre como aprimorar a próxima versão do Excel? Em caso afirmativo, confira os tópicos no site UserVoice do Excel.

Confira também

Corrigir um erro #VALOR!

Função CONCATENAR

Função CONCAT

Visão geral de fórmulas no Excel

Como evitar fórmulas quebradas

Detectar erros em fórmulas

Todas as funções do Excel (ordem alfabética)

Todas as funções do Excel (por categoria)

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×