Como corrigir um erro #REF!

Como corrigir um erro #REF!

Observação:  Desejamos fornecer o conteúdo da Ajuda mais recente no seu idioma da forma mais rápida possível. Esta página foi traduzida de forma automatizada e pode conter imprecisões ou erros gramaticais. Nosso objetivo é que este conteúdo seja útil para você. As informações foram úteis? Dê sua opinião no final desta página. Aqui está o artigo em inglês para facilitar a referência.

O #REF! erro mostra quando uma fórmula se refere a uma célula que não é válida. Isso acontece com mais frequência quando células que foram referenciadas por fórmulas obtém excluídas ou sobrepostas.

Exemplo - erro #REF! causado pela exclusão de uma coluna

O exemplo a seguir usa a fórmula =SOMA(B2;C2;D2) na coluna E.

Uma fórmula que usa referências de células explícitas como =SOMA(B2;C2;D2) poderá causar um erro #REF! se uma coluna for excluída.

Se você excluir a coluna B, C ou D-faria com que uma #REF! erro. Nesse caso, estamos excluirá coluna C (vendas de 2007), e a fórmula agora lê =SUM(B2,#REF!,C2). Quando você usa referências explícitas a células assim (onde você faz referência cada célula individualmente, separados por vírgula) e excluir uma referência de linha ou coluna, o Excel não consegue solucioná-lo, para que ela retorne a #REF! erro. Este é o principal motivo por que o uso de referências explícitas a células em funções não é recomendado.

Exemplo do erro #REF! causado pela exclusão de uma coluna.

Solução

  • Se excluiu linhas ou colunas por engano, você pode clicar imediatamente no botão Desfazer na Barra de Ferramentas de Acesso Rápido (ou pressionar CTRL+Z) para restaurá-las.

  • Ajuste a fórmula para que ele usa uma referência de intervalo em vez de células individuais, como =SUM(B2:D2). Agora você pode excluir qualquer coluna dentro do intervalo de soma e Excel ajustará automaticamente a fórmula. Você também pode usar =SUM(B2:B5) para uma soma de linhas.

Exemplo - PROCV com referências de intervalo incorretas

No exemplo a seguir, =PROCV(A8;A2:D5;5;FALSO) retornará um erro #REF! porque está procurando um valor de retorno da coluna 5, mas o intervalo de referência é A:D, que só tem quatro colunas.

Exemplo de uma fórmula PROCV com um intervalo incorreto.  A fórmula é =PROCV(A8;A2:D5;5;FALSO).  Não há uma quinta coluna no intervalo PROCV, assim, 5 causa um erro #REF!.

Solução

Ajustar o intervalo para ser maior ou reduzir o valor de pesquisa de coluna para coincidir com o intervalo de referência. =VLOOKUP(a8,a2:E5,5,False) seria um intervalo de referência válida, como faria = VLOOKUP(A8,A2:D5,4,FALSE).

Exemplo - ÍNDICE com uma referência incorreta de linha ou coluna

Nesse exemplo, a fórmula =ÍNDICE(B2:E5;5;5) retorna um erro #REF! porque o intervalo de índice é de quatro linhas por quatro colunas, mas a fórmula está pedindo para retornar o que está na quinta coluna e na quinta linha.

Exemplo de uma fórmula ÍNDICE com uma referência de intervalo inválida.  A fórmula é =ÍNDICE(B2:E5;5;5), mas o intervalo é de apenas quatro linhas por quatro colunas.

Solução

Ajuste as referências de linha ou coluna para que elas sejam dentro do intervalo de pesquisa de índice. =Index(B2:E5,4,4) retorna um resultado válido.

Exemplo – referência a uma pasta de trabalho fechada com INDIRETO

No exemplo a seguir, uma função INDIRETO está tentando fazer referência a uma pasta de trabalho fechada, causando um erro #REF!.

Exemplo de um erro #REF! causado porque INDIRETO faz referência a uma pasta de trabalho fechada.

Solução

Abra a pasta de trabalho referenciada

Problemas OLE

Se você usou um link OLE (Vinculação e Incorporação de Objeto) que está retornando um erro #REF!, inicie o programa que o link está chamando.

Observação: OLE é uma tecnologia que você pode usar para compartilhar informações entre programas.

Problemas DDE

Se você tiver usado um tópico de intercâmbio dinâmico de dados (DDE) que está retornando uma #REF! erro, verifique primeiro se que você estiver fazendo referência ao tópico correto. Se você ainda estiver recebendo um #REF! erro, verifique suas Configurações da Central de confiabilidade para conteúdo externo como descritas Bloquear ou desbloquear o conteúdo externo nos documentos do Office.

Observação: Intercâmbio dinâmico de dados (DDE)é um protocolo estabelecido para intercâmbio de dados entre programas baseados no Windows da Microsoft.

Problemas de Macro

Se uma macro insere uma função de planilha que se refere a uma célula acima da função e a célula que contém a função estiver na linha 1, a função retornará #REF! porque não há nenhuma célula acima da linha 1. Verifique a função para ver se um argumento refere-se a uma célula ou intervalo de células que não é válido. Isso pode exigir editando a macro no Visual Basic Editor (VBE) para fazer essa situação em conta.

Precisa de mais ajuda?

Você pode sempre consultar um especialista na Excel Tech Community, obter suporte na Comunidade de respostas ou sugerir um novo recurso ou melhoria no User Voice do Excel.

Confira também

Visão geral de fórmulas no Excel

Como evitar fórmulas quebradas

Usar a verificação de erros para detectar erros em fórmulas

Funções do Excel (ordem alfabética)

Funções do Excel (por categoria)

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×