Visão geral da conexão com dados (importação)

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Este artigo de referência discute importando e a conexão de dados. Você aprenderá sobre tarefas como importar, atualizar, protegendo e gerenciando dados.

Neste artigo

Trabalhando com conexões de dados externos

Atualizar dados

Importando dados de fontes de dados

Tornando o acesso a dados mais seguro

Problemas sobre como se conectar aos dados

Trabalhando com conexões de dados externos

As seções a seguir discutem como funcionam as conexões de dados externos e como localizar, editar, gerenciar e compartilhar as informações de conexão com outros programas e usuários.

Início da página

Noções básicas sobre conexões de dados

Os dados em uma pasta de trabalho do Excel são provenientes de dois locais diferentes. Eles podem ser armazenados diretamente na pasta de trabalho ou em uma fonte de dados externa, como um arquivo de texto, um banco de dados ou um cubo OLAP (processamento analítico online). Essas fontes de dados externas são conectadas à pasta de trabalho através de uma conexão de dados, que é um conjunto de informações que descreve como localizar, conectar e acessar uma fonte de dados externa.

A principal vantagem de se conectar a dados externos é que você pode analisar esses dados periodicamente, sem precisar copiá-los várias vezes na pasta de trabalho. A cópia repetida dos dados é uma operação que pode levar tempo e gerar erros. Após conectar-se aos dados externos, você também pode atualizar automaticamente as pastas de trabalho do Excel a partir da fonte de dados original sempre que essa fonte for atualizada com novas informações.

As informações de conexão são armazenadas na pasta de trabalho e em um arquivo de conexão; por exemplo, um arquivo de conexão de dados do Office (.odc) ou um arquivo de nome de fonte de dados (.dsn).

Para trazer dados externos para o Excel, você precisa de acesso aos dados. Se o fonte de dados externo que você deseja acessar não estiver em seu computador local, talvez seja necessário contatar o administrador do banco de dados para uma senha, permissões de usuário ou outras informações de conexão. Se a fonte de dados for um banco de dados, certifique-se de que o banco de dados não é aberto no modo exclusivo. Se a fonte de dados é um arquivo de texto ou uma planilha, certifique-se de que outro usuário abriu para acesso exclusivo.

Várias fontes de dados também exigem um driver ODBC ou provedor OLE DB para coordenar o fluxo de dados entre o Excel, o arquivo de conexão e a fonte de dados.

O diagrama a seguir resume os pontos-chave sobre as conexões de dados.

Conectando-se a fontes de dados externas

1. há uma variedade de fontes de dados que você pode se conectar a: Analysis Services, SQL Server, Microsoft Access, outros OLAP e bancos de dados relacionais, planilhas e arquivos de texto.

2. Várias fontes de dados possuem um driver ODBC ou provedor OLE DB associado.

3. um arquivo de conexão define todas as informações necessárias para acessar e recuperar dados de uma fonte de dados.

4. informações de Conexão são copiadas de um arquivo de conexão para uma pasta de trabalho e as informações de conexão facilmente podem ser editadas.

5. Os dados são copiados para uma pasta de trabalho a fim de que você possa usá-los exatamente como usa os dados armazenados diretamente na pasta de trabalho.

Início da página

Localizando conexões

Para localizar arquivos de conexão, use a caixa de diálogo Conexões Existentes. (Na guia Dados, no grupo Obter Dados Externos, clique em Conexões Existentes.) Nessa caixa de diálogo, você verá os seguintes tipos de conexões:

  • Conexões da pasta de trabalho   

    Essa lista exibe todas as conexões atuais da pasta de trabalho. Ela é criada com base nas conexões já definidas, que você criou usando a caixa de diálogo Selecionar Fonte de Dados do Assistente para Conexão de Dados, ou com base nas conexões que você selecionou anteriormente nessa caixa de diálogo.

  • Arquivos de Conexão no seu computador   

    Essa lista é criada na pasta Minhas Fontes de Dados, normalmente armazenada na pasta Meus documentos (Windows XP) ou Documentos (Windows Vista).

  • Arquivos de Conexão na rede   

    Esta lista pode ser criada com base em:

    • Um conjunto de pastas da rede local, o lugar que pode ser implantado na rede como parte da implantação das diretivas de grupo do Microsoft Office.

    • Um Serviços do Excel biblioteca de Conexão de dados (DCL) em um site de SharePoint Foundation. Para obter mais informações sobre DCLs, consulte a seção Publicando nos serviços do Excel com segurança.

Início da página

Editando propriedades de conexão

Você também pode usar o Excel como um editor de arquivo de conexão para criar e editar conexões a fontes de dados externas armazenadas em uma pasta de trabalho ou em um arquivo de conexão. Se você não localizar a conexão desejada, poderá criar uma conexão clicando em Procurar Mais para exibir a caixa de diálogo Selecionar Fonte de Dados e, em seguida, clicando em Nova Fonte para iniciar o Assistente para Conexão de Dados.

Depois de criar a conexão, você pode usar a caixa de diálogo Propriedades da Conexão (guia dados, no grupo Obter dados externos, clique em Propriedades.) para controlar várias configurações para conexões com fontes de dados externos e usar, reutilizar ou mudar os arquivos de conexão.

Se você usar um arquivo de conexão para se conectar a uma fonte de dados, o Excel copiará as informações de conexão do arquivo de conexão para a pasta de trabalho do Excel. Ao fazer alterações usando a caixa de diálogo Propriedades da Conexão, você estará editando as informações de conexão de dados armazenadas na pasta de trabalho atual do Excel, e não o arquivo de conexão de dados original que pode ter sido usado para criar a conexão (indicada pelo nome de arquivo exibido na propriedade Arquivo de Conexão na guia Definição). Depois que você editar as informações de conexão (com exceção das propriedades Nome da Conexão e Descrição da Conexão), o vínculo com o arquivo de conexão será removido, e a propriedade Arquivo de Conexão será apagada.

Para garantir que o arquivo de conexão sempre será usado quando uma fonte de dados for atualizada, clique em Sempre tentar usar este arquivo para atualizar dados na guia Definição. Se você marcar essa caixa de seleção, estará garantindo que as atualizações feitas no arquivo de conexão serão sempre usadas por todas as pastas de trabalho que usam esse arquivo de conexão, que também deve ter essa propriedade definida.

Início da página

Gerenciando conexões

Na caixa de diálogo Conexões da Pasta de Trabalho, você pode gerenciar facilmente essas conexões, incluindo sua criação, edição e exclusão. (Na guia Dados, no grupo Obter Dados Externos, clique em Conexões.) Use essa caixa de diálogo para fazer o seguinte:

  • Criar, editar, atualizar e excluir conexões que estão em uso na pasta de trabalho.

  • Verificar a fonte de dados externos. Convém fazer isso se a conexão foi definida por outro usuário.

  • Mostrar onde cada conexão é usada na pasta de trabalho atual.

  • Diagnosticar uma mensagem de erro sobre conexões a dados externos.

  • Redirecionar uma conexão para outro servidor ou fonte de dados, ou substituir o arquivo de conexão de uma conexão existente.

  • Facilitar a criação e o compartilhamento de arquivos de conexão com usuários.

Início da página

Compartilhando conexões

Arquivos de conexão são particularmente úteis para o compartilhamento de conexões consistente, tornando as conexões mais fáceis de serem detectadas, ajudando a melhorar a segurança das conexões e facilitando a administração de fontes de dados. A melhor maneira de compartilhar arquivos de conexão é colocando-os em um local seguro e confiável, como uma pasta de rede ou uma biblioteca do SharePoint, onde usuários possam ler o arquivo, mas somente os usuários designados possam modificá-lo.

Usando arquivos ODC

Você pode criar os arquivos de conexão de dados do Office (.odc) conectando-se a dados externos através da caixa de diálogo Selecionar Fonte de Dados ou usando o Assistente para Conexão de Dados para se conectar a novas fontes de dados. O arquivo ODC usa marcas HTML e XML personalizadas para armazenar as informações de conexão. Você pode exibir ou editar facilmente o conteúdo do arquivo no Excel.

É possível compartilhar os arquivos de conexão com outras pessoas para conceder a elas o mesmo acesso que você tem a uma fonte de dados externa. Os outros usuários não precisam configurar uma fonte de dados para abrir o arquivo de conexão, mas talvez precisem instalar o driver ODBC ou provedor OLE DB necessário para acessar os dados externos em seus computadores.

Os arquivos ODC são o método recomendado para a conexão e o compartilhamento de dados. Você pode converter facilmente outros arquivos de conexão tradicionais (DSN, UDL e arquivos de consulta) em arquivo ODC, abrindo o arquivo de conexão e clicando no botão Exportar Arquivo de Conexão na guia Definição da caixa de diálogo Propriedades da Conexão.

Usando arquivos de consulta

Os arquivos de consulta são arquivos de texto que contêm informações de fonte de dados, incluindo o nome do servidor onde os dados estão localizados e as informações de conexão que você fornece ao criar uma fonte de dados. Os arquivos de consulta são a forma tradicional de compartilhar consultas com outros usuários do Excel.

Usar arquivos de consulta. dqy    Você pode usar o Microsoft Query para salvar arquivos. dqy que contêm consultas de dados de bancos de dados relacionais ou arquivos de texto. Quando você abre esses arquivos no Microsoft Query, você pode exibir os dados retornados pela consulta e modificar a consulta para recuperar os resultados diferentes. Você pode salvar um arquivo. dqy para qualquer consulta que você criar usando o Assistente de consulta ou diretamente no Microsoft Query.

Usar arquivos de consulta. oqy    Você pode salvar arquivos. oqy para conectar-se a dados em um banco de dados OLAP, em um servidor ou em um arquivo de cubo offline (. cub). Quando você usa o Assistente de Conexão multidimensional no Microsoft Query para criar uma fonte de dados para um banco de dados OLAP ou um cubo, um arquivo. oqy é criado automaticamente. Como bancos de dados OLAP não estão organizados em registros ou tabelas, é possível criar consultas ou arquivos. dqy para acessar esses bancos de dados.

Usar arquivos de consulta. rqy    O Excel pode abrir arquivos de consulta no formato. rqy para suportar drivers de fonte de dados OLE DB que usam este formato. Para obter mais informações, consulte a documentação do seu driver.

Usar arquivos de consulta. qry    O Microsoft Query pode abrir e salvar arquivos de consulta no formato. qry para uso com versões anteriores do Microsoft Query que não é possível abrir arquivos. dqy. Se você tiver um arquivo de consulta no formato. qry que você deseja usar no Excel, abra o arquivo no Microsoft Query e salve-o como um arquivo. dqy. Para obter informações sobre como salvar arquivos. dqy, consulte a Ajuda do Microsoft Query.

Usando arquivos de consulta de Web. iqy    O Excel pode abrir arquivos de consulta de Web. iqy para recuperar dados da Web.

Início da página

Usando propriedades e intervalos de dados externos

Um intervalo de dados externos (também denominado tabela de consulta) é um nome definido ou nome de tabela que define o local dos dados trazidos para uma planilha. Quando você se conectar aos dados externos, o Excel criará automaticamente um intervalo de dados externos. A única exceção é um relatório de tabela dinâmica conectado a uma fonte de dados, que não cria um intervalo de dados externos. No Excel, você pode definir o formato e o layout de um intervalo de dados externos ou usá-lo em cálculos, como quaisquer outros dados.

O Excel nomeia um intervalo de dados externos automaticamente da seguinte maneira:

  • Os intervalos de dados externos dos arquivos de conexão de dados do Office (ODC) recebem o nome do arquivo.

  • Os intervalos de dados externos de bancos de dados são nomeados com o nome da consulta; por padrão, Consulta_de_fonte é o nome da fonte de dados usada para criar a consulta.

  • Os intervalos de dados externos de arquivos de texto são nomeados com o nome do arquivo de texto.

  • Intervalos de dados externos de consultas à Web são nomeados com o nome da página da Web da qual os dados foram recuperados.

Se a sua planilha tiver mais de um intervalo de dados externos da mesma fonte, os intervalos serão numerados. Por exemplo, MeuTexto, MeuTexto_1, MeuTexto_2 e assim por diante.

Um intervalo de dados externos possui propriedades adicionais (não confunda com as propriedades da conexão) que você pode usar para controlar os dados, como a preservação da formatação da célula e da largura da coluna. É possível alterar essas propriedades de intervalo de dados externos clicando em Propriedades no grupo Conexões da guia Dados e fazendo suas alterações nas caixas de diálogo Propriedades do Intervalo de Dados Externos ou Propriedades de Dados Externos.

Observação : Se você deseja compartilhar um resumo ou relatório baseado em dados externos, poderá fornecer a outras pessoas uma pasta de trabalho contendo um intervalo de dados externos ou poderá criar um modelo de relatório. Um modelo de relatório permite que você salve o resumo ou relatório sem salvar os dados externos, para que o arquivo fique menor. Os dados externos são recuperados quando um usuário abre o modelo de relatório.

Início da página

Noções básicas sobre suporte a fonte de dados no Excel e nos Serviços do Excel

Existem vários objetos de dados (como um intervalo de dados externos e um relatório de tabela dinâmica) que você pode usar para conectar-se a fontes de dados diferentes. No entanto, o tipo de fonte de dados ao qual você pode se conectar varia de acordo com cada objeto de dados. Você também pode usar e atualizar dados conectados nos Serviços do Excel, mas há limitações e soluções adicionais que você precisa saber.

Suporte a fontes de dados e objetos de dados do Excel

A tabela a seguir resume as fontes de dados com suporte em cada objeto de dados do Excel.

Fonte de dados com suporte

Objeto de
dados do
Excel

Cria
intervalo de
dados
externos?

OLE
DB

ODBC

Arquivo de
texto

Arquivo
HTML

Arquivo
XML

Lista
do
SharePoint

Assistente de Importação de Texto

Sim

Não

Não

Sim

Não

Não

Não

Relatório de tabela dinâmica
(não-OLAP)

Não

Sim

Sim

Sim

Não

Não

Sim

Relatório de tabela dinâmica
(OLAP)

Não

Sim

Não

Não

Não

Não

Não

Tabela do Excel

Sim

Sim

Sim

Não

Não

Sim

Sim

Mapa XML

Sim

Não

Não

Não

Não

Sim

Não

Consulta à Web

Sim

Não

Não

Não

Sim

Sim

Não

Assistente para Conexão de Dados

Sim

Sim

Sim

Sim

Sim

Sim

Sim

Microsoft Query

Sim

Não

Sim

Sim

Não

Não

Não

Observação : Esses arquivos, um arquivo de texto importado através do Assistente de Importação de Texto, um arquivo XML importado através de um Mapa XML e um arquivo HTML ou XML importado através de uma Consulta à Web não usam um driver ODBC ou um provedor OLE DB para fazer a conexão com a fonte de dados.

Suporte para fontes de dados e Serviços do Excel

Para exibir uma pasta de trabalho do Excel nos Serviços do Excel (Excel em um navegador da Web), você pode se conectar aos dados e atualizá-los, mas deve usar um relatório de tabela dinâmica. Os Serviços do Excel não oferecem suporte para intervalos de dados externos, ou seja, não oferecem suporte para uma tabela do Excel conectada a uma fonte de dados, uma consulta à Web, um mapa XML ou ao Microsoft Query.

No entanto, você pode resolver essa limitação usando uma tabela dinâmica para conectar-se à fonte de dados e definir o design e o layout da tabela dinâmica como uma tabela bidimensional sem níveis, grupos ou subtotais, para que todos os valores de linha e coluna desejados sejam exibidos. Para obter mais informações, confira os links na seção Consulte também.

Início da página

Noções básicas sobre os Componentes do Data Access

Microsoft Data Access Components (MDAC) 2,8 está incluído no Microsoft Windows Server 2003 e o Windows XP SP2. Com o MDAC, você pode se conectar a e usar dados de uma grande variedade de fontes de dados relacionais e. Você pode se conectar a várias fontes de dados usando drivers de banco de dados ODBC (Open Connectivity) ou provedores de OLE DB, que são criados e fornecidos pela Microsoft ou desenvolvidos por terceiros vários. Quando você instala o Microsoft Office, drivers ODBC adicionais e provedores OLE DB são adicionados ao seu computador.

O Windows Vista e o Windows 7 usam o Windows Data Access Components (Windows DAC).

Para obter uma lista completa dos provedores OLE DB instalados no computador, exiba a caixa de diálogo Propriedades do Link de Dados em um arquivo de link de dados e clique na guia Provedor.

Para obter uma lista completa dos provedores ODBC instalados no computador, exiba a caixa de diálogo Administrador de Banco de Dados ODBC e clique na guia Drivers.

Você também pode usar drivers ODBC e provedores OLE DB de outros fabricantes para obter informações de fontes que não sejam as fontes de dados da Microsoft, incluindo outros tipos de bancos de dados ODBC e OLE DB. Para obter informações sobre como instalar esses drivers ODBC ou provedores OLE DB, verifique a documentação do banco de dados ou contate o fornecedor do banco de dados.

Início da página

Usando o ODBC para conectar-se às fontes de dados

As seções a seguir descrevem detalhadamente o ODBC.

A arquitetura ODBC

Na arquitetura ODBC, um aplicativo (por exemplo, o Excel) conecta-se ao Gerenciador de Driver de ODBC, que, por sua vez, usa um driver ODBC específico (por exemplo, o driver ODBC do Microsoft SQL) para conectar-se a uma fonte de dados (por exemplo, um banco de dados do Microsoft SQL Server).

Definindo informações de conexão

Para conectar-se às fontes de dados ODBC, faça o seguinte:

  1. Verifique se o driver ODBC apropriado está instalado no computador que contém a fonte de dados.

  2. Defina um DSN (nome de fonte de dados) usando o Administrador de Fonte de Dados ODBC para armazenar as informações de conexão no Registro ou em um arquivo DSN, ou uma cadeia de conexão no código do Microsoft Visual Basic para passar as informações de conexão diretamente para o Gerenciador de Driver ODBC.

    Para definir uma fonte de dados, no Windows Vista, clique no botão Iniciar e clique em Painel de Controle. Clique em Sistema e Manutenção e em Ferramentas Administrativas. No Windows XP e Windows Server, clique em Iniciar e em Painel de Controle. Clique em Desempenho de Manutenção, em Ferramentas Administrativas e em Fontes de Dados (ODBC). Para obter mais informações sobre as diferentes opções, clique no botão Ajuda em cada caixa de diálogo.

Fontes de dados de máquina

Fontes de dados da máquina armazenam informações de conexão no registro, em um computador específico, com um nome definido pelo usuário. Você pode usar fontes de dados de máquina somente no computador em que são definidos. Há dois tipos de fontes de dados de máquina — usuário e sistema. Fontes de dados do usuário podem ser usadas somente pelo usuário atual e são visíveis apenas para esse usuário. Fontes de dados do sistema podem ser usadas por todos os usuários em um computador e são visíveis para todos os usuários no computador.

Uma fonte de dados de máquina é especialmente útil quando você deseja oferecer segurança adicional, pois somente usuários que estejam conectados podem ver uma fonte de dados de máquina, que não pode ser copiada por um usuário remoto para outro computador.

Fontes de dados de arquivo

Fontes de dados de arquivo (também denominadas arquivos DSN) armazenam informações de conexão em um arquivo de texto, e não no Registro. Elas são geralmente mais flexíveis que as fontes de dados de máquina. Por exemplo, você pode copiar uma fonte de dados de arquivo para qualquer computador com o driver ODBC correto, para que o seu aplicativo possa se basear em informações de conexão consistentes e precisas em todos os computadores que utilizar. Você também pode colocar a fonte de dados de arquivo em um único servidor, compartilhá-la entre vários computadores da rede e manter facilmente as informações de conexão em um único local.

Uma fonte de dados de arquivo também pode não ser compartilhável. Uma fonte de dados de arquivo não compartilhável reside em um único computador e aponta para uma fonte de dados de máquina. Você pode usar fontes de dados de arquivo não compartilháveis para acessar fontes de dados de máquina existentes com base em fontes de dados de arquivo.

Início da página

Usando o OLE DB para conectar-se às fontes de dados

As seções a seguir descrevem mais detalhadamente o banco de dados de vinculação e incorporação de objetos (OLE DB).

A arquitetura OLE DB

Na arquitetura OLE DB, o aplicativo que acessa os dados é chamado de consumidor de dados (por exemplo, o Excel) e o programa que permite o acesso nativo aos dados é chamado de provedor de banco de dados (por exemplo, Microsoft OLE DB Provider for SQL Server).

Definindo informações de conexão

Um arquivo de link de dados universal (.udl) contém informações de conexão que um consumidor de dados usa para acessar uma fonte de dados através do provedor OLE DB dessa fonte de dados. Você pode criar as informações de conexão executando um dos seguintes procedimentos:

  • No Assistente de Conexão de dados, use a caixa de diálogo de Propriedades de vínculo de dados para definir um vínculo de dados para um provedor OLE DB. Para obter mais informações, consulte a seção importando dados usando o Assistente de Conexão de dados.

  • Crie um arquivo de texto em branco com uma extensão de nome de arquivo .udl e edite o arquivo, o que exibirá a caixa de diálogo Propriedades do Link de Dados.

Início da página

Atualizando dados

Quando você estiver conectado a uma fonte de dados externa, também poderá executar uma operação de atualização para recuperar os dados atualizados. Cada vez que você atualizar os dados, verá a versão mais recente, incluindo quaisquer alterações feitas nos dados desde a última atualização.

A ilustração a seguir explica o processo básico de atualização dos dados conectados a uma fonte de dados externa.

o processo básico de atualização de dados externos

1. Uma operação de atualização captura os dados atualizados.

2. o arquivo de conexão define todas as informações necessárias para acessar e recuperar dados de uma fonte de dados externos.

3. Existem diversas fontes de dados que você pode atualizar: OLAP, SQL Server, Access, OLE DB, ODBC, planilhas e arquivos de texto.

4. Os dados atualizados são adicionados à pasta de trabalho atual.

O Excel fornece várias opções para atualizar dados importados, incluindo a atualização de dados sempre que você abre a pasta de trabalho e a atualização automática em intervalos regulares. Você pode continuar trabalhando no Excel enquanto os dados estão sendo atualizados e também pode verificar o status durante a atualização.

Se sua fonte de dados externa solicitar uma senha para ter acesso aos dados, você pode solicitar que a senha seja inserida sempre que o intervalo de dados externos for atualizado.

Início da página

Importando dados de fontes de dados

O Windows XP, o Windows Vista e o Microsoft Office fornecem os drivers ODBC e provedores OLE DB que você pode usar para recuperar dados das seguintes fontes de dados comuns: Microsoft Access, arquivos HTML da World Wide Web, arquivos de texto, Microsoft SQL Server, SQL Server Analysis Services e arquivos XML. Usando o Assistente para Conexão de Dados e o Microsoft Query, você também pode acessar várias outras fontes de dados que tenham os provedores OLE DB e drivers ODBC apropriados, incluindo outras planilhas do Excel, Microsoft FoxPro, dBASE, Paradox, Oracle e DB2.

Início da página

Importando dados de um banco de dados do Access

Existem várias maneiras de trocar dados entre o Microsoft Access e o Microsoft Excel.

  • Para trazer dados do Access para o Excel, você pode copiar dados de uma folha de dados do Access e colá-los em uma planilha do Excel, conectar-se a um banco de dados do Access em uma planilha do Excel ou exportar dados do Access para uma planilha do Excel.

  • Para trazer dados do Excel para o Access, você pode copiar dados de uma planilha do Excel e colá-los em uma folha de dados do Access, importar uma planilha do Excel para uma tabela do Access ou vincular-se a uma planilha do Excel a partir de uma tabela do Access.

Observação : O word Importar tem dois significados diferentes entre o Excel e o Access. No Excel importar significa fazer uma conexão permanente aos dados que podem ser atualizados. No Access importar significa trazer os dados para o Access uma vez, mas sem uma conexão de dados.

Trabalhando com dados do Access no Excel

Talvez você queira trabalhar com os dados do Access em uma planilha do Excel, para aproveitar as vantagens que os recursos de análise e gráfico de dados oferecem, além da flexibilidade no gerenciamento e layout dos dados ou das funções no Excel não disponíveis no Access.

Conectando-se aos dados do Access no Excel

Para trazer os dados atualizáveis do Access para o Excel, você pode criar uma conexão com o banco de dados do Access e recuperar todos os dados de uma tabela ou consulta. Por exemplo, talvez seja necessário atualizar um relatório orçamentário resumido do Excel que distribua todos os meses de modo a conter os dados do mês atual.

Exportando dados do Access para o Excel

Ao utilizar o Assistente para Exportação no Access, você pode exportar o objeto de banco de dados do Access (como uma tabela, consulta ou formulário) ou registros selecionados em um modo de exibição para uma planilha do Excel. Ao executar uma operação de exportação no Access, você pode salvar o design dessa operação para uso futuro e até mesmo agendar a exportação de forma que ela seja executada automaticamente em intervalos especificados.

Estes são os cenários comuns da exportação de dados do Access para o Excel:

  • Seu departamento ou grupo de trabalho usa o Access e o Excel para trabalhar com dados. Você armazena os dados em bancos de dados do Access, mas usa o Excel para analisar os dados e distribuir os resultados da análise. Sua equipe exporta os dados para o Excel quando necessário, mas você deseja tornar esse processo mais eficiente.

  • Você já tem bastante experiência no uso do Access, mas seu gerente prefere visualizar os relatórios no Excel. Em intervalos regulares, você copia os dados para o Excel, mas deseja automatizar esse processo para economizar seu tempo.

Para obter mais informações sobre como exportar dados do Access para o Excel, consulte o sistema de Ajuda do Access.

Trabalhando com dados do Excel no Access

Talvez seja necessário trabalhar com dados do Excel em um banco de dados do Access para que você possa tirar proveito dos recursos de multiusuário, segurança e gerenciamento de dados do Access. Embora haja várias recursos úteis no Access, existem dois recursos que os usuários consideram particularmente úteis no trabalho com dados do Excel:

  • Relatórios    Se estiver familiarizado com a criação de relatórios do Access e desejar resumir e organizar seus dados do Excel nesse tipo de relatório, você poderá criar um relatório no Access. Por exemplo, você pode criar relatórios mais flexíveis, como relatórios de grupo ou resumo, rótulos impressos e relatórios gráficos.

  • Formulários    Se você quiser usar um formulário para localizar ou exibir dados no Excel, você pode criar um formulário do Access. Por exemplo, você pode criar um formulário do Access para exibir campos em uma ordem diferente da ordem das colunas na planilha, ou você pode ver uma linha longa de dados mais facilmente em uma tela.

Para obter mais informações sobre como trabalhar com formulários e relatórios do Access, consulte o sistema de Ajuda do Access.

Vinculando-se aos dados do Excel no Access

Você pode vincular um intervalo do Excel a um banco de dados do Access como uma tabela. Use esse método para manter o intervalo de dados no Excel e também para que esses dados fiquem disponíveis no Access. Você pode criar esse tipo de link a partir de um banco de dados do Access, mas não do Excel.

Quando você se vincula a uma planilha do Excel ou a um intervalo nomeado, o Access cria uma nova tabela vinculada às células de origem. Qualquer alteração feita nas células de origem no Excel se reflete na tabela vinculada. No entanto, você não pode editar o conteúdo da tabela correspondente no Access. Para adicionar, editar ou excluir dados, faça as alterações no arquivo de origem do Excel.

Estes são os cenários comuns de vinculação a uma planilha do Excel no Access:

  • Você deseja manter os dados nas planilhas do Excel, mas continuar a usar os sofisticados recursos de consulta e geração de relatórios do Access.

  • Seu departamento ou grupo de trabalho usa o Access, mas os dados de fontes externas com os quais você trabalha estão armazenados em planilhas do Excel. Você não deseja manter cópias de dados externos, mas precisa trabalhar com eles no Access.

Para obter mais informações sobre como vincular dados do Access ao Excel, consulte o sistema de Ajuda do Access.

Importando dados do Excel para o Access

Para armazenar dados do Excel em um banco de dados do Access e, em seguida, usar e manter os dados no Access desse ponto em diante, importe os dados para o Access. Quando os dados são importados, o Access os armazena em uma tabela nova ou existente sem alterar os dados no Excel. Você pode importar somente uma planilha por vez durante uma operação de importação. Para importar dados de várias planilhas, repita a operação de importação para cada planilha.

Estes são os cenários comuns da importação dos dados do Excel para o Access:

  • Você já usa o Excel há bastante tempo mas, de agora em diante, deseja usar o Access para trabalhar com esses dados. Você deseja mover os dados para planilhas do Excel em um ou mais bancos de dados novos do Access.

  • Seu departamento ou grupo de trabalho usa o Access, mas, de vez em quando, você recebe dados no formato do Excel que devem ser mesclados com os bancos de dados do Access. Você deseja importar essas planilhas do Excel para seu banco de dados quando as receber.

  • Você usa o Access para gerenciar os dados, mas os relatórios semanais que recebe do restante da equipe são pastas de trabalho do Excel. Você deseja otimizar o processo de importação para garantir que os dados serão importados a cada semana em um horário específico para seu banco de dados.

Para obter mais informações sobre como importar dados Excel para o Access, consulte o sistema de Ajuda do Access.

Início da página

Importando dados da Web

As páginas da Web geralmente contêm informações que são perfeitas para análise no Excel. Por exemplo, você pode analisar cotações de ações no Excel usando informações provenientes diretamente de uma página da Web. Dependendo das suas necessidades, você pode recuperar dados atualizáveis (isto é, pode atualizar os dados no Excel com os dados mais recentes da página da Web) ou obter dados de uma página da Web e mantê-los estáticos na planilha.

Você pode usar uma consulta à Web para recuperar dados armazenados na intranet ou na Internet, como uma tabela, várias tabelas ou todo o texto de uma página da Web, e analisar os dados usando as ferramentas e os recursos do Excel. Clicando um simples botão, você pode atualizar facilmente os dados com as informações mais recentes da página da Web. Por exemplo, é possível recuperar e atualizar cotações de ações em uma página da Web pública, ou recuperar e atualizar uma tabela de informações de vendas em uma página da Web da empresa.

Você pode importar dados que se originam de uma página da Web usando a caixa de diálogo Nova consulta à Web. (Guia dados, no grupo Obter dados externos, clique em Da Web.) Você precisa ter acesso à World Wide Web através da intranet da sua empresa ou através de um modem no seu computador ou rede, ou você pode fazer uma consulta contra arquivos HTML ou XML que estão armazenados em seu computador.

Início da página

Importando arquivos de texto

Você pode usar o Excel para importar dados de um arquivo de texto para uma planilha. (Na guia Dados, no grupo Obter Dados Externos, clique em Conexões.) O Assistente de Importação de Texto examina o arquivo de texto que você está importando e garante que os dados serão importados da maneira desejada.

Existem duas maneiras de importar dados de um arquivo de texto usando o Excel: você pode abrir o arquivo de texto no Excel (que estabelece uma conexão com o arquivo de texto) ou importar o arquivo de texto como um intervalo de dados externos (que não estabelece uma conexão com o arquivo de texto).

Estes são os dois formatos de arquivo de texto comumente usados:

  • Arquivos de texto delimitados (.txt), nos quais o caractere de tabulação (código 009 do caractere ASCII) geralmente separa cada campo de texto.

  • Arquivos de texto de valores separados por vírgula (.csv), nos quais a vírgula (,) geralmente separa cada campo de texto.

Você também pode alterar o caractere separador usado nos arquivos de texto .csv e delimitados. Talvez isso seja necessário para verificar se a operação de importação ou exportação está funcionando da maneira desejada.

Início da página

Importando dados do Microsoft SQL Server

O Microsoft SQL Server é um banco de dados relacional completo projetado para soluções de dados empresariais que requerem desempenho, disponibilidade, escalabilidade e segurança ideais. No Excel, você pode se conectar facilmente a um banco de dados do Microsoft SQL Server. (Na guia Dados, no grupo Obter Dados Externos, clique em De Outras Fontes e em Do SQL Server.)

Quando você se conecta a um banco de dados do Microsoft SQL Server, o Assistente para Conexão de Dados exibe três páginas:

  • Página 1: conectar ao servidor de banco de dados    Use esta página para especificar o servidor de banco de dados e a maneira que você fizer logon no servidor.

  • Página 2: selecione o banco de dados e tabela    Use esta página para especificar o banco de dados e tabela ou consulta que contém os dados desejados.

  • Página 3: Salvar o Arquivo de Dados e a Conexão    Use esta página para especificar e descrever o arquivo de conexão e pesquisar frases para localizar o arquivo.

Início da página

Importando dados do Microsoft SQL Server Analysis Services

Do Analysis Services (um componente do Microsoft SQL Server) que suporta inteligência de negócios e é uma base para sistemas de análise de processamento analítico Online (OLAP), scorecards de chave de desempenho KPI (indicador), mineração de dados e sistemas de relatórios de painel. No Excel, você pode se conectar facilmente a um banco de dados OLAP de serviços de análise usando um provedor OLAP. (Na guia dados, no grupo Obter dados externos, clique em De outras fontes e clique em Do Analysis Services.) Um provedor OLAP é um conjunto de software que fornece acesso a um tipo específico de banco de dados OLAP. Este software pode incluir um driver de fonte de dados e outros softwares de cliente que é necessário para se conectar a um banco de dados. Você deve usar um relatório de tabela dinâmica para se conectar a um provedor OLAP.

Você também pode acessar dados OLAP quando estiver desconectado da fonte de dados OLAP. Um arquivo de cubo offline é um arquivo com uma extensão. cub que armazena uma parte do dados de origem de um banco de dados do servidor OLAP. Use um arquivo de cubo offline para continuar a fazer alterações em relatórios de tabela dinâmica e gráfico dinâmico quando o servidor está indisponível ou quando estiver desconectado da rede.

Quando você se conecta ao Analysis Services, o Assistente para Conexão de Dados exibe três páginas:

  • Página 1: Conectar ao Servidor do Banco de Dados     Use esta página para especificar o servidor e a maneira em que o logon deve ser feito no servidor de banco de dados.

  • Página 2: Selecionar o Banco de Dados e a Tabela    Use esta página para especificar o banco de dados e o cubo.

  • Página 3: Salvar o Arquivo de Dados e a Conexão    Use esta página para especificar e descrever o arquivo de conexão e pesquisar frases para localizar o arquivo.

Início da página

Importando dados XML

Excel facilita a importar dados de Extensible Markup Language (XML) que são criados a partir de outros bancos de dados e aplicativos, mapear elementos XML de um esquema XML a células de planilha e exportar dados XML revisados para interação com outros bancos de dados e aplicativos. Considere esses novos recursos XML como transformar o Excel em um gerador de arquivo de dados XML com uma interface de usuário familiar.

Usando mapas XML, você pode adicionar, identificar e extrair facilmente partes de dados comerciais específicas de documentos do Excel. Por exemplo, uma fatura que contenha o nome e o endereço de um cliente ou um relatório que contenha resultados financeiros do último trimestre não são mais relatórios estáticos. Você pode importar facilmente essas informações dos bancos de dados e aplicativos, revisá-las e exportá-las para o mesmo ou para outros bancos de dados e aplicativos.

Principais cenários XML

Estes são os principais cenários que os recursos XML podem resolver:

  • Estender a funcionalidade dos modelos do Excel existentes mapeando elementos XML para células existentes. Isso facilitará a obtenção de dados XML para dentro e para fora dos modelos sem precisar recriá-los.

  • Usar os dados XML como entrada para os modelos de cálculo existentes mapeando elementos XML para planilhas existentes.

  • Importar arquivos de dados XML para uma nova pasta de trabalho.

  • Importar dados XML de um serviço Web para a planilha do Excel.

  • Exportar dados das células mapeadas para arquivos de dados XML independente de outros dados da pasta de trabalho.

O processo básico de uso dos dados XML no Excel

O diagrama a seguir mostra como os diferentes arquivos e operações trabalham em conjunto quando você usa a XML com o Excel. Basicamente, há cinco fases a serem processadas.

Visão geral do funcionamento do Excel com dados XML

Texto explicativo 1 Adicionando um arquivo de esquema XML (. xsd) a uma pasta de trabalho.

Imagem de botão Mapeando elementos de esquema XML para células individuais ou XML listas.

Texto explicativo 3 Importando um arquivo de dados XML (. xml) e associando os elementos XML a células mapeadas.

Etapa 4 Inserindo dados, movendo células mapeadas e aproveitando a funcionalidade do Excel preservando definições e a estrutura XML.

Texto explicativo 5 Exportando dados revisados de células mapeadas para um arquivo de dados XML.

Usando dados XML

Quando você importar o conteúdo de um arquivo de dados XML para um mapa XML existente na pasta de trabalho, ligará os dados do arquivo para um mapa XML armazenado na pasta de trabalho. Isso significa que cada elemento de dados do arquivo de dados XML tem um elemento correspondente no esquema XML que você mapeou de um arquivo de esquema XML ou de um esquema inferido. Cada mapa XML pode ter apenas uma ligação de dados XML. Além isso, uma ligação de dados XML é ligada a todos os mapeamentos criados com base em um único mapa XML.

Você pode exibir a caixa de diálogo Propriedades do Mapa XML (na guia Desenvolvedor, no grupo XML, clique em Propriedades do Mapa.), em que serão exibidas três opções (todas selecionadas por padrão) que você pode definir ou desmarcar para controlar o comportamento de uma associação de dados XML:

  • Validar dados com base no esquema para importação e exportação    Especifique se o Excel valida dados com base no mapa XML ao importar os dados. Defina esta opção para garantir que os dados XML importados estejam em conformidade com o esquema XML.

  • Substituir os dados existentes pelos novos dados    Especifique se os dados serão substituídos quando você importar os dados. Defina esta opção para substituir os dados atuais por novos dados; por exemplo, quando os dados atualizados estiverem no novo arquivo de dados XML.

  • Acrescentar novos dados às listas XML existentes    Especifique se o conteúdo da fonte de dados será acrescentado aos dados existentes na planilha. Defina esta opção, por exemplo, quando estiver consolidando dados de vários arquivos de dados XML similares em uma lista XML ou quando não desejar substituir o conteúdo de uma célula que contenha uma função.

Início da página

Importando dados através do Assistente para Conexão de Dados

Você pode usar o Assistente para Conexão de Dados para conectar-se a uma fonte de dados externa OLE DB ou ODBC que já tenha sido definida. Para abrir o Assistente para Conexão de Dados, na guia Dados, no grupo Obter Dados Externos, clique em De Outras Fontese, em seguida, clique em Do Assistente de Conexão de Dados.

Se você escolher a opção de fonte de dados Outros/avançados no Assistente para Conexão de Dados, poderá exibir uma lista de provedores OLE DB disponíveis na caixa de diálogo Propriedades do Link de Dados. Além disso, o Microsoft OLE DB Provider for ODBC Drivers também permite o acesso a fontes de dados ODBC. Para obter mais informações sobre como usar cada guia dessa caixa de diálogo, clique em Ajuda na caixa de diálogo Propriedades do Link de Dados.

Em geral, para definir informações de conexão na caixa de diálogo Propriedades do Link de Dados, faça o seguinte:

  • Clique na guia Provedor, selecione o provedor OLE DB e clique em Avançar. A guia Conexão é exibida e você pode digitar informações de conexão específicas sobre esse provedor OLE DB.

    Cada provedor OLE DB define informações de conexão específicas. Por exemplo, o Microsoft OLE DB Provider for SQL Server requer um nome de servidor, um local de servidor e um nome de usuário. Você também pode definir informações adicionais, como uma senha, ou se você deseja usar a segurança integrada do Microsoft Windows.

  • Clique na guia Avançado para fornecer informações adicionais, como configurações de rede e permissões de acesso.

  • Clique na guia Tudo para definir propriedades de inicialização para o provedor OLE DB.

Observação : Você não pode filtrar ou associar dados no Assistente para Conexão de Dados.

Início da página

Importando dados através do Microsoft Query

Você também pode usar o Microsoft Query para importar dados. (Na guia Dados, no grupo Obter Dados Externos, clique em De Outras Fontes e, em seguida, clique em Do Microsoft Query.) Use o Microsoft Query para configurar fontes de dados ODBC para recuperar dados. No Microsoft Query, use o Assistente de Consulta para criar uma consulta simples ou use critérios avançados no Query para criar uma consulta mais complexa e faça o seguinte:

  • Filtre linhas ou colunas de dados antes que sejam inseridas no Excel.

  • Crie uma consulta parâmetro.

  • Classifique os dados antes de inseri-los no Excel.

  • Associe várias tabelas.

O Microsoft Query oferece um front end simples, que pode ser facilmente acessado no Excel, para executar essas tarefas especializadas de consulta.

Início da página

Importando dados programaticamente e através de funções

Se você for desenvolvedor, há várias abordagens no Excel que você pode utilizar para importar dados:

  • Você pode usar o Visual Basic for Applications para obter acesso a uma fonte de dados externa. Dependendo da fonte de dados, você pode usar o ActiveX Data Objects ou objetos de acesso a dados para recuperar os dados. Você também pode definir uma cadeia de conexão no seu código que especifica as informações de conexão. Usando uma cadeia de conexão é útil, por exemplo, quando você deseja evitar que os administradores de sistema ou usuários para primeiro criar um arquivo de conexão, ou para simplificar a instalação do seu aplicativo.

  • Se você importar dados de um banco de dados do SQL Server, considere o uso do SQL Native Client, que é uma API autônoma de acesso a dados usada no OLE DB e ODBC. Ele combina o SQL OLE DB Provider e o SQL ODBC Driver em uma DLL (biblioteca de vínculo dinâmico (DLL) nativa, além de fornecer uma nova funcionalidade separada e distinta dos MDAC (Microsoft Data Access Components). Você pode usar o SQL Native Client para criar novos aplicativos ou aperfeiçoar aplicativos existentes que podem tirar proveito dos recursos mais recentes do SQL Server, como suporte a MARS (Multiple Active Result Sets), UDT (Tipos Definidos pelo Usuário) e tipos de dados XML.

  • A função RTD recupera dados em tempo real de um programa que suporta automação COM. O suplemento de automação COM RTD o deve ser criado e registrado em um computador local.

  • O SQL. Função de solicitação conecta com uma fonte de dados externa e executa uma consulta a partir de uma planilha. O SQL. Função de solicitação, em seguida, retorna o resultado como uma matriz, sem a necessidade de programação de macro. Se esta função não estiver disponível, você deve instalar o programa suplementar do Microsoft Excel ODBC (XLODBC. XLA). Você pode instalar o suplemento do Office.com.

Para obter mais informações sobre como criar o Visual Basic for Applications, consulte a Ajuda do Visual Basic.

Início da página

Tornando o acesso a dados mais seguro

Quando você se conecta a uma fonte de dados externa ou atualiza os dados, é importante estar ciente dos possíveis problemas de segurança e de como resolvê-los. Use as diretrizes e práticas recomendadas a seguir para proteger os dados.

Início da página

Armazenando conexões de dados em um local confiável

Um arquivo de conexão de dados geralmente contém uma ou mais consultas que são usadas para atualizar dados externos. Se esse arquivo for substituído, um usuário mal-intencionado poderá criar uma consulta para acessar informações confidenciais e distribuí-las aos outros usuários ou executar outras ações prejudiciais. Portanto, é importante ter a certeza do seguinte:

  • O arquivo de conexão foi gravado por uma pessoa confiável.

  • O arquivo de conexão é seguro e está armazenado em um local confiável.

Para ajudar a melhorar a segurança, convém desabilitar as conexões com dados externos no computador. Para conectar-se aos dados quando abrir uma pasta de trabalho, você deve ativar as conexões de dados usando a barra da Central de Confiabilidade ou colocando a pasta de trabalho em um local confiável. Para obter mais informações, consulte os links na seção Consulte também.

Início da página

Usando credenciais de maneira segura

O acesso a uma fonte de dados externa geralmente requer as credenciais (como nome de usuário e senha) utilizadas para autenticar o usuário. Verifique se essas credenciais lhe foram fornecidas de maneira segura e confirme que você não as revelou inadvertidamente a outras pessoas.

Importante : Use senhas fortes que combinem letras maiusculas e minúsculas, números e símbolos. Senhas não combinar esses elementos. Senha forte: Y6dh! et5. Senha fraca: House27. Senhas devem ser 8 ou mais caracteres de comprimento. Uma frase secreta que usa 14 ou mais caracteres é melhor. É importante lembrar sua senha. Se você esquecer sua senha, a Microsoft não pode recuperá-la. Armazene as senhas que você escreve para baixo em um local seguro longe as informações que ajudam a proteger.

Evite salvar informações de logon ao se conectar a fontes de dados. Essas informações podem ser armazenadas como texto sem formatação na pasta de trabalho e no arquivo de conexão, e um usuário mal-intencionado pode acessá-las com a finalidade de comprometer a segurança da fonte de dados.

Quando possível, use a Autenticação do Windows (também conhecida como uma conexão confiável), que utiliza uma conta de usuário do Windows para se conectar ao SQL Server. Quando um usuário se conecta através de uma conta de usuário do Windows, o SQL Server usa as informações contidas no sistema operacional Windows para validar a senha e o nome da conta. Para usar a Autenticação do Windows, é necessário que um administrador de servidor configure o SQL Server para usar esse modo de autenticação. Se a Autenticação do Windows não estiver disponível, evite salvar as informações de logon dos usuários em um arquivo de pasta de trabalho ou de conexão. É mais seguro que os usuários insiram suas informações de logon todas as vezes que fizerem logon.

Início da página

Publicando dados de modo seguro nos Serviços do Excel

Quando você se conectar a uma fonte de dados, use a caixa de diálogo Configurações de Autenticação dos Serviços do Excel para escolher um método de autenticação ao acessar a fonte de dados nos Serviços do Excel. Você pode selecionar uma das opções a seguir para fazer logon na fonte de dados:

  • Autenticação do Windows    Selecione essa opção para usar o nome de usuário e a senha do Windows do usuário atual. Esse é o método mais seguro, mas pode impactar o desempenho onde houver muitos usuários.

  • SSS    Selecione essa opção para usar o serviço de armazenamento seguro e insira a cadeia de caracteres de identificação apropriado na caixa de texto ID SSS. Um administrador de site pode configurar um site do SharePoint para usar um banco de dados de serviço de armazenamento seguro onde um nome de usuário e senha podem ser armazenadas. Esse método pode ser mais eficiente quando há muitos usuários.

  • Nenhum    Selecione esta opção para salvar o nome de usuário e a senha no arquivo de conexão.

Observação : A configuração da autenticação é usada apenas pelos Serviços do Excel e não pelo Microsoft Excel. Para ter certeza de que os mesmos dados sejam acessados quando abrir a pasta de trabalho em Excel ou os Serviços do Excel, verifique se a configuração da autenticação no Excel é a mesma.

Para melhorar a segurança das suas conexões, use uma biblioteca de Conexão de dados (DCL). Um DCL é uma biblioteca de documentos do SharePoint especial que pode ser definido como uma biblioteca de local confiável e que facilita a armazenar, proteger, compartilhar e gerenciar arquivos ODC. Por exemplo, um administrador talvez seja necessário mover um banco de dados de um servidor de teste para um servidor de produção ou atualizar uma consulta que acessa os dados. Usando um arquivo ODC salvo em um DCL, administração dessas informações de conexão é muito mais fácil e acesso dos usuários aos dados é mais conveniente, pois todas as pastas de trabalho usam o mesmo arquivo de conexão, uma operação de atualização (se o computador cliente ou servidor) obtém atualizadas alterações nesse arquivo de conexão. Você pode até mesmo configurar SharePoint Server e o computador de cliente do usuário para detectar automaticamente as alterações a conexão de arquivo e em seguida, usam a versão mais atualizada desse arquivo de conexão. Para obter mais informações, consulte Microsoft SharePoint Foundation 2010 ajuda da Administração Central.

Início da página

Problemas sobre conexão de dados

As seguintes seções abordarão vários problemas que podem ocorrem durante a conexão aos dados externos

Início da página

Problema: fico sem espaço em disco quando tento importar dados.

Se você ficar sem espaço em disco quando se conectar aos dados externos, faça o seguinte:

Seleção e aumente disponível espaço em disco    Para liberar espaço no disco rígido, tente esvaziar a Lixeira, fazer backup de arquivos desnecessários e, em seguida, removê-los do disco rígido ou removendo componentes do Windows utilizados. Para obter mais informações sobre como liberar espaço em disco rígido, consulte a Ajuda do Windows.

Estratégias que você pode experimentar quando o espaço em disco é limitado    Se você tiver apenas uma quantidade limitada de espaço disponível em seu disco rígido, tente o seguinte:

Microsoft Query    Siga um ou mais destes procedimentos:

  • Simplifique sua consulta    Certifique-se de que você incluir apenas essas tabelas e campos que são necessários para sua consulta. Se sua consulta contiver tabelas ou campos desnecessários, exclua-os da consulta para reduzir o tamanho do arquivo de consulta temporário.

  • Use critérios para reduzir o tamanho do resultado definido    Use critérios para recuperar somente registros específicos em vez de recuperar todos os registros de um banco de dados. Para obter mais informações, consulte a Ajuda do Microsoft Query.

  • Definir um limite no número de registros retornados pela consulta    Limite o número de registros que a consulta retorna. No Microsoft Query, clique em Opções no menu Editar, selecione a caixa de seleção limitar o número de registros retornados para em configurações de usuário e, em seguida, insira o número máximo de registros para retornar na caixa registros.

Assistente de Conexão de dados    Embora você não pode limitar os dados através do Assistente de Conexão de dados, você poderá limitar os dados da fonte de dados definindo uma consulta na fonte de dados. Se você não tiver a capacidade ou permissão para definir uma consulta a fonte de dados, contate o administrador de dados.

Início da página

Problema: onde está o Assistente de Cubo OLAP?

O Assistente de Cubo OLAP do Microsoft Query, que criou um cubo OLAP em um banco de dados Jet, não está mais disponível no Excel.

Início da página

Problema: o que aconteceu com os serviços de recuperação de dados?

Incorporado no Microsoft Office 2003, os serviços de recuperação de dados usam um arquivo .udcx (Universal Data Connection) para acessar os Serviços Web e consultar diferentes fontes de dados.

No Assistente de Conexão de dados, na página Bem-vindo ao Assistente de Conexão de dados, você pode selecionar as opções de fonte de dados do Microsoft Business Solutions ou Serviços de recuperação de dados. A opção de Serviços de recuperação de dados permite que você escolha dois serviços de recuperação de dados: listas do Windows SharePoint Services, que recupera dados de listas e bibliotecas de documentos em um servidor executando SharePoint Foundation e o Microsoft SQL Server, que recupera dados do Microsoft SQL Server 2000 ou posterior.

Embora o Assistente para Conexão de Dados não ofereça mais suporte à edição de arquivos de conexão UDC, o Excel continuará oferecendo suporte às conexões de serviços de recuperação de dados existentes, e você ainda poderá atualizá-las.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×