Vincular ou incorporar dados no Office para Mac

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Quando você usa o Office, há várias maneiras de compartilhar informações entre os aplicativos. Copiar e colar é uma delas, mas você também pode vincular as informações para que elas sejam atualizadas automaticamente, ou inserir as informações para que elas sejam atualizadas apenas quando você as atualizar manualmente abrindo o arquivo. Você também pode vincular a uma parte de um arquivo, por exemplo, algumas células em uma planilha do Excel, usando um objeto vinculado.

Vantagens e desvantagens da vinculação versus inserção

Vinculação

Inserção

Atualiza as informações automaticamente

Facilita a abertura do aplicativo no qual as informações inseridas foram criadas

Mantém os arquivos com um tamanho pequeno

Resulta em tamanhos de arquivo maiores do que aqueles com informações vinculadas

Exige que os dois arquivos estejam acessíveis para exibição das informações

Exige que os dois arquivos estejam acessíveis para a atualização das informações, mas não para exibição

Não é adequado se você quiser distribuir o arquivo online

É adequado se você quiser distribuir o arquivo online, pois todas as informações estão contidas em um arquivo

Word

Se você mantiver dados em um arquivo do Excel e informações relacionadas em um arquivo do Word, você poderá vincular as informações para facilitar a atualização. Por exemplo, vamos supor que você deseja vincular os retornos de vendas mais recentes ao seu relatório de status mensal. O relatório de status é um documento do Word, e os retornos de vendas estão em uma planilha do Excel. Ao vincular o documento e a planilha, o relatório de status é atualizado automaticamente sempre que os retornos a vendas forem atualizados. Ou, talvez você queira inserir instruções de um documento do Word em diversos arquivos do Excel. Ao usar um link, você pode atualizar as instruções e as atualizações aparecem em todos os arquivos do Excel.

  1. Clique onde deseja inserir o vínculo.

  2. No menu Inserir, clique em Objeto e clique em Do Arquivo.

  3. Localize e clique no arquivo que você deseja vincular, clique em Opções.

  4. Marque a caixa de seleção Vincular ao arquivo

    Dica : Para que os leitores vejam somente um ícone que eles podem clicar para exibir as informações, marque a caixa de seleção Exibir como Ícone.

  5. Clique em Inserir se você estiver usando o Word ou Okey se você estiver usando o Excel.

  1. No menu Editar, clique em Links.

    Se o comando Links não estiver disponível, o arquivo não terá informações vinculadas.

  2. Em Arquivo de Origem, clique no arquivo vinculado e, em seguida, clique em Abrir Origem.

  3. Faça as alterações desejadas.

  4. No menu Arquivo, clique em Salvar para salvar suas alterações e, em seguida, feche o aplicativo.

    Observe que o arquivo com o link contém as alterações.

Se você quiser manter os dois arquivos conectados, mas não quiser atualizar o arquivo principal quando o outro arquivo for alterado, você poderá inserir as informações. Por exemplo, se você não quiser que o relatório de status mude quando a planilha do Excel mudar, ou se você não quiser que a planilha do Excel mude quando as instruções mudarem, você poderá inserir informações. Como as informações estão totalmente contidas em um único arquivo, a inserção será útil quando você quiser distribuir uma versão online do seu arquivo para as pessoas que não têm acesso ao arquivo inserido.

  1. Clique no local onde você deseja inserir o arquivo.

  2. No menu Inserir, clique em Objeto e clique em Do Arquivo.

  3. Selecione o arquivo desejado e clique em Opções.

    Se você inserir uma planilha do Excel, ela deverá ser a primeira planilha da pasta de trabalho.

  4. Desmarque a caixa de seleção Vincular ao arquivo.

    Dica : Para que os leitores vejam somente um ícone que eles podem clicar para exibir as informações, marque a caixa de seleção Exibir como Ícone.

  5. Clique em Inserir se você estiver usando o Word ou Okey se você estiver usando o Excel.

  1. Clique duas vezes no objeto inserido.

  2. Faça suas alterações e, em seguida, salvá-los.

  3. No menu Arquivo, clique em Fechar e Retornar a [nome do arquivo].

    Observe que o arquivo inserido contém suas alterações.

Você pode vincular a parte de um arquivo. Por exemplo, em um relatório de status mensal, talvez você queira vincular a um intervalo específico de células de uma planilha do Excel em vez de toda a planilha. Por exemplo, talvez você queira vincular a instruções específicas de um documento do Word em vez de todo o documento.

  1. Selecione as informações que você deseja colar, por exemplo, um intervalo de células em uma planilha do Excel.

  2. No menu Editar, clique em Copiar.

  3. Mude para o outro arquivo e clique no local onde você deseja exibir as informações.

  4. No menu Editar, clique em Colar Especial e, em seguida, clique em Colar Link.

  5. Na caixa Como, clique no tipo de objeto, por exemplo, Objeto de Planilha do Microsoft Excel e clique em OK.

PowerPoint

Se você quiser manter os dois arquivos conectados, mas não quiser atualizar o arquivo principal quando o outro arquivo for alterado, você poderá inserir as informações. Por exemplo, vamos supor que você deseja inserir os retornos de vendas mais recentes em seu relatório de status mensal. O relatório de status é uma apresentação do PowerPoint, e os retornos de vendas estão em uma planilha do Excel. Ao inserir a planilha em uma apresentação, os dois arquivos permanecem conectados.

  1. Clique no local onde você deseja inserir o arquivo.

  2. No menu Inserir, clique em objeto e, em seguida, clique em do arquivo.

  3. Localize e clique no arquivo que você deseja inserir.

    Se você inserir uma planilha do Excel, ela deverá ser a primeira planilha da pasta de trabalho.

  4. Clique em Inserir e depois em OK.

    Se você não conseguir ver as informações no arquivo inserido, arraste uma alça de dimensionamento até conseguir ver o conteúdo do arquivo.

  1. Clique duas vezes no arquivo inserido.

  2. Faça as alterações desejadas.

  3. Clique em arquivo e, em seguida, clique em Atualizar.

  4. No menu Arquivo, clique em Fechar e Retornar a [nome do arquivo].

    Observe que o arquivo inserido contém suas alterações.

Você pode inserir parte de um arquivo. Por exemplo, em um relatório de status mensal, talvez você queira inserir um intervalo específico de células de uma planilha do Excel em vez de toda a planilha.

  1. Selecione as informações que você deseja colar, por exemplo, um intervalo de células em uma planilha do Excel.

  2. No menu Editar, clique em Copiar.

  3. Mude para o outro arquivo e clique no local onde você deseja exibir as informações.

  4. No menu Editar, clique em Colar Especial.

  5. Na caixa Colar como, clique no tipo de objeto, por exemplo, Objeto de Planilha do Microsoft Excel e clique em OK.

Excel

Se você mantiver dados em um arquivo do Excel e informações relacionadas em um arquivo do Word, você poderá vincular as informações para facilitar a atualização. Por exemplo, vamos supor que você deseja vincular os retornos de vendas mais recentes ao seu relatório de status mensal. O relatório de status é um documento do Word, e os retornos de vendas estão em uma planilha do Excel. Ao vincular o documento e a planilha, o relatório de status é atualizado automaticamente sempre que os retornos a vendas forem atualizados. Ou, talvez você queira inserir instruções de um documento do Word em diversos arquivos do Excel. Ao usar um link, você pode atualizar as instruções e as atualizações aparecem em todos os arquivos do Excel.

  1. Clique onde deseja inserir o vínculo.

  2. No menu Inserir, clique em Objeto e clique em Do Arquivo.

  3. Selecione o arquivo que você deseja vincular e, em seguida, clique em Opções.

  4. Marque a caixa de seleção Vincular ao arquivo

    Dica : Para que os leitores vejam somente um ícone que eles podem clicar para exibir as informações, marque a caixa de seleção Exibir como Ícone.

  5. Clique em Inserir se você estiver usando o Word ou Okey se você estiver usando o Excel.

  1. No menu dados, clique em Editar vínculos.

    Se o comando Editar vínculos não estiver disponível, o arquivo não contiver informações vinculadas.

  2. Em Arquivo de Origem, clique no arquivo vinculado e, em seguida, clique em Abrir Origem.

  3. Faça as alterações desejadas.

  4. No menu Arquivo, clique em Salvar para salvar suas alterações e, em seguida, feche o aplicativo.

  5. Clique no arquivo vinculado. Observe que o arquivo contém as alterações.

Se você quiser manter os dois arquivos conectados, mas não quiser atualizar o arquivo principal quando o outro arquivo for alterado, você poderá inserir as informações. Por exemplo, se você não quiser que o relatório de status mude quando a planilha do Excel mudar, ou se você não quiser que a planilha do Excel mude quando as instruções mudarem, você poderá inserir informações. Como as informações estão totalmente contidas em um único arquivo, a inserção será útil quando você quiser distribuir uma versão online do seu arquivo para as pessoas que não têm acesso ao arquivo inserido.

  1. Clique no local onde você deseja inserir o arquivo.

  2. No menu Inserir, clique em Objeto e clique em Do Arquivo.

  3. Selecione o arquivo que você deseja inserir e, em seguida, clique em Opções.

    Se você inserir uma planilha do Excel, ela deverá ser a primeira planilha da pasta de trabalho.

    Dica : Para que os leitores vejam somente um ícone que eles podem clicar para exibir as informações, marque a caixa de seleção Exibir como Ícone.

  4. Desmarque a caixa de seleção Vincular ao Arquivo e, em seguida, clique em Inserir se você estiver usando o Word, ou clique em OK se você estiver usando o Excel.

  1. Clique duas vezes no arquivo inserido.

  2. Faça as alterações desejadas.

  3. No menu arquivo, clique em Atualizar.

    Observe que o arquivo inserido contém suas alterações.

Você pode vincular a parte de um arquivo. Por exemplo, convém vincular um intervalo específico de células de uma planilha do Excel em vez de toda a planilha.

  1. Selecione as informações que você deseja colar, por exemplo, algumas sentenças em um documento do Word.

  2. No menu Editar, clique em Copiar.

  3. Mude para o outro arquivo e clique no local onde você deseja exibir as informações.

  4. No menu Editar, clique em Colar Especial e, em seguida, clique em Colar Link.

  5. Na caixa Como, clique no tipo de objeto, por exemplo, Objeto de Documento do Microsoft Word e clique em OK.

Word

Se você mantiver dados em um arquivo do Excel e informações relacionadas em um arquivo do Word, você poderá vincular as informações para facilitar a atualização. Por exemplo, vamos supor que você deseja vincular os retornos de vendas mais recentes ao seu relatório de status mensal. O relatório de status é um documento do Word, e os retornos de vendas estão em uma planilha do Excel. Ao vincular o documento e a planilha, o relatório de status é atualizado automaticamente sempre que os retornos a vendas forem atualizados. Ou, talvez você queira inserir instruções de um documento do Word em diversos arquivos do Excel. Ao usar um link, você pode atualizar as instruções e as atualizações aparecem em todos os arquivos do Excel.

  1. Clique onde deseja inserir o vínculo.

  2. No menu Inserir, clique em Objeto e clique em Do Arquivo.

  3. Localize e clique no arquivo ao qual você deseja vincular.

    Dica : Para que os leitores vejam somente um ícone que eles podem clicar para exibir as informações, marque a caixa de seleção Exibir como Ícone.

  4. Marque a caixa de seleção Vincular ao Arquivo e, em seguida, clique em Inserir se você estiver usando o Word, ou clique em OK se você estiver usando o Excel.

  1. No menu Editar, clique em Links.

    Se o comando Links não estiver disponível, o arquivo não terá informações vinculadas.

  2. Em Arquivo de Origem, clique no arquivo vinculado e, em seguida, clique em Abrir Origem.

  3. Faça as alterações desejadas.

  4. No menu Arquivo, clique em Salvar para salvar suas alterações e, em seguida, feche o aplicativo.

    Observe que o arquivo com o link contém as alterações.

Se você quiser manter os dois arquivos conectados, mas não quiser atualizar o arquivo principal quando o outro arquivo for alterado, você poderá inserir as informações. Por exemplo, se você não quiser que o relatório de status mude quando a planilha do Excel mudar, ou se você não quiser que a planilha do Excel mude quando as instruções mudarem, você poderá inserir informações. Como as informações estão totalmente contidas em um único arquivo, a inserção será útil quando você quiser distribuir uma versão online do seu arquivo para as pessoas que não têm acesso ao arquivo inserido.

  1. Clique no local onde você deseja inserir o arquivo.

  2. No menu Inserir, clique em Objeto e clique em Do Arquivo.

  3. Localize e clique no arquivo que você deseja inserir.

    Se você inserir uma planilha do Excel, ela deverá ser a primeira planilha da pasta de trabalho.

    Dica : Para que os leitores vejam somente um ícone que eles podem clicar para exibir as informações, marque a caixa de seleção Exibir como Ícone.

  4. Desmarque a caixa de seleção Vincular ao Arquivo e, em seguida, clique em Inserir se você estiver usando o Word, ou clique em OK se você estiver usando o Excel.

  1. Clique no arquivo inserido.

  2. No menu Editar, aponte para Objeto [tipo de objeto], por exemplo, Objeto de Planilha e, em seguida, clique em Editar.

  3. Faça as alterações desejadas.

  4. No menu Arquivo, clique em Fechar e Retornar a [nome do arquivo].

    Observe que o arquivo inserido contém suas alterações.

Você pode vincular a parte de um arquivo. Por exemplo, em um relatório de status mensal, talvez você queira vincular a um intervalo específico de células de uma planilha do Excel em vez de toda a planilha. Por exemplo, talvez você queira vincular a instruções específicas de um documento do Word em vez de todo o documento.

  1. Selecione as informações que você deseja colar, por exemplo, um intervalo de células em uma planilha do Excel.

  2. No menu Editar, clique em Copiar.

  3. Mude para o outro arquivo e clique no local onde você deseja exibir as informações.

  4. No menu Editar, clique em Colar Especial e, em seguida, clique em Colar Link.

  5. Na caixa Como, clique no tipo de objeto, por exemplo, Objeto de Planilha do Microsoft Excel e clique em OK.

PowerPoint

Se você quiser manter os dois arquivos conectados, mas não quiser atualizar o arquivo principal quando o outro arquivo for alterado, você poderá inserir as informações. Por exemplo, vamos supor que você deseja inserir os retornos de vendas mais recentes em seu relatório de status mensal. O relatório de status é uma apresentação do PowerPoint, e os retornos de vendas estão em uma planilha do Excel. Ao inserir a planilha em uma apresentação, os dois arquivos permanecem conectados.

  1. Clique no local onde você deseja inserir o arquivo.

  2. No menu Inserir, clique em Objeto e clique em Criar do arquivo.

  3. Localize e clique no arquivo que você deseja inserir.

    Se você inserir uma planilha do Excel, ela deverá ser a primeira planilha da pasta de trabalho.

  4. Clique em Inserir e depois em OK.

    Se você não conseguir ver as informações no arquivo inserido, arraste uma alça de dimensionamento até conseguir ver o conteúdo do arquivo.

  1. Clique no arquivo inserido.

  2. No menu Editar, aponte para Objeto [tipo de objeto], por exemplo, Objeto de Planilha e, em seguida, clique em Editar.

  3. Faça as alterações desejadas.

  4. No menu Arquivo, clique em Fechar e Retornar a [nome do arquivo].

    Observe que o arquivo inserido contém suas alterações.

Você pode inserir parte de um arquivo. Por exemplo, em um relatório de status mensal, talvez você queira inserir um intervalo específico de células de uma planilha do Excel em vez de toda a planilha.

  1. Selecione as informações que você deseja colar, por exemplo, um intervalo de células em uma planilha do Excel.

  2. No menu Editar, clique em Copiar.

  3. Mude para o outro arquivo e clique no local onde você deseja exibir as informações.

  4. No menu Editar, clique em Colar Especial.

  5. Na caixa Colar como, clique no tipo de objeto, por exemplo, Objeto de Planilha do Microsoft Excel e clique em OK.

Excel

Se você mantiver dados em um arquivo do Excel e informações relacionadas em um arquivo do Word, você poderá vincular as informações para facilitar a atualização. Por exemplo, vamos supor que você deseja vincular os retornos de vendas mais recentes ao seu relatório de status mensal. O relatório de status é um documento do Word, e os retornos de vendas estão em uma planilha do Excel. Ao vincular o documento e a planilha, o relatório de status é atualizado automaticamente sempre que os retornos a vendas forem atualizados. Ou, talvez você queira inserir instruções de um documento do Word em diversos arquivos do Excel. Ao usar um link, você pode atualizar as instruções e as atualizações aparecem em todos os arquivos do Excel.

  1. Clique onde deseja inserir o vínculo.

  2. No menu Inserir, clique em Objeto e clique em Do Arquivo.

  3. Localize e clique no arquivo ao qual você deseja vincular.

    Dica : Para que os leitores vejam somente um ícone que eles podem clicar para exibir as informações, marque a caixa de seleção Exibir como Ícone.

  4. Marque a caixa de seleção Vincular ao Arquivo e, em seguida, clique em Inserir se você estiver usando o Word, ou clique em OK se você estiver usando o Excel.

  1. No menu Editar, clique em Links.

    Se o comando Links não estiver disponível, o arquivo não terá informações vinculadas.

  2. Em Arquivo de Origem, clique no arquivo vinculado e, em seguida, clique em Abrir Origem.

  3. Faça as alterações desejadas.

  4. No menu Arquivo, clique em Salvar para salvar suas alterações e, em seguida, feche o aplicativo.

    Observe que o arquivo com o link contém as alterações.

Se você quiser manter os dois arquivos conectados, mas não quiser atualizar o arquivo principal quando o outro arquivo for alterado, você poderá inserir as informações. Por exemplo, se você não quiser que o relatório de status mude quando a planilha do Excel mudar, ou se você não quiser que a planilha do Excel mude quando as instruções mudarem, você poderá inserir informações. Como as informações estão totalmente contidas em um único arquivo, a inserção será útil quando você quiser distribuir uma versão online do seu arquivo para as pessoas que não têm acesso ao arquivo inserido.

  1. Clique no local onde você deseja inserir o arquivo.

  2. No menu Inserir, clique em Objeto e clique em Do Arquivo.

  3. Localize e clique no arquivo que você deseja inserir.

    Se você inserir uma planilha do Excel, ela deverá ser a primeira planilha da pasta de trabalho.

    Dica : Para que os leitores vejam somente um ícone que eles podem clicar para exibir as informações, marque a caixa de seleção Exibir como Ícone.

  4. Desmarque a caixa de seleção Vincular ao Arquivo e, em seguida, clique em Inserir se você estiver usando o Word, ou clique em OK se você estiver usando o Excel.

  1. Clique no arquivo inserido.

  2. No menu Editar, aponte para Objeto [tipo de objeto], por exemplo, Objeto de Planilha e, em seguida, clique em Editar.

  3. Faça as alterações desejadas.

  4. No menu Arquivo, clique em Fechar e Retornar a [nome do arquivo].

    Observe que o arquivo inserido contém suas alterações.

Você pode vincular a parte de um arquivo. Por exemplo, convém vincular um intervalo específico de células de uma planilha do Excel em vez de toda a planilha.

  1. Selecione as informações que você deseja colar, por exemplo, algumas sentenças em um documento do Word.

  2. No menu Editar, clique em Copiar.

  3. Mude para o outro arquivo e clique no local onde você deseja exibir as informações.

  4. No menu Editar, clique em Colar Especial e, em seguida, clique em Colar Link.

  5. Na caixa Como, clique no tipo de objeto, por exemplo, Objeto de Documento do Microsoft Word e clique em OK.

Confira também

Criar, editar ou remover um hiperlink

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×