VALORCUBO (Função VALORCUBO)

Este artigo descreve a sintaxe da fórmula e o uso da função VALORCUBOno Microsoft Excel.

Descrição

Retorna um valor agregado do cubo.

Sintaxe

VALORCUBO(conexão; [expressão_membro1]; [expressão_membro2]; …)

A sintaxe da função VALORCUBO tem os seguintes argumentos:

  • Conexão    Obrigatório. Uma cadeia de texto do nome da conexão com o cubo.

  • Expressão_membro    Opcional. Uma cadeia de texto de uma expressão multidimensional (MDX) que resulta em um membro ou em uma tupla no cubo. De maneira alternativa, expressão_membro pode ser um conjunto definido com a função CONJUNTOCUBO. Use expressão_membro como um slicer para definir a porção do cubo para a qual o valor agregado é retornado. Se nenhuma medida for especificada na expressão_membro, será usada a medida padrão para esse cubo.

Comentários

  • Quando a função VALORCUBO faz uma avaliação, ela exibe temporariamente uma mensagem "#OBTENDO_DADOS…" na célula antes de todos os dados serem recuperados.

  • Se for usada uma referência de célula para expressão_membro, e essa referência de célula contiver uma função CUBO, a expressão_membro usará a expressão MDX para esse item na célula referenciada, e não o valor exibido nessa célula referenciada.

  • Se o nome da conexão não for uma conexão de pasta de trabalho válida armazenada na pasta de trabalho, o VALORCUBO retornará um valor de erro #NOME?. Se o servidor OLAP (Online Analytical Processing) não estiver em execução, não estiver disponível ou retornar uma mensagem de erro, o VALORCUBO retornará um valor de erro #NOME?.

  • Se pelo menos um elemento da tupla for inválido, VALORCUBO retornará um valor de erro #VALOR!.

  • VALORCUBO retornará um valor de erro #N/D quando:

    • A sintaxe da expressão_membro estiver incorreta.

    • O membro especificado pela expressão_membro não existir no cubo.

    • A tupla for inválida porque não existe uma interseção para os valores especificados (isso pode ocorrer com vários elementos da mesma hierarquia).

    • O conjunto contiver pelo menos um membro com uma dimensão diferente dos outros membros.

    • O VALORCUBO pode retornar um valor de erro #N/D se você fizer referência um objeto com base na sessão, como um conjunto nomeado ou membro calculado em uma Tabela Dinâmica ao compartilhar a conexão com a Tabela Dinâmica quando ela é excluída ou quando você a converte em fórmulas. (Na guia Opções no grupo Ferramentas clique em Ferramentas OLAP , e em Converter em Fórmulas.)

Problema: valores nulos são convertidos em cadeias de caracteres de comprimento zero

No Excel, quando uma célula não contém dados porque você nunca a alterou ou excluiu o conteúdo, ela contém um valor vazio. Em vários sistemas de bancos de dados, um valor vazio é chamado de valor Nulo. Um valor vazio ou Nulo significa literalmente "Sem valor". Entretanto, uma fórmula jamais pode retornar uma cadeia de caracteres vazia ou um valor Nulo. Uma fórmula sempre retorna um destes três valores: um número; um texto, que pode ser uma cadeia de comprimento zero, ou um erro como #NÚM! ou #VALOR.

Caso uma fórmula contenha uma função VALORCUBO conectada a um banco de dados OLAP (Online Analytical Processing) e uma consulta ao banco de dados resulte em um valor Nulo, o Excel converte o valor em uma cadeia de comprimento zero, mesmo que a fórmula fosse retornar um valor numérico. Isso pode levar a uma situação em que um intervalo de células contém uma combinação entre valores numéricos e de cadeia de comprimento zero, e essa situação pode afetar os resultados de outras fórmulas que referenciam o intervalo. Por exemplo, se A1 e A3 contiverem números e A2 contiver uma fórmula com uma função VALORCUBO que retorne uma cadeia de comprimento zero, a fórmula seguinte retornaria um erro #VALOR!:

=A1+A2+A3

Para evitar isso, é possível testar uma cadeia de comprimento zero, usando a função ÉTEXTO e a função SE para substituir o comprimento zero por um 0 (zero) como mostra o seguinte exemplo:

=SE(ÉTEXTO(A1);0;A1)+SE(ÉTEXTO(A2);0;A2)+SE(ÉTEXTO(A3);0;A3)

Como alternativa, é possível testar a função VALORCUBO em uma condição SE que retorne um valor 0 caso a função VALORCUBO avalie como cadeia de comprimento zero, como mostra o exemplo a seguir:

=SE(VALORCUBO("Vendas";"[Medidas].[Lucro]";"[Hora].[2004]";"[Todos os Produtos].[Bebidas]")=""; 0; VALORCUBO("Vendas";"[Medidas].[Lucro]";"[Hora].[2004]";"[Todos os Produtos].[Bebidas]"))

Observe que a função SOMA não exige o teste para uma cadeia de comprimento zero porque ignora automaticamente cadeias de comprimento zero durante o cálculo do valor de retorno.

Exemplos

VALORCUBO("Vendas";"[Medidas].[Lucro]";"[Hora].[2004]";"[Todos os Produtos].[Bebidas]")

=VALORCUBO($A$1;"[Medidas].[Lucro]";D$12;$A23)

=VALORCUBO("Vendas";$B$7;D$12;$A23)

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×