Usar valores de um banco de dados do Access para preencher uma caixa de listagem, caixa de listagem suspensa ou caixa de combinação

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Em um formulário do InfoPath, você pode preencher uma caixa de listagem, caixa de listagem suspensa ou caixa de combinação com dados de uma conexão de dados de consulta para um banco de dados de Microsoft Office Access 2007 (formato. accdb) ou um banco de dados do Access que foi salva em uma versão anterior (formato. mdb).

Neste artigo

Visão geral

Considerações sobre compatibilidade

Antes de começar

Etapa 1: Adicionar uma conexão de dados de consulta

Etapa 2: Configurar o controle

Opcional: Definir um filtro para limitar os itens no controle

Visão Geral

Uma caixa de listagem, caixa de listagem suspensa ou caixa de combinação exibe itens que os usuários possam selecionar quando eles preenchem um formulário do InfoPath. Quando você cria um modelo de formulário, você pode configurar esses tipos de controles para exibir dados de uma conexão de dados secundária para um banco de dados do Access.

Uma conexão de dados secundária é qualquer conexão de dados com uma fonte de dados externa adicionada a um modelo de formulário. Você pode configurar conexões de dados secundárias para recuperar dados de que os usuários precisam para preencher formulários baseados no seu modelo de formulário ou para enviar dados do formulário a uma fonte de dados externa, como um serviço da Web.

Quando você adiciona uma conexão de dados secundária esses dados de consultas para seu modelo de formulário, o InfoPath cria um secundário fonte de dados que contém os campos de dados e grupos que correspondem da maneira que os dados são armazenados no banco de dados. A conexão de dados de consulta recupera dados do serviço da Web e, em seguida, armazena esses dados na fonte de dados secundária do formulário.

Você pode configurar a conexão de dados secundária para salvar os resultados da consulta nos computadores dos usuários para que eles tenham acesso aos dados mesmo que seus computadores não estejam conectados a uma rede. Dependendo da natureza dos dados, convém exibir os resultados da consulta somente quando os usuários estiverem conectados a uma rede.

Observação de segurança : Se você estiver usando uma conexão de dados secundária para recuperar dados confidenciais de uma fonte de dados externos, talvez você queira desabilitar esse recurso para ajudar a proteger os dados de uso não autorizado, caso o computador seja perdido ou roubado. Se você desabilitar esse recurso, os dados estará disponíveis somente se o usuário estiver conectado à rede.

Se você quiser limitar o número de itens em um controle de caixa de listagem, você pode usar um filtro. Use um filtro sempre que você precisar exibir um subconjunto dos dados que serão retornados por uma consulta com base em critérios selecionados por um usuário. Que critério pode ser um item selecionado no outro controle (como uma caixa de listagem, caixa de combinação, caixa de listagem suspensa ou caixa de texto) que esteja vinculado a um campo na fonte de dados.

Como a estrutura de dados na fonte de dados secundária deve corresponder a maneira que os dados são armazenados no banco de dados, você não pode modificar campos ou grupos na fonte de dados secundária existentes. Encontre links para obter mais informações sobre fontes de dados e conexões de dados na seção Consulte também deste artigo.

Início da página

Considerações sobre compatibilidade

Você só poderá adicionar uma conexão de dados de consulta a um banco de dados do Access se estiver criando um modelo que não seja um modelo de formulário compatível com o navegador.

Início da página

Antes de começar

Antes de usar valores de um banco de dados do Access para preencher um controle no modelo de formulário, o administrador do banco de dados deverá lhe fornecer as seguintes informações:

  • O nome e o local do banco de dados.

    Observação : Se outros usuários na rede irá criar formulários baseados neste modelo de formulário, certifique-se de que seu banco de dados é acessível aos usuários.

  • O nome da tabela ou consulta que fornece os valores para os controles. Você usará essa tabela ou consulta como a tabela primária quando configurar a conexão de dados de consulta.

  • Os nomes de quaisquer outras tabelas ou consultas do qual a tabela primária ou a consulta pode exigir dados. Na maioria dos casos, as relações de tabela já estão estabelecidas no banco de dados. Se você precisar estabelecer manualmente as relações entre a tabela primária ou e outra tabela ou consulta, você precisará os nomes dos campos relacionados de ambas as tabelas ou consultas.

Início da página

Etapa 1: Adicionar uma conexão de dados de consulta

Se você não tiver uma conexão de dados de consulta existente que você pode usar no seu modelo de formulário, use o procedimento a seguir para adicionar uma conexão de dados secundária esses dados de consultas ao seu modelo de formulário. Se seu modelo de formulário já tem uma conexão de dados secundária que você pode usar, você pode pular esta seção e vá para etapa 2: configurar o controle.

  1. No menu Ferramentas, clique em Conexões de Dados.

  2. Na caixa de diálogo Conexões de dados, clique em Adicionar.

  3. No Assistente para Conexão de Dados, clique em Criar uma nova conexão para, clique em Receber dados e, em seguida, clique em Avançar.

  4. Na próxima página do assistente, clique em Banco de Dados (Microsoft SQL Server ou Microsoft Office Access apenas) e, em seguida, clique em Avançar.

  5. Na próxima página do assistente, clique em Selecionar Banco de Dados.

  6. Na caixa de diálogo Selecionar Fonte de Dados, vá para o local do banco de dados.

    Observação : Se seu banco de dados estiver armazenado em um local de rede, navegue até o caminho UNC (convenção) nomenclatura universal do local. Não navegue até o local de rede por meio de uma unidade de rede mapeada. Se você usar uma unidade de rede mapeada (ou seja, atribuir uma letra a uma unidade de rede, como h ou z), os formulários que os usuários criam baseados neste modelo de formulário irá procurar o banco de dados na unidade de rede mapeada específica. Se o usuário não tiver a unidade de rede mapeada exatamente da mesma maneira, o formulário não encontrará o banco de dados.

  7. Clique no nome do banco de dados e em Abrir.

  8. Na caixa de diálogo Selecionar Tabela, clique na tabela ou consulta primária desejada e, em seguida, clique em OK.

  9. Na página seguinte do assistente, marque a caixa de seleção Mostrar colunas da tabela.

    Por padrão, todos os campos na tabela ou consulta são adicionados à fonte de dados principal do modelo de formulário.

  10. Desmarque as caixas de seleção dos campos que você não deseja incluir na fonte de dados principal.

  11. Adicione as tabelas ou consultas adicionais que você deseja incluir na conexão de dados de consulta.

    Como?

    1. Clique em Adicionar Tabela.

    2. Na caixa de diálogo Adicionar tabela ou consulta, clique no nome da tabela filho e clique em Avançar. InfoPath tenta definir as relações combinando nomes de campos em ambas as tabelas. Se você não quiser usar a relação sugerida, selecione a relação e clique em Remover relação. Para adicionar uma relação, clique em Adicionar relação. Na caixa de diálogo Adicionar relação, clique no nome de cada campo relacionado na coluna respectiva e clique em OK.

    3. Clique em Concluir.

    4. Para adicionar tabelas filho adicionais, repita essas etapas.

  12. Clique em Avançar.

  13. Para tornar os resultados da conexão de dados de consulta disponíveis quando o formulário não estiver conectado a uma rede, marque a caixa de seleção Armazenar uma cópia dos dados no modelo de formulário.

    Observação de segurança : Marcar esta caixa de seleção armazena os dados no computador do usuário quando o formulário usa esta conexão de dados. Se o formulário está recuperando dados confidenciais desta conexão de dados, talvez você queira desabilitar esse recurso para ajudar a proteger os dados, caso o computador seja perdido ou roubado ou caso contrário for acessada por um usuário não autorizado.

  14. Clique em Avançar.

  15. Na página seguinte do assistente, digite um nome descritivo para essa conexão de dados secundária e verifique se as informações na seção Resumo estão corretas.

  16. Para configurar o formulário para receber dados automaticamente quando for aberto, marque a caixa de seleção Recuperar dados automaticamente quando o formulário é aberto.

Início da página

Etapa 2: Configurar o controle

  1. Se o modelo de formulário tiver vários modos de exibição, clique em nome de exibição no menu Exibir para ir para o modo de exibição com o controle onde você deseja exibir os dados da fonte de dados secundária.

  2. Clique duas vezes na caixa de listagem, caixa de listagem suspensa ou controle de caixa de combinação no modelo de formulário que você deseja configurar.

  3. Clique na guia Dados.

  4. Em Entradas da caixa de listagem, clique em Consultar valores de uma fonte de dados externa.

  5. Na lista Fonte de dados, clique na fonte de dados que você deseja usar.

  6. Clique em Selecionar XPath Imagem do botão , ao lado da caixa de entradas.

  7. Na caixa de diálogo Selecionar um Campo ou Grupo, especifique o campo ou grupo cujos campos contêm os dados que serão mostrados ao usuário e os dados que serão enviados à fonte de dados externa por meio de um dos procedimentos a seguir.

    Especificar que os dados que o usuário verá os mesmos dados que o usuário será enviado

    • Clique em um campo e, em seguida, clique em OK.

    Especificar que os dados que o usuário verá diferentes dos dados que o usuário enviará

    Observação : Nesse cenário, os dados que o usuário verá são provenientes de um dos campos no grupo, e os dados que enviará estão contidos em outro campo no mesmo grupo.

    1. Clique em um grupo e em OK.

    2. Na caixa de diálogo Propriedades de controle, clique em Selecionar XPath Imagem do botão , ao lado da caixa valor.

    3. Na caixa de diálogo Selecionar Campo ou Grupo, clique no campo ou grupo que contém os dados que serão enviados pelo usuário para a fonte de dados externa e, em seguida, clique em OK.

    4. Na caixa de diálogo Propriedades de controle, clique em Selecionar XPath Imagem do botão , ao lado da caixa de nome para exibição.

    5. Na caixa de diálogo Selecionar Campo ou Grupo, clique e um campo que contém os dados que aparecerão no controle e, em seguida, clique em OK.

  8. Se o campo na caixa Nome para exibição tiver valores com nomes para exibição parecidos e você quiser exibir apenas nomes exclusivos, marque a caixa de seleção Mostrar apenas entradas com nomes para exibição exclusivos.

Início da página

Início da página

Opcional: Definir um filtro para limitar os itens no controle

  1. Clique duas vezes na caixa de listagem, caixa de listagem suspensa ou controle de caixa de combinação no modelo de formulário que você deseja configurar.

  2. Clique na guia Dados.

  3. Clique em Selecionar XPath Imagem do botão ao lado da caixa de entradas.

  4. Na caixa de diálogo Selecionar Campo ou Grupo, clique no campo ou grupo que contém os campos que fornecem os valores para o controle. Em seguida, clique em Filtrar Dados.

  5. Na caixa de diálogo Dados de Filtro, clique em Adicionar.

    Observação : Se você quiser adicionar uma condição para um filtro existente, clique no filtro que você deseja aplicar e clique em Modificar.

  6. Na primeira caixa da caixa de diálogo Especificar Condições de Filtro, clique no nome do campo cujos dados você deseja filtrar.

  7. Na segunda caixa, clique no tipo de filtro que você deseja utilizar.

  8. Na terceira caixa, clique no tipo de condição que você deseja aplicar ao filtro e, em seguida, digite a condição.

  9. Para configurar mais de uma condição para o filtro, clique em e e, em seguida, siga um destes procedimentos:

    • Para aplicar a condição existente e a nova condição ao seu filtro, clique em e e adicione sua nova condição.

    • Para aplicar a condição existente ou nova condição em seu filtro, clique ou e, em seguida, adicione a condição adicional.

  10. Clique em OK para fechar as caixas de diálogo.

  11. Para testar as alterações, clique Visualizar na barra de ferramentas Padrão ou pressione CTRL+SHIFT+B.

    O modelo de formulário abre em uma nova janela.

  12. Na janela de visualização, selecione vários valores no controle de filtro para testar se o filtro está funcionando corretamente.

    O filtro não está funcionando corretamente

    Se os valores no controle que contém um filtro não estiverem corretos, seja porque há muitos valores ou insuficiente, tente o seguinte:

    • Se você estiver usando várias condições em seu filtro, remova apenas uma condição para verificar que os valores corretos são retornados de condição única. Se a primeira condição retorna os valores corretos, em seguida, adicionar outra condição e testá-lo.

    • Filtros de fazem uma distinção entre letras maiusculas e minúsculas. Se você quiser exibir dados que começa com um caractere de letras maiusculo ou minúsculo, criar um filtro com uma condição de letra maiuscula, selecione ou na caixa de diálogo Especificar condição de filtro e, em seguida, crie uma condição de letra minúscula.

    • Se os valores filtrados são exatamente opostos do que você espera, por exemplo os produtos de todos a exibição de fornecedores em vez de produtos de um único fornecedor, altere o tipo de filtro na condição. Por exemplo, se sua condição usa o tipo de filtro é igual a e você está obtendo muitos produtos, tente usar o tipo de filtro não é igual a.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×