Usar relatórios para medir o desempenho e o uso do site

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Se você for responsável pelo gerenciamento de um site, provavelmente, algumas perguntas comuns sobre o site serão feitas à você, incluindo:

  • Quantas pessoas visitam meu site?

  • Como o tráfego do site é alterado ao longo do tempo?

  • Quem são os principais usuários do meu site?

  • De onde vem o tráfego do meu site?

  • Quais são as páginas e os recursos acessados freqüentemente no meu site?

  • Como posso descobrir onde documentos e outros recursos permanecem em nosso processo de fluxo de trabalho?

Ao mesmo tempo, como gerenciador de um site, você também pode ter algumas perguntas que deseja ter respondidas, como:

  • Há recursos em meu site que posso remover porque não estão sendo usado ou são antigos?

  • Como posso encontrar problemas em meu site (como arquivos desvinculados, páginas lentas e hiperlinks desfeitos) antes que sejam percebidos e relatados pelos usuários?

Essas perguntas podem parecer opressivas, mas com o Microsoft Office SharePoint Designer 2007 e um site do Windows SharePoint Services 3.0 ou do Microsoft Office SharePoint Server 2007, você pode responder facilmente essas perguntas usando os relatórios do Office SharePoint Designer 2007. Este artigo mostra como usar relatórios para medir o desempenho e o uso do site.

Importante : Os dados dos relatórios gerados pelo Office SharePoint Designer 2007 são salvos no servidor em que o site está hospedado. Os administradores do servidor podem conceder ou negar acesso a esses relatórios. Se os relatórios solicitados não contiverem dados, contate o administrador do servidor para obter assistência. Para executar relatórios de uso, você deve ter a permissão Exibir Dados de Uso e o administrador do servidor deve ativar o conjunto de dados de uso no servidor. Por padrão, o conjunto de dados de uso no servidor fica desativado.

O que você deseja fazer?

Exibir o relatório de resumo do Site

Exibir relatórios sobre arquivos

Exibir relatórios sobre conteúdo compartilhado

Exibir relatórios sobre problemas

Exibir o relatório de resumo de uso

Exibir relatórios de uso detalhado

Os resultados de dados de uso do gráfico

Classificar um relatório

Filtrar um relatório

Copiar um relatório

Salvar um relatório

Exibir o relatório Resumo do Site

O relatório Resumo do Site fornece uma visão geral completa de seu site, bem como links para relatórios mais detalhados. Por exemplo, você pode gerar um relatório Resumo do Site como este da ilustração a seguir.

Relatório Resumo do Site

Para gerar um relatório Resumo do Site para seu site:

  1. Abra o site para o qual deseja executar o relatório no Office SharePoint Designer 2007.

  2. No menu Site, aponte para Relatórios e clique em Resumo do Site.

    O relatório é gerado.

Observação : Você pode clicar nos hiperlinks da coluna Nome para navegar até relatórios mais detalhados. Por exemplo, clique em Hiperlinks desfeitos para navegar diretamente para o relatório Hiperlinks Desfeitos.

Início da página

Exibir relatórios sobre arquivos

É possível gerar relatórios que exibem todos os arquivos, arquivos recentemente adicionados, arquivos recentemente alterados ou arquivos mais antigos. Por exemplo, se deseja realçar o novo conteúdo na home page de seu site ou em um boletim informativo que promove o site, você pode usar o relatório de arquivos Adicionados Recentemente para identificar rapidamente o novo conteúdo. Você também pode usar o relatório Arquivos Mais Antigos para identificar o conteúdo que é antigo o suficiente para ser revisado, de modo a verificar se é possível atualizá-lo ou removê-lo.

Para executar relatórios sobre arquivos, primeiro especifique suas definições para arquivos recentes e antigos e, também, quantos meses serão mostrados nos relatórios por mês:

  1. Abra o site para o qual deseja executar o relatório no Office SharePoint Designer 2007.

  2. No menu Ferramentas, clique em Opções do Aplicativo.

  3. Clique na guia Exibir Relatórios.

    Caixa de diálogo Opções do Aplicativo mostrando a guia Exibir Relatórios

  4. Na caixa Arquivos "recentes" com menos de, insira o número de dias que identifique uma página recente.

  5. Na caixa Arquivos "antigos" com mais de, insira o número de dias que identifique uma página antiga.

  6. Na caixa Número de meses mostrados, insira o número de meses que deve ser mostrado nos relatórios mensais.

  7. Clique em OK.

    Agora você está pronto para executar os relatórios.

  8. No menu Site, aponte para Relatórios, aponte para Arquivos e clique no relatório que deseja executar:

    • Todos os Arquivos     Exibe uma lista de todos os arquivos no site.

    • Arquivos Recentemente Adicionados     Exibe uma lista dos arquivos que foram adicionados ao site dentro do número de dias especificado na etapa 4.

    • Arquivos Recentemente Alterados     Exibe uma lista de arquivos que foram modificados no site dentro do número de dias especificado na etapa 4.

    • Arquivos Mais Antigos     Exibe uma lista de arquivos considerados "mais antigos", conforme determinado pelo número de dias especificado na etapa 5.

    • Status do Check-out     Exibe uma lista de arquivos de seu site com o Status do Check-out atual de cada arquivo. (Este relatório também inclui as colunas de dados Check-out feito por, Versão e Data Bloqueada.)

      No modo de exibição de Relatórios, para relatórios sobre arquivos, você pode clicar nas opções da lista para alterar rapidamente as configurações de arquivos recentes e antigos.

      Modo de exibição de Relatórios mostrando o menu do filtro por idade do arquivo

Início da página

Exibir relatórios sobre conteúdo compartilhado

O conteúdo compartilhado pode incluir páginas mestras, personalizadas e outras páginas incluídas na definição de site, bem como links de folha de estilos. O Office SharePoint Designer 2007 facilita a localização do conteúdo compartilhado. Por exemplo, se deseja alterar o logotipo em todas as páginas do seu site, e você usa páginas mestras para controlar a formatação da página, é possível usar o relatório Páginas Mestras para localizar todas as páginas mestras nas quais você deve alterar o logotipo. Também é possível usar o relatório Links de Folha de Estilos para localizar todas as folhas de estilos que precisam ser atualizadas de modo a refletir uma alteração na fonte ou formatação que você deseja aplicar em todo o site.

  1. Abra o site para o qual deseja executar o relatório no Office SharePoint Designer 2007.

  2. No menu Site, aponte para Relatórios, aponte para Conteúdo Compartilhado e clique no relatório que deseja executar:

    • Modelos Dinâmicos da Web     Exibe uma lista de todas as páginas do site, com a coluna Modelo Dinâmico da Web indicando se cada página está anexada a um Modelo Dinâmico da Web (se sim, a qual).

    • Páginas Mestras     Exibe uma lista de todas as páginas do site, com a coluna Página Mestra indicando se cada página está anexada a uma página mestra (se sim, a qual).

    • Páginas Personalizadas     Exibe uma lista de todas as páginas do site, com a coluna Personalizada indicando se alguma página baseada na definição de site foi personalizada.

    • Links de Folha de Estilos     Exibe uma lista de todas as páginas do site, com a coluna Links de Folha de Estilos indicando se cada página está anexada a uma folha de estilos.

      Observação : Os links de folha de estilos exibidos são links de folha de estilos estáticos (guias <link>). Os links de folha de estilos dinâmicos que são gerados pelos controles do Microsoft ASP.NET (como <SharePoint:CssLink>) não são incluídos neste relatório.

Início da página

Exibir relatórios sobre problemas

Os relatórios do Office SharePoint Designer 2007 sobre problemas podem ajudar você a prever possíveis problemas e corrigi-los antes que os usuários sejam afetados. Por exemplo, é possível usar esses relatórios para identificar páginas lentas, localizar hiperlinks desfeitos e encontrar arquivos candidatos à exclusão porque não estão vinculados a outros arquivos. Para executar os relatórios Problemas, primeiro configure suas preferências para saber como definir páginas lentas.

  1. Abra o site para o qual deseja executar o relatório no Office SharePoint Designer 2007.

  2. No menu Ferramentas, clique em Opções do Aplicativo.

  3. Clique na guia Exibir Relatórios.

    Caixa de diálogo Opções do Aplicativo mostrando a guia Exibir Relatórios

  4. Na caixa "Páginas lentas" levam pelo menos, insira o número de segundos que definem quanto tempo demora o download de uma página lenta.

  5. Na caixa Supor uma velocidade de conexão de, insira o número de quilobits por segundo (Kbps) da velocidade média de conexão do usuário.

  6. Clique em OK.

    Agora você está pronto para executar os relatórios.

  7. Clique em Site, aponte para Relatórios, aponte para Problemas e clique no relatório que deseja executar:

    • Arquivos Desvinculados     Exibe uma lista de todos os arquivos do site para os quais não há links. Essa lista pode ajudar a localizar arquivos não utilizados que devem ser removidos do site. Observe que esse relatório não considera links gerados pelos controles do ASP.NET, como a Web Part do Sumário em sites do Office SharePoint Server 2007.

    • Páginas Lentas      Exibe uma lista de páginas do site que são identificadas como lentas para serem carregadas na definição especificada na etapa 3 e a velocidade média de conexão especificada na etapa 4. Observe que esse relatório reflete o tempo necessário para carregar a marcação de página. Ele não considera conteúdo dinâmico gerado por controles do. ASP.NET.

    • Hiperlinks     Exibe uma lista de todos os hiperlinks do site. Depois de executar este relatório, uma caixa de diálogo perguntará se você deseja verificar os hiperlinks do site. Clique em Sim se desejar que o Office SharePoint Designer 2007 analise e verifique cada hiperlink para você. O resultado desse processo é uma lista de hiperlinks identificados como OK ou Desfeitos. Para editar qualquer link desfeito, clique no link do relatório e em Editar Hiperlink na barra de ferramentas que aparece no canto superior direito da janela do documento no modo de exibição de Relatórios.

      Observação :  caixa de diálogo editar hiperlink

    • Erros de Componentes     Exibe uma lista de todos os componentes — como Botões Interativos ou o contador de visitas (todos genérica e anteriormente conhecidos como webbots ou bots) — que estão gerando erros no momento. Você pode exibir uma lista de componentes da Web clicando em Componente da Web no menu Inserir.

Início da página

Exibir o relatório Resumo do Uso

Os relatórios de uso do site ajudam a responder algumas das perguntas mais freqüentes que os proprietários de sites têm sobre o site, como quantas pessoas estão usando o site, quais recursos são os mais comuns, quem mais usa o site e de onde são os visitantes que navegam até o site. O relatório Resumo do Uso inclui um resumo do total de visitas, visitas à página, bytes baixados e muito mais.

Relatório Resumo do Uso

Siga estas etapas para executar o relatório Resumo do Uso:

  1. Abra o site para o qual deseja executar o relatório no Office SharePoint Designer 2007.

  2. No menu Site, aponte para Relatórios, para Uso e clique em Resumo do Uso.

    O relatório é gerado. Você pode clicar em qualquer um dos itens com hiperlink na coluna Nome para exibir relatórios detalhados.

Início da página

Exibir relatórios de uso detalhados

É possível executar relatórios de uso detalhados para responder às perguntas sobre como os usuários estão acessando seu site. Por exemplo, ainda que o relatório Resumo do Uso gerado na seção anterior mostre o número total de visitas à página, o relatório Visitas Mensais à Página detalha quantas visitas foram contadas para cada página do site. A seguir, as etapas para executar relatórios detalhados de Uso:

  1. Abra o site para o qual deseja executar o relatório no Office SharePoint Designer 2007.

  2. No menu Site, aponte para Relatórios, aponte para Uso e clique no relatório que deseja executar:

    • Resumo Mensal     Resume, por mês, o número de Visitas, Total de Visitas e Tamanho do Download em seu site.

    • Resumo Semanal     Resume, por semana, o número de Visitas, Total de Visitas e Tamanho do Download em seu site.

    • Resumo Diário     Resume, por dia, o número de Visitas, Total de Visitas e Tamanho do Download em seu site.

    • Visitas Mensais à Página     Resume o número do Total de Visitas e as visitas por mês para todas as páginas do seu site.

    • Visitas Semanais à Página     Resume o número do Total de Visitas e as visitas por semana para todas as páginas do seu site.

    • Visitas Diárias à Página     Resume o número do Total de Visitas e visitas por dia para todas as páginas do seu site.

    • Usuários Visitantes     Resume o número de usuários visitantes e a porcentagem do total para um mês selecionado.

    • Sistemas Operacionais     Resume a contagem de sistemas operacionais de usuários visitantes e a porcentagem do total para um mês selecionado.

    • Navegadores     Resume a contagem de navegadores de usuários visitantes e a porcentagem do total para um mês selecionado.

    • Domínios de Referência     Resume a contagem de visitas originadas de um domínio específico, bem como a porcentagem do total para um mês selecionado.

    • URLs Citadas     Resume a contagem de visitas originadas de uma URL específica, bem como a porcentagem do total para um mês selecionado.

    • Cadeias de Pesquisa     Lista a contagem de cadeias de pesquisa digitadas na caixa de pesquisa do site, bem como a porcentagem do total para um mês selecionado.

Início da página

Representar em gráfico os resultados sobre os dados de uso

Você pode criar facilmente um gráfico que mostre os dados de uso em um formato gráfico, facilitando a marcação de tendências e a identificação de padrões de uso.

  1. No menu Site, aponte para Relatórios, aponte para Uso e clique no relatório que deseja executar.

  2. Na barra de ferramentas do canto superior direito da janela do documento, na lista Gráfico, clique no tipo de gráfico que deseja criar, como um Gráfico de Coluna.

    barra de ferramentas no modo de exibição de relatórios mostrando a lista gráficos

    O relatório é aberto em uma nova janela.

    Gráfico de dados de uso

    Observação : Por padrão, os dados do gráfico são gerados com relatórios de uso. Se você não encontrar dados de gráfico ao tentar executar o relatório, no menu Ferramenta, clique em Opções do Aplicativo, clique na guia Exibir Relatórios e certifique-se de que a caixa de seleção Incluir gráfico quando relatório de uso for salvo esteja marcada.

Início da página

Classificar um relatório

No modo de exibição de Relatórios, é possível classificar um relatório clicando nos títulos de coluna.

Início da página

Filtrar um relatório

Você pode limitar os resultados do relatório para ver apenas as informações desejadas. Também é possível filtrar por apenas uma coluna ou filtrar por várias colunas para criar um filtro progressivo.

  1. No menu Site, aponte para Relatórios e clique no relatório que deseja executar.

  2. Clique na seta próxima ao título da coluna pela qual você deseja filtrar e clique nos dados pelos quais deseja filtrar.

    Por exemplo, ao filtrar por tipo de arquivo, você pode clicar na seta próxima ao título da coluna Tipo e, em seguida, clicar em bmp para mostrar apenas os arquivos bitmap no relatório.

    Coluna Tipo mostrando o menu do filtro

  3. Se você deseja filtrar por mais de uma coluna, repita a etapa 2 para cada coluna.

  4. Para criar um filtro personalizado em uma coluna, clique na seta perto do título da coluna e clique em (Personalizado). Insira os critérios de pesquisa e clique em OK.

    Por exemplo, é possível usar um autofiltro personalizado para identificar todos os arquivos de imagem .bmp e .gif do site.

    Caixa de diálogo Personalizar AutoFiltro

  5. Para limpar um filtro de qualquer coluna, clique na seta próxima ao título da coluna e clique em (Tudo).

Observação : As configurações de filtro aplicadas atualmente são salvas quando você fecha o site. Se não for possível encontrar arquivos em um relatório executado recentemente, os filtros aplicados durante a sessão anterior podem ter ocultado esses arquivos.

Para remover todos os filtros de um relatório, clique com o botão direito em qualquer título de coluna e clique em Remover Filtros no menu de atalho.

Início da página

Copiar um relatório

Depois de executar um relatório, é conveniente copiar e colar os resultados em uma mensagem de email ou em outro documento (por exemplo, em uma planilha do Microsoft Office Excel). É possível copiar qualquer relatório, exceto o relatório Resumo do Site.

  1. Clique com o botão direito do mouse em qualquer título de coluna do relatório que você está executando e clique em Copiar Relatório no menu de atalho.

    menu da coluna nome com o comando copiar relatório selecionado

  2. Cole os dados no documento ou na mensagem.

Início da página

Salvar um relatório

É possível salvar relatórios se você deseja usar o Microsoft Office Excel 2007 para exibir e analisar os resultados ou para criar gráficos personalizados a partir deles.

  1. No menu Site, aponte para Relatórios e clique no relatório que deseja executar.

  2. No menu Arquivo, clique em Salvar. Ou pressione CTRL+S.

  3. Na caixa Nome do arquivo, digite um nome para o relatório e clique em Salvar. O relatório é salvo como um arquivo .htm no site.

    relatório aberto no excel

  4. Para abrir o relatório, clique duas vezes nele.

    O relatório é aberto no Office Excel 2007.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×