Usar o argumento matriz_tabela em uma função de pesquisa

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Ao criar uma fórmula usando as funções PROCV ou PROCH, um argumento matriz_tabela é inserido, que é um intervalo de células, assim como D2:F39. A função pesquisa esse intervalo dos dados que você está tentando encontrar.

O argumento matriz_tabela é sempre o segundo argumento em uma função PROCV ou PROCH (o primeiro é o valor que você está tentando encontrar). Essas funções não funcionarão sem o argumento tabela_matriz.

O primeiro argumento pode ser um valor específico, como "41" ou "smith", ou pode ser uma referência de célula, como F2. O primeiro argumento pode ter a seguinte aparência:

=PROCV(F2,...

O argumento matriz_tabela sempre acompanha o valor de pesquisa,, assim:

=PROCVV(F2,B4:D39,...

O intervalo de células listado no argumento matriz_tabela pode usar referências de célula relativas ou absolutas. Para copiar a fórmula para outras células, é necessário usar referências de célula absoluta (observe os sinais $), como esta:

=PROCV(F2,$B$2:BD$39, ...

Se as células no argumento de matriz_tabela estiverem em outra planilha na pasta de trabalho, o argumento deverá incluir o nome da planilha seguido de um ponto de exclamação. A fórmula ficará assim:

=PROCV(F2,Planilha2!$C$14:E$42, ...

A coluna que tem os valores que você está tentando encontrar é o terceiro argumento a ser inserido. Essa é a chamada coluna de pesquisa. Se os valores que você quer ver estiverem na coluna D (a terceira coluna na matriz_tabela), o último argumento será um 3.

=PROCV(F2,B4:D39,3)

Embora seja opcional, é recomendável que você use um quarto argumento, ou Falso ou Verdadeiro. Use Falso se você estiver procurando uma correspondência exata.

=PROCV(F2,B4:D39,3,Falso)

Se usar Verdadeiro ou deixar o quarto argumento em branco, a função retornará uma correspondência aproximada para o valor do primeiro argumento. Portanto, se o seu primeiro argumento for "smith" e você usar Verdadeiro, a função PROCV retornará "Smith", "Smithberg", e assim por diante. Mas se você usar Falso, a função só retornará "Smith", uma correspondência exata, que é o que a maioria das pessoas quer.

Para complicar ainda mais o uso de Verdadeiro, se a sua coluna de pesquisa (a coluna especificada no terceiro argumento) não estiver classificada em ordem crescente (de A - Z ou do menor para o maior número), a função poderá retornar o resultado errado.

Para saber mais sobre as funções PROCV e PROCH, consulte Funções de pesquisa e de referência (referência).

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×