Usar as funções SE com E, OU e NÃO

A função SE permite que se faça uma comparação lógica entre um valor e o que você espera, testando-se uma condição e retornando um resultado se essa condição for Verdadeiro ou Falso.

  • =SE(Algo for Verdadeiro, então faça algo, caso contrário, faça outra coisa)

Entretanto, e se você precisar testar várias condições, onde, vamos supor, todas as condições precisam ser Verdadeiras ou Falsas (e), ou apenas uma condição deve ser Verdadeira ou Falsa (OU), ou se você deseja verificar se uma condição NÃO atende aos critérios? Todas as três funções podem ser usadas por conta própria, mas é muito mais comum vê-las emparelhadas com funções SE avançadas.

Use a função SE junto com as funções E, OU e NÃO para realizar várias avaliações se as condições forem verdadeiras ou falsas.

Sintaxe

  • SE(E()) - SE(E(lógico1, [lógico2], ...), valor_se_verdadeiro, [valor_se_falso]))

  • SE(OU()) - SE(OU(lógico1, [lógico2], ...), valor_se_verdadeiro, [valor_se_falso]))

  • SE(NÃO()) - SE(NÃO(logical1), value_if_verdadeiro, [valor_se_falso]))

Nome do argumento

Descrição

teste_lógico (obrigatório)

A condição que você deseja testar.

valor_se_verdadeiro (obrigatório)

O valor que você deseja retornar se o resultado do teste_lógico for VERDADEIRO.

valor_se_falso (opcional)

O valor que você deseja retornar se o resultado do teste_lógico for FALSO.

Analisemos algumas visões gerais sobre como estruturar as funções E, OU e NÃO individualmente. Ao se combinar cada uma com uma instrução SE, elas são lidas da seguinte maneira:

  • E – =SE(E(Algo for Verdadeiro, Outra coisa será Verdadeira), Valor se Verdadeiro, Valor se Falso)

  • OU – =SE(OU(Algo for Verdadeiro, Outra coisa será Verdadeira), Valor se Verdadeiro, Valor se Falso)

  • NÃO – =SE(NÃO(Algo for Verdadeiro), Valor se Verdadeiro, Valor se Falso)

Exemplos

A seguir vejamos exemplos de algumas instruções SE(E()), SE(OU()) e SE(NÃO()) aninhadas comuns. As funções E e OU podem oferecer suporte a até 255 condições individuais, mas não é uma prática recomendável usar mais do que algumas, porque pode ser difícil compilar, testar e manter fórmulas complexas e aninhadas. A função NÃO toma apenas uma condição.

Exemplos de como usar a função SE com as funções E, OU e NÃO para avaliar valores numéricos e texto

Vejamos abaixo as fórmulas escritas por extenso de acordo com a sua lógica:

Fórmula

Descrição

=SE(E(A2>0,B2<100),VERDADEIRO, FALSO)

SE A2 (25) for maior do que 0, E B2 (75) for menor que 100, VERDADEIRO é retornado. Caso contrário, FALSO é retornado. Nesse caso, ambas as condições são verdadeiras, então VERDADEIRO é retornado.

=SE(E(A3="Vermelho",B3="Verde"),VERDADEIRO,FALSO)

Se A3 ("Azul") = "Vermelho", E B3 ("Verde") for igual a "Verde", VERDADEIRO é retornado. Caso contrário, FALSO é retornado. Nesse caso, somente a primeira condição é verdadeira, então FALSO é retornado.

=SE(OU(A4>0,B4<50),VERDADEIRO, FALSO)

SE A4 (25) for maior do que 0, E B4 (75) for menor que 50, VERDADEIRO é retornado. Caso contrário, FALSO é retornado. Nesse caso, apenas a primeira condição é VERDADEIRO, mas como OU somente requer que um argumento seja verdadeiro, a fórmula retorna VERDADEIRO.

=SE(OU(A5="Vermelho",B5="Verde"),VERDADEIRO,FALSO)

Se A5 ("Azul") for igual a "Vermelho", OU B5 ("Verde") for igual a "Verde", VERDADEIRO é retornado. Caso contrário, FALSO é retornado. Nesse caso, o segundo argumento é Verdadeiro, então a fórmula retorna VERDADEIRO.

=SE(NÃO(A6>50),VERDADEIRO,FALSO)

SE A6 (25) NÃO for maior do que 50, VERDADEIRO é retornado. Caso contrário, FALSO é retornado. Nesse caso, 25 não é maior que 50, então a fórmula retorna VERDADEIRO.

=SE(NÃO(A7="Red"),VERDADEIRO,FALSO)

SE A7 ("Azul") NÃO for igual a "Vermelho", VERDADEIRO é retornado. Caso contrário, FALSO é retornado.

Observe que todos os exemplos têm um parêntese de fechamento após suas respectivas condições são inseridas. Os argumentos restantes Verdadeiro/Falso em seguida permanecem como parte da instrução SE externa. Você também pode substituir os valores Texto ou Numérico para que os valores Verdadeiro/Falso sejam retornados nos exemplos.

Veja aqui alguns exemplos de como usar E, OU e NÃO para avaliar as datas.

Exemplos de como usar a função SE com as funções E, OU e NÃO para avaliar datas

Vejamos abaixo as fórmulas escritas por extenso de acordo com a sua lógica:

Fórmula

Descrição

=SE(A2>B2,VERDADEIRO,FALSO)

SE A2 for maior que B2, VERDADEIRO é retornado. Caso contrário, FALSO é retornado. 03/12/14 é maior que 01/01/14, então a fórmula retorna VERDADEIRO.

=SE(E(A3>B2,A3<C2),VERDADEIRO,FALSO)

SE A3 for maior que B2, E A3 for menor que C2, VERDADEIRO é retornado. Caso contrário, FALSO é retornado. Nesse caso, ambos argumentos são verdadeiros, então a fórmula retorna VERDADEIRO.

=SE(OU(A4>B2,A4<B2+60),VERDADEIRO,FALSO)

SE A4 for maior que B2 OU A4 for menor que B2+60, VERDADEIRO é retornado. Caso contrário, FALSO é retornado. Nesse caso, o primeiro argumento é verdadeiro, mas o segundo é falso. Como OU só precisa que um dos argumentos seja verdadeiro, a fórmula retorna VERDADEIRO. Se você usar o Assistente de avaliação de fórmula a partir da guia Fórmula, você verá como o Excel avalia a fórmula.

=SE(NÃO(A5>B2),VERDADEIRO,FALSO)

SE A5 não for maior que B2, VERDADEIRO é retornado. Caso contrário, FALSO é retornado. Nesse caso, A5 é maior que B2, então a fórmula retorna FALSO.

Exemplo do assistente Avaliar fórmula

Usando E, OU e NÃO com a formatação condicional

Você também pode usar E, OU e NÃO para configurar critérios de formatação condicional com a opção de fórmula. Quando você fizer isso, você pode omitir a função SE e usar E, OU e NÃO por conta própria.

Na guia Página Inicial, clique em Formatação Condicional > Nova Regra. Em seguida, selecione a opção "Usar uma fórmula para determinar quais células devem ser formatadas", insira sua fórmula e aplique o formato de sua escolha.

Formatação Condicional > Caixa de diálogo Editar regra mostrando o método de fórmula

Usando o exemplo de Datas anterior, veja aqui o que seria as fórmulas.

Exemplos de como usar as funções E, OU e NÃO como testes de formatação condicional


Fórmula

Descrição

=A2>B2

Se A2 for maior que B2, formate a célula, caso contrário, não faça nada.

=E(A3>B2,A3<C2)

Se A3 for maior que B2 E A3 for menor que C2, formate a célula. Caso contrário, não faça nada.

=OU(A4>B2,A4<B2+60)

Se A4 for maior que B2 OU A4 for menor que B2 mais 60 (dias), formate a célula. Caso contrário, não faça nada.

=NÃO(A5>B2)

Se A5 NÃO for maior que B2, formate a célula. Caso contrário, não faça nada. Nesse caso, A5 é maior que B2, então o resultado retornará FALSO. Se você alterar a fórmula para =NÃO(B2>A5), ela retornaria VERDADEIRO e a célula seria formatada.

Observação : Um erro comum é inserir a fórmula na Formatação Condicional sem o sinal de igual (=). Se você fizer isso, verá que a caixa de diálogo Formatação Condicional adicionará o sinal de igual e as aspas à fórmula - ="OU(A4>B2,A4<B2+60)". Portanto, você precisará remover as aspas antes que a fórmula responda corretamente.

Início da página

Precisa de mais ajuda?

Você pode sempre consultar um especialista na Excel Tech Community, obter suporte na Comunidade de respostas ou sugerir um novo recurso ou melhoria no UserVoice do Excel.

Consulte Também

Veja um vídeo sobre como usar a função SE

Saiba como usar funções aninhadas em uma fórmula

Função SE

Função E

Função OU

Função NÃO

Visão geral de fórmulas no Excel

Como evitar fórmulas quebradas

Usar a verificação de erros para detectar erros em fórmulas

Atalhos de teclado no Excel para Windows

Atalhos de teclado no Excel para Mac

Funções lógicas (referência)

Funções do Excel (ordem alfabética)

Funções do Excel (por categoria)

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×