Usar SOMARPRODUTO para somar o produto dos valores correspondentes em uma ou mais matrizes

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

SOMARPRODUTO usa intervalos de células (ou matrizes) como seus argumentos (as partes da fórmula que a fazem funcionar). Ela multiplica os itens das matrizes e depois soma o resultado.

Este exemplo é uma lista de supermercado, com uma matriz listando o custo de cada item e a outra matriz listando quantos itens serão comprados.

Preços e quantidades a serem multiplicados e somados

  1. Para criar a fórmula, digite =SOMARPRODUTO(B3:B6,C3:C6) e pressione Enter.

Cada célula da coluna B é multiplicada por sua célula correspondente na mesma linha na coluna C, e os resultados são somados. A quantidade total de gastos com alimentação é $21,60.

  1. Para escrever uma fórmula mais extensa que dá o mesmo resultado, digite = B3 * C3 + B4 * C4 + B5 * C5 + B6 * C6 e pressione Enter.

Após pressionar Enter, o resultado é o mesmo: R$ 21,60. A célula B3 é multiplicada por C3, e seu resultado é somado ao resultado da célula B4 vezes a célula C4, e assim por diante. Você pode imaginar como o uso de SOMARPRODUTO facilitará sua vida se você tiver milhares (ou mesmo centenas) de linhas.

Observações : 

  • As colunas ou linhas (matrizes) devem ter comprimento igual.

  • Se houver texto em uma célula em vez de um número, ele será tratado como zero.

Exemplo

Se quiser fazer experiências com SOMARPRODUTO e matrizes, veja aqui uma pasta de trabalho do Excel Online com dados diferentes dos usados neste artigo.

Copie os dados de exemplo da tabela a seguir e cole-os na célula A1 de uma nova planilha do Excel. Para as fórmulas mostrarem resultados, selecione-as, pressione F2 e pressione Enter. Se precisar, você poderá ajustar as larguras das colunas para ver todos os dados.

Um

N

D

E

3

4

2

7

8

6

6

7

1

9

5

3

Fórmula

Resultado

'=SOMAPRODUTO(A2:B4, D2:E4)

=SOMAPRODUTO(A2:B4, D2:E4)

Multiplica todos os componentes das duas matrizes (A2:B4 e D2:E4) e adiciona os produtos — ou seja, 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156).

Para uma experiência mais completa, você também pode abrir essa pasta de trabalho no Excel. Basta clicar no ícone do Excel no canto inferior direito da pasta de trabalho Ícone do Excel no Excel Web App  , salvar o arquivo em um local conveniente no seu computador e depois abri-lo.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×