Usar E com OU para testar uma combinação de condições

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Quando você precisar encontrar dados que cumpram mais de uma condição, como unidades vendidas entre abril e janeiro ou unidades vendidas por Luciana, você pode usar as funções E e OU juntas. Veja um exemplo:

Usando E e OU na mesma função

Essa fórmula aninha a função e dentro da função ou para procurar unidades vendidas entre 1 de abril de 2011 e 1º de janeiro de 2012 ou qualquer unidades vendidas por Paula Bento. Você pode ver a que ela retorna True para unidades vendidas por Paula Bento e também para unidades vendidas por Tim e Ed durante as datas especificadas na fórmula.

Aqui está a fórmula em um formato que você pode copiar e colar. Se desejar experimentá-la em uma pasta de trabalho de exemplo, consulte o fim deste artigo.

=OU(E(C2>DATA(2011;4;30);C2<DATA(2012;1;1));B2="Luciana")

Vamos examinar a fórmula um pouco mais a fundo. A função OU requer um conjunto de argumentos (dados) que ela possa testar para ver se são verdadeiros ou falsos. Nessa fórmula, o primeiro argumento é a função E e a função DADOS aninhada dentro dele, e o segundo é "Luciana". Você pode ler a fórmula desta maneira: testar para ver se uma venda foi feita após 30 de abril de 2011 e antes de 1 de janeiro de 2012 ou foi feita por Luciana.

A função E também retorna Verdadeiro ou Falso. Na maioria das vezes, você usa E para estender a capacidade de outra função, como OU e SE. Nesse exemplo, a função OU não encontraria as datas corretas sem a função E.

Usar E e OU com SE

Você também pode usar E e OU com a função SE.

A função E e OU aninhada em uma função SE

Neste exemplo, as pessoas não ganham bônus se não vendem no mínimo R$ 125.000,00 em mercadorias, a menos que trabalhem na região sul, onde o mercado é menor. Nesse caso, eles se qualificam para um bônus a partir de R$ 100.000,00 em vendas.

=SE(OU(D4>=125000;E(C4="Sul";D4>=100000))=VERDADEIRO;D4*0,12;"Sem bônus")

Vamos examinar a fórmula um pouco mais a fundo. A função SE requer três dados (argumentos) para ser executada corretamente. O primeiro é um teste lógico, o segundo é o valor que você quer ver se o teste retorna Verdadeiro e o terceiro é o valor que você quer ver se o teste retorna Falso. Nesse exemplo, a função OU e tudo aninhado nela fornece o teste lógico. Você pode lê-la assim: procurar valores maiores ou iguais a 125.000, a menos que o valor na coluna C seja "Sul", então procurar um valor maior que 100.000, e toda vez que ambas as condições forem verdadeiras, multiplicar o valor por 0,12, que é o valor da comissão. Caso contrário, exibir as palavras "Sem bônus".

Início da página

dados de exemplo

Se você quiser trabalhar com os exemplos deste artigo, copie a tabela a seguir na célula A1 em sua própria planilha. Certifique-se de selecionar a tabela inteira, incluindo a linha de título.


Vendedor

Região

Vendas

/ Resultado de fórmula

Sousa

Leste

87925

= Se (ou (C2 > = 125000, AND (B2 = "Sul", C2 > = 100000)) = verdadeiro, C2 * 0.12, "Nenhum bônus")

Giorgi

Norte

100000

= Se (ou (C3 > = 125000, AND (B3 = "Sul", C3 > = 100000)) = verdadeiro, C3 * 0.12, "Nenhum bônus")

Girbal

Oeste

145000

=SE(OU(D4>=125000;E(C4="Sul";D4>=100000))=VERDADEIRO;D4*0,12;"Sem bônus")

Lacerda

Sul

200750

= Se (ou (C5 > = 125000, AND (B5 = "Sul", C5 > = 100000)) = verdadeiro, C5 * 0.12, "Nenhum bônus")

Oliveira

Sul

178650

= Se (ou (C6 > = 125000, AND (B6 = "Sul", C6 > = 100000)) = verdadeiro, C6 * 0.12, "Nenhum bônus")

Thomas

Norte

99555

= Se (ou (C7 > = 125000, AND (B7 = "Sul", C7 > = 100000)) = verdadeiro, C7 * 0.12, "Nenhum bônus")

Keever

Leste

147000

= Se (ou (C8 > = 125000, AND (M8 = "Sul", C8 > = 100000)) = verdadeiro, C8 * 0.12, "Nenhum bônus")

Cassazza

Norte

213450

= Se (ou (C9 > = 125000, AND (B9 = "Sul", C9 > = 100000)) = verdadeiro, C9 * 0.12, "Nenhum bônus")

Brownlee

Sul

122680

= Se (ou (C10 > = 125000, AND (B10 = "Sul", C10 > = 100000)) = verdadeiro, C10 * 0.12, "Nenhum bônus")

Smithberg

Oeste

92500

= Se (ou (C11 > = 125000, AND (B11 = "Sul", C11 > = 100000)) = verdadeiro, C11 * 0.12, "Nenhum bônus")

Gouveia

Leste

88350

= Se (ou (C12 > = 125000, AND (B12 = "Sul", C12 > = 100000)) = verdadeiro, C12 * 0.12, "Nenhum bônus")

Leitura

Oeste

102500

= Se (ou (C13 > = 125000, AND (B13 = "Sul", C13 > = 100000)) = verdadeiro, C13 * 0.12, "Nenhum bônus")

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×