Usar E com OU para testar uma combinação de condições

Quando você precisar encontrar dados que atendam a mais de uma condição, como unidades vendidas entre abril e janeiro ou unidades vendidas por Luciana, você pode usar as funções E e OU juntas.

Este exemplo aninha a função E dentro da função OU para pesquisar unidades vendidas entre 30 de abril de 2011 e 1° de janeiro de 2012 ou qualquer unidade vendida por Luciana. Perceba que ela retorna Verdadeiro para unidades vendidas por Luciana e também para unidades vendidas por Paulo e Rui durante as datas especificadas na fórmula.

Usando E e OU na mesma função

Aqui está a fórmula em um formato que você pode copiar e colar em uma planilha.

=OU(E(C2>DATA(2011;4;30);C2<DATA(2012;1;1));B2="Luciana")

Vamos examinar a fórmula um pouco mais a fundo. A função OU requer um conjunto de argumentos (dados) que possam ser testados para ver se são verdadeiros ou falsos. Nessa fórmula, o primeiro argumento é o resultado da função E com a função DADOS aninhada dentro dela, o segundo argumento é “Luciana”. Você pode ler a fórmula desta maneira: testar para ver se uma venda foi feita após 30 de abril de 2011 e antes de 1° de janeiro de 2012 ou foi feita por Luciana.

Assim como a função OU, a função E também retorna Verdadeiro ou Falso. Na maioria das vezes, você usa E para estender a capacidade de outra função, como OU e SE. Nesse exemplo, a função OU não encontraria as datas corretas sem a função E.

Usar E e OU com SE

Você também pode usar E e OU com a função SE.

A função E e OU aninhada em uma função SE

Neste exemplo, as pessoas não ganham bônus se não venderem um mínimo de R$ 125.000,00 em mercadorias, a menos que trabalhem na Região Sul, onde o mercado é menor. Nesse caso, o bônus é oferecido a partir de R$ 100.000,00 em vendas.

=SE(OU(D4>=125000;E(C4="Sul";D4>=100000))=VERDADEIRO;D4*0,12;"Sem bônus")

Vamos examinar a fórmula um pouco mais a fundo. A função SE requer três argumentos para ser executada corretamente. O primeiro é um teste lógico, o segundo é o valor que você quer ver se o teste retornar Verdadeiro e o terceiro é o valor que você quer ver se o teste retornar Falso. Nesse exemplo, a função OU, juntamente com todo o conteúdo aninhado nela, fornece o teste lógico. Você pode lê-la da seguinte maneira: procurar valores maiores ou iguais a 125.000, a menos que o valor na coluna C seja "Sul", então procurar um valor maior do que 100.000, e sempre que ambas as condições forem verdadeiras, multiplicar o valor por 0,12, que é o valor da comissão. Caso contrário, exibir as palavras "Sem bônus".

Tente trabalhar com os exemplos mostrados acima

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×