Tarefas básicas no Access 2010

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Veja algumas tarefas básicas do banco de dados que você pode fazer para aprender a usar o Microsoft Access 2010.

 

Neste artigo

O que é o Access?

Bancos de dados relacionais no Access

Quando você abre o Access

Localizar e aplicar um modelo

Criar um banco de dados a partir do zero

Abrir um banco de dados do Access já existente

Comece a usar seu novo banco de dados

Adicionar uma tabela

Colar dados de outra fonte em uma tabela do Access

Importar ou vincular dados de outra fonte

Próximas etapas

Importar dados de uma planilha ou de outro programa

Importar uma planilha do Excel para o Access

Importar uma planilha do Excel como uma tabela em um novo banco de dados

Usar o Assistente de Análise de Tabela para organizar os dados

Trabalhar com dados de outros programas

Use uma versão anterior do banco de dados em várias versões do Access

Usar um arquivo de banco de dados do Access em várias versões do Access

Etapa 1: Criar uma cópia do banco de dados existente e salvá-la em um novo formato

Etapa 2: Dividir o banco de dados de cópia e usar o arquivo original como banco de dados back-end

Etapa 3: Conectar o novo front-end ao banco de dados original

Usar um aplicativo front-end/back-end em várias versões do Access

O que é o Access?

O Access 2010 é uma ferramenta de design e implantação de aplicativo do banco de dados que você pode usar para controlar informações importantes. Você pode manter os dados em seu computador ou publicá-los na Web, para que outras pessoas possam usar o seu banco de dados com um navegador da Web.

Muitas pessoas começam a usar o Access quando o programa que usam para controlar informações gradativamente fica menos adequado para a tarefa. Por exemplo, vamos supor que você seja um planejador de eventos e que deseja controlar todos os detalhes que precisa gerenciar para garantir o sucesso dos eventos. Se você usar um processador de texto ou um programa de planilha para fazer isso, poderá facilmente ter problemas com dados duplicados ou incoerentes. Você pode usar software de calendário, mas controlar informações financeiras em um calendário não é adequado.

Bancos de dados relacionais no Access

Às vezes, para acompanhar essas informações, é preciso ter um banco de dados relacional,  que é um depósito de dados dividido em coleções de dados menores (chamadas de tabelas), a fim de eliminar a redundância, e são relacionadas com base em informações comuns (chamadas de campos). Por exemplo, um banco de dados relacional de planejamento de eventos pode conter um tabela com informações sobre os clientes, uma com os fornecedores e outra com os eventos. A tabela com as informações sobre os eventos pode ter um campo relacionado à tabela de clientes e outro relacionado à de fornecedores. Dessa forma, se, por exemplo, um número de telefone de fornecedor for alterado, as informações poderão ser alteradas uma única vez na tabela de fornecedores, e não em cada evento que envolva o fornecedor.

O Access é uma ferramenta que pode ser usada com rapidez e facilidade para desenvolver aplicativos de banco de dados relacional que ajudem a gerenciar informações. Você pode criar um banco de dados para ajudar a acompanhar praticamente qualquer tipo de informação, como estoque, contatos profissionais ou processos empresariais. Na verdade, o Access vem com modelos que você pode usar imediatamente para acompanhar diversas informações, o que facilita o trabalho inclusive para um principiante.

Quando você abre o Access

O Access 2010 é iniciado no modo de exibição Microsoft Office Backstage, no qual é possível obter informações sobre o banco de dados atual, criar um novo banco de dados, abrir um banco de dados existente e exibir o conteúdo apresentado no Office.com.

modo de exibição backstage do access 2010

O modo de exibição Backstage também contém muitos comandos que podem ser usados para ajustar, manter ou compartilhar bancos de dados. Os comandos no modo de exibição Backstage geralmente se aplicam a bancos de dados inteiros, e não a objetos dentro de um banco de dados.

Observação : É possível acessar o modo de exibição Backstage a qualquer momento, clicando na guia Arquivo.

Início da Página

Localizar e aplicar um modelo

O Access oferece vários modelos que podem ser usados para agilizar o processo de criação do banco de dados. Um modelo é um banco de dados pronto para uso que contém tabelas, consultas, formulários e relatórios necessários para a execução de uma tarefa específica. Por exemplo, existem modelos que podem ser usados para acompanhar problemas, gerenciar contatos ou manter registros de despesas. Alguns modelos contêm registros de exemplo para ajudar a demonstrar seu uso. Os modelos de bancos de dados podem ser utilizados no estado em que se encontram ou podem ser personalizados para atender melhor às suas necessidades.

Para localizar e aplicar um modelo ao banco de dados, siga este procedimento:

  1. Na guia Arquivo, clique em Novo.

  2. Em Modelos Disponíveis, siga um destes procedimentos:

    • Para reutilizar um modelo usado recentemente, clique em Modelos Recentes e selecione o modelo desejado.

    • Para utilizar um modelo já instalado, clique em Meus Modelos e selecione o modelo desejado.

    • Para encontrar um modelo no Office.com, em Modelos do Office.com, clique em uma categoria de modelo, selecione o modelo que você deseja e clique em Download para baixar o modelo do Office.com no seu computador.

      Você também pode pesquisar modelos no Office.com pelo Access. Na caixa Pesquisar modelos no Office.com, digite um ou mais termos de pesquisa e clique no botão de seta para pesquisar.

  3. Opcionalmente, clique no ícone de pasta próximo à caixa Nome do Arquivo para procurar o local onde o banco de dados será criado. Se você não indicar um local específico, o Access criará o banco de dados no local padrão, que é exibido abaixo da caixa Nome do Arquivo.

  4. Clique em Criar.

O Access cria o banco de dados e o abre para uso.

Início da Página

Criar um banco de dados a partir do zero

Se você deseja uma introdução mais completa aos conceitos por trás do uso do Access para criar um banco de dados, consulte o artigo sobre noções básicas do design de banco de dados.

Se nenhum dos modelos satisfaz as suas necessidades ou se existem dados em outro programa que você deseja usar no Access, talvez seja melhor criar um banco de dados totalmente novo. No Access 2010, você tem duas opções: um banco de dados de área de trabalho padrão ou um banco de dados da Web.

Para obter mais informações sobre bancos de dados da Web, confira o artigo Criar um banco de dados para compartilhar na Web.

Para criar um novo banco de dados, siga este procedimento:

  1. Inicie o Access.

  2. Na guia Novo no modo de exibição Backstage, clique em Banco de Dados em Branco ou Banco de Dados da Web em Branco.

    Importante : A escolha feita aqui determinará os recursos que estarão disponíveis no banco de dados. Os bancos de dados da área de trabalho não podem ser publicados na Web, e os bancos de dados da Web não oferecem suporte a alguns recursos da área de trabalho, como consultas de totais.

  3. À direita, digite um nome para seu banco de dados na caixa Nome do Arquivo.

    Para alterar o local em que o arquivo será criado, clique em Procurar Imagem do botão ao lado da caixaNome do Arquivo, navegue até o novo local, selecione-o e clique em OK.

  4. Clique em Criar.

    O Access cria o banco de dados e abre uma tabela vazia (chamada Tabela1), no modo Folha de Dados.

  5. O Access posiciona o cursor na primeira célula vazia na coluna Clique para Adicionar da nova tabela.

    Para adicionar dados, comece a digitar  — ou cole os dados de uma outra fonte, como descreve a seção Colar dados de outra fonte em uma tabela do Access, mais adiante neste artigo.

    Observações : 

    • A inserção de dados no modo Folha de Dados foi pensada de modo a ser muito semelhante com a inserção de dados em uma planilha do Excel. A principal restrição é que os dados devem ser inseridos em linhas e colunas contíguas, começando no canto superior esquerdo da folha de dados. Não tente formatar os dados incluindo linhas ou colunas em branco como faria em uma planilha do Excel, pois isso vai ocupar espaço da tabela. A tabela simplesmente contém os dados. Toda a apresentação visual dos dados será feita nos formulários e relatórios que você criará depois.

    • A estrutura da tabela é criada enquanto você insere os dados. Sempre que você adicionar uma nova coluna à folha de dados, um novo campo será definido na tabela. O Access define o tipo de dados do campo com base no tipo de dados inserido. Por exemplo, se houver uma coluna na qual você tenha inserido apenas valores de data, o Access definirá o tipo de dados do campo como Data/Hora. Caso você tente inserir mais tarde um valor que não seja uma data (como nome ou número de telefone) nesse campo, o Access exibirá uma mensagem informando que o valor não corresponde ao tipo de dados da coluna. Se possível, planeje a tabela para que cada coluna contenha o mesmo tipo de dados, seja texto, datas, números ou qualquer outro. Isso facilita muito a construção de consultas, formulários e relatórios que selecionam apenas os dados desejados.

Se não quiser inserir dados ainda, clique em Fechar Imagem do botão .

Observação : O Access excluirá a Tabela1 se você a fechar sem salvar.

Início da Página

Abrir um banco de dados do Access já existente

Dica : Para abrir rapidamente um dos diversos bancos de dados abertos recentemente, na guia Arquivo, clique em Recente e clique no nome do arquivo.

  1. Na guia Arquivo, clique em Abrir.

  2. Clique em um atalho da caixa de diálogo Abrir — ou, na caixa Examinar, clique na unidade ou na pasta que contém o banco de dados desejado.

  3. Na lista de pastas, clique duas vezes nas pastas até abrir aquela que contém o banco de dados.

  4. Ao localizar o banco de dados, execute um destes procedimentos:

    • Para abrir o banco de dados no modo de abertura padrão, clique nele duas vezes.

    • Para abrir o banco de dados para acesso compartilhado em um ambiente multiusuário, de modo que você e outros usuários possam ler e gravar no banco de dados ao mesmo tempo, clique em Abrir.

    • Para abrir o banco de dados com acesso somente para leitura, de modo que você possa visualizá-lo mas não editá-lo, clique na seta ao lado do botão Abrir e clique em Abrir como Somente Leitura.

    • Para abrir o banco de dados com acesso exclusivo, assim mais ninguém poderá abri-lo enquanto você estiver com ele aberto, clique na seta ao lado do botão Abrir e clique em Abrir Exclusivo.

    • Para abrir o banco de dados para acesso somente leitura, clique na seta ao lado do botão Abrir e clique em Abrir Exclusivo como Somente Leitura Outros usuários ainda podem abrir o banco de dados, mas eles possuem apenas acesso somente leitura.

Se não conseguir localizar o banco de dados que deseja abrir   

  1. Na caixa de diálogo Abrir, clique no atalho Meu Computador — ou, na caixa Examinar, clique em Meu Computador.

  2. Na lista de unidades, clique com o botão direito do mouse na unidade onde você acredita que o banco de dados está e, em seguida, clique em Pesquisar.

  3. Insira o critério de pesquisa e pressione ENTER para localizar o banco de dados.

  4. Se ele for encontrado, abra-o clicando duas vezes nele na caixa de diálogo Resultados da Pesquisa.

    Como a pesquisa foi iniciada na caixa de diálogo Abrir, clique em Cancelar nessa caixa de diálogo para que o banco de dados seja aberto.

Você pode abrir diretamente um arquivo de dados em um formato de arquivo externo (como dBASE, Paradox, Microsoft Exchange, ou Excel). Você também pode abrir diretamente qualquer fonte de dados ODBC, como Microsoft SQL Server ou Microsoft FoxPro. O Access cria automaticamente um novo banco de dados do Access, na mesma pasta do arquivo de dados, e adiciona links a cada tabela no banco de dados externo.

Início da Página

Comece a usar seu novo banco de dados

Dependendo do modelo utilizado, você talvez precise executar um ou mais dos seguintes procedimentos para começar a usar o novo banco de dados:

  • Se o Access exibir uma caixa de diálogo Logon com uma lista de usuários vazia, use o procedimento a seguir para começar:

    1. Clique em Novo Usuário.

    2. Preencha o formulário Detalhes do Usuário.

    3. Clique em Salvar e Fechar.

    4. Selecione o nome de usuário que você inseriu e clique em Logon.

  • Se o Access exibir uma folha de dados vazia, comece digitando dados diretamente nessa folha de dados ou clique nos outros botões e guias para explorar o banco de dados.

  • Se o Access exibir uma página Introdução, clique nos links dessa página para saber mais sobre o banco de dados ou clique nos outros botões e guias para explorar o banco de dados.

  • Se o Access exibir uma mensagem Aviso de Segurança na barra de mensagens, e você confiar na fonte do modelo, clique em Habilitar Conteúdo. Se o banco de dados exigir um logon, você precisará fazer logon novamente.

Para bancos de dados desktop e da Web, convém começar com uma destas etapas:

Início da Página

Adicionar uma tabela

Você pode adicionar uma nova tabela a um banco de dados existente usando as ferramentas, no grupo Tabelas, na guia Criar.

Grupo Tabelas na guia Criar

Observação : Em um banco de dados da Web, apenas o comando Tabela está disponível no grupo Tabelas.

Independentemente do modo em que começar, você sempre poderá alternar para o outro com os botões de exibição na barra de status da janela do Access.

Criar uma tabela em branco no modo Folha de Dados    No modo Folha de Dados, você pode inserir os dados imediatamente e deixar que o Access crie a estrutura de tabelas nos bastidores. Os nomes de campos são atribuídos numericamente (Campo1, Campo2 e assim por diante), e o Access define o tipo de dados do campo, de acordo com o tipo de dados inseridos.

  1. Na guia Criar, no grupo Tabelas, clique em Tabela Imagem do botão .

  2. O Access cria a tabela e posiciona o cursor na primeira célula vazia da coluna Clique para Adicionar.

  3. Para adicionar dados, comece a digitar na primeira célula vazia  — ou cole dados de outra fonte, como descrito mais adiante neste artigo.

    • Para renomear uma coluna (campo), clique duas vezes no título da coluna e digite o novo nome.

      Dica : Dê um nome significativo para cada campo, de forma que você possa identificar o que ele contém sem precisar examinar os dados.

    • Para mover uma coluna, selecione-a clicando em seu título e, em seguida, arraste-a para onde quiser. Também é possível selecionar várias colunas contíguas e arrastá-las para um novo local de uma vez.

      Para adicionar mais campos à sua tabela, você pode começar a digitar na coluna Clique para Adicionar no modo Folha de Dados ou adicionar novos campos usando os comandos no grupo Adicionar e Excluir da guia Campos.

Criar uma tabela começando no modo Design    No modo Design, primeiro crie a estrutura da nova tabela. Em seguida, mude para o modo Folha de Dados para inserir dados ou insira os dados usando algum outro método, como um formulário.

O modo Design não está disponível para tabelas em um banco de dados da Web.

  1. Na guia Criar, no grupo Tabelas, clique em Design da Tabela. Imagem do botão

  2. Para cada campo na tabela, digite um nome na coluna Nome do Campo e, em seguida, selecione um tipo de dados na lista Tipo de Dados.

  3. Você pode inserir informações adicionais para cada campo na coluna Descrição. A descrição que você inserir será exibida na barra de status quando o ponto de inserção estiver nesse campo e será usada como o texto da barra de status para qualquer controle que você criar arrastando o campo do painel Lista de Campos para um formulário ou relatório e para qualquer controle que for criado para esse campo pelo Assistente de Formulário ou Assistente de Relatório.

  4. Após ter adicionado todos os seus campos, salve a tabela.

    • Na guia Arquivo, clique em Salvar.

  5. Você pode começar a inserir dados na tabela a qualquer momento, basta mudar para o modo Folha de Dados, clicar na primeira célula vazia e digitar. Também pode colar dados de outra fonte, como descrito na próxima seção.

Criar uma tabela baseada em uma lista do SharePoint    Com uma lista do SharePoint, seus dados poderão ser usados por pessoas que não possuem o Access. Além disso, os dados da lista são armazenados em um servidor, que geralmente oferece melhor proteção contra perda de dados do que os arquivos armazenados em um computador desktop. Você pode começar com uma nova lista ou vincular a uma lista existente. É preciso ter permissões suficientes no site do SharePoint onde você deseja criar a lista; isso pode variar conforme o site, portanto contate o administrador do SharePoint para obter detalhes sobre suas opções.

Esse recurso não está disponível em um banco de dados da Web.

  1. Na guia Criar, no grupo Tabelas, clique em Listas do SharePoint.

  2. Você pode usar um dos modelos de lista para criar uma lista padrão do SharePoint, como Contatos ou Eventos.

    Você também pode optar por criar uma lista personalizada, ou vincular ou importar uma lista existente. Clique na opção desejada.

  3. Se você escolher qualquer um dos modelos da lista ou criar uma lista personalizada, a caixa de diálogo Criar Nova Lista será aberta para orientá-lo no processo. Se você optar por usar uma lista existente, abra a caixa de diálogo Obter Dados Externos para ajudá-lo.

Para obter mais informações sobre tabelas, confira o artigo de Introdução às tabelas.

Início da Página

Colar dados de outra fonte em uma tabela do Access

Se os dados estiverem armazenados em outro programa, como no Excel, você pode copiar e colar dados em uma tabela do Access. Em geral, isso funciona melhor se eles já estiverem separados em colunas, como em uma planilha do Excel. Se os dados estiverem em um processador de texto, primeiro separe as colunas de dados usando guias ou converta-os em tabela no programa de processador de texto e depois copie os dados. Se for necessário editar ou manipular os dados (por exemplo, separando nomes completos em nome e sobrenome), convém fazer isso antes de copiar os dados, especialmente se você não estiver acostumado com o Access.

Quando você cola os dados em uma tabela vazia, o Access define o tipo de dados de cada campo de acordo com o tipo de dado encontrado nele. Por exemplo, se um campo colado contiver exclusivamente valores de datas, o Access aplicará a ele o tipo de dados Data/Hora. Se contiver apenas as palavras "sim" e "não", o Access aplicará a ele o tipo de dados Sim/Não.

O Access nomeia os campos de acordo com o que ele encontra na primeira linha de dados colados. Se ela for semelhante em tipo às linhas seguintes, o Access determinará que a primeira linha seja parte dos dados e atribuirá aos campos nomes genéricos (Campo1, Campo2 e assim por diante). Se a primeira linha de dados colados não for semelhante às linhas seguintes, o Access usará a primeira linha como nomes de campo e excluirá a primeira linha nos dados reais.

Se o Access atribuir nomes de campo genéricos, você deverá renomear os campos o mais rápido possível para evitar confusão. Use o seguinte procedimento:

  1. Na guia Arquivo, clique em Salvar para salvar a tabela.

  2. No modo Folha de Dados, clique duas vezes em cada título de coluna e digite um nome para a coluna.

  3. Salve a tabela novamente.

Início da Página

Importar ou vincular dados de outra fonte

Pode haver dados coletados em outro programa que você gostaria de usar no Access. Talvez você trabalhe com pessoas que armazenam seus dados em outros programas e deseje trabalhar com seus dados no Access. Ou talvez você tenha várias fontes de dados diferentes e precise de um "local de destino" onde possa reunir todos para uma análise mais profunda.

O Access facilita a importação ou o vínculo de dados de outros programas. Você pode obter dados de uma planilha do Excel, de uma tabela de outro banco de dados do Access, de uma lista do SharePoint ou de qualquer outra das diversas fontes existentes. O processo é um pouco diferente dependendo da fonte de dados, mas estas instruções ajudarão você a dar o primeiro passo:

  1. Na guia Dados Externos, no grupo Importar e Vincular, clique no comando referente ao tipo de arquivo do qual você está importando.

    Por exemplo, se você estiver importando dados de uma tabela do Excel, clique em Excel. Caso não veja o tipo de programa correto, clique em Mais.

    Observação : Se você não conseguir localizar o tipo de formato correto no grupo Importar e Vincular, talvez seja necessário iniciar o programa no qual os dados foram originalmente criados e depois usá-lo para salvar os dados em um formato de arquivo com suporte no Access (como um arquivo de texto delimitado) e depois importar os dados para o Access.

  2. Na caixa de diálogo Obter Dados Externos, clique em Procurar para localizar o arquivo de origem dos dados ou digite o caminho completo que leva a ele na caixa Nome do arquivo.

  3. Clique na opção desejada em Especificar como e onde você deseja armazenar os dados no banco de dados atual. Você pode criar uma nova tabela usando os dados importados ou criar uma tabela vinculada que mantenha um vínculo com a fonte dos dados.

  4. Clique em OK.

    Dependendo de sua escolha, a caixa de diálogo Vincular Objetos ou Importar Objetos é aberta.

  5. Use a caixa de diálogo para concluir o processo. O procedimento exato a seguir depende da opção de importação ou vinculação escolhida.

  6. Na última página do assistente, clique em Concluir.

    Se optar por importar, o Access perguntará se você deseja salvar os detalhes da operação de importação que acabou de concluir.

  7. Se você acha que realizará novamente a mesma operação de importação, clique em Salvar etapas de importação e informe os detalhes.

    Em seguida, você pode reproduzir facilmente a operação de importação clicando em Importações Salvas, no grupo Importar, na guia Dados Externos, clicando na especificação de importação e clicando em Executar.

  8. Se não quiser salvar os detalhes da operação, clique em Fechar.

O Access importa os dados para a nova tabela e, em seguida, exibe a tabela em Tabelas no Painel de Navegação.

Para saber mais sobre como importar dados para o Access, siga os links da seção Consulte Também deste artigo.

Início da Página

Próximas etapas

O restante do processo de design varia com base em suas metas, mas você provavelmente irá considerar a criação de consultas, formulários, relatórios e macros. Este artigo não fornece informações sobre como criar objetos de banco de dados adicionais.

Para obter mais informações, consulte estes artigos:

Início da Página

Importar dados de uma planilha ou de outro programa

Se você está acostumado com outros programas de banco de dados ou planilhas, provavelmente conhece os princípios básicos de funcionamento do banco de dados e sua utilidade. A diferença entre o Access e outros aplicativos de bancos de dados é que ele possibilita a criação de bancos de dados relacionais e, mais do que isso, seu diferencial em comparação com a maioria dos programas de planilha é que ele fornece ferramentas para desenvolver consultas, formulários e relatórios sofisticados. Além disso, o Access oferece várias opções para se trabalhar com outros programas de banco de dados, como o SQL Server.

Importar uma planilha do Excel para o Access

Muitas pessoas começam a explorar o Access depois de criar uma lista no Excel. O Excel é ótimo para se começar uma lista, mas a medida que ela cresce, fica mais difícil organizá-la e mantê-la atualizada. Transferir essa lista para o Access geralmente é o passo lógico.

Uma tabela de banco de dados tem uma estrutura similar a de uma planilha, sendo que os dados são armazenados em linhas e colunas. Como resultado, normalmente é fácil importar uma planilha para uma tabela de banco de dados. A principal diferença entre armazenar dados em uma planilha e em um banco de dados é o modo como os dados são organizados. A simples importação da planilha para uma tabela nova de banco de dados não resolverá os problemas referentes à organização e à atualização dos dados, especialmente se a planilha contiver dados em duplicidade. Para resolver esses problemas, é preciso separar os dados da planilha em tabelas distintas, cada uma com dados relacionados. Para obter mais informações sobre como organizar os dados em suas tabelas, consulte o artigo Noções básicas sobre o design de bancos de dados.

O Access oferece o Assistente de Análise de Tabela, que pode ajudar você a concluir esse processo. Depois de importar os dados para uma tabela, o assistente ajuda você a dividi-la em tabelas separadas, sendo que os dados contidos em cada uma não estão duplicados em nenhuma outra. O assistente também cria as relações necessárias entre as tabelas.

Início da Página

Importar uma planilha do Excel como uma tabela em um novo banco de dados

  1. Na guia Arquivo, clique em Novo e em Banco de Dados em Branco.

  2. Digite um nome para o novo banco de dados na caixa Nome do Arquivo e, em seguida, clique em Criar.

    O novo banco de dados é aberto e o Access cria uma nova tabela em branco, Tabela1.

  3. Feche a Tabela1.

    Quando perguntado se você deseja salvar as alterações feitas no design da Tabela1, clique em Não.

  4. Na guia Dados Externos, no grupo Importar e Vincular, clique em Excel. Imagem do botão

  5. Na caixa de diálogo Obter Dados Externos clique em Procurar.

  6. Use a caixa de diálogo Abrir Arquivo para localizar o arquivo.

  7. Selecione o arquivo e clique em Abrir.

  8. Na caixa de diálogo Obter Dados Externos, confirme se a opção Importar os dados de origem para uma nova tabela do banco de dados atual está selecionada.

  9. Clique em OK.

    O Assistente de Importação de Planilha é iniciado e faz algumas perguntas sobre os dados.

  10. Siga as instruções, clicando em Avançar ou Voltar para navegar pelas páginas. Na última página do assistente, clique em Concluir.

    Observação : O Access pergunta se você deseja salvar os detalhes da operação de importação que você acabou de concluir. Se você acha que realizará novamente a mesma operação de importação, clique em Sim e informe os detalhes. Assim você poderá reproduzir rapidamente a operação no futuro, clicando em Importações Salvas, no grupo Importar da guia Dados Externos. Se você não quiser salvar os detalhes da operação, clique em Fechar.

O Access importa os dados para a nova tabela e, em seguida, ela é exibida em Todas as Tabelas no Painel de Navegação.

Início da Página

Usar o Assistente de Análise de Tabela para organizar os dados

Depois de importar os dados para uma tabela do Access, use o Assistente de Análise de Tabela para identificar rapidamente dados redundantes. O assistente é uma maneira simples de organizar os dados em tabelas separadas, de forma que sejam armazenados com mais eficiência. O Access preserva a tabela original como backup e cria tabelas novas que você pode usar como base para o aplicativo de banco de dados.

  1. Abra o banco de dados do Access que contém a tabela a analisar.

  2. Na guia Ferramentas de Bancos de Dados, no grupo Análise, clique em Analisar Tabela.

    O Assistente de Análise de Tabela é iniciado.

    As duas primeiras páginas do assistente contêm um breve tutorial  completo com botões nos quais você pode clicar para ver exemplos. Se as páginas introdutórias não aparecerem e você vir apenas a caixa de seleção rotulada Mostrar páginas de introdução?, marque essa caixa e clique Voltar duas vezes para ver a introdução. Para não exibir as páginas introdutórias novamente depois de ler a introdução, desmarque a caixa de seleção Mostrar páginas de introdução?.

  3. Na página Que tabela contém campos com valores que são repetidos em diversos registros?, selecione a tabela a analisar e clique em Avançar.

  4. Você pode deixar o assistente decidir quais campos devem ir para qual tabela ou fazer suas próprias escolhas. Mesmo seguindo as sugestões do assistente, você ainda poderá alterar o layout da tabela na página seguinte do assistente.

    Observação : Se você deixar o assistente decidir quais campos colocar em qual tabela, talvez as escolhas dele nem sempre sejam apropriadas para os seu dados, especialmente se não houver muitos dados com que trabalhar. Verifique atentamente o resultado apresentado pelo assistente. Por outro lado, o assistente pode sugerir uma organização mais eficaz que a sua, então é uma boa ideia testar as decisões do assistente pelo menos uma vez. Se você não gostar das sugestões, poderá reorganizar os campos manualmente e sempre poderá clicar em Voltar e organizar todos os campos por conta própria.

  5. Clique em Avançar. Nessa página, especifique quais tabelas devem conter quais campos. Se você deixou o assistente decidir, verá várias tabelas conectadas por linhas de relação. Caso contrário, o Access cria apenas uma tabela com todos os campos. Em qualquer situação, é possível fazer alterações nessa página.

    • Você pode arrastar campos de uma tabela para uma área vazia da página para criar uma nova tabela com esses campos. O Access pedirá um nome para a tabela.

    • Pode também arrastar campos de uma tabela para outra se achar que este é o armazenamento mais adequado.

    • A maioria das tabelas terá um campo ID ou Código Exclusivo Gerado. Para saber mais sobre campos de identificação, clique em Dicas no canto direito superior do assistente.

    • Para desfazer uma alteração, clique no botão Desfazer.

    • Para renomear uma tabela, clique duas vezes na barra de título, digite o nome novo e clique em OK.

  6. Depois de organizar os campos conforme desejado, clique em Avançar.

  7. Se o assistente encontrar registros com valores muito semelhantes, identificará esses valores como possíveis erros tipográficos e apresentará uma tela onde você poderá confirmar o que fazer com eles. Role a lista para localizar esses valores na coluna Correção e, em seguida, clique no item apropriado da lista suspensa. Selecione (Deixar como está) para impedir que o assistente faça qualquer alteração no valor. Quando acabar, clique em Avançar.

  8. O assistente pergunta se você deseja criar uma consulta semelhante à tabela original. Se você já criou formulários e relatórios com base na tabela original, criar essa consulta é uma boa ideia. Se você escolher Sim, crie a consulta, o assistente renomeará a tabela original acrescentando "_OLD" ao nome dela e depois dará o nome da tabela original à nova consulta. Os formulários e relatórios que se baseavam na tabela agora usarão a consulta para acessar os dados e continuarão funcionando como antes.

  9. Clique em Concluir.

    O assistente cria novas tabelas conforme especificado e as abre. Feche-as quando terminar de analisar o resultado.

Início da Página

Trabalhar com dados de outros programas

O Access 2010 fornece recursos para trabalhar com dados armazenados em outros programas.

Criar um novo banco de dados Access que vincula os dados em outro formato de arquivo    Você pode usar o Access para abrir um arquivo em outro formato de arquivo, como texto, dBASE ou uma planilha. O Access cria automaticamente um banco de dados do Access e vincula o arquivo para você.

  1. Inicie o Access.

  2. Na guia Arquivo, clique em Abrir.

  3. Na caixa de diálogo Abrir, clique no tipo de arquivo que deseja abrir na lista. Se você não tiver certeza sobre o tipo de arquivo, clique em Todos os Arquivos (*.*).

  4. Se necessário, procure a pasta que contém o arquivo desejado. Encontrando o arquivo, clique duas vezes nele para abri-lo.

  5. Siga as instruções do assistente. Na última página do assistente, clique em Concluir.

Importar ou vincular dados para um banco de dados existente do Access    É possível importar dados de outras fontes e programas para tabelas do Access para que os dados fiquem em um arquivo do Access ou vincular os dados a partir do Access, assim eles permanecem no arquivo original (fora do arquivo do Access).

  1. Na guia Dados Externos, no grupo Importar e Vincular, clique no formato em que os dados serão armazenados.

    Você pode importar ou vincular dados das seguintes fontes:

    • Excel    Você pode obter dados de uma planilha ou um intervalo nomeado em uma pasta de trabalho do Excel. Cada planilha ou intervalo nomeado deve ser importado ou vinculado separadamente.

    • Access    É muito útil para separar o processo dos dados, criando um banco de dados dividido. Isto é, você pode usar um banco de dados para conter todos os seus formulários, relatórios e macros, e manter os dados em outro banco de dados. Em seguida, você pode desenvolver aperfeiçoamentos sem interromper o trabalho das pessoas. Também é possível combinar dados de vários bancos de dados diferentes do Access em apenas um, tornando mais fácil resumir os dados entre departamentos ou entre parceiros comerciais.

    • Banco de dados ODBC    Muitos programas oferecem suporte a esse formato, incluindo muitos produtos de servidor de banco de dados. Ele ajuda a criar bancos de dados de "local de aterrissagem", onde você combina dados de sistemas diferentes.

    • Arquivo de texto    Você pode se conectar a um arquivo de texto simples e inclusive usar o Access para alterar o conteúdo desse arquivo. Isso pode ajudar a tornar o Access mais fácil de ser consumido por uma grande variedade de programas.

    • Arquivo XML    Esse formato também oferece compatibilidade com vários outros programas, incluindo alguns servidores Web.

    • Lista do SharePoint    Torna seus dados utilizáveis com um navegador da Web, a forma padrão para usar uma lista do SharePoint.

    • Serviços de dados    Você pode se conectar a serviços de dados da Web dentro de sua empresa.

    • Documento HTML    

    • Pasta do Outlook    Você pode se conectar a pastas do Outlook, para integrar mais facilmente suas informações de contato com o restante dos dados.

    • Arquivo do dBase    O dBase é um sistema de banco de dados alternativo popular com suporte no Access

      A caixa de diálogo Obter Dados Externos aparece.

  2. Siga as instruções da caixa de diálogo.

    O Access importará ou vinculará os dados ao banco de dados. Para a maioria dos formatos, especifique a localização dos dados e escolha como os dados devem ser armazenados no banco de dados.

Início da Página

Use uma versão anterior do banco de dados em várias versões do Access

Se o banco de dados ou o projeto do Access tiver sido criado no Access 2000 ou posterior, você poderá usar o banco de dados ou o projeto na versão do Access na qual ele foi criado ou em qualquer versão posterior , mesmo se o arquivo estiver com segurança habilitada. Por exemplo, os arquivos do Access 2000 podem ser usados no Access 2000, Access 2002, Access 2003, Access 2007 e Access 2010.

Você pode ter uma situação onde deseja manter os dados em uma versão anterior do Access, mas você tem usuários com uma versão posterior do Access que desejam se vincular a esses dados mas ainda utilizam alguns recursos da versão anterior. A solução é criar um novo banco de dados "front-end" na versão posterior (contendo formulários, relatórios, consultas, macros, mas não tabelas) e vinculá-lo às tabelas no arquivo da versão anterior. Use um dos procedimentos a seguir, dependendo de se o banco de dados está contido em um arquivo ou já está dividido em um aplicativo front-end/back-end.

Usar um arquivo de banco de dados do Access em várias versões do Access

Se todas as tabelas, formulários ou outros objetos do banco de dados de sua versão anterior do Access estiverem contidos em um único arquivo e você quiser usar o banco de dados em várias versões do Access, poderá criar um novo banco de dados front-end em uma versão posterior e vinculá-lo ao arquivo original. Os usuários que possuem a versão anterior do Access ainda podem usar o banco de dados original. Os usuários que possuem a versão posterior podem usar o novo banco de dados front-end para vincular aos mesmos dados. Você poderá criar várias versões front-end se precisar acomodar diversas versões do Access.

Início da Página

Etapa 1: criar uma cópia do banco de dados existente e salvá-la em um novo formato

Use o procedimento a seguir para converter o banco de dados para qualquer um dos três formatos mais recentes: Access 2000, Access 2002-2003 ou Access 2007. Esse comando preserva o banco de dados original no seu formato original e cria uma cópia no formato especificado.

  1. Feche o arquivo do Access. Se o arquivo for um banco de dados multiusuário do Access, localizado em um servidor ou em uma pasta compartilhada, confirme se ninguém está com ele aberto.

  2. Inicie o Access 2010.

  3. Na guia Arquivo, clique em Abrir.

  4. Navegue até o local do arquivo que você deseja converter e clique duas vezes nele para abri-lo.

    Se a caixa de diálogo Aprimoramento do Banco de Dados for exibida, perguntando se você deseja aprimorar o banco de dados, clique em Não.

  5. Se um formulário for aberto quando você iniciar o banco de dados, feche o formulário.

  6. Na guia Arquivo, clique em Salvar Banco de Dados como.

  7. Na caixa de diálogo Salvar Como, digite um nome para o novo banco de dados.

    Observação : A menos que você salve o novo banco de dados em outro lugar, seu respectivo nome deve ser diferente do nome do banco de dados original. Em qualquer caso, geralmente o melhor é usar um outro nome, assim você distingue facilmente o banco de dados front-end do banco de dados back-end. No entanto, se você estiver convertendo para o formato do Access 2007, a extensão do nome do arquivo será alterada de .mdb para .accdb para você poder usar o mesmo nome de arquivo.

  8. Clique em Salvar.

Início da Página

Etapa 2: Dividir o banco de dados de cópia e usar o arquivo original como banco de dados back-end

Divida o banco de dados convertido usando o seguinte procedimento:

  • Na guia Ferramentas de Banco de Dados, no grupo Mover Dados, clique em Banco de Dados do Access. Imagem do botão

  • Na caixa de diálogo Divisor de Banco de Dados, clique em Dividir Banco de Dados.

    Você pode fazer um backup se desejar, mas também pode apenas recriar a cópia usando o banco de dados original.

  • Digite um nome para o banco de dados back-end e clique em Dividir.

Início da Página

Etapa 3: Conectar o novo front-end ao banco de dados original

  1. Exclua o banco de dados de back-end que a ferramenta Divisor de banco de dados criou  — cuidado para não excluir o banco de dados original.

  2. Vincule o novo banco de dados front-end às tabelas no banco de dados original. Na guia Dados Externos, no grupo Importar e Vincular, clique em Gerenciador de Tabelas Vinculadas. Imagem do botão

  3. Clique em Selecionar Tudo e marque a caixa de seleção Sempre emitir aviso para novo local.

  4. Clique em OK, localize o banco de dados na versão mais antiga e clique duas vezes nele.

    Se tudo der certo, o Access exibirá uma mensagem informando que todas as tabelas vinculadas selecionadas foram atualizadas com sucesso.

Agora é possível aprimorar o novo banco de dados front-end para dar suporte aos novos recursos para usuários com versões mais recentes do Access. Os usuários com versões mais antigas podem continuar usando o banco de dados dessas versões.

Início da Página

Usar um aplicativo de front-end/back-end em várias versões do Access

Se o seu banco de dados do Access já for um aplicativo front-end/back-end, você pode converter o front-end no novo formato de arquivo. Nenhuma alteração é necessária no banco de dados back-end.

O procedimento a seguir mostra como usar o comando Salvar Banco de Dados como para converter o banco de dados de front-end para qualquer um dos três formatos mais recentes: Access 2000, Access 2002-2003 ou Access 2007. Esse comando preserva o banco de dados original no seu formato original e cria uma cópia no formato especificado.

  1. Feche o banco de dados front-end. Se o arquivo for um banco de dados do Access multiusuário localizado em um servidor ou em uma pasta compartilhada, confirme se ninguém está com ele aberto.

  2. Inicie o Access 2010.

  3. Na guia Arquivo, clique em Abrir.

  4. Navegue até o local onde está o banco de dados de front-end a ser convertido e clique duas vezes nele para abri-lo.

    Se a caixa de diálogo Aprimoramento do Banco de Dados for exibida, perguntando se você deseja aprimorar o banco de dados, clique em Não.

  5. Se um formulário aparecer quando você abrir o banco de dados, feche o formulário.

  6. Na guia Arquivo, clique em Salvar Banco de Dados como.

  7. Na caixa de diálogo Salvar Como, digite um nome para o novo banco de dados.

  8. Clique em Salvar.

Agora é possível aprimorar o novo banco de dados front-end para dar suporte aos novos recursos.

Início da Página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Essas informações foram úteis?

Como podemos melhorá-lo?

Como podemos melhorá-lo?

Para proteger sua privacidade, não inclua informações de contato em seus comentários. Avalie nosso política de privacidade.

Obrigado por seus comentários!