Tarefas básicas de um banco de dados de área de trabalho do Access

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Bancos de dados da área de trabalho do Access podem ajudá-lo a armazenar e rastrear praticamente qualquer tipo de informação, como inventário, contatos ou processos de negócios. Vamos percorrer os caminhos que você pode tomar para criar um banco de dados da área de trabalho do Access, adicione dados a ele e, em seguida, saiba mais sobre as próximas etapas em direção a personalizar e usar seu novo banco de dados.

Observação : Se você tem mais interesse em aplicativos do Access projetados para a web, dê uma olhada como criar um aplicativo do Access e Saiba mais sobre tarefas básicas para um aplicativo do Access.

Neste artigo

Escolher um modelo

Os modelos do Access têm tabelas, consultas, formulários e relatórios internos prontos para usar. Quando você inicia o Access, a primeira coisa que vê é uma variedade de modelos, e também é possível pesquisar mais opções online.

Exibição de modelos na tela inicial do Access

  1. No Access, clique em Arquivo > Novo.

  2. Selecione um modelo de banco de dados da área de trabalho e insira um nome para seu banco de dados em Nome do arquivo.(Se você não vir , de um modelo que é adequada para vocêusar a Pesquisar modelos onlinecaixa.)

  3. Você pode usar o local padrão que o Access mostra abaixo da caixa Nome do Arquivo ou clicar no ícone de pasta para escolher outro local.

  4. Clique em Criar.

Criar um banco de dados da área de trabalho do Access a partir de um modelo

Dependendo do modelo, pode ser necessário executar qualquer um destes procedimentos para começar:

  • Se o Access exibe um caixa de diálogo logon com uma lista vazia de usuários:

    1. Clique em novo usuário.

    2. Preencha o formulário Detalhes do usuário.

    3. Clique em Salvar e fechar.

    4. Selecione o nome de usuário que você acabou de digitado e, em seguida, clique em Login.

  • Se o Access exibe um mensagem de Aviso de segurança na barra de mensagens e você confia na fonte do modelo, clique em Habilitar conteúdo. Se o banco de dados exigir um logon, faça logon novamente.

Para saber mais, consulte como criar um banco de dados da área de trabalho do Access a partir de um modelo.

Criar um banco de dados a partir do zero

Se nenhum dos modelos atender às suas necessidades, você poderá começar com um banco de dados da área de trabalho em branco.

  1. No Access, clique em Novo > Banco de dados do desktop em branco.

  2. Digite um nome para o banco de dados na caixa Nome do Arquivo.

  3. Você pode usar o local padrão que o Access mostra abaixo da caixa Nome do Arquivo ou clicar no ícone de pasta para escolher outro local.

  4. Clique em Criar.

Adicionar uma tabela

Em um banco de dados, suas informações são armazenadas em várias tabelas relacionadas. Para criar uma tabela:

  1. Quando você abre o banco de dados pela primeira vez, você verá uma tabela em branco no modo de exibição de folha de dados onde você pode adicionar dados. Para adicionar outra tabela, clique na guia criar > tabela. Você pode começar a inserir dados no campo vazio (célula) ou colar dados de outra fonte como uma pasta de trabalho do Excel.

  2. Para renomear uma coluna (campo), clique duas vezes no título da coluna e digite o novo nome.

Dica :  Nomes com significados ajudam a saber o que cada campo contém sem precisar ver seu conteúdo.

  1. Clique em Arquivo > Salvar.

  • Para adicionar mais campos, digite na coluna Clique para Adicionar.

  • Para mover uma coluna, selecione-a clicando em seu título e, em seguida, arraste-a para onde quiser. Você também pode selecionar colunas contíguas e arrastar todas elas para um novo local.

Para saber mais, consulte Introdução às tabelas.

Copiar e colar dados

Você pode copiar e colar dados de outro programa, como o Excel ou o Word, em uma tabela do Access. Isso funciona melhor quando os dados estão separados em colunas. Se os dados estiverem em um editor de texto, como o Word, use tabulações para separar as colunas ou converta-os em formato de tabela antes de copiar.

  1. Se for necessário editar os dados, por exemplo, separar nomes inteiros em nomes e sobrenomes, faça isso primeiro no programa de origem.

  2. Abra a origem e copie (Ctrl + C) os dados.

  3. Abra a tabela do Access na qual você quer adicionar os dados no modo Folha de Dados e cole-os (Ctrl + V).

  4. Clique duas vezes em cada título de coluna e digite um nome representativo.

  5. Clique em arquivo > Salvar e dê um nome para sua nova tabela.

    Observação : O Access define o tipo de dados de cada campo com base nas informações que você cola na primeira linha de cada coluna, então verifique se as informações nas linhas seguintes correspondem à primeira linha.

Importar ou vincular a dados

Você pode importar dados de outras fontes ou pode vincular aos dados do Access sem mover as informações de onde elas estão armazenadas. A vinculação pode ser uma boa opção quando você tem vários usuários atualizando os dados e você quer ter certeza de que está vendo a versão mais recente ou para economizar espaço de armazenamento. Você pode escolher se deseja vincular ou importar os dados na maioria dos formatos.

Opções da guia Dados Externos no Access

O processo é um pouco diferente dependendo da fonte de dados, mas estas instruções servirão de introdução:

  1. Sobre o Dados externos da guia, clique no formato de dados, você estará importar de ou vincular a. Se você não vir o formato correto, clique em mais.

Observação : Se o formato certo ainda não for exibido, talvez você precise exportar os dados primeiro para um formato de arquivo aceito pelo Access (como um arquivo de texto delimitado).

  1. Siga as instruções na caixa de diálogo Obter dados externos.

Estas são as fontes externas das quais você pode importar ou vincular dados:

Adicionando um botão a um layout de controle empilhado

Vincular

glifo ba

Sim

Sim
(somente leitura)

Microsoft Access

Sim

Sim

Bancos de dados ODBC, como o SQL Server

Sim

Sim

Arquivos de texto ou CSV (valor separado por vírgula)

Sim

Sim
(apenas adicionar novos registros)

Lista do SharePoint

Sim

Sim

XML

Sim

Serviços de Dados

Sim
(somente leitura)

Documento HTML

Sim

Sim

Pasta do Outlook

Sim

Sim

Para obter mais informações, consulte Importar dados para um banco de dados do Access e Importar dados de um banco de dados do Access.

Organizar dados com a Análise de Tabela

Você pode usar o Assistente de Análise de Tabela para identificar rapidamente dados redundantes. Em seguida, o assistente oferece uma maneira simples de organizar os dados em tabelas separadas. O Access preserva a tabela original como um backup.

  1. Abra o banco de dados do Access que contém a tabela a analisar.

  2. Clique em Ferramentas de Banco de Dados > Analisar tabela.

    As primeiras duas páginas do assistente contêm um breve tutorial com exemplos. Se você vir uma caixa de seleção Mostrar páginas de introdução?, marque-a e clique em Voltar duas vezes para ver a introdução. Se não quiser ver as páginas de introdução novamente, desmarque Mostrar páginas de introdução?

Início da Página

Próximas etapas

O restante do processo de design varia com base no que você quer fazer, mas provavelmente você pretenderá criar consultas, formulários, relatórios e macros. Estes artigos podem ajudá-lo:

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Essas informações foram úteis?

Ótimo! Outros comentários?

Como podemos melhorá-lo?

Obrigado por seus comentários!

×