TIPO.ERRO (Função TIPO.ERRO)

Este artigo descreve a sintaxe da fórmula e o uso da função TIPO.ERRO no Microsoft Excel.

Descrição

Retorna um número que corresponde a um dos valores de erro do Microsoft Excel ou retorna o erro #N/D se não houver erro. Você pode usar TIPO.ERRO em uma função SE para testar um valor de erro e retornar uma cadeia de texto, como uma mensagem, em vez de um valor de erro.

Sintaxe

TIPO.ERRO(val_erro)

A sintaxe da função TIPO.ERRO tem os seguintes argumentos:

  • Val_erro    Obrigatório. O valor de erro cujo número de identificação você deseja localizar. Apesar de val_erro poder ser o valor de erro real, ele será normalmente uma referência a uma célula que contenha uma fórmula que se deseje testar.

Se val_erro for

TIPO.ERRO retornará

#NULO!

1

#DIV/0!

2

#VALOR!

3

#REF!

4

#NOME?

5

#NÚM!

6

#N/D

7

#GETTING_DATA

8

Outros

#N/D

Exemplo

Copie os dados de exemplo da tabela a seguir e cole-os na célula A1 de uma nova planilha do Excel. Para as fórmulas mostrarem resultados, selecione-as, pressione F2 e pressione Enter. Se precisar, você poderá ajustar as larguras das colunas para ver todos os dados.

Dados

#NULO!

#DIV/0!

Fórmula

Descrição

Resultado

=TIPO.ERRO(A2)

Número do Erro #NULO! (1).

1

=SE(TIPO.ERRO(A3)<3;ESCOLHER(TIPO.ERRO(A3);"Os intervalos não interceptam";"O divisor é zero"))

Verifica a célula A3 para ver se contém o valor de erro #NULO! ou o valor de erro #DIV/0!. Se contiver, o número do valor de erro será usado na função de planilha ESCOLHER para exibir uma entre duas mensagens; caso contrário, será retornado o valor de erro #N/D.

O divisor é zero.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×