Somar valores com base em várias condições

Somar valores com base em várias condições

Você quer somar valores com mais de uma condição, como a soma das vendas de um determinado produto em uma determinada região. Nesse caso, use a função SOMASES em uma fórmula.

Veja um exemplo em que temos duas condições: queremos a soma de vendas de Carne (da coluna C) na região Sul (da coluna A).

Dados em uma planilha do Excel

Veja a fórmula que deve ser usada:

=SOMASES(D2:D11,A2:A11,”Sul”,C2:C11,”Carne”)O resultado é 14719; veja como a fórmula funciona.

=SOMASES é uma fórmula aritmética. Ela calcula números que, nesse caso, estão na coluna D. Então, comece dizendo para a fórmula onde estão os números:

  • =SOMASES(D2:D11,

Em outras palavras, você quer que a fórmula some os números nessa coluna, se elas atenderem às condições. Esse intervalo de células é o primeiro argumento, ou seja, os dados de que a função precisa para ser executada.

Em seguida, você quer encontrar os dados que atendem a duas condições, então você insere a primeira condição, dizendo à função onde estão os dados (A2:A11) e qual é a condição, que é “Sul”. Note os pontos e vírgulas entre os argumentos separados.

  • =SOMASES(D2:D11;A2:A11;”Sul”;

As aspas em torno de “Sul” dizem ao Excel que esses dados são texto.

Por fim, você insere os argumentos da segunda condição; o intervalo de células (C2:C11) que contém a palavra "carne", mais a própria palavra (entre aspas) para que o Excel possa compará-la. Termine a fórmula com um parêntese de fechamento ) e pressione Enter para aparecer o resultado 14719.

  • =SOMASES(D2:D11;A2:A11;”Sul”;C2:C11;”Carne”)

Enquanto você digita a função SOMASES no Excel, se esquecer dos argumentos, é fácil conseguir ajuda. Depois que você digita =SOMASES( aparece, ao lado da fórmula, o Preenchimento Automático da Fórmula com a lista de argumentos na ordem certa.

Veja a imagem do Preenchimento Automático da Fórmula e a lista de argumentos. No exemplo, intervalo_soma é D2:D11, a coluna de números que você quer somar; intervalo_critérios1 é A2.A11, a coluna de dados em que critério1 "Sul" se encontra.

Usando o Preenchimento Automático da Fórmula para inserir a função SOMASES

Conforme você digita, os outros argumentos aparecem no Preenchimento Automático da Fórmula (não mostrado aqui); intervalo_critérios2 é C2:C11, a coluna de dados onde está critério2 "Carne".

Se você clica em SOMASES no Preenchimento Automático da Fórmula, é aberto um artigo com mais ajuda.

Experimente

Se quiser brincar com a função SOMASES, veja alguns dados de exemplo e uma fórmula que usa a função.

Você pode trabalhar com dados de exemplo e fórmulas aqui, nesta pasta de trabalho do Excel Online. Altere valores e fórmulas ou adicione seus próprios valores e fórmulas e veja os resultados mudarem em tempo real.

Copie todas as células na tabela abaixo e cole-as na célula A1 em uma nova planilha em Excel. Você pode desejar ajustar as larguras de coluna para ver melhor as fórmulas

Região

Vendedor

Tipo

Vendas

Sul

Ito

Bebidas

3571

Oeste

Lannin

Laticínios

3338

Leste

Makovec

Bebidas

5122

Norte

Makovec

Laticínios

6239

Sul

Jordan

Hortigranjeiros

8677

Sul

Lannin

Carne

450

Sul

Lannin

Carne

7673

Leste

Makovec

Hortigranjeiros

664

Norte

Lannin

Hortigranjeiros

1500

Sul

Jordan

Carne

6596

Fórmula

 

Descrição

Resultado

'=SOMASES(D2:D11;A2:A11,
”Sul”; C2:C11;”Carne”)

Soma as Vendas de Carne na
Coluna C na região
Sul na Coluna A (o resultado é 14719).

=SOMASES(D2:D11;A2:A11,
”Sul”; C2:C11;”Carne”)

Observações : 

  • Quer mais exemplos? Você pode encontrar mais no artigo sobre função SOMASES.

  • Para criar um valor total para apenas um intervalo com base em um valor em outro intervalo, use a função SOMASE.

Início da página

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×