Simulação de elementos da interface do Windows XP

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Use o modelo de Interface do Usuário do Windows XP para criar simulações de interfaces do usuário com formas projetadas de acordo com as diretrizes do Microsoft Windows XP. As formas contêm os elementos normalmente usados nas interfaces, como um formulário em branco para servir de base para a janela de um aplicativo, páginas de assistentes, formas de menu e barra de ferramentas e formas de controle.

Você pode usar essas formas para criar desde uma simulação de uma janela de aplicativo complexa ou uma caixa de diálogo com guias a uma caixa de mensagem simples ou um único botão.

O que você deseja fazer?

Criar uma única caixa de diálogo

Criar uma caixa de diálogo com guias

Criar uma janela de aplicativo

Criar menus e barras de ferramentas

Criar uma única caixa de diálogo

  1. Em Janelas e Caixas de Diálogo, arraste uma forma Formulário em branco para a página de desenho.

  2. Com a forma selecionada, digite um título para a caixa de diálogo.

  3. Arraste uma forma Botão de janela para a extremidade direita da barra de título e selecione o tipo de botão. Geralmente, há um botão Ajuda e um botão Fechar, dispostos da esquerda para a direita.

  4. Adicione botões de comando, como OK, Cancelar e Aplicar, no canto inferior direito da forma Formulário em branco.

    how

    1. Em Controles Comuns, arraste as formas Botão de comandopara a borda inferior direita da forma Formulário em branco.

    2. Selecione cada botão e digite o nome do controle.

  5. Arraste os controles apropriados para a forma Formulário em branco. Clique com o botão direito do mouse nas formas para escolher as opções adequadas.

    Para obter ajuda sobre uma forma de controle específica, clique com o botão direito do mouse na forma e clique em Ajuda.

    Se você usar a ferramenta Texto para criar seu próprio texto na forma Formulário em branco, formate o texto como Tahoma 8 pt.

  6. Agrupe comandos em grupos lógicos.

  7. Arraste as formas Caixa de grupo e Linha de grupo para a forma Formulário em branco para separar os grupos visualmente.

    Use Guias para alinhar os controles.

    A caixa de diálogo Imprimir, no menu Arquivo, é um bom exemplo de uma caixa de diálogo com vários dos elementos mais comuns.

Início da página

Criar uma caixa de diálogo com guias

  1. Em Janelas e Caixas de Diálogo, arraste uma forma Formulário em branco para a página de desenho.

  2. Com a forma selecionada, digite um título para a caixa de diálogo.

  3. Arraste uma forma Botão de janela para a extremidade direita da barra de título e selecione o tipo de botão. Geralmente, há um botão Ajuda e um botão Fechar, dispostos da esquerda para a direita.

  4. Adicione botões de comando, como OK, Cancelar e Aplicar, no canto inferior direito da forma Formulário em branco.

    how

    1. Em Controles Comuns, arraste as formas Botão de comandopara a borda inferior direita da forma Formulário em branco.

    2. Selecione cada botão e digite o nome do controle.

  5. Arraste uma forma Controle da Guia (corpo) para o Formulário em branco e dimensione-a para caber no formulário, deixando espaço para as guias.

  6. Arraste uma forma Controle da Guia (guias) e cole-a na borda superior da forma Controle da Guia (corpo).

  7. Com a forma Controle da Guia (guias) selecionada, digite um nome para a guia.

  8. Repita as etapas 6 e 7 para cada guia, colando as guias umas nas outras e na forma Controle da Guia (corpo).

  9. Clique com o botão direito do mouse na guia que deseja mostrar em primeiro plano, clique em Guia de Primeiro Plano e defina as outras como Guia de Plano de Fundo.

  10. Arraste os controles apropriados para a forma Formulário em branco. Clique com o botão direito do mouse nas formas para escolher as opções adequadas.

    Para obter ajuda sobre uma forma de controle específica, clique com o botão direito do mouse na forma e clique em Ajuda.

    Se você usar a ferramenta Texto para criar seu próprio texto na forma Formulário em branco, formate o texto como Tahoma 8 pt.

  11. Agrupe comandos em grupos lógicos.

  12. Arraste as formas Caixa de grupo e Linha de grupo para a forma Formulário em branco para separar os grupos visualmente.

    Use Guias para alinhar os controles.

    A caixa de diálogo Configurar Página, no menu Arquivo, é um bom exemplo de uma caixa de diálogo com vários dos elementos mais comuns.

Início da página

Criar uma janela de aplicativo

  1. Em Janelas e Caixas de Diálogo, arraste uma forma Formulário em branco para a página de desenho.

  2. Com a forma selecionada, digite um título para a janela de aplicativo.

  3. Para adicionar um ícone à esquerda do texto na barra de título, clique com o botão direito na forma Formulário em branco e marque a caixa de seleção Espaço para Ícone.

  4. Arraste uma forma Botões de janela para a extremidade direita da barra de título e selecione o tipo de botão. Geralmente, há três botões: um botão Minimizar, um botão Maximizar ou Restaurar e um botão Fechar, dispostos da esquerda para a direita.

  5. Em Barras de Ferramentas e Menus, arraste uma forma Barra de menus para a forma Formulário em branco, cole-a na parte inferior da barra de título e adicione os itens de menu.

    how

    1. Arraste uma forma Item de menu de nível superior para a página e cole-a na borda esquerda da Barra de menus.

      Você pode colocar um ícone à esquerda do primeiro item de menu.

    2. Com a forma selecionada, digite um nome. Se o item de menu tiver um atalho de teclado, sublinhe a letra apropriada.

    3. Repita as etapas 1 e 2 conforme necessário.

      Para obter ajuda sobre uma forma, clique nela com o botão direito e clique em Ajuda.

      Para ocultar os pontos de conexão Imagem do ponto de conexão - X azul , no menu Exibir, clique em Pontos de Conexão.

      Os itens de uma coluna devem ter sempre a largura do mais largo.

    Para mostrar os pontos da alça na borda esquerda da barra de menus, clique com o botão direito na forma e desmarque a caixa de seleção Bloquear Barra de Menus.

  6. Em Barras de Ferramentas e Menus, arraste uma forma Barras de ferramentas para a forma Formulário em branco, cole-a na parte inferior da barra de menus e adicione os botões da barra de ferramentas.

    how

    1. Arraste uma das formas Botões de barra de ferramentas para a página e cole-a na borda esquerda da forma Barra de ferramentas.

    2. Na caixa de diálogo Dados da Forma, escolha o tipo de botão desejado. Para alterar o botão mais tarde, clique com o botão direito do mouse na forma e clique em Definir o Tipo de Botão para abrir novamente a caixa de diálogo Dados da Forma.

    3. Arraste outras formas Botões de barra de ferramentas e Separador de botão conforme necessário e cole-as umas às outras.

      Para obter ajuda sobre uma forma, clique nela com o botão direito e clique em Ajuda.

      Para ocultar os pontos de conexão Imagem do ponto de conexão - X azul , no menu Exibir, clique em Pontos de Conexão.

    Para mostrar os pontos da alça na borda esquerda da barra de ferramentas, clique com o botão direito na forma e desmarque a caixa de seleção Bloquear Barra de Ferramentas.

  7. Em Controles Comuns, arraste as barras de rolagem horizontal e vertical conforme necessário para as bordas direita e inferior da forma Formulário em branco.

  8. Clique com o botão direito do mouse nas barras de rolagem e escolha Definir Tamanho de Miniatura para indicar a extensão de rolagem da janela.

    Para indicar que somente uma pequena parte do documento está visível, escolha um tamanho de miniatura pequeno. Para indicar que a maior parte do documento está visível, escolha um tamanho de miniatura grande.

  9. Arraste uma forma Barra de status para a borda inferior da janela do aplicativo e formate-a de maneira apropriada.

    how

    1. Arraste uma forma Linha divisória da Barra de status para a página e cole-a na alça de controle da forma Barra de status imagem de alça de controle - losango amarelo .

      As alças de controle fornecem um local para colar uma forma Linha divisória da Barra de status a uma forma Barra de status ou a outra Linha divisória da Barra de status.

      Caso não consiga ver uma forma Linha divisória da Barra de status depois de colá-la a uma forma Barra de status, selecione a forma Barra de status e, no menu Forma, aponte para Ordem e clique em Recuar.

    2. Arraste uma forma Redimensionamento de Janelas para a borda direita da barra de status a fim de indicar que a janela pode ser redimensionada.

Início da página

Criar menus e barras de ferramentas

Use as formas do Windows XP para criar barras de ferramentas, menus suspensos e menus básicos.

Criar um menu

  1. Em Barras de Ferramentas e Menus, arraste uma forma Barra de menus para a página de desenho. Para mostrar os pontos da alça na borda esquerda da barra de menus, clique com o botão direito na forma e desmarque a caixa de seleção Bloquear Barra de Menus.

  2. Arraste uma forma Item de menu de nível superior e cole-a na borda esquerda da Barra de menus.

    Dica : Convém colocar um ícone à esquerda do primeiro item de menu.

  3. Com a forma selecionada, digite um nome. Se o item de menu tiver um atalho de teclado, sublinhe a letra apropriada.

  4. Repita as etapas 2 e 3 conforme necessário.

    Para obter ajuda sobre uma forma, clique nela com o botão direito e clique em Ajuda.

    Para ocultar os pontos de conexão Imagem do ponto de conexão - X azul , no menu Exibir, clique em Pontos de Conexão.

    Os itens de uma coluna devem ter sempre a largura do mais largo.

Criar um menu suspenso

  1. Arraste uma forma Item de menu de nível superior para a página de desenho.

  2. Com a forma selecionada, digite um nome. Se o item de menu tiver um atalho de teclado, sublinhe a letra apropriada.

  3. Arraste uma forma Item de Menu Suspenso, cole-a na parte inferior de Item de menu de nível superior e digite um nome.

  4. Repita a etapa 3 para todos os itens de menu suspenso da coluna.

  5. Redimensione todos os Itens de Menu Suspenso com a largura do mais largo.

  6. Clique com o botão direito em cada forma Item de Menu Suspenso, clique em Propriedades de Item de Menu e selecione as opções apropriadas.

    Para obter ajuda sobre uma forma, clique nela com o botão direito e clique em Ajuda.

    Para ocultar os pontos de conexão Imagem do ponto de conexão - X azul , no menu Exibir, clique em Pontos de Conexão.

Criar uma barra de ferramentas

  1. Em Barras de Ferramentas e Menus, arraste uma forma Barra de Ferramentas para a página de desenho. Para mostrar os pontos da alça na borda esquerda da barra de ferramentas, clique com o botão direito na forma e desmarque a caixa de seleção Bloquear Barra de Ferramentas.

  2. Arraste uma forma Botão de barra de ferramentas e cole-a na borda esquerda da forma Barra de Ferramentas.

  3. Na caixa de diálogo Dados da Forma, escolha o tipo de botão desejado. Para alterar o botão mais tarde, clique com o botão direito do mouse na forma e clique em Definir o Tipo de Botão para abrir novamente a caixa de diálogo Dados da Forma.

  4. Arraste outras formas Botão de barra de ferramentas e Separador de botão conforme necessário e cole-as umas às outras.

    Para obter ajuda sobre uma forma, clique nela com o botão direito e clique em Ajuda.

    Para ocultar os pontos de conexão Imagem do ponto de conexão - X azul , no menu Exibir, clique em Pontos de Conexão.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×