Selecionar e usar modelos do Access 2007

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Neste artigo

Visão geral

Etapa 1: Selecione um modelo

Etapa 2: Personalizar um modelo

Etapa 3: Adicionar dados ao seu novo banco de dados

Etapa 4: Localizar registros


Visão geral

Para facilitar seu trabalho inicial com um banco de dados eficiente, o Microsoft Office Access oferece vários modelos de banco de dados profissionalmente projetados. Cada modelo cria uma solução completa que você pode usar sem nenhuma modificação ou personalizar para atender às suas necessidades. Cada modelo contém tabelas, formulários, relatórios, consultas, macros e relações predefinidos que podem lhe fornecer idéias para a personalização do seu próprio banco de dados.

Além disso, você pode baixar facilmente outros modelos de banco de dados do Access a partir do site do Microsoft Office Online clicando em links no Access. Depois de selecionar um modelo e personalizá-lo para atender às suas necessidades, você pode adicionar dados e começar a navegar pelos registros.

Etapa 1: selecionar um modelo

Você pode selecionar um dos modelos que são instalados com o Access ou navegar até um modelo online.

Selecionar um modelo instalado

  1. Na janela Introdução ao Microsoft Access, em Categorias de Modelo, clique em Modelos Locais.

    Lista de modelos disponíveis   

Modelo

Usar para

Ativos

Controle ativos, incluindo detalhes e proprietários de ativos. Você pode inserir ativos em categorias e registrar sua condição, a data de aquisição, a localização e o proprietário.

Contatos

Gerencie informações sobre as pessoas com as quais a sua equipe trabalha, como clientes e parceiros. Você pode controlar informações sobre nomes e endereços, números de telefone, endereços de email e até mesmo anexar uma imagem.

Eventos

Controle reuniões futuras, prazos e outros eventos importantes. Registre título, local, hora de início, hora de término e descrição e anexe também uma imagem.

Faculdade

Gerencie informações importantes sobre membros do corpo docente, como números de telefone, endereços, informações de contato de emergia e dados de contratação.

Falhas

Gerencie e controle um conjunto de falhas ou problemas. Você pode atribuir, priorizar e acompanhar o andamento das falhas do início ao fim.

Projetos de Marketing

Gerencie os detalhes de um projeto de marketing, programe e monitore as entregas do projeto.

Projetos

Gerencie tarefas e controle o orçamento de um ou mais projetos.

Pipeline de Vendas

Monitore o progresso de vendas potenciais de um pequeno grupo de profissionais de vendas.

Alunos

Gerencie informações sobre seus alunos, incluindo contatos de emergência, informações médicas e informações sobre seus tutores.

Tarefas

Controle um grupo de itens de trabalho que você ou seu time precisam completar.

Northwind 2007

Crie um sistema de controle de pedidos. Você precisa remover os dados inclusos como exemplo.

  1. Clique no modelo no qual deseja modelar seu banco de dados.

  2. Na caixa Nome do Arquivo, digite um nome para o banco de dados.

  3. Para selecionar um local específico para o novo banco de dados, clique no ícone de arquivo ao lado da caixa Nome do Arquivo.

    Dica : Para vincular o banco de dados a um site do Windows SharePoint Services, marque a caixa de seleção Criar e vincular o banco de dados a um site do Windows SharePoint Services.

  4. Clique em Criar.

Seu novo banco de dados já está pronto para ser usado, e você pode optar por personalizá-lo como desejar.

Selecionar um modelo online

  1. Na janela Introdução ao Microsoft Access, siga um destes procedimentos:

    • Para navegar por todos os modelos online em destaque, em Categorias de Modelo, clique em Recurso e selecione o modelo desejado.

    • Para selecionar um modelo online com base em um tema, clique em um tema Do Microsoft Online e selecione o modelo desejado.

  2. Na caixa Nome do Arquivo, digite um novo nome para o modelo e clique no ícone de arquivo ao lado da caixa de texto para selecionar um local específico para o novo banco de dados.

  3. Clique em Download.

Dica : Para vincular o banco de dados a um site do Microsoft Windows SharePoint Services, marque a caixa de seleção Criar e vincular o banco de dados a um site do Windows SharePoint Services.

Seu novo banco de dados já está pronto para ser usado, e você pode optar por personalizá-lo como desejar.

Início da página

Etapa 2: personalizar um modelo

Depois de selecionar o seu modelo de banco de dados, você pode personalizá-lo para atender às suas necessidades. Um banco de dados criado a partir de um modelo contém várias tabelas, formulários e relatórios internos e pré-projetados com os quais você pode trabalhar imediatamente. Quando um banco de dados é criado a partir de um modelo, o Access cria as tabelas e os outros objetos necessários para servir de suporte para a finalidade com a qual o modelo foi projetado. Em alguns casos, a estrutura do banco de dados no modelo é complexa e talvez seja necessário personalizar algumas partes dessa estrutura. Se você fizer alterações de design nas tabelas fornecidas, precisará tomar cuidado para não invalidar nenhuma relação existente. Se você descobrir que precisa fazer alterações mais significativas na estrutura de um modelo, talvez seja mais fácil começar com um banco de dados em branco.

Ao personalizar um modelo, tente evitar renomear campos ou tabelas. Esses campos e tabelas podem ser usados em outros objetos de banco de dados, como formulários e relatórios, e renomeá-los pode impedir que esses outros objetos que fazem referência a esses nomes de campos e tabelas, ou que dependem deles, funcionem conforme esperado. Antes de renomear uma tabela no Painel de Navegação ou de renomear um campo no modo Folha de Dados ou Design, verifique se o recurso AutoCorreção de Nomes está ativado. Esse recurso propaga automaticamente as alterações de nomes em campos, tabelas, formulários ou relatórios para outros objetos do banco de dados. Em geral, a configuração AutoCorreção de Nomes está ativada por padrão para todos os novos bancos de dados.

Personalizar um formulário ou relatório

Você pode personalizar um formulário ou relatório de modelo de várias maneiras. Por exemplo, pode alterar o formato de um formulário abrindo-o no modo Layout e escolhendo um novo formato no grupo AutoFormatação (na guia Formatar). Também é possível personalizar um formulário ou relatório adicionando novos campos. Ao adicionar um campo a um formulário ou relatório, você cria um controle nesse formulário ou relatório. Se quiser personalizar controles existentes em um modelo, poderá alterar as propriedades desses controles.

Adicionar um novo controle a um formulário ou relatório

  1. No Painel de Navegação, clique com o botão direito no formulário ou relatório ao qual deseja adicionar o controle e clique em Modo Design.

  2. Clique na guia Design.

  3. No grupo Controles, clique no controle que deseja adicionar e clique em Usar Assistentes de Controle.

    comando Usar Assistentes de Controle no grupo Controles

  4. Siga as etapas no assistente para criar e personalizar o novo controle.

Para obter mais informações sobre como criar formulários e relatórios, consulte os links na seção Consulte Também.

Alterar um controle

Você pode personalizar a forma como um controle existente aparece em um formulário ou relatório. Para alterar um formato de exibição, é necessário alterar a propriedade Formato de um campo. A propriedade Formato do campo é então herdada automaticamente por controles que se baseiam nesse campo em qualquer novo formulário ou relatório que você criar.

Definir o formato de exibição no modo Folha de Dados

  1. Clique no Botão do Microsoft Office Imagem do botão Office e clique em Abrir.

  2. Na caixa de diálogo Abrir, abra o banco de dados que contém o controle que você deseja alterar.

  3. No Painel de Navegação, clique duas vezes na tabela que contém o campo cujo formato você deseja definir.

    A tabela abrirá no modo Folha de Dados.

  4. Clique no campo cujo formato de exibição você deseja definir.

  5. Na guia folha de dados, no grupo tipo de dados e formatação, clique na seta na lista suspensa ao lado de formato e selecione um formato. Imagem do grupo Tipo de Dados e Formatação da Faixa de Opções do Access

    O campo é exibido com o novo formato de exibição aplicado.

Definir o formato de exibição no modo Design

  1. Clique no Botão do Microsoft Office Imagem do botão Office e clique em Abrir.

  2. Na caixa de diálogo Abrir, abra o banco de dados que contém o controle que você deseja alterar.

  3. No Painel de Navegação, clique com o botão direito na tabela que contém o campo cujo formato de exibição você deseja alterar e clique em Modo Design.

    A tabela é aberta no modo Design.

  4. Clique no campo cujo formato de exibição você deseja definir.

  5. Em Propriedades do Campo, na guia Geral, selecione um formato de exibição na lista Formato.

  6. Para salvar as alterações, clique em Salvar na Barra de Ferramentas de Acesso Rápido.

Início da página

Etapa 3: adicionar dados ao novo banco de dados

Depois de selecionar um modelo e fazer todas as personalizações necessárias, você pode adicionar dados ao banco de dados importando-os ou vinculando-os a dados externos.

Importar dados

Você pode importar dados em vários formatos, incluindo pastas de trabalho do Excel, listas do Windows SharePoint Services 3.0, catálogos de endereços do Outlook ou outros bancos de dados do Access.

  • Para importar dados, na guia Dados Externos, no grupo Importar, clique no comando referente ao tipo de arquivo que você está importando.

    Botões de comando no grupo Importar

    Observações : 

    • Se você não visualizar um ícone para o tipo de dados que deseja importar, clique em Mais e siga as instruções na caixa de diálogo Obter Dados Externos.

    • Se ainda não conseguir localizar um comando para importar seus dados externos, talvez seja necessário iniciar o programa no qual você criou os dados originalmente (isso deve ser feito fora do Access) e usar esse programa para salvar os dados em um formato de arquivo comum (como um arquivo de texto delimitado). Em seguida, retorne ao Access e use um dos comandos de dados externos para importar esses dados.

  • Na última página do assistente, você poderá ser solicitado a salvar os detalhes dessas etapas de importação. Salvar os detalhes poderá ser útil caso você venha a importar dados da mesma fonte de dados no futuro. Marque a caixa de seleção Salvar Etapas de Importação, insira os detalhes e clique em Salvar Importação. Agora, você pode repetir a mesma importação clicando em Importações Salvas, no grupo Importar da guia Dados Externos. Se não quiser salvar os detalhes dessa operação de importação, clique em Fechar.

Vincular dados

Ao vincular dados, estes continuam a ser armazenados em seu local original, aparecendo como uma tabela vinculada no seu novo banco de dados. Para a maioria dos formatos de arquivo, você pode visualizar e modificar dados usando o Access ou o programa original que os criou, pois ambos trabalham com os mesmos dados físicos. Entretanto, se os dados forem armazenados em uma pasta de trabalho do Excel, você apenas poderá exibir os dados vinculados no Access, mas não poderá modificá-los. Para modificar dados em uma pasta de trabalho vinculada, é preciso usar o Excel.

    1. Clique no Botão do Microsoft Office Imagem do botão Office e clique em Abrir.

    2. Na caixa de diálogo Abrir, selecione e abra o banco de dados.

    3. Na guia Dados Externos, no grupo Importar, clique no comando para o tipo de arquivo com o qual deseja criar um vínculo. Por exemplo, se quiser criar um vínculo com os dados em uma pasta de trabalho do Excel, clique em Excel. Se não visualizar um ícone para o tipo de dados com os quais deseja criar um vínculo, clique em Mais.

      A caixa de diálogo Obter Dados Externos aparece.

      Observação : Se ainda não conseguir localizar um comando para criar um vínculo com os seus dados externos, talvez seja necessário iniciar o programa (isso deve ser feito fora do Access) no qual você criou os dados originalmente e usar esse programa para salvar os dados em um formato de arquivo comum (como um arquivo de texto delimitado). Em seguida, retorne ao Access e use um dos comandos de dados externos para vincular esses dados.

    4. Na caixa de diálogo Obter Dados Externos, clique em Procurar para localizar o arquivo de dados fonte, ou digite o caminho completo do arquivo de dados fonte na caixa Nome do arquivo.

    5. Clique na opção desejada em Especificar como e onde você deseja armazenar os dados no banco de dados atual.

      Para a maioria dos formatos de arquivo, um assistente é iniciado. Entretanto, se estiver criando vínculos com dados em um banco de dados do Access, a caixa de diálogo Importar Objetos será exibida. Faça suas opções na caixa de diálogo Vincular Tabelas e continue até a etapa 7. Caso contrário, continue até a etapa 6.

    6. Conclua as etapas no assistente. O processo exato a ser seguido dependerá das opções escolhidas.

Início da página

Etapa 4: localizar registros

Depois de importar dados para o seu banco de dados, você precisará de uma maneira eficiente para localizar registros específicos. Para isso, é possível usar a barra de ferramentas na parte inferior do banco de dados.

Botões de navegação

Use os botões de navegação para localizar registros em uma tabela ou modo de exibição.:

Botão de navegação

Use para ir até

1.

Primeiro registro

2.

Registro anterior

3.

Registro específico — Clique na caixa de texto, digite o número do registro e pressione ENTER para exibir esse registro. Os números de registros são contados seqüencialmente a partir do início do formulário ou da folha de dados.

4.

Próximo registro

5.

Último registro

6.

Novo registro (em branco)

7.

Filtro — Esse indicador mostra se um filtro foi aplicado. Se não houver um filtro aplicado ou se todos os filtros tiverem sido desmarcados, o indicador Sem Filtro será exibido.

8.

Caixa Pesquisar — Insira texto na caixa Pesquisar, e o primeiro valor correspondente será realçado em tempo real à medida que você digita cada caractere. Use esse recurso para procurar rapidamente um registro.

Opções adicionais para a localização de registros

Você também pode localizar registros usando um destes métodos

Ir para um registro específico

Pesquisar um registro específico

Filtro para exibir apenas um conjunto específico de registros

Realizar uma pesquisa personalizada usando uma consulta

Ir para um registro específico

Alguns modelos contêm formulários que possuem a opção de exibir um registro específico com o uso de uma lista suspensa Ir para. Por exemplo, o formulário Detalhes do Contato no modelo Detalhes e o formulário Projetos e Tarefas no modelo Projetos de Marketing têm essa opção, que você pode usar para exibir um registro específico a partir de uma lista suspensa. Se disponível, a caixa Ir para estará localizada na seção superior esquerda do formulário.

  1. Clique na seta ao lado da lista Ir para.

    A caixa Ir para

  2. Clique no registro que você deseja exibir.

Procurar um registro específico

Use a guia Localizar na caixa de diálogo Localizar e Substituir para procurar registros específicos. É possível pesquisar em um campo específico ou em uma tabela ou modo de exibição inteiro.

Observação : Apenas será possível usar a caixa de diálogo Localizar e Substituir se a tabela ou o modo de exibição estiver exibindo dados.

  1. Abra a tabela que deseja pesquisar e clique no campo que contém o registro que deseja localizar.

  2. Na guia Início, no grupo Localizar, clique em Localizar.

    botão de comando Localizar

  3. Na caixa de diálogo Localizar e Substituir, digite seu critério de pesquisa na caixa Localizar.

  4. Na lista Pesquisar, selecione Tudo e clique em Localizar Próximo.

Para obter mais informações sobre como usar a caixa de diálogo Localizar e Substituir, confira os links na seção Consulte Também.

Filtrar para exibir somente um conjunto específico de registros

Você pode ativar ou desativar um filtro para poder alternar facilmente entre modos de exibição filtrados e não filtrados dos mesmos dados.

É possível aplicar um filtro para limitar os registros exibidos somente àqueles que correspondem aos seus critérios. A aplicação de um filtro facilita a localização dos registros desejados. Por exemplo, para restringir rapidamente os registros exibidos, clique com o botão direito em um campo cujo valor você deseja corresponder e então selecione uma das opções do menu de seleção É Igual a, É Diferente de, Contém ou Não Contém.

  • Abra a tabela ou o formulário ao qual deseja adicionar um filtro.

  • Para garantir que uma tabela ou formulário ainda não esteja filtrado, na guia Início, no grupo Classificar e Filtrar, clique em Avançado e em Limpar Todos os Filtros. Se esse comando não estiver disponível (se estiver esmaecido), significa que nenhum filtro foi aplicado.

    grupo Classificar e Filtrar

  • Para aplicar um filtro, clique no campo no qual deseja filtrar e, na guia Início, no grupo Classificar e Filtrar, clique em Filtrar e selecione uma opção de filtragem.

  • Para aplicar um filtro com base em uma seleção, abra uma tabela ou formulário e navegue até o registro que contém o valor que você deseja usar como parte do filtro. Em seguida, clique no campo. Na guia página inicial, no grupo Classificar e filtrar, clique em seleção e, em seguida, clique no filtro que você deseja aplicar.

  • Para aplicar um filtro com base em uma seleção parcial, selecione apenas os caracteres que você deseja. Na guia página inicial, no grupo Classificar e filtrar, clique em seleção e, em seguida, clique no filtro que você deseja aplicar.

Para obter mais informações sobre como aplicar um filtro, confira os links na seção Consulte Também.

Realizar uma pesquisa personalizada usando uma consulta

Você pode usar consultas para realizar pesquisas personalizadas, aplicar filtros personalizados e classificar registros. Consultas podem ser salvas e reutilizadas e eles podem ser usados para criar formulários e relatórios. Você também pode usar uma consulta para localizar apenas os registros da tabela que você está interessado. O tipo de consulta que você cria depende os registros que você deseja que sejam retornados e se você deseja que o Access fazer nada com os resultados.

  1. Na guia Criar, no grupo Outros, clique em Assistente de Consulta.

    comando Assistente de Consulta no grupo Outros

  2. Siga as etapas no Assistente de Consulta.

Para obter informações adicionais sobre como criar consultas, confira os links na seção Consulte Também.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×