SOMASES (Função SOMASES)

SOMASES (Função SOMASES)

A função SOMASES, uma das funções de matemática e trigonometria, adiciona todos os seus argumentos que atendem a vários critérios. Por exemplo, você usaria SOMASES para somar o número de revendedores no país que (1) residem em um único CEP e (2) cujos lucros excedem um valor em dólar específico.

Seu navegador não oferece suporte a vídeo. Instale o Microsoft Silverlight, o Adobe Flash Player ou o Internet Explorer 9.

Este vídeo faz parte de um treinamento chamado Funções SE avançadas.

Sintaxe

SOMASES(intervalo_soma; intervalo_critérios1; critérios1; [intervalo_critérios2; critérios2];...)

  • =SOMASES(A2:A9;B2:B9;"=A*";C2:C9;"Diogo")

  • =SOMASES(A2:A9;B2:B9;"<>Bananas";C2:C9;"Diogo")

Nome do argumento

Descrição

Intervalo_soma    (obrigatório)

O intervalo de células para somar.

Intervalo_critérios1    (obrigatório)

O intervalo testado usando os Critérios1.

Intervalo_critérios1 e Critérios1 configuram um par de pesquisa no qual um intervalo é pesquisado em busca de critérios específicos. Depois que os itens no intervalo forem encontrados, seus correspondentes valores em Intervalo_soma serão adicionados.

Critérios1    (obrigatório)

Os critérios que definem quais células no Intervalo_critérios1 serão adicionadas. Por exemplo, os critérios podem ser inseridos como 32, ">32", B4, "maçãs" ou "32".

Intervalo_critérios2;critérios2;...    (opcional)

Intervalos adicionais e seus critérios associados. Você pode inserir até 127 pares de intervalo/critérios.

Exemplos

Para usar esses exemplos no Excel, arraste para selecionar os dados na tabela, clique com o botão direito do mouse na seleção e escolha Copiar. Em uma nova planilha, clique com botão direito do mouse na célula A1 e escolha Fazer Correspondência com a Formatação de Destino, em Opções de Colagem

Quantidade Vendida

Produto

Vendedor

5

Maçãs

Diogo

4

Maçãs

Sara

15

Alcachofras

Diogo

3

Alcachofras

Sara

22

Bananas

Diogo

12

Bananas

Sara

10

Cenouras

Diogo

33

Cenouras

Sara

Fórmula

Descrição

=SOMASES(A2:A9;B2:B9;"=A*";C2:C9;"Diogo")

Adiciona o número de produtos que começam com A e foram vendidos por Diogo. Usa o caractere curinga * em Critérios1, "="A* para procurar por nomes de produto no correspondentes em Intervalo_critérios1 B2:B9, e procura o nome "Diogo" em Intervalo_critérios2 C2:C9. Em seguida, adiciona os números em Intervalo_soma A2:A9 que atendem a ambas as condições. O resultado é 20.

=SOMASES(A2:A9;B2:B9;"<>Bananas";C2:C9;"Diogo")

Adiciona o número de produtos que não são bananas e que foram vendidos por Diogo. Exclui bananas usando <> em Critérios1, "<> Bananas" e procura o nome "Diogo" em Intervalo_critérios2 C2:C9. Em seguida, adiciona os números em Intervalo_soma A2:A9 que atendam a ambas as condições. O resultado é 30.

Problemas comuns

Problema

Descrição

0 (zero) é mostrado em vez do resultado esperado.

Certifique-se de que Critérios1,2 estejam entre aspas se você estiver testando valores de texto, como o nome de uma pessoa.

O resultado será incorreto quando Intervalo_soma tiver valores VERDADEIRO ou FALSO.

Valores VERDADEIRO e FALSO para Intervalo_soma são avaliados de maneira diferente, que podem causar resultados inesperados quando são adicionados.

As células em Intervalo_soma que contêm VERDADEIRO são avaliadas como 1. As células em que contêm FALSO são avaliadas como 0 (zero).

Práticas recomendadas

Siga este procedimento

Descrição

Use caracteres curinga.

O uso de caracteres curinga, como o ponto de interrogação (?) e o asterisco (*), em critérios1,2 pode ajudar você a localizar correspondências semelhantes, mas não exatas.

Um ponto de interrogação corresponde a qualquer caractere único. Um asterisco corresponde a qualquer sequência de caracteres. Se você quiser localizar um ponto de interrogação ou asterisco real, digite um til (~) antes do ponto de interrogação.

Por exemplo, =SOMASES (A2:A9;B2:B9;"=A *";C2: C9;"To?") adicionará todas as instâncias com o nome que começa com "To" e termina com uma última letra que pode variar.

Compreenda a diferença entre SOMASE e SOMASES.

A ordem dos argumentos é diferente entre SOMASES e SOMASE. Particularmente, o argumento intervalo_soma é o primeiro argumento em SOMASES, mas é o terceiro argumento em SOMASE. Esta é uma fonte comum de problemas usando essas funções.

Se você estiver copiando e editando essas funções semelhantes, verifique se você colocou os argumentos na ordem correta.

Use o mesmo número de linhas e colunas para argumentos de intervalo.

O argumento Intervalo_critérios deve conter o mesmo número de linhas e colunas que o argumento Intervalo_soma.

Início da Página

Você tem dúvida sobre uma função específica?

Postar uma pergunta no fórum da comunidade do Excel

Ajude-nos a melhorar o Excel

Você tem sugestões sobre como podemos melhorar a próxima versão do Excel? Em caso afirmativo, confira os tópicos no site User Voice do Excel.

Consulte Também

Assista a um vídeo sobre como usar funções avançadas SE, como SOMASES

A função SOMASE adiciona apenas os valores que atendem a um único critério

A função SOMAQUAD soma vários valores depois de executar uma operação matemática de raiz quadrada em cada um deles

A função CONT.SE calcula apenas os valores que atendem a um único critério

A função CONT.SES calcula apenas os valores que atendem a vários critérios

A função SES (Office 365, Excel 2016 e posterior)

Visão geral de fórmulas do Excel

Como evitar fórmulas quebradas

Usar a verificação de erros para detectar erros em fórmulas

Funções de matemática e trigonometria

Funções do Excel (por ordem alfabética)

Funções do Excel (por categoria)

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×