SEERRO (Função SEERRO)

Este artigo descreve a sintaxe da fórmula e o uso da função SEERRO no Microsoft Excel.

Descrição

Retorna um valor especificado se uma fórmula gerar um erro; caso contrário, retorna o resultado da fórmula. Use a função SEERRO para capturar e controlar os erros em uma fórmula.

Sintaxe

SEERRO(valor, valor_se_erro)

A sintaxe da função SEERRO tem os seguintes argumentos:

  • Valor    Obrigatório. O argumento verificado quanto ao erro.

  • Valor_se_erro    Obrigatório. O valor a ser retornado se a fórmula gerar um erro. Os seguintes tipos de erro são considerados: #N/D, #VALOR!, #REF!, #DIV/0!, #NÚM!, #NOME? ou #NULO!.

Comentários

  • Se Valor ou Valor_se_erro for uma célula vazia, SEERRO a tratará como um valor de cadeia vazio ("").

  • Se o Valor for uma fórmula de matriz, SEERRO retornará uma matriz de resultados para cada célula no intervalo especificado no valor. Consulte o segundo exemplo a seguir.

Exemplos

Copie os dados de exemplo da tabela a seguir e cole-os na célula A1 de uma nova planilha do Excel. Para as fórmulas mostrarem resultados, selecione-as, pressione F2 e pressione Enter. Se precisar, você poderá ajustar as larguras das colunas para ver todos os dados.

Cota

Unidades Vendidas

210

35

55

0

23

Fórmula

Descrição

Resultado

=SEERRO(A2/B2, "Erro no cálculo")

Verifica se há erros na fórmula no primeiro argumento (divide 210 por 35), não localiza nenhum erro e, em seguida, retorna os resultados da fórmula.

6

=SEERRO(A3/B3, "Erro no cálculo")

Verifica se há erros na fórmula no primeiro argumento (divide 55 por 0), localiza um erro de divisão por 0 e, em seguida, retorna valor_se_erro

Erro no cálculo

=SEERRO(A4/B4, "Erro no cálculo")

Verifica se há erros na fórmula no primeiro argumento (divide "" por 23), não localiza nenhum erro e, em seguida, retorna os resultados da fórmula.

0

Exemplo 2

Cota

Unidades Vendidas

Proporção

210

35

6

55

0

Erro no cálculo

23

0

Fórmula

Descrição

Resultado

=C2

Verifica se há erros na fórmula no primeiro argumento, no primeiro elemento da matriz (A2/B2 ou divide 210 por 35), não localiza nenhum erro e, em seguida, retorna o resultado da fórmula

6

=C3

Verifica se há erros na fórmula no primeiro argumento, no segundo elemento da matriz (A3/B3 ou divide 55 por 0), localiza um erro de divisão por 0 e, em seguida, retorna valor_se_erro

Erro no cálculo

=C4

Verifica se há erros na fórmula no primeiro argumento, no terceiro elemento da matriz (A4/B4 ou divide "" por 23), não localiza nenhum erro e, em seguida, retorna o resultado da fórmula

0

Observação: a fórmula no exemplo precisa ser inserida como uma fórmula de matriz. Após copiar o exemplo em uma planilha em branco, selecione o intervalo C2:C4, pressione F2 e, em seguida, pressione CTRL+SHIFT+ENTER.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×