Roteiro: Exibir um desenho do Visio com dados conectados em uma Web Part do SharePoint

Se precisar apresentar informações aprofundadas rapidamente e a muitas pessoas, crie um diagrama no Visio como uma web part que forneça relatórios visuais. O Visio 2010 permite puxar dados de fontes externas como Serviços do Excel, SQL Server, listas do SharePoint ou mesmo outros bancos de dados OLEDB ou ODBC. É possível também aplicar gráficos de dados às formas do seu desenho, para melhor visualizar esses dados externos,publicar o desenho em um site do SharePoint, e ainda usar uma web part do Visio Web Access para exibir o diagrama no site do SharePoint.

Ele é ideal na criação de painéis personalizados para valiosas soluções em business intelligence. Tomadores de decisões podem enxergar a representação visual de um desempenho empresarial num piscar de olhos e agir rapidamente com base naquelas informações. Para saber mais sobre como usar o SharePoint para business intelligence, consulte o artigo O que é o business intelligence do SharePoint?

Baixar o guia visual

Seu navegador não oferece suporte a vídeo. Instale o Microsoft Silverlight, o Adobe Flash Player ou o Internet Explorer 9.

Neste artigo

Requisitos

Baixar o modelo

Etapa 1: Importar dados para o desenho do Visio

Etapa 2: Aplicar gráficos de dados a formas

Etapa 3: Exibir o diagrama em uma web part do SharePoint

Opcional: Adicionar interatividade a uma web part do Visio Web Access

Requisitos

A web part do Visio Web Access é um recurso dos Serviços do Visio, incluídos no Microsoft SharePoint Server 2010. Para usar os Serviços do Visio, é necessário ter a Licença de Acesso para Cliente Enterprise (ECAL) do Microsoft SharePoint Server 2010; os Serviços do Visio devem ser implantados e configurados para que sejam utilizados.

Além disso, você precisa ter o Microsoft Visio Professional 2010 ou o Microsoft Visio Premium 2010 para salvar um diagrama em um site do SharePoint.

Para obter mais informações sobre o que fazer para habilitar os Serviços do Visio em um site do SharePoint, consulte a administração do Serviço de Gráfico do Visio.

Início da página

Baixar o modelo

É possível baixar e usar o modelo destacado no vídeo e no guia visual referidos acima. O modelo inclui as amostras e os gráficos de dados usados nos exemplos.

Baixar o diagrama de exemplo e os dados

Início da página

Etapa 1: Importar dados para o desenho do Visio

  1. No Visio, vá à guia de Dados e, no grupo Dados Externos, clique em Vincular Dados a Formas.

Na primeira página do Assistente do Seletor de Dados, selecione a fonte de dados que deseja usar.

Importante :  Os Serviços do Access não podem ser usados como fonte de dados por um Desenho da Web dos Serviços do Visio. Alguns tipos de diagramas, como os Diagramas Dinâmicos, não são atualizáveis quando publicados em um site do SharePoint. Para obter os melhores resultados, tenha certeza de que sua fonte de dados está salva no mesmo site do SharePoint site que a web part dos Serviços do Visio.

  1. Siga as instruções no Assistente do Seletor de Dados.

  2. Após clicar em Terminar na última página do Assistente do Seletor de Dados, a janela Dados Externos aparece com seus dados importados mostrados em uma tabela.

  3. Para aplicar dados de uma fonte externa em uma forma no seu desenho, arraste uma linha a partir da janela Dados Externos para dentro da forma.

Para obter mais informações sobre como importar dados para o Visio a partir de uma fonte de dados externa, consulte Importar dados do Excel, SQL Server, sites do SharePoint e outras fontes externas.

Início da página

Etapa 2: Aplicar gráficos de dados a formas

Para criar um novo gráfico de dados, faça o seguinte:

  1. No Visio, vá à guia Dados e, no grupo Exibir Dados, clique em Gráficos de Dados; a seguir, clique em Criar Novos Gráficos de Dados.

  2. Na caixa de diálogo Novo Item:

    1. Em Exibir, vá até a lista Campo de dados e clique no campo Dados da Forma que você deseja representar visualmente.

    2. Também em Exibir, vá à lista Exibido como e selecione o gráfico que melhor representa o campo de dados (Texto, Barra de Dados, Conjunto de Ícones ou Colorir de acordo com Valor.)

    3. Ainda em Exibir, vá até a lista de Estilos e selecione o estilo de gráfico que desejar (Se escolher Colorir de acordo com Valor como tipo de gráfico, esta é a lista de Método de coloração.)

    4. Em Detalhes, personalize o gráfico como desejar.

    5. Quando terminar de editar o item gráfico, clique em OK.

  3. Repita a etapa anterior até ter criado um item para cada um dos campos de dados da forma que deseja exibir.

Para aplicar um gráfico de dados a formas no desenho, faça o seguinte:

  1. Na página do desenho, selecione a forma em que deseja aplicar os gráficos de dados.

Observação :  Para selecionar diversas formas na página de desenho, pressione e mantenha pressionada a tecla CTRL para, então, selecionar cada forma em que deseja aplicar os dados de gráficos.

  1. Na guia Dados, vá ao grupo Exibir Dados e clique em Gráficos de Dados; a seguir, em Gráficos de Dados Disponíveis, clique no gráfico de dados que desejar.

Para obter mais informações sobre como criar e aplicar gráficos de dados, consulte Aprimorar seus dados com gráficos de dados.

Início da página

Etapa 3: Exibir o diagrama em uma web part do SharePoint

  1. Na página do SharePoint à qual você deseja adicionar a web part, vá à guia Página e, no grupo Editar, clique em Editar.

  2. Em Ferramentas de Edição, vá à guia Inserir e, no grupo Web Parts, clique em Web Part. A seguir, faça o seguinte:

    1. Em Categorias, clique em Dados Corporativos.

    2. Em Web Parts, clique em Visio Web Access.

    3. Clique em Adicionar.

  3. Na web part do Visio Web Access, clique no link para abrir o painel de ferramentas.

  4. Nesse painel de ferramentas, expanda a Exibição do Desenho da Web e, na caixa URL do Desenho da Web, navegue até o Desenho da Web do Visio que você deseja exibir.

Importante :  Antes que possa usar o Visio Web Access para exibir seu diagrama em uma web part, é necessário publicar o arquivo do Visio no site do SharePoint como um Desenho da Web. Para obter mais informações sobre como publicar um Desenho da Web do Visio em um site do SharePoint, consulte Roteiro: Publicar desenhos do Visio em um site do SharePoint.

  1. Na parte inferior do painel de ferramentas, clique em Aplicar e, a seguir, em OK.

Para obter mais informações sobre como exibir um Desenho da Web do Visio em uma web part, consulte Exibir um desenho da Web do Visio em uma Web Part.

Início da página

Opcional: Adicionar interatividade a uma web part do Visio Web Access

Se você puder escrever em ECMAScript, pode personalizar a web part do Visio Web Access para incluir camadas visuais sobrepostas que exibem informações adicionais a respeito das formas no desenho do Visio.

Para obter mais informações sobre como programar um elemento interativo para um Desenho no Visio ou para um Desenho do na Página de Web Parts Page, consulte MSDN: Criar um Desenho Mashup ECMAScript no Visio 2010 para exibir no SharePoint Server 2010.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×