Publicar uma pasta de trabalho em uma biblioteca do SharePoint no Excel 2016 para Windows

Você pode publicar uma pasta de trabalho em uma biblioteca do Microsoft SharePoint para que as pessoas possam exibi-la ou editá-la em um navegador da Web sem precisar instalar o Excel em seus computadores. Essencialmente, publicar é igual a salvar, mas com algumas opções internas que permitem controlar o que as pessoas podem ver quando abrem a pasta de trabalho em um navegador.

A adoção em toda a organização da prática de salvar ou publicar uma pasta de trabalho em um site central do SharePoint pode ajudar você a assegurar que versões ligeiramente diferentes da mesma pasta de trabalho não comecem a surgir por toda a organização quando ela for distribuída em um email.

Ao definir algumas opções de publicação, você pode enfatizar partes específicas da sua pasta de trabalho, como gráficos, ou excluir outras partes da exibição no navegador. Por exemplo, você pode mostrar um gráfico, mas não seus dados subjacentes. Ou pode mostrar apenas determinadas planilhas às pessoas que precisam vê-las e ocultar as demais planilhas.

Este artigo mostra como publicar uma pasta de trabalho do Excel 2016 para Windows, mas não abrange a conexão de uma pasta de trabalho ou de dados de uma pasta de trabalho a uma Web Part do Excel Web Access em uma página do SharePoint.

Quando você publica uma pasta de trabalho em um site do SharePoint, a pasta de trabalho inteira é salva no SharePoint. Um usuário com as permissões necessárias do SharePoint pode exibir a pasta de trabalho inteira e trabalhar com ela no navegador ou no programa de desktop Excel.

Se o Office Online for implantado no SharePoint, exibir e trabalhar com seus dados no navegador poderá ser muito semelhante a trabalhar com seus dados no programa de área de trabalho do Excel. De fato, diferentemente do programa de área de trabalho do Excel, vários usuários podem editar simultaneamente uma pasta de trabalho na grade do navegador. Quando você exibe uma pasta de trabalho no navegador, se o botão Editar no Excel Online estiver visível, você saberá que o Office Online está pronto para ser usado.

Editar no Excel Online no menu Editar Pasta de Trabalho

Preparar a pasta de trabalho

Antes de publicar a pasta de trabalho, você pode optar por selecionar apenas as planilhas ou os itens que quer que fiquem visíveis no navegador. Lembre-se apenas de que, embora você possa limitar o que pode ser visualizado nesse modo, todo o conteúdo da pasta de trabalho ainda é salvo no servidor do SharePoint.

Se quiser incluir planilhas inteiras como um item, além de outros itens, como gráficos ou Tabelas Dinâmicas, defina a planilha inteira como um intervalo nomeado. Selecione a planilha inteira e defina um intervalo nomeado, o qual será exibido como um item disponível na caixa de diálogo Opções de Publicação quando você estiver pronto para publicar.

Para permitir que os usuários insiram um valor em uma célula para trabalhar com uma fórmula em outra célula, configure essa célula como um nome definido no Excel antes de publicar a pasta de trabalho. Você pode então adicionar esse nome definido como um parâmetro na guia Parâmetros da caixa de diálogo Opções de Exibição no Navegador.

Por exemplo, a seguir está uma célula D2, que tem o nome definido "Taxa". No navegador, um usuário insere o valor 5,625 na caixa Taxa no painel Parâmetros e clica em Aplicar. Esse valor então aparece na célula D2 e a fórmula em A2 usa o valor em D2. O resultado da fórmula é recalculado e mostrado em A2: US$ 1.151,31.

A inserção de um parâmetro no painel usado na célula D2

Observação : Se você criar segmentações de dados para uma tabela do Excel e definir um nome para o intervalo de células contendo a tabela e as segmentações de dados, você não poderá usar as segmentações de dados para filtrar a tabela no navegador se publicar o intervalo definido. Se você publicar a tabela ou a planilha inteira ou sua pasta de trabalho, as segmentações de dados funcionarão conforme o esperado no navegador.

Publicar a pasta de trabalho

  1. Clique na guia Arquivo, clique em Salvar como e clique em SharePoint.

  2. Se você vir a sua pasta do SharePoint em Atual, Recente ou Mais antigos, clique na pasta desejada.

    A caixa de diálogo Salvar como é exibida.


    Caso contrário, clique em Procurar, insira o endereço Web do site do SharePoint e navegue até a pasta na qual você deseja publicar a pasta de trabalho.

    Clique em uma pasta do SharePoint ou clique em Procurar
  3. Para selecionar planilhas ou itens individuais da pasta de trabalho, clique em Opções de Exibição do Navegador.

    Na caixa de diálogo Salvar como, clique em Opções de Exibição do Navegador

    Você verá a guia Mostrar e a guia Parâmetros.

  4. Se quiser apenas publicar a pasta de trabalho inteira, clique em Salvar. Caso contrário, siga um destes procedimentos:

    • Para mostrar a pasta de trabalho inteira no navegador, na guia Mostrar, selecione Pasta de Trabalho Inteira na caixa de listagem.

    • Para mostrar apenas planilhas específicas no navegador, na guia Mostrar, selecione Planilhas na caixa de listagem e depois desmarque as caixas de seleção das planilhas que você não quer ocultar no navegador.

      Por padrão, todas as planilhas estão selecionadas. Para tornar todas as planilhas rapidamente visíveis após desmarcar algumas caixas de seleção, marque a caixa de seleção Todas as Planilhas.

    • Para mostrar apenas itens específicos no navegador (como intervalos nomeados, gráficos, tabelas ou Tabelas Dinâmicas), na guia Mostrar, selecione Itens na Pasta de Trabalho na caixa de listagem e depois marque as caixas de seleção dos itens que você deseja mostrar.

    • Na guia Parâmetros, adicione todos os nomes definidos que você deseja usar para especificar células que são editáveis quando os usuários exibem a pasta de trabalho no navegador e clique em OK.

  5. Salve a pasta de trabalho.

Observações : 

  • Se você selecionar itens que tenham o mesmo nome (como um gráfico e sua tabela de dados subjacente), somente um desses itens estará disponível no navegador. Para mostrar todos os itens, verifique se cada item na pasta de trabalho tem um nome exclusivo.

  • Você pode renomear tabelas na guia Design do grupo Propriedades, renomear Tabelas Dinâmicas na guia Opções do grupo Tabela Dinâmica e renomear gráficos ou Gráficos Dinâmicos na guia Layout do grupo Propriedades. Renomeie outros itens duplicados, como intervalos nomeados, na guia Fórmulas do grupo Nomes Definidos.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×