Publicar uma pasta de trabalho em uma biblioteca do SharePoint

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

No Microsoft Excel 2013, você pode publicar uma pasta de trabalho em uma biblioteca do Microsoft SharePoint para que as pessoas possam exibi-la ou editá-la em um navegador da Web sem precisar ter o Excel instalado em seus computadores. Essencialmente, publicar é igual a salvar, mas com algumas opções internas que que lhe permitem controlar o que as pessoas podem ver quando abrem a pasta de trabalho em um navegador.

A adoção em toda a organização da prática de salvar ou publicar uma pasta de trabalho em um site central do SharePoint pode ajudar você a assegurar que versões ligeiramente diferentes da mesma pasta de trabalho não comecem a surgir por toda a organização quando ela for distribuída em um email.

Ao definir algumas opções de publicação, você pode enfatizar partes específicas da sua pasta de trabalho, como gráficos, ou excluir outras partes da exibição no navegador. Por exemplo, você pode mostrar um gráfico, mas não seus dados subjacentes. Ou pode mostrar apenas determinadas planilhas às pessoas que precisam vê-las e ocultar as demais planilhas.

Este artigo mostra como publicar uma pasta de trabalho a partir do programa de desktop Excel 2013 e não abrange a conexão de uma pasta de trabalho ou dos dados de uma pasta de trabalho com uma Web Part do Excel Web Access em uma página do SharePoint. Para obter mais informações sobre Web Parts do Excel Web Access, consulte o artigo Conectar uma Web Part do Excel Web Access a uma pasta de trabalho do Excel.

Quando você publica uma pasta de trabalho em um site do SharePoint, a pasta de trabalho inteira é salva no SharePoint. Um usuário com as permissões necessárias do SharePoint pode exibir a pasta de trabalho inteira e trabalhar com ela no navegador ou no programa de desktop Excel.

Se o Office Online for implantado no SharePoint, exibir e trabalhar com seus dados no navegador poderá ser muito semelhante a trabalhar com seus dados no programa de área de trabalho do Excel. De fato, diferentemente do programa de área de trabalho do Excel, vários usuários podem editar simultaneamente uma pasta de trabalho na grade do navegador. Quando você exibe uma pasta de trabalho no navegador, se o botão Editar no Excel Online estiver visível, você saberá que o Office Online está pronto para ser usado.

Editar no Excel Online no menu Editar Pasta de Trabalho

Para obter mais informações, consulte o artigo Diferenças entre o uso de uma pasta de trabalho no Excel e nos Serviços do Excel.

Preparar a pasta de trabalho

Antes de publicar a pasta de trabalho, você pode optar por selecionar apenas as planilhas ou os itens que quer que fiquem visíveis no navegador. Lembre-se apenas de que, embora você possa limitar o que pode ser visualizado nesse modo, todo o conteúdo da pasta de trabalho ainda é salvo no servidor do SharePoint.

Se quiser incluir planilhas inteiras como um item, além de outros itens, como gráficos ou Tabelas Dinâmicas, defina a planilha inteira como um intervalo nomeado. Selecione a planilha inteira e defina um intervalo nomeado, o qual será exibido como um item disponível na caixa de diálogo Opções de Publicação quando você estiver pronto para publicar.

Para permitir que os usuários insiram um valor em uma célula para trabalhar com uma fórmula em outra célula, configure essa célula como um nome definido no Excel antes de publicar a pasta de trabalho. Você pode então adicionar esse nome definido como um parâmetro na guia Parâmetros da caixa de diálogo Opções de Exibição no Navegador.

Por exemplo, o gráfico a seguir mostra uma célula D2 com o nome definido "Taxa". No navegador, um usuário insere um valor, 5,625, na caixa do painel Parâmetros e clica em Aplicar. Esse valor é então exibido na célula D2, e a fórmula em A2 usa o valor contido em D2. O resultado da fórmula é recalculado e mostrado em A2: US$ 1.151,31.

Consulte a Ajuda do Excel para obter informações sobre como definir intervalos.

A inserção de um parâmetro no painel usado na célula D2

Observação : Se você criar segmentações de dados para uma tabela do Excel e definir um nome para o intervalo de células contendo a tabela e as segmentações de dados, você não poderá usar as segmentações de dados para filtrar a tabela no navegador se publicar o intervalo definido. Se você publicar a tabela ou a planilha inteira ou sua pasta de trabalho, as segmentações de dados funcionarão conforme o esperado no navegador.

Publicar a pasta de trabalho

  1. Clique em Arquivo > Salvar como > SharePoint.

  2. Se você vir sua pasta do SharePoint empasta atual ou pastas recentes, clique na pasta que você deseja. Caso contrário, clique em Procurar e insira o endereço da web do site do SharePoint. Em seguida, navegue até a pasta onde você deseja publicar a pasta de trabalho. A caixa de diálogo Salvar como é exibida.

  3. Para selecionar planilhas ou itens individuais da pasta de trabalho a serem publicados, clique em Opções de Exibição no Navegador. Você verá uma guia Mostrar e uma guia Parâmetros. Se quiser apenas publicar a pasta de trabalho inteira, clique em Salvar. Caso contrário, siga um destes procedimentos:

  • Para mostrar a pasta de trabalho inteira no navegador, na guia Mostrar, selecione Pasta de Trabalho Inteira na caixa de listagem.

  • Para mostrar apenas planilhas específicas no navegador, na guia Mostrar, selecione Planilhas na caixa de listagem e depois desmarque as caixas das planilhas que você não quer ocultar no navegador.

    Por padrão, todas as planilhas estão selecionadas. Para tornar todas as planilhas rapidamente visíveis novamente após desmarcar algumas caixas, marque a caixa de seleção Todas as Planilhas.

  • Para mostrar apenas itens específicos no navegador (como intervalos nomeados, gráficos, tabelas ou Tabelas Dinâmicas), na guia Mostrar, selecione Itens na Pasta de Trabalho na caixa de listagem e depois desmarque as caixas dos itens que você deseja mostrar.

  • Na guia Parâmetros, adicione todos os nomes definidos que você deseja usar para especificar células que são editáveis quando os usuários exibem a pasta de trabalho no navegador. Em seguida, clique em OK para fechar a caixa de diálogo.

  1. Salve a pasta de trabalho.

Observações : 

  • Se você selecionar itens que tenham o mesmo nome (como um gráfico e sua tabela de dados subjacente), somente um desses itens estará disponível no navegador. Para mostrar todos os itens, verifique se cada item na pasta de trabalho tem um nome exclusivo.

  • Se você selecionar itens que tenham o mesmo nome (como um gráfico e sua tabela de dados subjacente), somente um desses itens estará disponível no navegador. Para mostrar todos os itens, verifique se cada item na pasta de trabalho tem um nome exclusivo.

  • Você pode renomear tabelas na guia Design do grupo Propriedades, renomear Tabelas Dinâmicas na guia Opções do grupo Tabela Dinâmica e renomear gráficos ou Gráficos Dinâmicos na guia Layout do grupo Propriedades. Renomeie outros itens duplicados, como intervalos nomeados, na guia Fórmulas do grupo Nomes Definidos.

  • Você pode renomear tabelas na guia Design do grupo Propriedades, renomear Tabelas Dinâmicas na guia Opções do grupo Tabela Dinâmica e renomear gráficos ou Gráficos Dinâmicos na guia Layout do grupo Propriedades. Renomeie outros itens duplicados, como intervalos nomeados, na guia Fórmulas do grupo Nomes Definidos.

Saiba mais sobre os Serviços do Excel e como trabalhar com dados no navegador

Recursos de business intelligence nos Serviços do Excel

Trabalhando com dados externos nos Serviços do Excel

Atualizar dados em uma pasta de trabalho em uma janela do navegador

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×