Preparar, publicar e manter o site do Publisher

Importante    Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Depois de planejar e criar uma publicação da Web em Microsoft Office Publisher 2007, você poderá publicá-lo na Web, um servidor de rede ou uma pasta compartilhada no seu próprio computador. Qualquer que seja o destino, o Publisher criará arquivos HTML filtrados da publicação da Web. Você pode abrir e ler esses arquivos HTML em qualquer navegador da Web, como o Windows Internet Explorer.

Publicação da Web com barra de navegação, texto e elementos gráficos

Neste artigo

Este artigo aborda os procedimentos para criar e publicar sua publicação da Web como arquivos HTML e atualizar seu site editando a publicação da Web e publicando-o novamente.

Preparar o seu site da Web

Publicar seu site da Web

Manter seu site da Web

Preparar o seu site da Web

Seu site é uma extensão de você, sua empresa e sua marca comercial. Antes de criar seu site da Web, planeje-a. Para obter ajuda sobre como fazer isso, consulte o artigo planejar seu site da Web.

Qual é a melhor ferramenta?

Ao planejar seu site e as informações que ele fornecerá, considere qual ferramenta de criação é ideal para suas necessidades. Office Publisher 2007 é uma ferramenta excelente para usar quando você deseja criar, publicar e gerenciar sites da Web simples e estáticos que coincide com a marca comercial e que exigem revisões de somente texto e elementos gráficos rapidamente. Office Publisher 2007 não é a ferramenta apropriada nos seguintes casos:

  • Se seu site da Web precisa de interatividade ou conteúdo orientado pelo banco de dados, para que os visitantes possam responder em uma Web log (blog) ou comprar itens em um carrinho de compras

  • Se o site requerer validação de dados, por exemplo, para verificação de crédito números de cartão

  • Se você pretende posteriormente alterar o código HTML bruto em um editor de HTML após criar seu site no Office Publisher 2007, que combina o código HTML, XML e VML para produzir sites da Web

Para hospedagem de Web básico e criação de site on-line, Microsoft® Office Live pode ser a ferramenta certa para você. Para obter informações, vá para o site Microsoft® Office Live .

Para sites interativos, o Microsoft Expression Web fornece ferramentas para a produção sites da Web de dados rich, baseada em padrões. Para obter informações, vá para o site do Microsoft Expression Web .

Crie seu site

Você pode criar uma nova publicação da Web em Office Publisher 2007. Se você deseja trabalhar em um site existente para as quais não há nenhuma publicação da Web, você pode copiar e colar conteúdo de páginas da Web publicadas em uma nova publicação da Web, que o recria o site como uma publicação da Web, ou você pode usar uma ferramenta de edição de HTML.

  1. No menu Arquivo, clique em Novo.

  2. Na lista de Tipos de publicação, clique em Sites.

  3. Siga um destes procedimentos:

    • Para criar um site personalizado com base nas metas do seu site, certifique-se de que o Assistente da Web fácil de usar, no painel de tarefas Opções está selecionada e, em seguida, clique no design desejado.

    • Para criar um site da Web a partir do zero, em Sites da Web, clique em Tamanhos em branco e, em seguida, clique no tamanho que desejar.

  4. Clique em Criar.

  5. Se você optar por usar o Assistente de Web simples, selecione as opções desejadas na caixa de diálogo Criação rápida de sites da Web e, em seguida, clique em OK.

  6. Adicionar conteúdo à sua publicação e faça as alterações que desejar.

    Dica   Evite colocar objetos em páginas mestras em sua publicação da Web. Objetos que são colocados em páginas-mestre Office Publisher 2007 não são exibidos corretamente quando elas são vistas em alguns navegadores da Web.

Verifique sua publicação da Web

Antes de publicar seu site da Web, certifique-se de que o site funcione conforme o esperado e você resolveu todos os possíveis problemas que possam surgir.

Você pode procurar por problemas usando o verificador de Design e visualizar seu site.

Use o verificador de Design para encontrar e corrigir problemas

O verificador de Design é uma ferramenta poderosa para localizar problemas potenciais. Muitas de suas verificações são para problemas básicos de formatação. No entanto, alguns testes são específicos para problemas que podem afetar as publicações da Web. Para executar o verificador de Design, faça o seguinte:

  1. No menu Ferramentas, clique em Verificador de Design.

  2. No painel de tarefas Verificador de Design, marque as caixas de seleção Executar verificações gerais de design e Executar verificações no site.

    Observação   Certifique-se de que a caixa de seleção Executar verificações em impressão comercial não está selecionada.

  3. No painel de tarefas Verificador de Design, em Selecione um item para corrigir, clique na seta ao lado do item que você deseja corrigir e siga um destes procedimentos:

    • Clique em correção automática para corrigir automaticamente o problema com o item.

      A correção automática variará, dependendo do problema. Na maioria dos casos, a correção automática não estará disponível.

    • Clique em Ir para este Item para ir para a página onde se encontra o item com problema selecionado.

      Em seguida, você pode corrigir o problema fazendo as alterações necessárias.

    • Clique em Explicar para abrir um tópico de Ajuda que explica o problema com mais detalhes e oferece sugestões de como corrigi-lo.

    • Clique em Nunca executar esta verificação novamente para desativar a verificação.

      Clicar nesta opção afetará todas as instâncias do problema.

Visualizar seu site da Web

  • No menu Arquivo, clique em Visualizar Página da Web.

O site será visualizado no navegador padrão. Verifique a visualização para o seguinte:

  • O site é aberto e todas as páginas estão acessíveis.

  • Todos os hiperlinks funcionam conforme o esperado.

  • Controles de navegação funcionam conforme o esperado.

  • Nenhum elemento está ausente.

  • Os sons de fundo reproduzidos conforme o esperado.

Localizar uma serviço de hospedagem na Web

Antes de publicar seu site na Web, você precisa se inscrever em uma serviço que é fornecido por um provedor de serviços de Internet (ISP) de hospedagem na Web. Esse serviço fornece acesso à Internet, o espaço de armazenamento em um servidor Web e um localizador de recursos uniforme (URL) para que as pessoas possam acessar seu site da Web. Antes de publicar seu site da Web, entre em contato com seu ISP ou administrador do sistema para obter as informações que você precisa e a URL do site ou o endereço do site FTP onde você pode salvar arquivos.

Alguns ISPs estão provavelmente disponíveis na sua área. Certifique-se de que o ISP que você assinar oferece o tipo de suporte desejado. Se você tiver pouca experiência em publicação na Web, será necessário um ISP que pode ajudá-lo a resolver problemas potenciais.

Início da página

Publicar seu site da Web

Depois de verificar e visualizar sua publicação da Web e inscrever-se em uma serviço de hospedagem na Web, você está pronto para publicar seu site da Web.

Você pode publicar um site da Web para um servidor Web, um servidor de rede, um servidor de protocolo de transferência de arquivo (FTP) ou uma pasta no seu computador.

Publicando o seu site em um local no seu computador pode servir a vários propósitos:

  • Você pode usar os arquivos publicados para testar seu site antes de você disponibilizar os arquivos na Web.

  • Você pode usar um utilitário de FTP para publicar os arquivos na Web, carregando-os partir da localização do arquivo em seu computador.

  • Manter uma cópia local dos arquivos HTML, bem como a publicação da Web.

Seu ISP pode fornecer a você com informações que ajudarão você a decide o método de publicação que é melhor para você.

Se você publicar na Web ou ao seu computador, Office Publisher 2007 reúne todos os arquivos relacionados que ele cria em uma única pasta. Os arquivos que Office Publisher 2007 cria incluir as páginas HTML que constituem o site, elementos gráficos GIF e JPEG usados nas suas páginas e os arquivos para sons incorporados.

Você pode configurar Office Publisher 2007 para organizar esses arquivos na pasta onde você publica seu site da Web de duas maneiras. Por padrão, o Office Publisher 2007 cria uma única home page e uma subpasta que contém todos os arquivos de suporte que são necessários para o seu site da Web. Ou você pode organizar a home page com todos os arquivos de suporte para o seu site da Web em uma única pasta.

Como controlar onde Office Publisher 2007 organiza o site arquivos publica?

No menu Ferramentas, clique em Opções, clique na guia Web e, em seguida, siga um destes procedimentos:

  • Para separar a home page de arquivos de suporte, selecione a caixa de seleção Organizar arquivos de suporte em uma pasta.

  • Para agrupar a home page e todos os arquivos de suporte na mesma pasta, desmarque a caixa de seleção Organizar arquivos de suporte em uma pasta.

Quando você publica uma publicação na Web, Office Publisher 2007 cria arquivos HTML filtrados que se propagam para a Web mais rapidamente do que arquivos HTML não filtrados. Como o HTML filtrado arquivos que Office Publisher 2007 cria contêm sem marcas específicas do Microsoft Office, você não pode abrir os arquivos HTML no Office Publisher 2007 e editá-los. Você deve fazer alterações em seu site na publicação da Web e, em seguida, republicar o site na Web.

Publicar um site da Web em um local na Internet ou em uma rede

Antes de seguir este procedimento, contate seu ISP ou administrador do sistema para obter as informações necessárias para publicar e a URL do site da Web onde você possa salvar arquivos.

  1. No menu Arquivo, clique em Publicar na Web.

  2. Na caixa de diálogo Publicar na Web, na caixa nome do arquivo, digite a URL do servidor de rede ou da Web onde você deseja salvar seu site da Web. Por exemplo, digite http://www.northwindtraders.com.

  3. Clique em Salvar.

  4. Se solicitado, digite seu nome de usuário e sua senha e clique em OK.

    O diretório associado ao URL aparecerá na caixa de diálogo Publicar na Web.

  5. Clique duas vezes na pasta em que deseja salvar o site.

  6. Na caixa Nome do arquivo, selecione index como nome padrão para sua home page e, em seguida, clique em Salvar.

    Observação   Index.htm é a seleção padrão. Selecionar index como o nome da sua home page facilita o acesso e impede que os usuários vejam uma lista dos arquivos que compõem o seu site.

  7. Quando solicitado, clique em OK.

Publicar um site da Web usando FTP

Antes de seguir este procedimento, contate o administrador do sistema ou o provedor para obter as informações necessárias para publicar em um site FTP. Você também precisa criar um site FTP em Locais FTP.

Como?

Antes de adicionar um site FTP à lista de Locais FTP, você deve ter acesso à Internet ou a intranet.

No Windows Vista

  1. No menu Arquivo, clique em Publicar na Web.

  2. Na caixa de diálogo Publicar na Web, clique em Ferramentas e, em seguida, clique em Mapear unidade de rede.

  3. Na caixa de diálogo Mapear unidade de rede, faça o seguinte:

    • Na lista unidade, clique em uma letra de unidade. Você pode escolher qualquer letra disponível.

    • Para se conectar sempre que você efetuar logon no seu computador, marque a caixa de seleção Reconectar no logon.

    • Clique em conectar-se a um site da Web que você pode usar para armazenar documentos e imagens.

  4. No Assistente para adicionar local de rede, clique em Avançar, clique em Escolher um local de rede personalizado e, em seguida, clique em Avançar.

  5. Na caixa de endereço Internet ou rede, digite o endereço do site FTP (por exemplo, tipo ftp://ftp.microsoft.com) e, em seguida, clique em Avançar.

    Observação   Se você não pode se conectar a uma pasta ou unidade de rede, o computador pode estar desligado ou talvez você não tenha as permissões corretas. Se você não conseguir conectar, entre em contato com seu administrador de rede ou ISP.

  6. Se você não deseja fazer logon anônimo, desmarque a caixa de seleção fazer logon anônimo, digite um nome de usuário na caixa nome de usuário e, em seguida, clique em Avançar.

  7. Digite um nome para esse local de rede e, em seguida, clique em Avançar.

  8. Clique em Concluir.

No Microsoft Windows XP

  1. No menu Arquivo, clique em Publicar na Web.

  2. Na lista Salvar em, clique na seta e, em seguida, clique em Locais FTP.

  3. Clique duas vezes em Adicionar/Modificar Locais FTP.

  4. Na caixa nome do site FTP, digite o nome do site FTP. Por exemplo, digite ftp.microsoft.com.

  5. Siga um destes procedimentos:

    • Se você desejar fazer logon em um site FTP que permita logon anônimo, em fazer logon como, clique em anônimo.

    • Se você desejar efetuar logon em um site FTP que você tenha permissões de usuário, em fazer logon como, clique em usuário e digite sua senha na caixa senha.

  6. Clique em Adicionar.

  7. Clique em OK.

  1. No menu Arquivo, clique em Publicar na Web.

  2. Na lista Salvar em, clique em Locais FTP.

  3. Na lista de sites FTP, clique duas vezes no site que você deseja e, em seguida, clique duas vezes na pasta onde você deseja publicar seu site da Web.

    Observação   Se seu ISP requer que você use um programa específico para carregar o site ou se você estiver publicando o seu site da Web em uma intranet corporativa, talvez seja necessário salvar uma versão de seu site da Web em um formato de arquivo específico HTML e seguir um procedimento diferente para publicar seu site da Web. Pergunte ao seu ISP ou o administrador do sistema para obter informações sobre como salvar e publicar seu site da Web.

Publicar um site da Web em uma pasta no seu computador

No Windows Vista

  1. No menu Arquivo, clique em Publicar na Web.

  2. Na barra de endereços, clique na unidade ou pasta onde você deseja publicar seu site da Web, como a pasta documentos.

    Observação   Se quiser adicionar o site a uma nova pasta, clique em Nova Pasta na barra de ferramentas para criar uma nova pasta, digite um nome para a nova pasta e pressione ENTER.

  3. Na caixa Nome do arquivo, selecione index como nome padrão para sua home page e, em seguida, clique em Salvar.

    Observação   Index.htm é a seleção padrão. Selecionar index como o nome da sua home page facilita o acesso e impede que os usuários vejam uma lista dos arquivos que compõem o seu site.

No Windows XP

  1. No menu Arquivo, clique em Publicar na Web.

  2. Na lista Salvar em, clique na unidade ou pasta onde você deseja publicar seu site da Web, como a pasta Meus documentos.

    Observação   Se quiser adicionar o site a uma nova pasta, clique com o botão direito no local em que deseja adicionar essa pasta, selecione Novo, clique em Pasta para criar uma nova pasta, digite um nome para ela na caixa Nome e clique em Abrir.

  3. Na caixa Nome do arquivo, selecione index como nome padrão para sua home page e, em seguida, clique em Salvar.

    Observação   Index.htm é a seleção padrão. Selecionar index como o nome da sua home page facilita o acesso e impede que os usuários vejam uma lista dos arquivos que compõem o seu site.

Início da página

Manter seu site da Web

Depois de publicar seu site da Web, você pode atualizá-la conforme necessário para refletir as novas informações. No entanto, você não pode abrir os arquivos HTML filtrados no Publisher. Abra a publicação da Web original, fazer as alterações que você deseja e, em seguida, republique seu site na Web.

Observação   Você não deve tentar atualizar os arquivos HTML filtrados usando um editor de texto, como o Microsoft Notepad ou Microsoft WordPad. Embora seja possível fazê-lo, HTML gerado pelo Publisher é muito complexo e você provavelmente achará difícil editá-lo manualmente. Para obter melhores resultados, sempre atualize o site do Publisher usando a publicação da Web e publique-o na Web.

Publicar somente o que mudou

No Office Publisher 2007, você pode publicar atualizações em um site publicado anteriormente rapidamente usando incremental publicar na Web, que publica somente as páginas que você atualizou. Se você planeja atualizar seu site da Web com freqüência ou se seu site for grande e complexa, incremental publicar na Web pode acelerar a tarefa de atualizar seu site.

Se você fizer alterações no site diretamente em um servidor Web fora de Office Publisher 2007, no entanto, ativando incremental publicar na Web pode impedir a publicação subseqüente de atualizações para o seu site da Web usando o comando Publicar na Web. Se você planeja gerenciar os arquivos do site diretamente no servidor Web (como um programa separado FTP ), deve ser desativada incremental publicar na Web.

Observação   Publicação incremental na Web é ativada por padrão no Publisher.

Ativar incremental publicar na Web ou desativar

  1. No menu Ferramentas, clique em Opções e, em seguida, clique na guia Web.

  2. Em Salvar, siga um destes procedimentos:

    • Para desativar incremental publicar na Web, desmarque a caixa de seleção Permitir publicação incremental na Web.

    • Para ativar o incremental publicar na Web, marque a caixa de seleção Permitir publicação incremental na Web.

Publicar alterações ao seu site

Publicar atualizações feitas em um site da Web é um pouco diferente de publicar um site pela primeira vez. Depois que você publicar um site da Web em um local na Web ou em uma rede, será exibido um atalho para o servidor Web ou servidor de rede em Meus locais de rede.

No Windows Vista

  1. No menu Arquivo, clique em Publicar na Web.

  2. Na caixa de diálogo Publicar na Web, no painel de navegação, clique em computador.

  3. Na lista de arquivos, clique duas vezes no atalho para a pasta no servidor Web ou servidor de rede onde você publicou o site.

  4. Clique duas vezes na pasta onde deseja salvar o arquivo.

  5. Na caixa nome do arquivo, digite o nome do arquivo que você está atualizando e, em seguida, clique em Salvar.

No Windows XP

  1. No menu Arquivo, clique em Publicar na Web.

  2. Na caixa de diálogo Publicar na Web, clique em Meus locais de rede.

  3. Clique duas vezes no atalho para a pasta no servidor Web ou servidor de rede onde você publicou o site.

  4. Clique duas vezes na pasta onde deseja salvar o arquivo.

  5. Na caixa nome do arquivo, digite o nome do arquivo que você está atualizando e, em seguida, clique em Salvar.

Início da página

Observação   Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Aplicável a: Publisher 2007



Essas informações foram úteis?

Sim Não

Como podemos melhorá-lo?

255 caracteres restantes

Para proteger sua privacidade, não inclua informações de contato em seus comentários. Avalie nosso política de privacidade.

Obrigado por seus comentários!

Alterar idioma