Ponto de Partida do Access 2007

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Existem várias maneiras para se começar a usar o Microsoft Office Access 2007, dependendo se você está usando o Access pela primeira vez, movendo os dados de um outro banco de dados ou programa de planilha para o Access ou atualizando, a partir de uma versão anterior do Access. Este artigo apresenta questões que normalmente surgem em cada uma dessas situações.

O que deseja fazer?

Começar a usar o Access pela primeira vez

Importar dados de uma planilha ou em outro programa

Usar um banco de dados de versão anterior em várias versões do Access

Começar a usar o Access pela primeira vez

O Office Access 2007 apresenta diversas melhorias que facilitam ainda mais o processo de criação de um banco de dados. Os usuários que já criaram bancos de dados no Access vão gostar do modo como esses recursos novos e aprimorados agilizam o processo de criação.

Ao iniciar o Office Access 2007, a primeira tela que aparece é a página Introdução ao Microsoft Office Access (a menos que você tenha iniciado o Access clicando duas vezes em um arquivo específico de banco de dados do Access; nesse caso, o banco de dados é aberto diretamente). A página Introdução ao Microsoft Office Access é o ponto de partida para se criar um novo banco de dados, abrir um banco de dados existente ou visualizar o conteúdo do Microsoft Office Online.

Criar um banco de dados usando um modelo

Baixar um modelo do Microsoft Office Online

Criar um banco de dados do zero

Criar um banco de dados em branco

Adicionar uma tabela

Colar dados de outra fonte em uma tabela do Access

Importar dados de outra fonte

Abrir um banco de dados existente

Access 2010 tem ferramentas poderosas que tornam mais fácil acompanhar, relatar e compartilhar seus dados.

Criar um banco de dados usando um modelo

O Access oferece vários modelos que podem ser usados para agilizar o processo de criação do banco de dados. Um modelo é um banco de dados pronto para uso que contém tabelas, consultas, formulários e relatórios necessários para a execução de uma tarefa específica. Por exemplo, existem modelos que podem ser usados para acompanhar problemas, gerenciar contatos ou manter registros de despesas. Alguns modelos contêm registros de exemplo para ajudar a demonstrar seu uso. Os modelos de bancos de dados podem ser utilizados no estado em que se encontram ou podem ser personalizados para atender melhor às suas necessidades.

  1. Inicie o Access, se ele ainda não estiver sendo executado.

    Se um banco de dados já estiver aberto, faça o seguinte para exibir a página Introdução ao Microsoft Office Access:

    • Clique o Botão Microsoft Office Imagem do botão Office e clique em Fechar banco de dados. Imagem do botão

      Página Introdução ao Microsoft Office Access

  2. Vários modelos são exibidos em Destaque modelos Online na página Introdução ao Microsoft Office Access e mais estarão disponíveis se você clicar em uma das categorias em Categorias de modelo no lado esquerdo da Janela do Access. Ainda mais podem ser baixado do site do Microsoft Office (consulte a próxima seção, baixar um modelo do Microsoft Office Online, para obter detalhes).

  3. Clique no modelo que você deseja usar.

  4. No painel à direita da janela do Access, o Access sugere um nome de arquivo para o banco de dados na caixa Nome do arquivo. É possível editar o nome do arquivo e especificar outra pasta. Como opção, você pode criar o banco de dados e vinculá-lo a um site do Windows SharePoint Services 3.0.

  5. Clique em Criar (ou em Download para obter um Modelo do Office Online).

    O Access cria e, em seguida, abre o banco de dados. Um formulário é exibido, no qual você pode começar a inserir dados.

    Se o modelo contiver dados de exemplo, faça o seguinte para excluir cada registro:

    • Clique no cabeçalho da linha do registro a excluir. (O cabeçalho da linha é a caixa ou barra logo à esquerda do registro.)

    • Na guia página inicial, no grupo registros, clique em Excluir. Imagem do botão

  6. Para começar a inserir dados, clique na primeira célula vazia do formulário e comece a digitar. Depois de inserir alguns registros, use o Painel de Navegação para ver se há outros formulários ou relatórios que poderiam ser úteis.

Baixar um modelo do Microsoft Office Online

Se você não conseguir encontrar um modelo adequado às suas necessidades, na página Introdução ao Microsoft Office Access, pode explorar no site Office Online uma seleção mais ampla.

  1. Inicie o Access, se ele ainda não estiver sendo executado.

    Se um banco de dados já estiver aberto, faça o seguinte para exibir a página Introdução ao Microsoft Office Access:

    • Clique o Botão Microsoft Office Imagem do botão Office e clique em Fechar banco de dados. Imagem do botão

  2. Junto à parte inferior da página Introdução ao Microsoft Office Access, em Mais sobre o Office Online, clique em Modelos.

    O site Office Online aparece em uma nova janela do navegador.

  3. Use as ferramentas de pesquisa do site Office Online para localizar e baixar o modelo desejado.

  4. Depois que você baixar um modelo, o novo banco de dados será armazenado em uma das pastas a seguir:

    • Windows Vista    c:\Users\user name\Documents

    • Microsoft Windows Server 2003 ou Microsoft Windows XP    c:\Documents and Settings Settings name\My documentos

      Para trabalhar com o banco de dados uma outra vez, use o Access ou o Windows Explorer para abri-lo a partir desse local.

Início da seção

Criar um banco de dados a partir do zero

Se nenhum dos modelos satisfaz suas necessidades, ou se existem dados em outro programa que você quer importar para o Access, talvez seja melhor criar um banco de dados do zero. Para a maioria dos aplicativos, geralmente esse processo envolve um destes procedimentos ou ambos:

  • Criar novas tabelas e, em seguida, inserir, colar ou importar os dados nessas tabelas.

  • Importar dados de outras fontes, criando novas tabelas durante o processo.

Para saber mais sobre como planejar e projetar um banco de dados ou sobre como criar relações, formulários, relatórios ou consultas, siga os links da seção Consulte também deste artigo.

Criar um banco de dados em branco

  1. Inicie o Access.

  2. Na página Introdução ao Microsoft Office Access, clique em Banco de Dados em Branco.

    Botão Banco de Dados em Branco

  3. No painel Banco de Dados em Branco, digite um nome de arquivo na caixa Nome do Arquivo. O Access acrescenta a extensão do arquivo se você não especificá-la. A localização padrão dos arquivos é uma das seguintes.

    • Windows Vista    c:\Users\user name\Documents

    • Microsoft Windows Server 2003 ou Microsoft Windows XP    c:\Documents and Settings Settings name\My documentos

      Para alterar o local do arquivo, clique em Procurar Imagem do botão ao lado da caixa de Nome de arquivo, procure e selecione o novo local e clique em Okey.

  4. Clique em Criar.

    O Access cria o banco de dados e abre uma tabela vazia (chamada Tabela1), no Datasheet view.

  5. O Access posiciona o cursor na primeira célula vazia na coluna Adicionar Novo Campo.

    Uma tabela nova, em branco, em um novo banco de dados

    Para adicionar dados, comece a digitar — ou pode colar dados de outra fonte, conforme descrito na seção Colar dados de outra fonte em uma tabela do Access, mais adiante neste artigo.

    Observações : 

    • A inserção de dados no modo Folha de Dados foi pensada de modo a ser muito semelhante com a inserção de dados em uma planilha do Excel. A principal restrição é que os dados devem ser inseridos em linhas e colunas contíguas, começando no canto superior esquerdo da folha de dados. Não tente formatar os dados incluindo linhas ou colunas em branco como faria em uma planilha do Excel, pois isso vai ocupar espaço da tabela. A tabela simplesmente contém os dados. Toda a apresentação visual dos dados será feita nos formulários e relatórios que você criará depois.

    • A estrutura da tabela é criada enquanto você insere os dados. Sempre que você inserir uma nova coluna na tabela, um novo campo é definido. O Access define o data type do campo de acordo com o tipo de dados inserido. Por exemplo, se houver uma coluna na qual você inseriu somente valores de data, o Access definirá o tipo de dados do campo como Data/Hora. Se mais tarde você tentar inserir um valor que não seja uma data (como um nome ou número de telefone) nesse campo, o Access exibirá uma mensagem informando que o valor não corresponde ao tipo de dados da coluna. Se possível, planeje a tabela para que cada coluna contenha o mesmo tipo de dados, seja texto, datas, números ou qualquer outro. Isso facilita muito a construção de consultas, formulários e relatórios que selecionam apenas os dados desejados.

    • Para obter mais informações sobre como trabalhar com folhas de dados, consulte o artigo Abrir uma folha de dados em branco.

Se você não estiver interessado em inserindo dados no momento, clique em Fechar Imagem do botão .

Adicionar uma tabela

Você pode adicionar uma nova tabela a um banco de dados existente usando as ferramentas, no grupo Tabelas, na guia Criar.

imagem da faixa de opções do access

Clique em Tabela para criar uma tabela em branco no modo Folha de Dados. Use o modo Folha de Dados para começar a inserir os dados imediatamente e fazer com que o Access crie a estrutura de tabelas à medida que você avança, ou é possível usar o Design view para primeiro criar a estrutura de tabelas. Em seguida, retorne para o modo Folha de Dados para inserir os dados. Não importa em qual modo você vai começar, sempre poderá mudar para o outro modo usando os botões de exibição da barra de status da janela do Access.

Inserir uma tabela, começando no modo Folha de Dados    No modo Folha de Dados, você pode inserir os dados imediatamente e deixar que o Access crie a estrutura de tabelas nos bastidores. Os nomes de campos são atribuídos numericamente (Campo1, Campo2 e assim por diante), e o Access define o tipo de dados do campo, de acordo com o tipo de dados inseridos.

  1. Na guia criar, no grupo tabelas, clique em tabela. Imagem do botão

  2. O Access cria a tabela e, em seguida, posiciona o cursor na primeira célula vazia da coluna Adicionar Novo Campo.

    Observação : Se não houver uma coluna chamada Adicionar Novo Campo, talvez você esteja no modo Design em vez de Folha de Dados. Para mudar para o modo Folha de Dados, clique duas vezes na tabela no Painel de Navegação. O Access pede um nome para a nova tabela e, em seguida, passa para o modo Folha de Dados.

  3. Na guia folha de dados, no grupo campos e colunas, clique em Novo campo. Imagem do botão

    O Access exibe o painel Modelos de Campo, que contém uma lista de tipos de campo usados com freqüência. Se você arrastar um desses campos para a folha de dados, o Access incluirá o campo por esse nome e definirá suas propriedades com um valor apropriado ao seu tipo. Posteriormente, é possível alterar suas propriedades. Arraste o campo para a área da folha de dados que contém dados. Uma barra de inserção vertical aparece, mostrando onde o campo será localizado.

  4. Para adicionar dados, comece a digitar na primeira célula vazia  — ou cole dados de outra fonte, como descrito mais adiante neste artigo.

    • Para renomear uma coluna (campo), clique duas vezes no título da coluna e digite o novo nome. É aconselhável dar um nome representativo para cada campo, assim você saberá o que cada um contém quando vê-los no painel Lista de Campos.

    • Para mover uma coluna, selecione-a clicando em seu título e, em seguida, arraste-a para onde quiser. Também é possível selecionar várias colunas contíguas e arrastá-las para um novo local de uma vez.

Inserir uma tabela, começando no modo Design    No modo Design, primeiro crie a estrutura da nova tabela. Em seguida, mude para o modo Folha de Dados para inserir dados ou insira os dados usando algum outro método, como colar ou anexar.

  1. Na guia Criar, no grupo Tabelas, clique em Design da Tabela. Imagem do botão

  2. Para cada campo na tabela, digite um nome na coluna Nome do Campo e, em seguida, selecione um tipo de dados na lista Tipo de Dados.

    Observação : Se você não encontrar as colunas Nome do Campo e Tipo de Dados, talvez você esteja no modo Folha de Dados em vez de Design. Para mudar para o modo Design, clique no botão modo Design na barra de status da janela do Access. O Access pede um nome para a nova tabela e, em seguida, passa para o modo Design.

  3. Se quiser, você pode inserir uma descrição para cada campo na coluna Descrição. A descrição inserida será exibida na barra de status quando o ponto de inserção estiver no campo e é utilizada como texto da barra de status para qualquer controle que você criar arrastando o campo do painel Lista de Campos para um formulário ou relatório e para qualquer controle criado para esse campo, pelo Assistente de Formulário ou Assistente de Relatório.

  4. Depois de incluir todos os campos, salve a tabela.

    • Clique o Botão Microsoft Office Imagem do botão Office e, em seguida, clique em Salvar ou pressione CTRL + S.

  5. Você pode começar a inserir dados na tabela a qualquer momento, basta mudar para o modo Folha de Dados, clicar na primeira célula vazia e digitar. Também pode colar dados de outra fonte, como descrito na próxima seção.

Se, depois de inserir alguns dados, você quiser incluir um ou mais campos na tabela, pode começar a digitar na coluna Adicionar Novo Campo, no modo Folha de Dados, ou adicionar novos campos usando os comandos, no grupo Campos e Colunas, da guia Folha de Dados.

Para obter mais informações sobre a criação de tabelas, incluindo o uso de modelos de tabela, consulte o artigo criar tabelas em um banco de dados.

Início da seção

Colar dados de outra fonte em uma tabela do Access

Se os dados estiverem armazenados em outro programa, como no Office Excel 2007, você pode copiar e colá-los em uma tabela do Access. Em geral, isso funciona melhor se eles já estiverem separados em colunas, como em uma planilha do Excel. Se os dados estiverem em um processador de texto, é melhor separar as colunas de dados usando guias ou convertê-los em tabela no processador de texto antes de copiar os dados. Se for necessário editar ou manipular os dados (por exemplo, separando nomes completos em nome e sobrenome), convém fazer isso antes de copiar os dados, particularmente se você não estiver acostumado com o Access.

Quando você cola os dados em uma tabela vazia, o Access define o tipo de dados de cada campo de acordo com o dados encontrados nele. Por exemplo, se um campo colado não tiver nada além de valores de data, o Access aplica o tipo de dados Data/Hora a esse campo. Se o campo colado tiver apenas as palavras "sim" e "não", o Access aplica o tipo de dados Sim/Não a esse campo.

O Access nomeia os campos de acordo com o que ele encontra na primeira linha de dados colados. Se ela for semelhante em tipo às linhas seguintes, o Access determina que a primeira linha seja parte dos dados e atribui aos campos nomes genéricos (F1, F2 e assim por diante). Se a primeira linha de dados colados não for semelhante às linhas seguintes, o Access determina que ela consista de nomes de campos. O Access nomeia os campos de acordo e não inclui a primeira linha nos dados.

Se o Access atribuir nomes de campo genéricos, você deverá renomear os campos o mais rápido possível para evitar confusão. Use o seguinte procedimento:

  1. Salve a tabela.

    • Clique o Botão Microsoft Office Imagem do botão Office e, em seguida, clique em Salvar ou pressione CTRL + S.

  2. No modo Folha de Dados, clique duas vezes no título de cada coluna e então digite um nome de campo válido para cada coluna. Pode parecer que você está sobrescrevendo os dados, mas a linha do cabeçalho da coluna contém nomes de campo, não dados.

  3. Salve a tabela novamente.

Observação : Também é possível renomear os campos alternando para o modo Design e editando os nomes de campo lá. Para alternar para o modo Design, clique com o botão direito do mouse na tabela no Painel de Navegação e clique em Modo Design. Para voltar para o modo Folha de Dados, clique duas vezes na tabela no Painel de Navegação.

Início da seção

Importar dados de outra fonte

Talvez haja dados que foram coletados em outro programa e que você deseja importar para o Access. Ou talvez você trabalhe com pessoas que armazenam seus dados em outros programas e lhe convém trabalhar com esses dados no Access. Seja qual for o caso, o Access facilita a importação de dados de outros programas. Você pode importar dados de uma planilha do Excel, de uma tabela de outro banco de dados Access, de uma lista do SharePoint ou de qualquer outra das diversas fontes existentes. O processo é um pouco diferente dependendo da fonte, mas estas instruções ajudarão você a dar o primeiro passo:

  1. Na guia Dados Externos, no grupo Importar, clique no comando para o tipo de arquivo que você está importando.

    imagem da faixa de opções do access

    Por exemplo, se você estiver importando dados de uma tabela do Excel, clique em Excel. Caso não veja o tipo de programa correto, clique em Mais.

    Observação : Se não conseguir localizar o tipo de formato correto, no grupo Importar, talvez seja necessário iniciar o programa no qual os dados foram originalmente criados e, em seguida, usar esse programa para salvar os dados em um formato de arquivo comum (como um delimited text file), antes de poder importar os dados para o Access.

  2. Na caixa de diálogo Obter Dados Externos, clique em Procurar para localizar o arquivo de origem dos dados ou digite o caminho completo que leva a ele na caixa Nome do arquivo.

  3. Clique na opção desejada em Especificar como e onde você deseja armazenar os dados no banco de dados atual. Você pode criar uma nova tabela usando os dados importados, anexá-los a uma tabela existente ou criar uma tabela vinculada que mantém um vínculo com a fonte dos dados.

  4. Clique em OK.

    O Access inicia o Assistente para Importação.

  5. Siga as instruções do Assistente para Importação. O procedimento exato a seguir depende da opção de importação ou vinculação escolhida.

  6. Na última página do assistente, clique em Concluir.

    O Access pergunta se você deseja salvar os detalhes da operação de importação que você acabou de concluir.

    • Se você acha que realizará novamente a mesma operação de importação, clique em Salvar etapas de importação e informe os detalhes.

      Em seguida, você pode reproduzir facilmente a operação de importação clicando em Importações Salvas, no grupo Importar, na guia Dados Externos, clicando na especificação de importação e clicando em Executar.

    • Se não quiser salvar os detalhes da operação, clique em Fechar.

O Access importa os dados para a nova tabela e, em seguida, exibe a tabela em Tabelas no Painel de Navegação.

Para saber mais sobre como importar dados para o Access, siga os links da seção Consulte Também deste artigo.

Início da seção

Abrir um banco de dados do Access já existente

  1. Clique no Botão do Microsoft Office Imagem do botão Office e clique em Abrir.

  2. Clique em um atalho da caixa de diálogo Abrir — ou, na caixa Examinar, clique na unidade ou na pasta que contém o banco de dados desejado.

  3. Na lista de pastas, clique duas vezes nas pastas até abrir aquela que contém o banco de dados.

  4. Ao localizar o banco de dados, execute um destes procedimentos:

    • Para abrir o banco de dados no modo de abertura padrão, clique nele duas vezes.

    • Para abrir o banco de dados para acesso compartilhado em um ambiente multiusuário, de modo que você e outros usuários possam ler e gravar no banco de dados ao mesmo tempo, clique em Abrir.

    • Para abrir o banco de dados com acesso somente para leitura, de modo que você possa visualizá-lo mas não editá-lo, clique na seta ao lado do botão Abrir e clique em Abrir como Somente Leitura.

    • Para abrir o banco de dados com acesso exclusivo, assim mais ninguém poderá abri-lo enquanto você estiver com ele aberto, clique na seta ao lado do botão Abrir e clique em Abrir Exclusivo.

    • Para abrir o banco de dados para acesso somente leitura, clique na seta ao lado do botão Abrir e clique em Abrir Exclusivo como Somente Leitura Outros usuários ainda podem abrir o banco de dados, mas eles possuem apenas acesso somente leitura.

Se não conseguir localizar o banco de dados que deseja abrir   

  1. Na caixa de diálogo Abrir, clique no atalho Meu Computador — ou, na caixa Examinar, clique em Meu Computador.

  2. Na lista de unidades, clique com o botão direito do mouse na unidade onde você acredita que o banco de dados está e, em seguida, clique em Pesquisar.

  3. Insira o critério de pesquisa e pressione ENTER para localizar o banco de dados.

  4. Se ele for encontrado, abra-o clicando duas vezes nele na caixa de diálogo Resultados da Pesquisa.

  5. Como a pesquisa foi iniciada na caixa de diálogo Abrir, clique em Cancelar nessa caixa de diálogo para que o banco de dados seja aberto.

Observação : Você pode abrir diretamente um arquivo de dados em um formato de arquivo externo (como dBASE, Paradox, Microsoft Exchange, ou Excel). Você também pode abrir diretamente qualquer ODBC data source, como Microsoft SQL Server ou Microsoft FoxPro. O Access cria automaticamente um novo banco de dados do Access, na mesma pasta do arquivo de dados, e adiciona links a cada tabela no banco de dados externo.

Dicas

  • Para abrir um dos últimos bancos de dados que você tinha aberta, clique no nome de arquivo na lista Abrir bancos de dados recentes na página Introdução ao Microsoft Office Access. O Access abre o banco de dados, aplicando as mesmas configurações de opção que o banco de dados tinha a última vez em que você a abriu. Se a lista de arquivos usados recentemente não for exibida, clique no Botão Microsoft Office Imagem do botão Office e clique em Opções do Access. Caixa de diálogo Opções do Access é exibida. Clique na categoria Avançado e, em seguida, sob a seção de exibição, marque a caixa de seleção lista de arquivos usados recentemente. (Você também pode especificar o número de arquivos usados recentemente que você gostaria de ter exibido na lista, até no máximo nove).

  • Se você estiver abrindo um banco de dados clicando o Botão Microsoft Office Imagem do botão Office e usando o comando Abrir, você pode exibir uma lista de atalhos para bancos de dados que você tenha aberto anteriormente clicando em Meus documentos recentes na Abrir caixa de diálogo.

Início da seção

Início da página

Importar dados de uma planilha ou de outro programa

Se você estiver familiarizado com outros programas de banco de dados ou planilha, você provavelmente sabe Noções básicas de como esses aplicativos funcionam e quais bancos de dados são usados para. Acesso difere muitos outros aplicativos de banco de dados, permitindo que você crie bancos de dados relacionais. O Access também fornece muitas opções para trabalhar com outros programas de banco de dados, como o SQL Server.

Nesta seção

Importar uma planilha do Excel para o Access

Importar uma planilha do Excel como uma tabela em um novo banco de dados do Office Access 2007

Usar o Assistente de análise de tabela para organizar seus dados

Trabalhar com dados de outros programas

Importar uma planilha do Excel para o Access

Muitas pessoas começam a explorar o Access depois de criar uma lista no Excel. O Excel é ótimo para se começar uma lista, mas a medida que ela cresce, fica mais difícil organizá-la e mantê-la atualizada. Transferir essa lista para o Access geralmente é o passo lógico.

Uma tabela de banco de dados tem uma estrutura similar a de uma planilha, sendo que os dados são armazenados em linhas e colunas. Como resultado, normalmente é fácil importar uma planilha para uma tabela de banco de dados. A principal diferença entre armazenar dados em uma planilha e em um banco de dados é o modo como os dados são organizados. A simples importação da planilha para uma tabela nova de banco de dados não resolverá os problemas referentes à organização e à atualização dos dados, especialmente se a planilha contiver dados em duplicidade. Para resolver esses problemas, é preciso separar os dados da planilha em tabelas distintas, cada uma com dados relacionados. Para obter mais informações sobre como organizar os dados em suas tabelas, consulte o artigo Noções básicas sobre o design de bancos de dados.

O Access oferece o Assistente de Análise de Tabela, que pode ajudar você a concluir esse processo. Depois de importar os dados para uma tabela, o assistente ajuda você a dividi-la em tabelas separadas, sendo que os dados contidos em cada uma não estão duplicados em nenhuma outra. O assistente também cria as relações necessárias entre as tabelas.

Importar uma planilha do Excel como uma tabela de um novoOffice Access 2007 banco de dados

  1. Clique no Botão do Microsoft Office Imagem do botão Office e clique em Novo.

  2. Digite um nome para o novo banco de dados na caixa Nome do Arquivo e, em seguida, clique em Criar.

  3. Feche a Tabela1.

    Quando perguntado se você deseja salvar as alterações feitas no design da Tabela1, clique em Não.

  4. Na guia Dados externos, no grupo Importar, clique em Excel. Imagem do botão

  5. Na caixa de diálogo Obter Dados Externos clique em Procurar.

  6. Use a caixa de diálogo Abrir Arquivo para localizar o arquivo.

  7. Selecione o arquivo e clique em Abrir.

  8. Na caixa de diálogo Obter Dados Externos, confirme se a opção Importar os dados de origem para uma nova tabela do banco de dados atual está selecionada.

  9. Clique em OK.

    O Assistente de Importação de Planilha é iniciado e faz algumas perguntas sobre os dados.

  10. Siga as instruções, clicando em Avançar ou Voltar para navegar pelas páginas. Na última página do assistente, clique em Concluir.

    Observação : O Access pergunta se você deseja salvar os detalhes da operação de importação que você acabou de concluir. Se você acha que realizará novamente a mesma operação de importação, clique em Sim e informe os detalhes. Assim você poderá reproduzir rapidamente a operação no futuro, clicando em Importações Salvas, no grupo Importar da guia Dados Externos. Se você não quiser salvar os detalhes da operação, clique em Fechar.

O Access importa os dados para a nova tabela e, em seguida, ela é exibida em Todas as Tabelas no Painel de Navegação.

Usar o Assistente de Análise de Tabela para organizar os dados

Depois de importar os dados para uma tabela do Access, use o Assistente de Análise de Tabela para identificar rapidamente dados repetidos. O assistente é uma maneira simples de organizar dados repetidos em tabelas separadas, assim o armazenamento dos dados é mais eficiente. O Access preserva a tabela original como backup e, em seguida, cria tabelas novas que você pode usar de base com o aplicativo de banco de dados.

  1. Abra o banco de dados do Access que contém a tabela a analisar.

  2. Na guia Ferramentas de Bancos de Dados, no grupo Análise, clique em Analisar Tabela.

    O Assistente de Análise de Tabela é iniciado.

    Se o conceito de normalização for novidade para você, o assistente possui duas páginas introdutórias com um breve tutorial  — que é completado com botões nos quais você pode clicar para ver exemplos. Se as páginas introdutórias não aparecerem e você vir apenas a caixa de seleção Mostrar páginas de introdução?, marque essa caixa e clique Voltar duas vezes para ver a introdução. Para não ver mais as páginas introdutórias novamente depois de ler a introdução, desmarque a caixa de seleção.

  3. Na página que começa com Que tabela contém campos com valores que são repetidos em diversos registros?, selecione a tabela a analisar e clique em Avançar.

  4. Você pode deixar o assistente decidir quais campos devem ir para qual tabela ou fazer suas próprias escolhas. Mesmo seguindo as sugestões do assistente, você ainda poderá alterar o layout da tabela na página seguinte do assistente.

    Observação : Se você deixar o assistente decidir quais campos colocar em qual tabela, as escolhas dele nem sempre são apropriadas para os seu dados, especialmente se não houver muitos dados com que trabalhar. Verifique atentamente o resultado apresentado pelo assistente. Por outro lado, o assistente pode sugerir uma organização mais eficaz que a sua, então é uma boa idéia testar as decisões do assistente pelo menos uma vez. Se você não gostar das sugestões, pode reorganizar os campos manualmente e sempre pode clicar em Voltar e organizar todos os campos por conta própria.

  5. Clique em Avançar. Nessa página, especifique quais tabelas devem conter quais campos. Se você deixou o assistente decidir, verá várias tabelas conectadas por linhas de relação. Caso contrário, o Access cria apenas uma tabela com todos os campos. Em qualquer situação, é possível fazer alterações nessa página.

    • Você pode arrastar campos de uma tabela para uma área vazia da página para criar uma nova tabela com esses campos. O Access pedirá um nome para a tabela.

    • Pode também arrastar campos de uma tabela para outra se achar que este é o armazenamento mais adequado.

    • A maioria das tabelas terá um campo ID ou Código Exclusivo Gerado. Para saber mais sobre campos de identificação, clique em Dicas no canto direito superior do assistente.

    • Para desfazer uma alteração, clique no botão Desfazer.

    • Para renomear uma tabela, clique duas vezes na barra de título, digite o nome novo e clique em OK.

  6. Depois de organizar os campos conforme desejado, clique em Avançar.

  7. Se o assistente encontrar registros com valores muito semelhantes, identificará esses valores como possíveis erros tipográficos e apresentará uma tela onde você poderá confirmar o que fazer com eles. Role a lista para localizar esses valores na coluna Correção e, em seguida, clique no item apropriado da lista suspensa. Selecione (Deixar como está) para impedir que o assistente faça qualquer alteração no valor. Quando acabar, clique em Avançar.

  8. O assistente pergunta se você deseja criar uma consulta semelhante à tabela original. Se você já criou formulários e relatórios com base na tabela original, criar essa consulta é uma boa ideia. Se você escolher Sim, crie a consulta, o assistente renomeará a tabela original acrescentando "_OLD" ao nome dela e depois dará o nome da tabela original à nova consulta. Os formulários e relatórios que se baseavam na tabela agora usarão a consulta para acessar os dados e continuarão funcionando como antes.

  9. Clique em Concluir.

    O assistente cria novas tabelas conforme especificado e as abre. Feche-as quando terminar de analisar o resultado.

Início da seção

Trabalhar com dados de outros programas

O Office Access 2007 oferece recursos para se trabalhar com dados que estão armazenados em outros programas.

  • Criar um novo banco de dados Access que vincula os dados em outro formato de arquivo    Você pode usar o Access para abrir um arquivo em outro formato de arquivo, como texto, dBASE ou uma planilha. O Access cria automaticamente um banco de dados do Access e vincula o arquivo para você.

    1. Inicie o Access.

    2. Clique no Botão do Microsoft Office Imagem do botão Office e clique em Abrir.

    3. Na caixa de diálogo Abrir, clique no tipo de arquivo que deseja abrir na lista. Se você não tiver certeza sobre o tipo de arquivo, clique em Todos os Arquivos (*.*).

    4. Se necessário, procure a pasta que contém o arquivo desejado. Encontrando o arquivo, clique duas vezes nele para abri-lo.

    5. Siga as instruções do assistente. Na última página do assistente, clique em Concluir.

  • Importar ou vincular dados para um banco de dados existente do Access    É possível importar dados de outras fontes e programas para tabelas do Access para que os dados fiquem em um arquivo do Access ou vincular os dados a partir do Access, assim eles permanecem no arquivo original (fora do arquivo do Access).

    Importar ou vincular dados

    1. Na guia Dados Externos, no grupo Importar, clique no formato em que os dados serão armazenados.

      Você pode importar ou vincular dados que estão nos seguintes formatos:

      • Microsoft Office Access

      • Microsoft Office Excel

      • Microsoft Windows SharePoint Services

      • Arquivos de texto

      • Arquivos XML

      • Bancos de dados ODBC

      • Documentos HTML

      • Microsoft Office Outlook

      • dBase

      • Paradox

      • Lotus 1-2-3

        A caixa de diálogo Obter Dados Externos aparece.

    2. Siga as instruções da caixa de diálogo.

      O Access importará ou vinculará os dados ao banco de dados. Para a maioria dos formatos, especifique a localização dos dados e escolha como os dados devem ser armazenados no banco de dados.

Início da seção

Início da página

Use uma versão anterior do banco de dados em várias versões do Access

Se o banco de dados ou o projeto do Access tiver sido criado no Access 2000 ou posterior, você poderá usar o banco de dados ou o projeto na versão do Access, na qual foi criado, ou em qualquer versão posterior — mesmo se o arquivo estiver com segurança habilitada. Por exemplo, os arquivos do Access 2000 podem ser usados no Access 2000, por meio do Office Access 2007, e os arquivos do Access 2002-2003 podem ser usados no Access 2002-2003, por meio do Office Access 2007.

Você pode ter uma situação onde deseja manter os dados em uma versão anterior do Access, mas você tem usuários com uma versão posterior do Access que desejam se vincular a esses dados mas ainda utilizam alguns recursos da versão anterior. A solução é criar um novo banco de dados "front-end" na versão posterior (contendo formulários, relatórios, consultas, macros, mas não tabelas) e vinculá-lo às tabelas no arquivo da versão anterior. Use um dos procedimentos a seguir, dependendo de se o banco de dados está contido em um arquivo ou já está dividido em um front-end/back-end application.

Usar um banco de dados do Access de um arquivo em várias versões do Access

Usar um aplicativo de front-end/back-end em várias versões do Access

Usar um banco de dados Access de um arquivo em várias versões do Access

Se todas as tabelas, formulários ou outros objetos do banco de dados do Access estiverem contidos em um arquivo .mdb e você desejar usar o banco de dados em várias versões do Access, poderá criar um novo banco de dados front-end em uma versão posterior e vinculá-lo ao arquivo original. Os usuários que possuem a versão anterior do Access ainda podem usar o banco de dados original. Os usuários que possuem a versão posterior podem usar o novo banco de dados front-end para se vincular aos mesmos dados.

  1. Use o procedimento a seguir para converter o banco de dados para qualquer um dos três formatos mais recentes: Access 2000, Access 2002-2003 ou Access 2007. Esse comando preserva o banco de dados original no seu formato original e cria uma cópia no formato especificado.

    • Feche o arquivo do Access. Se o arquivo for um banco de dados multiusuário do Access, localizado em um servidor ou em uma pasta compartilhada, confirme se ninguém está com ele aberto.

    • Inicie o Access 2007.

    • Clique no Botão do Microsoft Office Imagem do botão Office e clique em Abrir.

    • Navegue até o local onde está o arquivo a ser convertido e clique duas vezes nele para abri-lo.

      Se a caixa de diálogo Aprimoramento do Banco de Dados for exibida, perguntando se você deseja aprimorar o banco de dados, clique em Não.

    • Se um formulário for aberto quando você iniciar o banco de dados, feche o formulário.

    • Clique o Botão Microsoft Office Imagem do botão Office , aponte para Salvar como e, em Salvar banco de dados em outro formato, clique no formato de arquivo ao qual você deseja converter.

    • Na caixa de diálogo Salvar Como, digite um nome para o novo banco de dados.

      Observação : A menos que você queira salvar o novo banco de dados em outro lugar, esse nome deve ser diferente do nome do banco de dados original. Em qualquer caso, geralmente o melhor é usar um outro nome, assim você distingue facilmente o banco de dados de front-end do banco de dados de back-end. No entanto, se você estiver convertendo para o formato do Access 2007, a extensão do arquivo mudará de .mdb para .accdb, portanto, é possível usar o mesmo nome de arquivo.

    • Clique em Salvar.

  2. Divida o banco de dados convertido em um aplicativo front-end/back-end usando o procedimento a seguir:

    • Na guia Ferramentas de Banco de Dados, no grupo Mover Dados, clique em Banco de Dados do Access. Imagem do botão

    • Na caixa de diálogo Divisor de Banco de Dados, clique em Dividir Banco de Dados.

    • Digite um nome para o banco de dados back-end e clique em Dividir.

  3. Exclua o banco de dados de back-end que a ferramenta Divisor de banco de dados criou  — cuidado para não excluir o banco de dados original.

  4. Vincular um novo banco de dados front-end às tabelas do banco de dados original: na guia Ferramentas de banco de dados, no grupo Ferramentas de banco de dados, clique em Gerenciador de tabelas vinculadas. Imagem do botão

  5. Clique em Selecionar Tudo e marque a caixa de seleção Sempre emitir aviso para novo local.

  6. Clique em OK, localize o banco de dados na versão mais antiga e clique duas vezes nele.

    Se tudo der certo, o Access exibirá uma mensagem informando que todas as tabelas vinculadas selecionadas foram atualizadas com sucesso.

    Agora é possível aprimorar o novo banco de dados de front-end para oferecer suporte a novos recursos para usuários que atualizaram para Access 2000, Access 2002-2003 ou Access 2007. Os usuários com versões anteriores podem continuar usando a versão antiga do banco de dados.

    Se desejar, você também pode converter o novo banco de dados front-end para ainda outra versão. Por exemplo, se o banco de dados original estivesse no formato Access 2000, você poderia criar um front-end do Access 2002-2003 para os usuários com essa versão e um front-end do Access 2007 para os usuários com essa versão. As duas versões front-end iriam se vincular aos dados no arquivo do Access 2000.

Início da seção

Usar um aplicativo de front-end/back-end em várias versões do Access

Se o banco de dados do Access já for um front-end/back-end application, basta converter o front end para o formato de arquivo do Access 2000, do Access 2002-2003 ou do Access 2007. Nenhuma alteração é necessária no banco de dados back-end.

O procedimento a seguir mostra como usar o comando Salvar Banco de Dados como para converter o banco de dados de front-end para qualquer um dos três formatos mais recentes: Access 2000, Access 2002-2003 ou Access 2007. Esse comando preserva o banco de dados original no seu formato original e cria uma cópia no formato especificado.

  1. Feche o banco de dados de front-end. Se o arquivo for um banco de dados do Access multiusuário, localizado em um servidor ou em uma pasta compartilhada, confirme se ninguém está com ele aberto.

  2. Inicie o Access 2007.

  3. Clique no Botão do Microsoft Office Imagem do botão Office e clique em Abrir.

  4. Navegue até o local onde está o banco de dados de front-end a ser convertido e clique duas vezes nele para abri-lo.

    Se a caixa de diálogo Aprimoramento do Banco de Dados for exibida, perguntando se você deseja aprimorar o banco de dados, clique em Não.

  5. Se um formulário aparecer quando você abrir o banco de dados, feche o formulário.

  6. Clique o Botão Microsoft Office Imagem do botão Office , aponte para Salvar como e, em Salvar banco de dados em outro formato, clique no formato de arquivo ao qual você deseja converter.

  7. Na caixa de diálogo Salvar Como, digite um nome para o novo banco de dados.

  8. Clique em Salvar.

Agora é possível aprimorar o novo banco de dados de front-end para oferecer suporte a novos recursos para usuários que atualizaram para Access 2000, Access 2002-2003 ou Access 2007.

Início da seção

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×