Pesquisar valores com PROCV, INDICE ou CORRESP

Para localizar um valor em uma lista grande, você pode usar uma função de pesquisa. A função PROCV é amplamente utilizada, mas a função PROCH em o uso das funções ÍNDICE e CORRESP também podem funcionar bem para você.

Aqui estão as informações do PROCV e os argumentos que ele usa:

=PROCV(<valor de pesquisa>,<intervalo de pesquisa>,<coluna>,<Correspondência aproximada>)

Por exemplo; =PROCV(21500;C2:E7;3;FALSO)

  • O primeiro argumento — uma peça necessária para o funcionamento da função — é o valor que você deseja obter. Pode haver uma referência de célula como B2 ou um valor como “smith” ou 21500.

  • O segundo argumento é o intervalo de células que provavelmente contém o valor a ser obtido.

    Importante : Com o PROCV, a coluna que contém o valor ou a célula de referência buscada precisa ser a última coluna à esquerda no intervalo.

  • O terceiro argumento é a coluna no intervalo de células da pesquisa que contém o valor que você deseja ver.

Embora o quarto argumento seja opcional, a maioria das pessoas digita FALSO (ou 0). Por quê? Porque isso força a função a localizar uma correspondência exata na pesquisa. Você pode deixar de inserir um argumento ou inserir VERDADEIRO, mas, se uma correspondência exata não for localizada, a função retornará a correspondência maisaproximada e, geralmente, a maioria das pessoas não quer uma correspondência aproximada.

Para mostrar como uma correspondência aproximada pode ser um problema sério, vamos imaginar uma situação hipotética: digamos que você esteja procurando o preço de uma peça com ID 2345768, mas troque dois números na fórmula, assim: =PROCV(2345678,A1:E7,5). A fórmula retornará o preço da peça errada, pois PROCV localiza o número mais próximo menor ou igual ao número especificado (2345678). Você pode acabar cobrando o cliente errado devido ao erro.

Se você especificar FALSO ou 0 para o argumento Correspondência Aproximada e não houver uma correspondência exata, a fórmula retornará #N/D na célula em vez do valor errado — um cenário muito melhor. Nesse caso, #N/D não significa que a fórmula digitada estava incorreta (exceto pela troca de números); isso significa que 2345678 não foi encontrado, e você queria 2345768.

Esse exemplo mostra como a função funciona. Ao inserir um valor na célula B2 (o primeiro argumento), o PROCV pesquisa as células C2:E7 (o segundo argumento) e retorna a correspondência mais aproximada encontrada na terceira coluna do intervalo, a coluna E (o terceiro argumento).

Um uso típico da função PROCV

Nesse exemplo, o quarto argumento foi deixado em branco, portanto, a função retorna uma correspondência aproximada.

Usando a função PROCH

Quando você estiver familiarizado com o PROCV, a função PROCH não deverá ser difícil de usar. São inseridos os mesmos argumentos, mas a função localiza valores em linhas, em vez de colunas.

Usando o ÍNDICE e CORRESP juntos

Quando você não quiser restringir a busca à última coluna à esquerda, você pode usar uma combinação das funções ÍNDICE e CORRESP. Uma fórmula que usa essas duas funções em conjunto é um pouco mais complexa que uma fórmula que usa a função PROCV, mas pode ser mais avançada — e há pessoas que preferem muito mais a combinação de INDÍCE/CORRESP do que a função PROCV.

Esse exemplo mostra uma pequena lista onde o valor que se deseja pesquisar, Chicago, não está na última coluna à esquerda. Portanto, não podemos usar o PROCV. Em vez disso, usaremos a função CORRESP para localizar Chicago no intervalo B1:B11. O termo está localizado na linha 4. Em seguida, o ÍNDICE usa esse valor como o argumento de pesquisa e localiza a população de Chicago na 4° coluna (coluna D). A fórmula usada é mostrada na célula A14.

Usando ÍNDICE e CORRESP para pesquisar um valor

Mais informações sobre funções de pesquisa

Início da página

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×