PROCV (Função PROCV)

Este artigo descreve a sintaxe da fórmula e o uso da funçãoPROCV no Microsoft Excel.

Descrição

Você pode usar a função PROCV para pesquisar a primeira coluna de um intervalo de células e, em seguida, retornar um valor de qualquer célula na mesma linha do intervalo. Por exemplo, suponhamos que você tenha uma lista de funcionários contida no intervalo A2:C10. Os números de identificação dos funcionários são armazenados na primeira coluna do intervalo, como mostrado na ilustração a seguir.

Um intervalo de células em uma planilha

Se souber o número de identificação do funcionário, você poderá usar a função PROCV para retornar o departamento ou o nome desse funcionário. Para obter o nome do funcionário número 38, você pode usar a fórmula =PROCV(38, A2:C10, 3, FALSO). Essa fórmula procura o valor 38 na primeira coluna do intervalo A2:C10 e, em seguida, retorna o valor contido na terceira coluna do intervalo e na mesma linha do valor procurado ("Nuno Farinha") ("Nuno Farinha").

O V em PROCV significa vertical. Use PROCV em vez de PROCH quando os valores da comparação estiverem posicionados em uma coluna à esquerda ou à direita dos dados que você deseja procurar.

Sintaxe

PROCV(valor_procurado, matriz_tabela, núm_índice_coluna, [procurar_intervalo])

A sintaxe da função PROCV tem os seguintes argumento:

  • valor_procurado    Obrigatório. O valor a ser procurado na primeira coluna da tabela ou intervalo. O argumento valor_procurado pode ser um valor ou uma referência. Se o valor que você fornecer para o argumento valor_procurado for menor do que o menor valor da primeira coluna do argumento matriz_tabela, PROCV retornará o valor de erro #N/D.

  • matriz_tabela    Obrigatório. O intervalo de células que contém os dados. Você pode usar uma referência a um intervalo (por exemplo, A2:D8) ou um nome de intervalo. Os valores na primeira coluna de matriz_tabela são os valores procurados por valor_procurado. Os valores podem ser texto, números ou valores lógicos. Textos em maiúsculas e minúsculas são equivalentes.

  • núm_índice_coluna    Obrigatório. O número da coluna no argumento matriz_tabela do qual o valor correspondente deve ser retornado. Um argumento núm_índice_coluna de 1 retorna o valor na primeira coluna em matriz_tabela; um núm_índice_coluna de 2 retorna o valor na segunda coluna em matriz_tabela e assim por diante.

    Se o argumento núm_índice_coluna for:

    • Menor que 1, PROCV retornará o valor de erro #VALOR!.

    • Maior do que o número de colunas em matriz_tabela, PROCV retornará o valor de erro #REF!.

  • procurar_intervalo    Opcional. Um valor lógico que especifica se você quer que PROCV localize uma correspondência exata ou aproximada.

    • Se procurar_intervalo for VERDADEIRO, ou for omitido, uma correspondência exata ou aproximada será retornada. Se uma correspondência exata não for localizada, o valor maior mais próximo que seja menor que o valor_procurado será retornado.

      Importante   Se procurar_intervalo for VERDADEIRO, ou for omitido, os valores na primeira coluna de matriz_tabela deverão ser colocados em ordem ascendente; caso contrário, PROCV poderá não retornar o valor correto.

      Para obter informações, consulte Classificar dados em um intervalo ou tabela.

      Se procurar_intervalo for FALSO, os valores na primeira coluna de matriz_tabela não precisarão ser ordenados.

    • Se o argumento procurar_intervalo for FALSO, PROCV encontrará somente uma correspondência exata. Se houver dois ou mais valores na primeira coluna de matriz_tabela que não coincidem com o valor_procurado, o primeiro valor encontrado será utilizado. Se nenhuma correspondência exata for localizada, o valor de erro #N/D será retornado..

Comentários

  • Ao procurar valores de texto na primeira coluna da matriz_tabela, verifique se os dados na primeira coluna da matriz_tabela não contenham espaços à esquerda ou de fim de linha, nem usem de modo inconsistente aspas normais ( ' ou " ) e curvas ( ‘ ou “ ) ou caracteres não imprimíveis. Nesses casos, a função PROCV pode retornar um valor incorreto ou inesperado.

    Para obter informações, consulte a função TIRAR e a função ARRUMAR.

  • Ao procurar valores de número ou data, certifique-se de que os dados na primeira coluna da matriz_tabela não estejam armazenados como valores de texto. Nesse caso, PROCV pode retornar um valor incorreto ou inesperado.

  • Se procurar_intervalo for FALSO e valor_procurado for texto, você poderá usar os caracteres curinga  — ponto de interrogação (?) e asterisco (*) — em valor_procurado. Um ponto de interrogação coincide com qualquer caractere único; um asterisco coincide com qualquer cadeia de caracteres. Se você quiser localizar um ponto de interrogação ou asterisco real, digite um til (~) antes do caractere.

Exemplo

A pasta de trabalho abaixo mostra os exemplos dessa função. Inspecione-as, altere as fórmulas existentes ou insera suas próprias fórmulas para saber sobre o funcionamento da função.

Copie os dados de exemplo da tabela a seguir e cole-os na célula A1 de uma nova planilha do Excel. Para as fórmulas mostrarem resultados, selecione-as, pressione F2 e pressione Enter. Se precisar, você poderá ajustar as larguras das colunas para ver todos os dados.

Densidade

Viscosidade

Temperatura

0,457

3,55

500

0,525

3,25

400

0,606

2,93

300

0,675

2,75

250

0,746

2,57

200

0,835

2,38

150

0,946

2,17

100

1,09

1,95

50

1,29

1,71

0

Fórmula

Descrição

Resultado

=PROCV(1,A2:C10,2)

Usando uma correspondência aproximada, procura o valor 1 na coluna A, localiza o maior valor menor ou igual a 1 na coluna A, que é 0,946 e retorna o valor da coluna B na mesma linha.

2,17

=PROCV(1,A2:C10,3,VERDADEIRO)

Usando uma correspondência aproximada, procura o valor 1 na coluna A, localiza o maior valor menor ou igual a 1 na coluna A, que é 0,946 e retorna o valor da coluna C na mesma linha.

100

=PROCV(0,7,A2:C10,3,FALSO)

Usando uma correspondência exata, procura o valor 0,7 na coluna A. Como não há nenhuma correspondência exata na coluna A, é retornado um erro.

#N/D

=PROCV(0,1,A2:C10,2,VERDADEIRO)

Usando uma correspondência aproximada, procura o valor 0,1 na coluna A. Como 0,1 é menor que o menor valor na coluna A, é retornado um erro.

#N/D

=PROCV(2,A2:C10,2,VERDADEIRO)

Usando uma correspondência aproximada, procura o valor 1 na coluna A, localiza o maior valor menor ou igual a 2 na coluna A, que é 1,29 e retorna o valor da coluna B na mesma linha.

1,71

Para trabalhar de forma mais aprofundada com os dados de exemplo no Excel, baixe a pasta de trabalho incorporada para seu computador e a abra no Excel.

Exemplo 2

ID do Item

Item

Custo

Marcação

ST-340

Carrinho

$145,67

30%

BI-567

Babador

$3,56

40%

DI-328

Fraldas

$21,45

35%

WI-989

Lenços

$5,12

40%

AS-469

Aspirador

$2,56

45%

Fórmula

Descrição

Resultado

= PROCV("DI-328", A2:D6, 3, FALSO) * (1 + PROCV("DI-328", A2:D6, 4, FALSO))

Calcula o preço de varejo de fraldas adicionando o percentual de marcação ao custo.

$28,96

= (PROCV("WI-989", A2:D6, 3, FALSO) * (1 + PROCV("WI-989", A2:D6, 4, FALSO))) * (1 - 20%)

Calcula o preço de venda de lenços, subtraindo um desconto especificado a partir do preço de varejo.

$5,73

= IF(PROCV(A2, A2:D6, 3, FALSO) >= 20, "Marcação é " & 100 * PROCV(A2, A2:D6, 4, FALSO) &"%", "Custo abaixo de $20,00")

Se o custo de um item for maior ou igual a $20,00, exibe a cadeia de caracteres "Marcação é nn%"; caso contrário, exibe a cadeia de caracteres "Custo abaixo de $20,00"

Marcação é 30%

= IF(PROCV(A3, A2:D6, 3, FALSO) >= 20, "Marcação é: " & 100 * PROCV(A3, A2:D6, 4, FALSO) &"%", "Custo é $" & PROCV(A3, A2:D6, 3, FALSO))

Se o custo de um item for maior ou igual a $20,00, exibe a cadeia de caracteres "Marcação é nn%"; caso contrário, exibe a cadeia de caracteres "Custo é $n.nn

Custo é $3,56

Exemplo 3

ID

Sobrenome

Nome

Título

Data de nascimento

1

Davis

Sara

Representante de vendas

08/12/1968

2

Fontana

Olivier

VP de vendas

19/02/1952

3

Leal

Karina

Representante de vendas

30/08/1963

4

Patten

Pedro

Representante de vendas

19/09/1958

5

Barreto

Brian

Gerente de vendas

04/03/1955

6

Sousa

Luis

Representante de vendas

02/07/1963

Fórmula

Descrição

Resultado

=INT(FRAÇÃOANO(DATA(2004,6,30), PROCV(5,A2:E7,5, FALSO), 1))

Para o ano fiscal de 2004, localiza a idade do funcionário com a identificação de 5. Usa a função FRAÇÃOANO para subtrair a data de nascimento data de fim do ano fiscal e exibe o resultado como um inteiro usando a função INT.

49

=SE(ISNA(PROCV(5,A2:E7,2,FALSO)) = VERDADEIRO, "Funcionário não encontrado", PROCV(5,A2:E7,2,FALSO))

Se houver um funcionário com uma identificação de 5, exibe o sobrenome do funcionário; caso contrário, exibe a mensagem "Funcionário não encontrado".

A função ISNA retorna um valor VERDADEIRO quando a função PROCV retorna o valor de erro #N/D.

Barreto

=SE(ISNA(PROCV(15,A3:E8,2,FALSO)) = VERDADEIRO, "Funcionário não encontrado", PROCV(15,A3:E8,2,FALSO))

Se houver um funcionário com uma identificação de 15, exibe o sobrenome do funcionário; caso contrário, exibe a mensagem "Funcionário não encontrado".

A função ISNA retorna um valor VERDADEIRO quando a função PROCV retorna o valor de erro #N/D.

Funcionário não encontrado

=PROCV(4,A2:E7,3,FALSO) & " " & PROCV(4,A2:E7,2,FALSO) & " é um " & PROCV(4,A2:E7,4,FALSO)

Para o funcionário com uma identificação de 4, concatena (combina) os valores de três células em uma frase completa.

Michael Patten é um Representante de vendas

Início da página

Aplicável a: Excel 2013, Excel Online



Essas informações foram úteis?

Sim Não

Como podemos melhorá-lo?

255 caracteres restantes

Para proteger sua privacidade, não inclua informações de contato em seus comentários. Avalie nosso política de privacidade.

Obrigado por seus comentários!

Recursos de suporte

Alterar idioma