O que aconteceu com os modelos, o menu e os recursos de modelagem de banco de dados?

Nem todas as edições do Microsoft Office Visio contêm recursos de modelagem de banco de dados. Se você não conseguir encontrar os recursos que procura, verifique o seguinte:

Qual edição você está usando?    

Para descobrir qual a sua edição do Visio, clique em Sobre o Microsoft Office Visio no menu Ajuda. O nome da edição está na primeira linha do texto da caixa de diálogo.

  • O Microsoft Office Visio Standard não contém o modelo Diagrama de Modelo de Banco de Dados.

  • O Microsoft Office Visio Professional oferece suporte aos recursos de engenharia reversa do modelo Diagrama de Modelo de Banco de Dados (isto é, usar um banco de dados existente para criar um modelo no Visio), mas não oferece suporte à engenharia prospectiva (isto é, usar um modelo de banco de dados do Visio para gerar código SQL).

  • Você pode encontrar o conjunto completo de recursos de modelagem de banco de dados, incluindo tanto a engenharia reversa quanto a prospectiva, no Visio for Enterprise Architects. O Visio for Enterprise Architects está incluído na assinatura do MSDN Premium, que está disponível nas edições do Visual Studio Professional e do Visual Studio Team System, baseadas em função.

Você está trabalhando no modelo Diagrama de Modelo de Banco de Dados?    

Você pode ter aberto um modelo de diagrama de banco de dados Express-G ou ORM, ou então um modelo que não seja de banco de dados. Esses modelos não oferecem suporte a recursos de modelagem de banco de dados como o menu Banco de Dados; apenas o modelo Diagrama de Modelo de Banco de Dados oferece suporte a esses recursos. Para abri-lo, aponte para Novo no menu Arquivo, aponte para Software e Banco de Dados e clique em Diagrama de Modelo de Banco de Dados.

Você consegue ver o menu Banco de Dados?    

O menu Banco de Dados pode desaparecer se o Visio encontrar um erro inesperado de origem interna ou externa. Para recuperar o menu, tente o seguinte:

  1. Se o Visio encerrar inesperadamente, reinicie o programa.

  2. No menu Ferramentas, clique em Opções.

  3. Na guia Segurança, selecione Permitir Eventos de Automação e clique em OK.

O menu do banco de dados é restaurado depois que você reinicia o Visio e abre novamente o modelo Diagrama de Modelo de Banco de Dados.

Aplicável a: Visio 2007



Essas informações foram úteis?

Sim Não

Como podemos melhorá-lo?

255 caracteres restantes

Para proteger sua privacidade, não inclua informações de contato em seus comentários. Avalie nosso política de privacidade.

Obrigado por seus comentários!

Recursos de suporte

Alterar idioma