NÃO (Função NÃO)

Use a função NÃO, uma das funções lógicas, quando desejar verificar se um valor não é igual a outro.

Exemplo

Exemplos da função NÃO para reverter argumentos.  Por exemplo, =NÃO(1+1=2)

A função NÃO inverte o valor do argumento.

Um uso comum para a função NÃO é expandir a utilidade de outras funções que realizam testes lógicos. Por exemplo, a função SE realiza um teste lógico e retornará um valor se o teste for avaliado como VERDADEIRO e outro valor se o teste for avaliado como FALSO. Usando a função NÃO como argumento teste_lógico da função SE, você pode testar várias condições diferentes em vez de apenas uma.

Sintaxe

NÃO(lógico)

A sintaxe da função NÃO tem os seguintes argumentos:

  • Lógico    Obrigatório. Um valor ou expressão que pode ser avaliado como VERDADEIRO ou FALSO.

Comentários

Se lógico for FALSO, NÃO retornará VERDADEIRO; se lógico for VERDADEIRO, NÃO retornará FALSO.

Exemplos

Aqui estão alguns exemplos de uso geral de NÃO por si só e em conjunto com SE, E e OU.

Exemplos de NÃO com as funções SE, E e OU

Fórmula

Descrição

=NÃO(A2>100)

A2 NÃO é maior que 100

=SE(E(NÃO(A2>1);NÃO(A2<100));A2;"O valor está fora do intervalo")

50 for maior que 1 (VERDADEIRO), E 50 for menor que 100 (VERDADEIRO), então NÃO inverte os dois argumentos como FALSO. E requer que ambos os argumentos sejam VERDADEIRO, assim, retornará o resultado se for FALSO.

=SE(OU(NÃO(A3<0);NÃO(A3>50));A3;"O valor está fora do intervalo")

100 não for menor que 0 (FALSO) e 100 for maior que 50 (VERDADEIRO), então NÃO inverte os argumentos para VERDADEIRO/FALSO. OU requer que apenas um argumento seja VERDADEIRO, então, retornará o resultado se for VERDADEIRO.

Cálculo de comissão de vendas

Aqui está um cenário bastante comum em que precisaremos calcular se vendedores se qualificam para uma comissão usando NÃO com SE e E.

Exemplo de cálculo de uma comissão de vendas com SE, E e NÃO.  A fórmula na célula E14 é =SE(E(NÃO(B14<$B$7);NÃO(C14<$B$5));B14*$B$8;0)
  • =SE(E(NÃO(B14<$B$7);NÃO(C14<$B$5));B14*$B$8,0)- SE Total de vendas NÃO for inferior à Meta de Vendas E Contas NÃO forem menores que a Meta de Conta, multiplicar Total de Vendas por % da Comissão, caso contrário, retornar 0.

Precisa de mais ajuda?

Você pode sempre consultar um especialista na Excel Tech Community, obter suporte na Comunidade de respostas ou sugerir um novo recurso ou melhoria no User Voice do Excel.

Tópicos Relacionados

Vídeo: Funções SE avançadas
Saiba como usar funções aninhadas em uma fórmula
Função SE
Função E
Função OU
Visão geral de fórmulas no Excel
Como evitar fórmulas quebradas
Usar a verificação de erros para detectar erros em fórmulas
Atalhos de teclado no Excel 2016 para Windows
Atalhos de teclado no Excel 2016 para Mac
Funções lógicas (referência)
Funções do Excel (ordem alfabética)
Funções do Excel (por categoria)

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×