Mover um modelo de formulário publicado para uma nova biblioteca do SharePoint

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Neste artigo

Visão geral

Antes de começar

Obter uma cópia de trabalho de seu modelo de formulário

Etapa 1: Publicar o modelo de formulário para a nova biblioteca de documentos

Etapa 2: Copiar e vincular novamente os formulários existentes

Visão geral

Depois de publicar um modelo de formulário em uma biblioteca de documentos para seus usuários preencherem, você precisará mover esse modelo para outra biblioteca. Por exemplo, talvez você tenha que mover seu modelo de formulário para um servidor com mais capacidade para que mais usuários possam preencher formulários ao mesmo tempo. Alguns usuários talvez já tenham preenchido formulários baseados nesse modelo que foi armazenado na biblioteca de documentos original. Ao mover seu modelo de formulário para uma nova biblioteca de documentos, talvez você queira mover também esses formulários existentes. Talvez seja conveniente verificar se esses formulários existentes funcionarão na nova biblioteca de documentos antes de você arquivar ou excluir a biblioteca de documentos antigos.

Dica : Antes de mover modelos de formulário publicados para uma nova biblioteca de documentos, crie um plano que inclua informar os usuários de que seus formulários foram movidos para uma nova biblioteca de documentos. Você deseja que seus usuários usem a nova biblioteca de documentos para armazenar novos formulários ou para modificar os existentes. O plano também deve incluir um processo de arquivamento ou exclusão da biblioteca de documentos original.

Para mover um modelo de formulário e seus formulários existentes para uma nova biblioteca de documentos, primeiro publique a cópia de trabalho do modelo na nova biblioteca. A cópia de trabalho é a versão armazenada no computador ou em um programa de controle de versão, como o Microsoft Visual SourceSafe.

Dica : Se você não tiver uma cópia de trabalho do modelo de formulário, poderá salvar uma da biblioteca de documentos original no computador para usar como cópia de trabalho.

Depois de publicar a cópia de trabalho na nova biblioteca de documentos, copie qualquer formulário da biblioteca antiga na nova e vincule novamente os formulários na nova biblioteca ao modelo de formulário recém-publicado.

Se precisar fazer alguma alteração por ter movido o modelo de formulário, faça antes de publicá-lo. Por exemplo, o local das fontes de dados externas usadas pelos formulários baseados nesse modelo também podem mudar como resultado da movimentação do modelo. Nesse caso, altere a conexão de dados do modelo de formulário para o novo local das fontes de dados externas antes de publicar o modelo. Há links para mais informações sobre como alterar conexões de dados na seção Consulte também.

Observação : Publicação de um modelo de formulário não é a mesma que salvar um modelo de formulário. Quando você publica um modelo de formulário, o Assistente de publicação adiciona o local de publicação e instruções de processamento para o modelo de formulário para que os usuários podem abrir formulários que são baseados neste modelo de formulário. Quando você salva um modelo de formulário, você está salvando uma cópia do modelo de formulário, assim como faz quando você salva um arquivo no seu computador. Você sempre deve usar o Assistente de publicação quando você quiser disponibilizar seu modelo de formulário para seus usuários preencher.

Início da página

Antes de começar

Antes de mover o modelo de formulário e qualquer formulário existente baseado nele para uma nova biblioteca de documentos, você precisará do seguinte:

  • A cópia de trabalho do modelo de formulário    É a cópia do modelo de formulário que você modificará e republicará na nova biblioteca de documentos. A cópia de trabalho pode estar armazenada no computador ou em um programa de controle de versão, como o Visual SourceSafe.

  • Os locais de qualquer fonte de dados externa    Se os formulários baseados no modelo usam fontes de dados externas que foram alteradas, você precisará do novo local das fontes externas. Consulte o administrador para ver se você e seus usuários têm permissões apropriadas para usar fontes de dados externas. Se o modelo de formulário usa configurações de um arquivo de conexão de dados para se conectar a uma fonte de dados externa, verifique se o arquivo de conexão de dados foi atualizado com o novo local da fonte de dados externa.

  • Os direitos apropriados no servidor em execução Windows SharePoint Services 3.0    Você precisará dos direitos apropriados no servidor para publicar um modelo de formulário e copiar qualquer formulário existente da biblioteca de documentos antiga para a nova. Consulte o administrador do servidor para ver se você tem esses direitos.

Início da página

Obter uma cópia de trabalho de seu modelo de formulário

Se desejar modificar um modelo de formulário publicado em uma biblioteca de documentos ou em um local de rede compartilhado e não tiver uma cópia de trabalho dele, salve a cópia do local de publicação em seu computador.

Dica : Considere a possibilidade de usar um programa de controle de versão, como o Microsoft Visual SourceSafe, para gerenciar as cópias de trabalho dos modelos de formulário.

Salve uma cópia do modelo de formulário de uma biblioteca de documentos em seu computador.

  1. Em um navegador da Web, abra a biblioteca de documentos onde o modelo de formulário foi publicado.

  2. No menu configurações, clique em configurações e, em seguida, clique em Configurações da biblioteca de formulário.

  3. Em Configurações Gerais, clique em Configurações avançadas.

  4. Na seção Modelo de documento, clique em Editar Modelo.

    O modelo de formulário será aberto no Microsoft Office InfoPath.

  5. Na caixa de diálogo Microsoft Office InfoPath, clique em Sim.

  6. No menu Arquivo, clique em Salvar como.

  7. Na caixa de diálogo Microsoft Office InfoPath, clique em OK.

  8. Na caixa de diálogo Salvar Como, procure o local no qual deseja salvar uma cópia do modelo de formulário e, em seguida, clique em Salvar.

Salvar uma cópia do modelo de formulário da pasta de rede compartilhada em seu computador

  1. No menu arquivo, clique em Design de um modelo de formulário.

  2. Em Abrir um modelo de formulário, clique em No Meu Computador.

  3. Navegue até a pasta de rede compartilhada do modelo de formulário publicado, clique no modelo de formulário e clique em Abrir.

  4. No menu Arquivo, clique em Salvar como.

  5. Na caixa de diálogo Microsoft Office InfoPath, clique em OK.

  6. Na caixa de diálogo Salvar como, selecione um local diferente de original publicar o local onde você deseja salvar uma cópia de trabalho do modelo de formulário e clique em Salvar.

Início da página

Etapa 1: Publique o modelo de formulário na nova biblioteca de documentos.

  1. Abra a cópia de trabalho do modelo de formulário publicado no modo de design.

  2. No menu Arquivo, clique em Publicar.

  3. No Assistente para Publicação, clique em Para um servidor do SharePoint com ou sem InfoPath Forms Services e clique em Avançar.

  4. Na caixa Digite o local do site do SharePoint ou do InfoPath Forms Services, digite o local do site do SharePoint que contém a nova biblioteca de documentos para a qual deseja mover o modelo de formulário e clique em Avançar.

  5. Na próxima página do assistente, clique em Biblioteca de Documentos e, em seguida, clique em Avançar.

  6. Clique em Criar uma nova biblioteca de documentos e clique em Avançar.

  7. Na próxima página do assistente, digite um nome e uma descrição para a nova biblioteca de documentos e clique em Avançar.

  8. No modelo de formulário, escolha os campos a serem exibidos como colunas no modo de exibição padrão da biblioteca de documentos.

    Como?

    1. Clique em Adicionar.

    2. Selecione o campo que você deseja adicionar como uma coluna na biblioteca de documentos e, em seguida, siga um destes procedimentos:

      • Digite um nome para a coluna na caixa nome da coluna.

      • Selecione a coluna de site na lista de grupo de colunas de Site, selecione um nome na lista nome da coluna e clique em OK.

        Observação : Se você selecionou um campo de repetição para exibir dados na biblioteca de documentos, você pode definir como deseja exibir o campo na biblioteca de documentos, clicando em um valor na lista de função. Você pode escolher se deseja exibir o primeiro valor no campo, o último valor no campo ou uma contagem de todas as ocorrências do campo, ou por mesclar todos os valores juntos.

    3. Clique em OK.

    Localize os links para mais informações sobre como exibir dados em colunas em uma biblioteca de documentos na seção Consulte também.

  9. Clique em Avançar.

  10. Na próxima página do assistente, verifique se as informações mostradas estão corretas e clique em Publicar.

  11. Para abrir a biblioteca de documentos e testar o processo de preenchimento de um formulário com base nesse modelo, marque a caixa de seleção Abrir esta biblioteca de documentos e clique em Fechar.

    A biblioteca de documentos será aberta em um navegador. Quando você clicar em Novo na barra de ferramentas da lista, um formulário baseado nesse modelo será aberto no Microsoft Office InfoPath.

Depois de publicar o modelo de formulário em uma nova biblioteca de documentos, você poderá copiar os formulários existentes baseados na versão antiga do modelo da biblioteca de documentos antiga para a nova. Depois de copiar os formulários existentes, vincule-os novamente à nova versão do modelo de formulário. Se não fizer isso, os usuários talvez não consigam abrir esses formulários.

Início da página

Etapa 2: Copie e vincule novamente os formulários existentes

Este procedimento pressupõe que ambas as bibliotecas de documentos estejam em um servidor que esteja executando o Windows SharePoint Services 3.0.

  1. Abra a biblioteca de documentos antiga em um navegador da Web.

  2. No menu Exibir, clique em Exibição do Explorer.

  3. Mantenha pressionada a tecla CTRL, selecione cada formulário que deseja mover e clique com o botão direito do mouse em um deles.

  4. Na caixa de diálogo Internet Explorer, clique em Sim e clique em Copiar no menu de atalho.

  5. Abra a nova biblioteca de documentos.

  6. Em Selecione uma Exibição, clique em Exibição do Explorer.

  7. Clique com o botão direito do mouse na área em branco da janela da pasta.

  8. Na caixa de diálogo Internet Explorer, clique em Sim e clique em Colar no menu de atalho.

  9. No menu Exibir, clique em Vincular Documentos Novamente.

  10. Na coluna Vincular Novamente, marque a caixa de seleção de cada formulário que deseja vincular ao novo modelo.

  11. Na barra de ferramentas da lista, clique em Vincular Documentos Selecionados Novamente.

Depois que você vincular novamente os formulários existentes ao novo modelo, seus usuários poderão alterar os formulários existentes que copiou na nova biblioteca de documentos ou preencher novos formulários baseados no modelo recém-publicado.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×