Migrar para o Access 2010

Visão geral

Alternar para o Access 2010 de uma versão anterior Se você for um usuário com experiência no Access, este curso é para você. Este curso explica como alternar para o Access 2010 de uma versão anterior. Você aprenderá a realizar tarefas conhecidas no Access 2010, como usar bancos de dados existentes, criar novos bancos de dados, criar tabelas e criar ou editar formulários e relatórios.

Após concluir este curso você poderá:

  • Use o modo de exibição Backstage para abrir bancos de dados existentes e criar novos bancos de dados.

  • Salve um banco de dados existente como um arquivo do Access 2010.

  • Use a faixa de opções para iniciar o modo de exibição Design para tabelas, formulários, relatórios e consultas.

  • Use o modo de exibição Layout para editar formulários e relatórios.

  • Use o modo de exibição Layout para agrupar dados em relatórios.

Este curso inclui:

  • Uma lição individualizada.

  • Um pequeno teste no final da lição. O teste não conta pontos.

  • Um Cartão de Referência Rápida que você pode imprimir no fim do curso.

Este curso supõe que você tem pelo menos um nível moderado de experiência com o Access; você criou alguns bancos de dados e compreendeu as noções básicas de relacionamentos entre design e tabela de banco de dados. Se você for novo no Access, consulte Introdução ao Access 2010.

Versão Offline (115.7 MB)

Introdução ao Access 2010

Seu navegador não oferece suporte a vídeo. Instale o Microsoft Silverlight, o Adobe Flash Player ou o Internet Explorer 9.

Iniciar algo com o Painel de Navegação

Seu navegador não oferece suporte a vídeo. Instale o Microsoft Silverlight, o Adobe Flash Player ou o Internet Explorer 9.

Conhecer a faixa de opções

Seu navegador não oferece suporte a vídeo. Instale o Microsoft Silverlight, o Adobe Flash Player ou o Internet Explorer 9.

Usar arquivos de versões anteriores do Access

Seu navegador não oferece suporte a vídeo. Instale o Microsoft Silverlight, o Adobe Flash Player ou o Internet Explorer 9.

Começar rápido com modelos e bancos de dados da Web

Seu navegador não oferece suporte a vídeo. Instale o Microsoft Silverlight, o Adobe Flash Player ou o Internet Explorer 9.

Criar dinamicamente com o modo de exibição Layout

Seu navegador não oferece suporte a vídeo. Instale o Microsoft Silverlight, o Adobe Flash Player ou o Internet Explorer 9.

Etapas práticas sugeridas

Se você tiver alguma experiência com o Access 2003 ou anterior — uma dupla de pequenos bancos de dados ou mais — este curso foi escrito para você. Estas são algumas formas sugeridas para praticar o que você viu no curso.

Importante    Para seguir estas etapas, você deve ter o Access 2010 instalado no computador e precisa estar conectado à Internet.

Criar um novo banco de dados em branco

Para seguir estas etapas, você pode usar um de seus próprios esquemas de banco de dados.

  1. Inicie o Access 2010. Ele é aberto automaticamente no modo de exibição Backstage.

  2. Clique na guia Novo. O modelo Banco de Dados em Branco já está selecionado.

  3. No lado direito da guia, na caixa Nome do Arquivo, insira um nome para o novo banco de dados.

  4. Como opção, clique no ícone de pasta localizado à direita da caixa Nome do Arquivo.

    Isso inicia a caixa de diálogo Novo Arquivo de Banco de Dados e você pode usá-la para selecionar outro local para o banco de dados.

  5. Clique em Download.

    O banco de dados é aberto e exibe uma tabela em branco, pronta para você adicionar campos, no modo de exibição Folha de Dados.

Adicionar campos em uma tabela

O Access oferece diversos modos para adicionar campos a uma tabela. Veja aqui alguns dos mais comuns.

  1. Com a tabela aberta no modo de exibição Folha de Dados, verifique se você está na guia Campos (clique nela se não estiver).

  2. No grupo Adicionar e Excluir, abra a lista Mais Campos.

  3. Na parte inferior da lista, em Início Rápido, clique em Nome.
    A lista Mais Campos

  4. Clique no título do campo em branco à direita dos novos campos (as palavras Clique para Adicionar) e repita a etapa 4 para adicionar os campos Endereço e Telefone à tabela.

  5. Clique com o botão direito do mouse no título do campo em branco (as palavras Clique para Adicionar) e, na lista exibida, selecione Memorando.

    Isso define o tipo de dados para o campo e torna o título do campo gravável.

  6. No título do campo, digite Comentários e clique fora do título para confirmar suas alterações.

Ir para o Painel de Navegação

Observação    Você precisa ter conexão com a Internet para seguir estas etapas. Comece baixando o banco de dados de exemplo Northwind. Para isso, clique na guia Novo e clique em Modelos de Exemplo. Confie no banco de dados (na barra de mensagens amarela, clique em Habilitar Conteúdo ) e faça logon nele.

  1. O Painel de Navegação é fechado neste modelo, portanto, clique na seta dupla para abri-lo.

    O botão abrir/fechar do Painel de Navegação

  2. No painel, clique na barra Relatórios para expandir esse grupo.

    Observe que o grupo exibe um conjunto de atalhos para os objetos do banco de dados. É assim que você sabe que está olhando para uma categoria ou um grupo personalizado.

  3. Clique na barra na parte superior do painel (leia-se Northwind Traders) e clique em Tipo de Objeto. Agora você está olhando para uma lista de objetos no banco de dados.

  4. Clique em Formulários, clique com o botão direito do mouse no formulário Lista de Clientes e clique em Modo Layout.

  5. Clique no grupo Tabelas para expandi-lo e clique duas vezes na tabela Clientes.

  6. Clique com o botão direito do mouse na parte superior do painel e clique em Barra de Pesquisa.

    Para tornar a Barra de Pesquisa visível, repita esta etapa.

  7. Com a Barra de Pesquisa visível, expanda todos os grupos e, na Barra de Pesquisa, digite lentamente cliente. Observe como o Access filtra a lista de objetos conforme você digita.

Navegar na faixa de opções

Tente estas etapas com um banco de dados, como o Northwind.

  • Abra uma tabela no modo de exibição Folha de Dados e observe quais guias contextuais aparecem. Explore essas guias para ver os comandos que elas fornecem.

  • Abra uma consulta no modo de exibição Design e observe quais guias contextuais aparecem. Explore essas guias para ver os comandos que elas fornecem.

  • Abra um formulário no modo de exibição Layout e observe quais guias contextuais aparecem. Explore essas guias também.

Etapas bônus!

  1. Com qualquer objeto do banco de dados aberto e a guia Página Inicial sendo mostrada, pressione a tecla ALT.

    Um conjunto de Dicas de Tecla é exibido.

    Dicas de Tecla

    O Access oferece uma Dica de Tecla para cada guia da faixa de opções e uma Dica de Tecla para os comandos em cada guia.

  2. Pressione a tecla ALT novamente e observe que as Dicas de Tecla desaparecem.

  3. Pressione ALT+C para ir para a guia Criar.

    Como você navegou para a guia Criar a partir da guia Página Inicial, o Access exibe um conjunto de Dicas de Tecla para cada comando na guia Criar.

  4. Pressione a tecla ALT novamente e observe que as Dicas de Tecla desaparecem.

  5. Agora pressione ALT+C e observe as Dicas de Tecla de cada comando reaparecerem.

    Se você fechar acidentalmente as Dicas de Tecla de uma determinada guia, pressione ALT e a letra dessa guia para ver as Dicas de Tecla novamente.

  6. Pressione QD para iniciar o designer de consulta.

  7. Com o designer de consulta aberto, pressione ALT+H para ir para a guia Página Inicial.

    Observe que as Dicas de Tecla dos comandos desabilitados (cinza) também estão desabilitadas.

Publicar um banco de dados da Web

Comece baixando um dos modelos de banco de dados da Web, como o modelo Banco de Dados da Web de Ativos. Para isso, clique na guia Novo e clique em Modelos de Exemplo. Confie no banco de dados (na barra de mensagens amarela, clique em Habilitar Conteúdo ) e faça logon nele.

  1. No modo de exibição Backstage, clique na guia Salvar e Publicar.

  2. Clique em Publicar nos Serviços do Access.

  3. Clique em Executar Verificador de Compatibilidade.

  4. Clique em Sim para fechar todos os objetos abertos e permitir a execução do Verificador de Compatibilidade.

    Se a verificação de compatibilidade não encontrar problemas, ou se somente encontrar avisos, o banco de dados está pronto para ser publicado.

  5. Digite a URL do servidor e um nome para o site. Obtenha a URL do administrador do sistema.

  6. Clique em Publicar nos Serviços do Access.

    Você precisará aguardar que o processo de publicação seja concluído e que o servidor conclua o processamento do seu novo site.

  7. Inicie o navegador, vá para o site, abra o formulário Ativos Atuais e insira alguns dados.

Alterar um banco de dados da Web e salvar suas alterações na Web

  1. Abra o banco de dados da Web de ativos no Access.

  2. Abra o formulário principal no modo Layout.

  3. Clique com o botão direito do mouse na guia Introdução no formulário e clique em Excluir. Em seguida, pressione CTRL+S para salvar suas alterações.

  4. Clique na guia Arquivo para ir para o modo de exibição Backstage.

  5. Na guia Informações, clique em Sincronizar Tudo para gravar (salvar) suas alterações na Web.

    O botão Sincronizar Tudo

Teste seus conhecimentos

Conclua os testes a seguir para ter certeza de que compreendeu o material. Suas respostas são confidenciais e os resultados do teste não são avaliados.

Você pode usar o modo de exibição Design para alterar os formulários e relatórios em um banco de dados da Web.

Verdadeiro.

Incorreto. Você só pode usar o modo de exibição Design para formulários ou relatórios que não publicará nos Serviços do Access. Para um banco de dados da Web, use o modo de exibição Layout para criar e alterar formulários e relatórios.

Falso.

Muito bem. Você pode usar o modo de exibição Layout para alterar os formulários e relatórios em um banco de dados da Web, mas não no modo Design.

Você abre um banco de dados do Access 97 no Access 2010. Agora você insere dados e faz alterações de design.

Verdadeiro.

Tente novamente. Você somente pode ler dados quando abre um banco de dados do Access 97 no Access 2010.

Falso.

Exatamente. Você só pode ler dados. Se desejar fazer algo mais, salve o arquivo no formato de arquivo do Access 2010.

Você pode publicar um banco de dados da Web em qualquer site.

Verdadeiro.

Não é verdade. Você só pode publicar bancos de dados da Web em um servidor do SharePoint que execute os Serviços do Access.

Falso.

Ótimo. O servidor do SharePoint 2010 deve executar os Serviços do Access.

No Painel de Navegação, você abre um formulário para entrada de dados:

Clicando com o botão direito do mouse no formulário e clicando no modo Design.

Incorreto. Se você fez isso, abriria o formulário para alterações de design, mas não para uso regular.

Clicando duas vezes no formulário.

Dê a si mesmo dois pontos. Você também pode clicar com o botão direito do mouse em um objeto e clicar em Abrir.

Você não usa o Painel de Navegação. Você usa o comando Abrir na guia Página Inicial da faixa de opções.

Tente novamente. Certamente, você pode usar o Painel de Navegação para abrir objetos para uso.

Ao salvar um arquivo MDB no novo formato de arquivo (como um arquivo ACCDB), você pode abrir esse novo arquivo no Access 2003.

Verdadeiro.

Tente novamente. Não é possível abrir arquivos ACCDB no Access 2003.

Falso.

Ótimo. Somente é possível abrir arquivos ACCDB no Access 2007 ou 2010. Além disso, lembre-se de que os recursos exclusivos da versão 2010 não funcionarão na versão 2007.

Comentários

Cartão de Referência Rápida

Mais treinamento

Primeiro em uma série de iniciantes.

Criar as tabelas de um novo banco de dados

Consulte também

Personalizar a Faixa de Opções

Pasta de trabalho para mapeamento da faixa de opções do Access

Mostrar ou ocultar o Painel de Navegação

Caixa de diálogo Opções de Navegação

Converter um banco de dados do Access 2010 em um formato de arquivo anterior

Qual modo devo usar: Layout ou Design?

Mover-se no modo de exibição Backstage

  • O Access 2010 é aberto no modo de exibição Backstage. Mova-se no modo de exibição Backstage clicando na guia Arquivo.

  • Você pode abrir um banco de dados clicando no nome dele em Arquivo, ou clicando na guia Recente.

  • Na guia Novo, você pode criar um novo banco de dados, incluindo bancos de dados em branco e modelos:

  • Na guia Salvar e Enviar, você pode salvar um banco de dados em outro formato de arquivo, empacotar e assinar um banco de dados, compilá-lo em um arquivo executável e publicar um banco de dados em um servidor do SharePoint 2010 que execute Serviços do Access.

  • Clique em Opções para iniciar a caixa de diálogo Opções do Access e definir opções para seus bancos de dados e para o próprio Access.

Criar um novo banco de dados em branco

  1. Clique duas vezes no modelo que você deseja.

  2. Aceite o nome padrão ou digite um melhor.

  3. Clique em Criar.

Usar o Painel de Navegação

  • Clique duas vezes em um objeto para abri-lo para uso.

  • Clique com o botão direito do mouse em um objeto para fazer alterações de design no objeto, exportá-lo, renomeá-lo ou abrir a folha de propriedades do objeto selecionado.

Alterar o modo como o painel categoriza objetos

  1. Clique na barra na parte superior do painel. Isso abre uma lista de categorias e grupos.

  2. Selecione uma categoria da metade superior da lista ou um grupo da metade inferior.

Definir opções para o painel

  • Clique com o botão direito do mouse na parte superior do painel e clique em Opções de Navegação.

Pesquisar objetos

  1. Se a barra de Pesquisa não estiver visível, clique com o botão direito do mouse na barra, na parte superior do Painel de Navegação, e clique em Barra de Pesquisa.

  2. Digite parte ou todo o nome do objeto na caixa Pesquisar. O painel filtra a lista de objetos conforme você digita.

Para que os objetos do banco de dados não ocultem uns aos outros

  1. No modo de exibição Backstage, clique em Opções.

  2. Clique em Banco de Dados Atual.

  3. Selecione Documentos com Guias e Exibir Guias de Documento.

  4. Feche e reabra o banco de dados para ver suas alterações.

Usar a faixa de opções

  • A faixa de opções não é estática, ela é alterada dependendo do objeto que tem o foco ou da tarefa que você está fazendo.

  • A faixa de opções coloca comandos em um conjunto de guias e divide essas guias em grupos.

  • A guia Página Inicial fornece os comandos que você mais usa.

  • Além disso, a Barra de Ferramentas de Acesso Rápido no canto superior esquerdo da janela do Access contém os comandos usados com mais frequência. A Barra de Ferramentas de Acesso Rápido permanece a mesma seja qual for a guia da faixa de opções que você está usando.

  • Você pode personalizar a Barra de Ferramentas de Acesso Rápido e a faixa de opções.

Usar Dicas de Tecla

  • Pressione a tecla ALT para exibir Dicas de Tecla para cada guia da faixa de opções. Pressionando ALT mais a letra atribuída atribuída a uma guia o levará para essa guia.

  • Quando você usa Dicas de Tecla para ir para uma guia, também vê as Dicas de Tecla para cada comando dessa guia. Para usar um comando, basta pressionar o número ou a(s) letra(s). Se as Dicas de Tecla dos comandos nessa guia desaparecerem, pressione ALT mais a letra da guia.

Personalizar a Barra de Ferramentas de Acesso Rápido

  1. Clique na seta no lado direito da barra de ferramentas para abrir um menu de comandos.

  2. Selecione o comando que você deseja adicionar à barra de ferramentas.

  3. Se o comando desejado não estiver visível, clique em Mais Comandos. Isso inicia a caixa de diálogo Opções do Access.

  4. Adicione comandos do painel esquerdo ao painel direito.

Personalizar a faixa de opções

Quando você personaliza a faixa de opções, suas alterações se aplicam ao Access, não a um banco de dados individual.

Importante    Quando você colocar um comando em uma guia ou grupo da faixa de opções personalizada, acabará com o link entre esse comando e seu tópico da ajuda F1.

  1. Clique na guia Arquivo para ir para o modo de exibição Backstage e, em seguida, clique em Opções.

  2. Clique em Personalizar a Faixa de Opções.

  3. Abaixo do painel esquerdo, clique em Nova Guia, Novo Grupo ou Renomear, dependendo do que deseja fazer.

  4. No painel esquerdo, digite o nome da guia ou do grupo.

  5. Se você estiver criando uma nova guia ou um novo grupo, selecione o comando que deseja do painel esquerdo e clique duas vezes no comando ou clique em Adicionar para mover o comando para o painel direito.

Regras para usar arquivos de versões anteriores do Access

  • Os bancos de dados criados no Access 2000, Access 2002 e Access 2003 serão executados no Access 2010, mas alguns recursos não funcionarão, incluindo a janela Banco de Dados e a replicação.

  • Os arquivos do Access 97 são abertos no Access 2010, mas você só pode exibir objetos e adicionar registros. Não é possível salvar as alterações de design a menos que você converta o banco de dados no formato de arquivo do Access 2010.

  • Depois que você salvar um banco de dados antigo como arquivo ACCDB, só poderá usá-lo no Access 2007 ou 2010.

  • Se você abrir um banco de dados do Access 2010 no Access 2007, os recursos exclusivos do Access 2010 não funcionarão.

Usar modelos e bancos de dados da Web

O Access fornece duas classes de modelos: local e online. Os modelos locais são instalados no seu computador quando você instala o Access. Os modelos online estão disponíveis se você tiver conexão com a Internet.

Para usar modelos online

  1. No modo de exibição Backstage, na guia Novo, clique em Modelos de Exemplo ou clique duas vezes em uma das categorias de modelo em Modelos do Office.com.

  2. Dê um nome ao novo banco de dados, escolha um local se for necessário e clique em Criar para baixar e abrir o modelo.

  3. Habilite qualquer conteúdo bloqueado, e comece a inserir dados, ou modifique o modelo para se adequar às suas necessidades.

Para publicar um banco de dados da Web

  1. No modo de exibição Backstage, clique na guia Salvar e Publicar se ela não estiver selecionada e clique em Publicar nos Serviços do Access.

  2. Clique em Executar Verificador de Compatibilidade.

  3. Clique em Sim para fechar todos os objetos abertos e permitir a execução do Verificador de Compatibilidade.

  4. Se não houver problemas, o banco de dados está pronto para ser publicado.

  5. Digite a URL do servidor e um nome para o site.

  6. Clique em Publicar nos Serviços do Access.
    Depois que o processo de publicação estiver concluído, as tabelas do seu banco de dados se tornarão listas do SharePoint e os formulários terão a aparência e o comportamento que eles têm no Access.

Usar o modo Layout

O modo Layout é um designer visual de formulários e relatórios no Access 2010. Ele é também o único designer de formulários e relatórios em um banco de dados da Web.

Para usar o modo Layout

  • No Painel de Navegação, clique com o botão direito do mouse em um formulário ou relatório e clique em Modo Layout.
    - ou -
    Clique com o botão direito do mouse na guia do documento de qualquer formulário ou relatório aberto e clique em Modo Layout.

Algumas alterações rápidas que você pode fazer no modo Layout

  • Selecione um único controle ou rótulo e arraste-o para redimensionar todos os controles ou rótulos nessa coluna.

  • Selecione um rótulo, clique na guia Formato e use os comandos para alterar a fonte, a cor da fonte ou o alinhamento do texto.

  • Pressione CTRL, selecione vários rótulos e formate-os.

  • Para fazer alterações globais em um layout, clique no seletor de Layout, a cruz no canto superior esquerdo do layout. Por exemplo, selecione o layout inteiro. Na guia Design, clique em Folha de Propriedades para abrir as propriedades do formulário e definir os controles para uma altura diferente.

Para mover ou colocar os controles adicionando colunas e linhas em branco a um layout

  1. Na guia Design, clique em Adicionar Campos Existentes.

  2. Arraste os campos que deseja usar para o layout.

  3. Conforme necessário, arraste os controles separadamente de seus rótulos e solte-os no local desejado. Uma barra laranja indica o destino.

Para agrupar e classificar os dados em seus relatórios

  1. Na guia Design, clique em Agrupar e Classificar.

  2. No painel Agrupar, Classificar e Total, clique em Adicionar um grupo e, em seguida, clique no campo em que deseja agrupar seus dados. Sua alteração aparece diretamente.
    Você pode adicionar no máximo sete rótulos de agrupamento.

Aplicável a: Access 2010



Essas informações foram úteis?

Sim Não

Como podemos melhorá-lo?

255 caracteres restantes

Para proteger sua privacidade, não inclua informações de contato em seus comentários. Avalie nosso política de privacidade.

Obrigado por seus comentários!

Recursos de suporte

Alterar idioma