Mesclar vários formulários do InfoPath

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

InfoPath Forms Services é uma tecnologia de servidor, disponível em Microsoft Office Forms Server 2007 e Microsoft Office SharePoint Server 2007, que permite aos usuários preencher formulários de Microsoft Office InfoPath 2007 usando um navegador da Web, em vez de, ou além, o programa de cliente Office InfoPath 2007. Essa tecnologia permite acesso mais amplo aos formulários que era possível com versões anteriores do Microsoft Office InfoPath.

Este artigo explica como mesclar formulários do Office InfoPath 2007 em um servidor que executa o InfoPath Forms Services.

Neste artigo

Visão geral

Mesclar vários formulários do InfoPath em uma biblioteca

Visão Geral

Uma biblioteca é um local em um site onde você pode criar, coletar, atualizar e gerenciar arquivos com membros da equipe. Cada biblioteca exibe uma lista de arquivos e informações-chave sobre os arquivos, o que ajuda as pessoas a usarem os arquivos para trabalhar juntos.

Ao armazenar formulários do InfoPath em uma biblioteca, você pode compartilhar e controlar os formulários facilmente. Por exemplo, você pode criar uma biblioteca para os formulários de relatórios de status da sua equipe. Se o designer do modelo de formulário habilitou a opção de mesclagem de formulários para o modelo de formulário, você também pode mesclar formulários em uma biblioteca. A mesclagem de formulários permite que os usuários consolidem os dados de vários formulários diferentes que se baseiam no mesmo modelo de formulário. Mesclar os dados do formulário é útil se você deseja comparar ou resumir os dados de vários formulários. Por exemplo, um gerente cuja equipe preenche um formulário de relatório de status semanal pode mesclar os dados de vários formulários em um único formulário de resumo para o gerente. Os dados nos formulários originais não são excluídos quando você mescla os formulários. Os usuários ainda podem ver os dados originais abrindo cada formulário individualmente.

Para mesclar os formulários em uma biblioteca, você usa o comando Mesclar Documentos no menu Exibir dessa biblioteca. Esse comando é adicionado ao menu Exibir de uma biblioteca de documentos quando o designer do modelo de formulário publica um modelo de formulário em uma nova biblioteca do Microsoft Office InfoPath. O comando também é adicionado quando um tipo de conteúdo do site que oferece suporte a mesclagem de formulários é adicionado a uma biblioteca existente.

Quando o comando Mesclar Documentos está disponível, você pode selecionar os arquivos que deseja mesclar sem abrir qualquer um dos arquivos. Quando você mescla formulários do InfoPath usando o comando Mesclar Documentos, o InfoPath é aberto para exibir um novo formulário que contém os dados mesclados dos formulários selecionados. O novo formulário é aberto no InfoPath, mesmo se os formulários forem baseados em um modelo de formulário habilitado para navegador. Se você salvar o novo formulário na mesma biblioteca dos formulários originais, ele será habilitado para navegador como os outros formulários dessa biblioteca.

Observações : 

  • Para garantir que um modelo de formulário habilitado para navegador sempre abra no navegador, você deve clicar em Exibir como uma página da Web na página Configurações Avançadas da biblioteca.

  • Por padrão, quando vários formulários são mesclados em um único formulário, os únicos dados mesclados são os dados contidos em uma tabela de repetição ou em uma seção de repetição, ou os dados associados a um controle de listagem ou a um controle de caixa de rich text. No entanto, ao criar o modelo de formulário, você pode especificar que os dados em outros tipos de controles também devem ser mesclados.

Início da página

Mesclar vários formulários do InfoPath em uma biblioteca

Para mesclar vários formulários armazenados em uma biblioteca de documentos, execute o seguinte procedimento:

  1. Se a biblioteca não estiver aberta, clique em seu nome no Início Rápido.

    Se o nome da biblioteca não for exibido, clique em Exibir Todo o Conteúdo do Site e no nome da biblioteca.

  2. No o menu de exibição menu exibir , clique em Mesclar documentos.

  3. Na coluna Mesclar, marque as caixas de seleção ao lado dos formulários que deseja mesclar.

  4. Na barra de ferramentas de lista, clique em Mesclar Documentos Selecionados.

    O InfoPath é aberto com um novo formulário que se baseia no mesmo modelo de formulário e contém os dados mesclados.

    Observação : Quando um usuário mescla modelos de formulário de email do InfoPath, os dados mesclados de controles de repetição podem conter uma linha em branco. Por exemplo, se um usuário mescla três formulários de relatórios de despesas, cada um dos quais com uma única linha de despesas em uma tabela de repetição, a tabela de repetição no formulário de email do InfoPath que contém dados mesclados pode conter uma linha em branco, seguida de três linhas de dados de cada um dos outros formulários de email do InfoPath.

  5. Para salvar o formulário que contém os dados mesclados, no menu Arquivo, clique em Salvar como, navegue até o local onde deseja salvar o formulário e, em seguida, clique em Salvar.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×