Maneiras de somar valores em uma planilha

Contar x somar

A soma (adição de valores) é parte integrante da análise de dados, se você estiver subtotalizando vendas na região noroeste ou o total de recibos semanais. O Excel fornece várias técnicas que você pode usar para somar dados.

Para que você faça a melhor escolha, este artigo fornece um resumo abrangente de métodos e informações de apoio para ajudar você a decidir rapidamente qual técnica usar, e links para artigos detalhados.

A soma do conteúdo das células não deve ser confundida com a contagem do número de células. Para mais informações sobre a contagem do número de células, colunas ou linhas de dados, consulte CONT.SE (Função CONT.SE).

Neste artigo

Adição simples e subtração

Adicionar os valores em uma célula usando uma fórmula simples

Subtrair os valores em uma célula usando uma fórmula simples

Adicione os valores em uma coluna ou linha usando um botão

Adicione os valores em um intervalo usando uma função

Subtraia os valores em um intervalo usando uma função

Somando dados por meio de agrupamento e dinamização

Adicionar os valores em uma coluna usando um tópico

Adicionar os valores em uma lista ou coluna de tabela do Excel usando uma função

Somar dados e observá-los de diferentes perspectivas

Somar dados com base em uma ou mais condições

Adicionar os valores em um intervalo com base em uma única condição usando uma única função ou uma combinação de funções

Adicionar os valores em um intervalo com base em uma única condição usando uma única função ou uma combinação de funções

Adicionar os valores em um intervalo com base em múltiplas condições usando uma única função ou uma combinação de funções

Somar valores ao quadrado e matriz

Somar o produto dos valores correspondentes em uma ou mais matrizes

Casos especiais (execução de total, valores únicos)

Criar um total de análise usando uma função

Adicionar os valores exclusivos usando uma fórmula composta

Incluir valores de outras pasta de trabalho ou de planilhas em uma fórmula

Somar e subtrair os valores de data e hora

Exibir cálculos na barra de status do Excel

Adição simples e subtração

Você pode somar e subtrair números usando uma fórmula simples, clicando em um botão, ou usando uma função de planilha.

Adicionar os valores em uma célula usando uma fórmula simples

Se você só precisar de um resultado rápido, use o Excel como uma minicalculadora. Faça isso usando o operador aritmético sinal de mais. (+).

Fórmula

Descrição

Resultado

=5+10

Usa o operador + (sinal de mais) para adicionar dois ou mais valores.

15

=A2+B2

Adiciona os valores em duas ou mais células. Neste caso, presume que A2 = 5 e B2 = 10.

15

=A2+B2+20

Adiciona os valores nas duas células para um número que você insere diretamente na fórmula. Neste caso, presume que A2 = 5 e B2 = 10.

35

Início da página

Subtrair os valores em uma célula usando uma fórmula simples

Faça isso usando o operador aritmético sinal de menos (-). Por exemplo, a fórmula =12-9 exibe um resultado de 3.

Para mais informações sobre como usar operadores aritméticos em uma fórmula, consulte o artigo Usar o Excel como calculadora.

Início da página

Adicione os valores em uma coluna ou linha usando um botão

Você pode usar AutoSoma para somar rapidamente uma série de números em uma coluna ou linha. Clique uma célula vazia abaixo de uma coluna de números ou à direita de uma linha de números, e clique em AutoSoma.O Excel seleciona o que determina ser a faixa mais provável de dados. Clique em AutoSoma novamente para aceitar o intervalo que o Excel selecionar, ou selecione seu próprio intervalo e clique em AutoSoma.

Usar a AutoSoma para adicionar rapidamente uma linha de dados

Para mais informações sobre como usar o AutoSoma, consulte o artigo Usar o Excel como calculadora.

Início da página

Adicione os valores em um intervalo usando uma função

A função SOMA é útil quando você deseja adicionar ou subtrair valores de diferentes intervalos ou combinar valores numéricos com intervalos de números. Use a função SOMA para adicionar todos os argumento que você especificar na abertura e fechamento parênteses. Cada argumento pode ser um intervalo, uma referência de célula, ou um valor numérico positivo ou negativo.

Para inserir uma fórmula simples, digite =SOMA em uma célula, seguido por um parêntese de abertura. Em seguida, digite um ou mais números, referências de células, ou intervalos de células, separadas por vírgulas. Em seguida, digite um parêntese de fechamento e pressione ENTER para exibir o resultado. Você também pode usar o mouse para selecionar as células que contenham dados que você deseja somar.

1

2

3

A

Participação

4823

12335

Por exemplo, ao usar os dados na tabela anterior, todas as fórmulas a seguir usam a função SOMA para retornar o mesmo valor (17158):

  • =SOMA(4823,12335)

  • =SOMA(A2,A3)

  • =SOMA(A2:A3)

  • =SOMA(A2,12335)

A figura a seguir mostra a fórmula que usa a função SOMA para adicionar o valor da célula A2 e 12335. Abaixo da fórmula, uma Dica de Tela fornece orientação sobre a utilização da função. SOMA.

Usar a função SOMA para adicionar uma célula e um valor


Observações   

  • Não existe a função SUBTRAIR no Excel. Para subtrair valores usando uma função, use os valores negativos com a função SOMA. Por exemplo, a fórmula =SOMA(30,A3,-15,-B6) adiciona 30 ao valor na célula A3, subtrai 15, e subtrai o valor na célula B6.

  • Você pode incluir até 255 valores numéricos ou referências de célula ou intervalo, em qualquer combinação, como argumentos na função SOMA.

Para obter mais informações, consulte o artigo Função SOMA.

Início da página

Subtraia os valores em um intervalo usando uma função

Use a função SOMA para subtrair números, digitando os números que deseja subtrair como números negativos na fórmula.

1

2

3

A

Participação

29072

12335

Por exemplo, usando os dados na tabela anterior, todas as fórmulas a seguir usam a função SOMA para retornar o mesmo valor (16737):

  • =SOMA(29072,-12335)

  • =SOMA(A2,-A3)

  • =SOMA(A2,-12335)

  • =SOMA(A2,(-1*(A3)))

Início da página

Somando dados por meio de agrupamento e dinamização

Você pode usar um esquema ou um relatório de Tabela Dinâmica para agrupar e resumir os seus dados.

Adicionar os valores em uma coluna usando um tópico

Se os dados estiverem organizados normalmente (isto é, em linhas e colunas) e você puder agrupá-los logicamente por valores de coluna, você poderá agrupar e resumir os dados através da criação de um esboço. Criar um esboço pode resumir dados por meio da inserção de subtotais e totais gerais. Imagine que você tenha os seguintes números de vendas, organizados por região e por mês.

1

2

3

4

5

6

7

A

B

C

Região

Mês

Vendas

Leste

Jan

R$ 18.000

Leste

Fev

R$ 23.000

Leste

Mar

R$ 19.000

Oeste

Jan

R$ 17.000

Oeste

Fev

R$ 27.000

Oeste

Mar

R$ 21.000

A ilustração abaixo mostra um resumo com subtotais, agrupados por região, e um total geral.

Estrutura de tópicos com subtotais e o total geral

Use o comando Subtotal (guia Dados, grupo Estrutura de tópicos) para criar uma estrutura de tópicos, subtotais e um total geral.

Os dados originais incluíram três linhas de dados para a região Leste e três linhas de dados para a região Oeste (linhas 2 a 7). Observe que a operação de subtotal inserido o total do Leste na linha 5 entre a última linha de dados Leste e a primeira linha de dados Oeste.

Se você clicar na célula A4 e no comando Subtotal, o Excel irá criar uma estrutura de tópicos e inserir linhas paraTotal Leste, Total Oeste e Total Geral e preenche as células na coluna Vendas com esses totais.

Para obter mais informações, consulte os artigos a seguir:

Início da página

Adicionar os valores em uma lista ou coluna de tabela do Excel usando uma função

Como uma alternativa mais flexível ao comando Subtotal, você pode usar a função SUBTOTAL para calcular subtotais e totais gerais em listas ou tabelas do Excel que contenham linhas ou colunas ocultas. Na função SUBTOTAL, você especifica um argumento que inclua ou não valores ocultos.

Observação   A função SUBTOTAL pode controlar se as linhas ocultas são ou não incluídas nos resultados e sempre ignora linhas que foram filtradas.

Por exemplo, suponha que você queira calcular subtotais e um total geral de dados em células de C2 até C7, mas deseja ignorar os dados ocultos na linha 3 e linha 6. A função que você usa é semelhante ao seguinte:

=SUBTOTAL(109,C2:C7)

O primeiro argumento (109) especifica que você deseja adicionar os valores no intervalo e ignora valores ocultos. Para incluir os valores escondidos, em vez disso use 9 como o primeiro argumento.

Para obter mais informações, consulte o artigo Função SUBTOTAL.

Início da página

Somar dados e observá-los de diferentes perspectivas

Quando uma planilha contém centenas ou mesmo milhares de linhas de dados semelhantes, pode ser difícil obter o significado desses números. Você pode criar um relatório de Tabela Dinâmica no Excel a partir desses dados que mostre subtotais, totais, e que possa resumir os dados com base em categorias que você especificar.

Você pode criar rapidamente uma Tabela Dinâmica, selecionando uma célula em um intervalo de dados ou uma tabela do Excel e, em seguida, na guia Inserir, no grupo Tabelas, clicando em Tabela Dinâmica.

Para mostrar a eficiência e uma Tabela Dinâmica, observe que, no exemplo a seguir, os dados de vendas contêm várias linhas (na verdade há 40 linhas de dados, mas o gráfico mostra apenas uma parte). Além disso, os dados não estão resumidos e não têm subtotais ou total geral.

Dados em um relatório de Tabela Dinâmica

Um relatório de Tabela Dinâmica com base nos mesmos dados mostra subtotais, totais, e fornece um resumo conciso imediato.

Dados resumidas e totalizados em um relatório de Tabela Dinâmica

Criar e trabalhar com Tabelas Dinâmicas pode exigir uma preparação inicial dos dados e uma familiaridade com alguns conceitos. Para obter informações detalhadas para ajudar você a começar, consulte os seguintes artigos:


Início da página

Somar dados com base em uma ou mais condições

Ao usar funções de planilha, você pode aplicar condições (também conhecidas como critérios) para adicionar apenas os dados que atendam às condições que você especificar.

Adicionar os valores em um intervalo com base em uma única condição usando uma única função ou uma combinação de funções

Use a função SOMASE ou a aninhe a função SOMA dentro da função SE.

Você pode adicionar números com base em um único critério usando a SOMASE ou usando uma combinação da SOMA e as funções SE.

Por exemplo, a fórmula =SOMASE(A2:A6,">20") adiciona somente os números no intervalo A2 a A6 que são maiores que 20.

Observação   As informações a seguir são um pouco técnicas, mas definitivamente vale a pena aprender.

Se a função SOMASE não existisse, você ainda poderia produzir a mesma resposta, combinando as funções SE e SOMA. Combinar funções dessa maneira também conhecido como "aninhamento", porque uma função é usada em outra função.

Para criar uma fórmula que imita a função SOMASE, insira uma fórmula que trata o intervalo A2 a A6 como uma matriz, o que significa que o intervalo é considerado como uma entidade única contendo cinco células.

Sua fórmula é assim: {=SOMA(SE(A2:A6>20,A2:A6))}. As chaves em "caracóis" que cercam a fórmula indicam que esta é uma fórmula de matriz. Uma fórmula de matriz requer um tratamento especial: em vez de digitar as chaves manualmente, pressione CTRL + SHIFT + ENTER  . Excel, em seguida, envolve a fórmula =SOMA(SE(A2:A6>20,A2:A6)) com as chaves. Se digitar as chaves, você não vai criar uma fórmula de matriz.

Tente isto!    

Copie os dados da tabela a seguir em uma planilha na célula A1. Depois de colar os dados, observe que a célula A10 contém um erro #VALOR! erro. Isto significa que é preciso converter a célula A10 em uma fórmula de matriz. Faça isso pressionando a tecla F2 e em seguida, pressionando CTRL+SHIFT+ENTER. O Excel exibe o resultado (65) nas células A8 e A10.

1

2

3

4

5

6

7

8

9

10

A

Espessura

18

29

36

11

16

Usar a função SOMASE

=SOMASE(A2:A5,">160000")

Usar as funções SOMA e SE

=SOMA(SE(A2:A6>20,A2:A6))

Para mais informações, consulte o artigo Função SOMASE e a seção "Adicionar números com base em uma condição" no artigo Adicionar números.

Consulte também o artigo da Base de Conhecimento Quando usar SOMA(SE()) em vez de Contar.Vazio() fornece orientação adicional sobre quando usar a função SOMASE.

Início da página

Adicionar os valores em um intervalo com base em uma única condição usando uma única função ou uma combinação de funções

Use a função BDSOMA para adicionar os números em um campo (coluna) de registros em uma lista ou banco de dados que correspondam às condições (também conhecidas como critérios) que você especificar.

Use também a função BDSOMA quando você tiver uma lista de colunas e achar que é mais fácil definir as suas condições em um intervalo separado de células em vez de usar uma função aninhada.

Para obter mais informações, consulte o artigo Função BDSOMA.

Consulte também a seção "Adicionar números com base nas condições armazenadas em um intervalo separado" no artigo Adicionar números para mais informações.

Início da página

Adicionar os valores em um intervalo com base em múltiplas condições usando uma única função ou uma combinação de funções

Use a função SOMASES Forneça o intervalo que deseja somar, um intervalo que contém condições e as condições que são aplicadas à faixa condições. Como alternativa, aninhe as funções SOMA e SE.

Para obter mais informações, consulte o artigo Função SOMASES.

Consulte a seção "Adicionar números com base em várias condições" no artigo Adicionar números para obter mais informações sobre como usar as funções SOMA e SE juntas.

Além disso, consulte os artigos da Base de Conhecimento para seguintes informações adicionais:

Início da página

Somar valores ao quadrado e matriz

Você pode usar funções de planilha para adicionar valores em duas ou mais colunas que correspondem entre si. Este tipo de operação pode ser tão simples quanto determinar uma média ponderada (veja o exemplo a seguir que calcula uma média de notas), ou pode ser um cálculo complexo de estatísticas ou de engenharia.

Somar o produto dos valores correspondentes em uma ou mais matrizes

Use a função SOMARPRODUTO. Por exemplo, você pode calcular a média de notas de um aluno usando a função SOMARPRODUTO e dividindo esse resultado pelo número de créditos, como mostrado na figura a seguir.

Multiplicar os valores correspondentes em duas matrizes

A fórmula =SOMARPRODUTO(A2:A6,B2:B6)/SOMA(B2:B6) multiplica a nota obtida para cada matéria pelo seu número de créditos, soma esses produtos (61,3), divide a soma pelo total de créditos (18), e determina a média de notas (3,41). Este tipo de cálculo também é conhecido como uma média ponderada.

Use também a função SOMARPRODUTO em operações matemáticas mais avançadas multiplicando várias matriz.

A função SOMARPRODUTO é fácil de usar com matrizes que têm as mesmas dimensões, mas você também pode usar a função SOMA em uma fórmula de matriz se precisar de mais flexibilidade.

Para obter mais informações, consulte o artigo Função SOMARPRODUTO.

As seguintes quatro funções normalmente são utilizadas apenas em estatísticas avançadas ou aplicações matemáticas complexas, de modo que apenas uma breve descrição é fornecida. Para mais informações, clique no nome da função para ir diretamente ao seu tópico de referência.

  • Função SOMAQUADRetorna a soma dos quadrados de uma lista de números ou valores em um intervalo. Por exemplo, SOMAQUAD(2,3) retorna 13.

  • Função SOMAX2SY2Acrescenta a soma dos quadrados dos valores correspondentes em duas matrizes.

  • Função SOMAX2MY2  Retorna a soma da diferença dos quadrados dos valores correspondentes em duas matrizes.

  • Função SOMAXMY2 Retorna a soma dos quadrados das diferenças dos valores correspondentes em duas matrizes.

Início da página

Casos especiais (execução de total, valores únicos)

Você pode usar funções de planilha para criar totais que são atualizados automaticamente quando você adiciona mais dados a um intervalo ou uma tabela, ou para adicionar apenas os valores exclusivos que são encontrados em um intervalo ou uma tabela.

Criar um total de análise usando uma função

Use a função SOMA. Por exemplo, crie títulos de coluna em uma planilha chamada Depósitos, Retiradas e Balanço.

  1. Na primeira célula, na coluna Balanço, insira o seu balanço inicial.

  2. Na célula diretamente abaixo do seu balanço (neste caso, C3), digite uma fórmula que adicione o valor da coluna Depósitos na mesma linha e subtraia o valor da coluna Retiradas(=SOMA(C2,A3,-B3).

  3. Arraste esta fórmula para baixo para qualquer linha nova que você adicionar. No exemplo a seguir, a fórmula é arrastada para a linha 4.

1

2

3

4

A

B

C

Depósitos

Retiradas

Balanço

500

1000

625

=SOMA(C2;A3;-B3)

1000

740

=SOMA(C3,A4,-B4)

Você pode usar um balanço atual como usaria um registrador para observar valores de itens nas células aumentar ou diminuir à medida que você inserir novos itens e valores ao longo do tempo.

Para obter mais informações, consulte o artigo Calcular o balanço atual.

Início da página

Adicionar os valores exclusivos usando uma fórmula composta

Em uma coluna, insira uma lista de valores que contenha duplicatas, depois use uma combinação das funções SOMA, SE e FREQUÊNCIA para adicionar somente os valores exclusivos encontrados naquele intervalo.

Para obter informações detalhadas sobre como executar este tipo de operação, consulte a seção "Adicionar valores únicos" seção no artigo Adicionar números.

Início da página

Incluir valores de outras pasta de trabalho ou de planilhas em uma fórmula

Você pode adicionar ou subtrair células ou intervalos de dados de outras planilhas ou pastas de trabalho em uma fórmula através da inclusão de uma referência a eles. Para se referir a uma célula ou um intervalo em outra planilha ou pasta de trabalho, use as instruções na tabela a seguir.

Para se referir a:

Insira isto

Exemplos

Uma célula ou intervalo em outra planilha na mesma pasta de trabalho

O nome da planilha seguido por um ponto de exclamação, seguido da referência de célula ou o nome de intervalo.

Folha2!B2:B4
Folha3!NúmerosDeVendas

Uma célula ou intervalo em outra pasta de trabalho que está atualmente aberta

O nome do arquivo da pasta de trabalho entre parênteses ([]) e o nome da planilha seguido por um ponto de exclamação, seguido da referência de célula ou nome de intervalo.

[MinhaPastaDeTrabalho.xlsx]Folha1!A7

Uma célula ou intervalo em outra pasta de trabalho que não está aberta

O caminho completo e o nome do arquivo da pasta de trabalho entre parênteses ([]) e o nome da planilha seguido por um ponto de exclamação, seguido da referência de célula ou nome de intervalo. Se o caminho completo contiver caracteres de espaço, cerque o início do caminho e o final do nome da planilha com aspas simples (veja o exemplo).

['C:\Meus Documentos\[MinhaPastaDeTrabalho.xlsx]Folha1'!A2:A5


Início da página

Somar e subtrair os valores de data e hora

Você pode usar funções de data e hora e até mesmo uma simples adição ou subtração para calcular o tempo decorrido, estimar datas de conclusão de projetos, e muito mais. A tabela a seguir mostra algumas fórmulas que calculam horas e dias decorridos. Observe que se você subtrair uma data ou hora que resulte em um valor negativo, o Excel exibe os caracteres ### na célula que contém a fórmula.

1

2

3

4

5

A

B

C

Hora de início

Hora de término

Fórmula de tempo decorrido

Descrição (resultado)

11:55:24 AM

2:48:13 PM

=B2-A2

Exibe o tempo decorrido em horas, minutos e segundos. Neste caso, o Excel exibe o resultado (02:52:49 AM) em um formato "AM" porque a diferença é menor que 12 horas. Se a diferença for de 12 horas ou mais, o Excel exibirá um formato "PM".

Data de início

Data de término

Fórmula de dias decorridos

Descrição (resultado)

28/05/2008

03/06/2008

=B5-A5

Exibe dias decorridos como um número (6)

Trabalhar com valores de data e hora pode produzir resultados inesperados, então siga com cuidado.

Início da página

Exibir cálculos na barra de status do Excel

Para conferir rapidamente os totais de células que são selecionados em sua planilha, confira a barra de status do Excel (a barra de status está na parte inferior da janela do documento). Na barra de status, o Excel exibe a soma de duas ou mais células selecionadas que contenham dados numéricos. O valor da soma da barra de status atualiza tão rapidamente quanto você pode marcar ou desmarcar células.

Barra de status do Excel

Barra de status do Excel

Valor da soma calculada na barra de status do Excel

Quando uma ou mais células são selecionadas, as informações sobre os dados nessas células são exibidas na barra de status do Excel. Por exemplo, se quatro células na sua planilha forem selecionadas, e contiverem os valores 2, 3, uma cadeia de texto (como "nuvem"), e 4, todos os valores a seguir poderão ser exibidos na barra de status ao mesma tempo: Média, Contagem, Contagem Numérica, Mín, Máx e Soma. Clique com botão direito do mouse na barra de status para mostrar ou ocultar alguns ou todos esses valores. Estes valores são mostrados na ilustração a seguir.

Barra de status mostrando cálculos e contagens de células selecionadas

Observação    Nas versões do Excel anteriores ao Excel 2007, esses mesmos valores podem ser exibidos na barra de status, mas apenas um valor por vez.

Início da página

Aplicável a: Excel 2007, Excel 2010



Essas informações foram úteis?

Sim Não

Como podemos melhorá-lo?

255 caracteres restantes

Para proteger sua privacidade, não inclua informações de contato em seus comentários. Avalie nosso política de privacidade.

Obrigado por seus comentários!

Recursos de suporte

Alterar idioma