Maneiras de somar valores em uma planilha

Contar x somar

Somar (adicionar valores) faz parte da análise de dados, seja subtotalizando vendas na região noroeste ou fazendo uma soma acumulada dos recibos semanais. O Excel fornece várias técnicas que você pode usar para somar dados.

Para ajudá-lo a fazer a melhor escolha, este artigo fornece um resumo abrangente de métodos, informações para ajudá-lo a decidir rapidamente qual técnica usar e links para artigos detalhados.

Somar o conteúdo de células não deve ser confundido com contar o número de células. Para obter mais informações sobre como contar o número de células, colunas ou linhas de dados, confira a função CONT.SE.

Neste artigo

Adição e subtração simples

Somando dados agrupando e dinamizando

Somar dados com base em uma ou mais condições

Somar valores quadrados e de matriz

Casos especiais (soma acumulada, valores exclusivos)

Incluindo valores de outras planilhas ou pastas de trabalho em uma fórmula

Somando e subtraindo valores de data e hora

Exibindo cálculos na barra de status do Excel

Adição e subtração simples

Você pode adicionar e subtrair números usando uma fórmula simples, clicando em um botão ou usando uma função de planilha.

Adicionar os valores em uma célula usando uma fórmula simples

Se você precisa apenas de um resultado rápido, poderá usar o Excel como uma minicalculadora. Faça isso usando o operador aritmético + (sinal de mais).

Fórmula

Descrição

Resultado

=5+10

Usa o operador + (sinal de mais) para adicionar dois ou mais valores.

15

=A2+B2

Adiciona os valores em duas ou mais células. Neste caso, vamos supor A2 = 5 e B2 = 10.

15

=A2+B2+20

Adiciona os valores nas duas células a um número que você insere diretamente na fórmula. Neste caso, vamos supor A2 = 5 e B2 = 10.

35

Início da página

Subtrair os valores em uma célula usando uma fórmula simples

Faça isso usando o operador aritmético - (sinal de menos). Por exemplo, a fórmula =12-9 exibe um resultado 3.

Para obter mais informações sobre como usar operadores aritméticos em uma fórmula, confira o artigo Usar o Excel como calculadora.

Início da página

Adicionar os valores em uma coluna ou linha usando um botão

Você pode usar a AutoSoma para somar rapidamente um intervalo de números em uma coluna ou linha. Clique em uma célula vazia abaixo de uma coluna de números ou à direita de uma linha de números e, em seguida, clique em AutoSoma. O Excel seleciona o que determina ser o intervalo de dados mais provável. Clique em AutoSoma novamente para aceitar o intervalo que o Excel seleciona ou escolha seu próprio intervalo e, em seguida, clique em AutoSoma.

Usar a AutoSoma para adicionar rapidamente uma linha de dados

Para obter mais informações sobre como usar AutoSoma, confira o artigo Usar o Excel como calculadora.

Início da página

Adicione os valores em um intervalo usando uma função

A função SOMA é útil quando você quer adicionar ou subtrair valores de intervalos diferentes ou combinar valores numéricos com intervalos de números. Use a função SOMA para adicionar todos os argumentos especificados por você dentro dos parênteses de abertura e fechamento. Cada argumento pode ser um intervalo, uma referência de célula ou um valor numérico positivo ou negativo.

Para inserir uma fórmula simples, digite =SOMA na célula e, depois, insira um parêntese de abertura. Em seguida, digite um ou mais números, referências de célula ou intervalos de células, separados por vírgulas. Em seguida, digite um parêntese de fechamento e pressione ENTER para exibir o resultado. Você também pode usar o mouse para selecionar células que contêm dados que você quer somar.

1

2

3

A

Presença

4823

12335

Por exemplo, com os dados da tabela anterior, todas as fórmulas a seguir usam a função SOMA para retornar o mesmo valor (17158):

  • =SOMA(4823;12335)

  • =SOMA(A2;A3)

  • =SOMA(A2:A3)

  • =SOMA(A2;12335)

A figura a seguir mostra a fórmula que usa a função SOMA para adicionar o valor da célula A2 e 12335. Abaixo da fórmula, uma Dica de Tela fornece orientação para usar a função SOMA.

Usar a função SOMA para adicionar uma célula e um valor


Observações : 

  • Não existe a função SUBTRAIR no Excel. Para subtrair valores usando uma função, use os valores negativos com a função SOMA. Por exemplo, a fórmula =SOMA(30;A3;-15;-B6) adiciona 30 ao valor na célula A3; subtrai 15 e, em seguida, subtrai o valor na célula B6.

  • Você pode incluir até 255 valores numéricos ou referências de célula ou intervalo, em qualquer combinação, como argumentos na função SOMA.

Para obter mais informações, confira o artigo Função SOMA.

Início da página

Subtraia os valores em um intervalo usando uma função

Use a função SOMA para subtrair números inserindo os números que você deseja subtrair como números negativos na fórmula.

1

2

3

A

Presença

29072

12335

Por exemplo, com os dados da tabela anterior, todas as fórmulas a seguir usam a função SOMA para retornar o mesmo valor (16737):

  • =SOMA(29072;-12335)

  • =SOMA(A2;-A3)

  • =SOMA(A2;-12335)

  • =SOMA(A2;(-1*(A3)))

Início da página

Somar dados agrupando e dinamizando

Você pode usar uma estrutura de tópicos ou um relatório de tabela dinâmica para agrupar e resumir seus dados.

Adicionar os valores em uma coluna usando uma estrutura de tópicos

Se seus dados estiverem organizados normalmente (ou seja, em linhas e colunas) e você puder agrupá-los logicamente por valores de coluna, você poderá agrupar e resumir dados criando uma estrutura de tópicos. Criar uma estrutura de tópicos pode resumir dados inserindo subtotais e totais gerais. Suponha que você tenha as seguintes estimativas de vendas, organizadas por mês e região.

1

2

3

4

5

6

7

A

B

C

Região

Mês

Vendas

Leste

Jan

R$ 18.000

Leste

Fev

R$ 23.000

Leste

Mar

R$ 19.000

Oeste

Jan

R$ 17.000

Oeste

Fev

R$ 27.000

Oeste

Mar

R$ 21.000

A ilustração a seguir mostra uma estrutura de tópicos com subtotais, agrupados por região, e um total geral.

estrutura de tópicos com subtotais e o total geral

Use o comando Subtotal (guia Dados, grupo Estrutura de Tópicos) para criar uma estrutura de tópicos, subtotais e um total geral.

Os dados originais incluíam três linhas de dados para a região Leste e três linhas de dados para a Oeste (linhas 2 a 7). Observe que a operação de subtotal inseriu o Total do Leste na linha 5 entre a última linha de dados do Leste e a primeira linha de dados do Oeste.

Se você clicar na célula A4 e, em seguida, no comando Subtotal, o Excel criará uma estrutura de tópicos e inserirá linhas para Total do Leste, Total do Oeste e Total Geral, e preencherá as células na coluna Vendas com esses totais.

Para obter mais informações, consulte os seguintes artigos:

Início da página

Adicionar os valores em uma lista ou coluna de tabela do Excel usando uma função

Como uma alternativa mais flexível para o comando Subtotal, você pode usar a função SUBTOTAL para calcular subtotais e totais gerais em listas ou tabelas do Excel que contêm linhas ou colunas ocultas. Na função SUBTOTAL, você especifica um argumento que inclui ou não valores ocultos.

Observação : A função SUBTOTAL pode controlar se as linhas ocultas são incluídas ou não nos resultados e sempre ignora linhas que foram filtradas.

Por exemplo, suponha que você deseja calcular subtotais e total geral de dados nas células C2 a C7, mas deseja ignorar os dados ocultos nas linhas 3 e 6. A função que você usa é semelhante ao seguinte:

=SUBTOTAL(109;C2:C7)

O primeiro argumento (109) especifica que você deseja adicionar os valores no intervalo e ignorar valores ocultos. Para incluir os valores ocultos, em vez disso, use 9 como primeiro argumento.

Para obter informações detalhadas, confira o artigo Função SUBTOTAL.

Início da página

Somar dados e examiná-los de perspectivas diferentes

Quando uma planilha contém centenas ou mesmo milhares de linhas de dados semelhantes, pode ser difícil obter algum significado a partir desses números. Você pode criar um relatório de tabela dinâmica no Excel a partir desses dados que mostre subtotais, totais e que pode resumir dados com base nas categorias que você especificar.

Você pode criar rapidamente uma tabela dinâmica, selecionando uma célula em um intervalo de dados ou tabela do Excel e, em seguida, na guia Inserir, no grupo Tabelas, clicando em Tabela Dinâmica.

Para mostrar o poder de uma tabela dinâmica, observe que, no exemplo a seguir, os dados de vendas contêm muitas linhas (há na verdade 40 linhas de dados, mas o gráfico mostra somente uma parte). Além disso, os dados não estão resumidos, e não há subtotais ou total geral.

Dados em um relatório de Tabela Dinâmica

Um relatório de tabela dinâmica com base nos mesmos dados mostra subtotais, totais gerais e fornece um resumo conciso num relance.

Dados resumidas e totalizados em um relatório de Tabela Dinâmica

Criar e trabalhar com tabelas dinâmicas pode exigir alguma preparação inicial dos seus dados e familiaridade com alguns conceitos. Para obter informações detalhadas para ajudá-lo a começar, confira os seguintes artigos:


Início da página

Somar valores com base em uma ou mais condições

Usando funções de planilha, você pode aplicar condições (também conhecidas como critérios) para adicionar somente os dados que atendam às condições especificadas.

Adicione os valores em um intervalo com base em uma única condição usando uma única função ou uma combinação de funções

Use a função SOMASE ou aninhe a função SOMA dentro da função SE.

Você pode adicionar números com base em um único critério usando a função SOMASE ou usando uma combinação das funções SOMA e SE.

Por exemplo, a fórmula =SOMASE(A2:A6;">20") adiciona apenas os números no intervalo de A2 a A6 que são maiores do que 20.

Observação : As informações a seguir são um pouco técnicas, mas definitivamente vale a pena aprender.

Se a função SOMASE não existisse, você ainda poderia produzir a mesma resposta combinando as funções SE e SOMA. Combinar funções dessa maneira também é conhecido como "aninhamento", porque uma função é usada em outra função.

Para criar uma fórmula que simule a função SOMASE, insira uma fórmula que trate o intervalo de A2 a A6 como uma matriz, o que significa que o intervalo é considerado uma única entidade que contém cinco células.

Sua fórmula tem esta aparência: {=SOMA(SE(A2:A6>20;A2:A6))}. As chaves que envolvem a fórmula indicam que se trata de uma fórmula de matriz. Uma fórmula de matriz exige algum tratamento especial: Em vez de digitar as chaves, você deverá pressionar CTRL+SHIFT+ENTER  – o Excel envolve a fórmula =SOMA(SE(A2:A6>20;A2:A6)) com as chaves. Se você digitar as chaves, não crie uma fórmula de matriz.

Tente fazer isto!    

Copie os dados da tabela a seguir para uma planilha na célula A1. Depois de colar os dados, observe que a célula A10 contém um erro #VALOR!. Isso significa que você precisa converter a célula A10 para uma fórmula de matriz. Faça isso pressionando F2 e, em seguida, pressionando CTRL+SHIFT+ENTER. O Excel exibe o resultado (65) nas células A8 e A10.

1

2

3

4

5

6

7

8

9

10

A

Peso

18

29

36

11

16

Usando a função SOMASE

=SOMASE(A2:A6;">20")

Usando a função SOMA e SE

=SOMA(SE(A2:A6>20;A2:A6))

Para obter mais informações, confira o artigo função SOMASE e a seção "Adicionar números com base em uma condição" no artigo Adicionar números.

Além disso, o artigo da Base de Dados de Conhecimento Quando usar SOMA(SE()) em vez de ContarVazio() fornece orientações sobre quando usar a função SOMASE.

Início da página

Adicionar os valores em uma coluna com base em uma única condição ou várias usando uma função

Use a função BDSOMA para adicionar os números em um campo (coluna) de registros em uma lista ou banco de dados que coincidem com as condições (também chamadas de critérios) especificadas.

Você também pode usar a função BDSOMA quando tiver uma lista de colunas e achar mais fácil definir as condições em um intervalo separado de células em vez de usar uma função aninhada.

Para obter mais informações, confira o artigo Função BDSOMA.

Veja também a seção “Adicionar números com base em condições armazenadas em um intervalo separado” no artigo Adicionar números para obter mais informações.

Início da página

Adicionar os valores em um intervalo com base em várias condições usando uma única função ou uma combinação de funções

Use a função SOMASE. Forneça o intervalo que você deseja somar, um intervalo que contém as condições e as condições que se aplicam ao intervalo de condições. Como alternativa, você pode aninhar as funções SOMA e SE.

Para obter mais informações, confira o artigo Função SOMASE.

Confira a seção "Adicionar números com base em condições múltiplas" no artigo Adicionar números para obter mais informações sobre como usar as funções SOMA e SE em conjunto.

Além disso, confira os seguintes artigos da Base de Dados de Conhecimento da Microsoft para obter informações adicionais:

Início da página

Somar valores quadrados e de matriz

Você pode usar funções de planilha para adicionar valores em duas ou mais colunas que se correspondem entre si. Esse tipo de operação pode ser tão simples quanto determinar uma média ponderada (confira o exemplo a seguir que calcula a média de uma pontuação) ou pode ser um cálculo estatístico ou de engenharia complexo.

Somar o produto dos valores correspondentes em uma ou mais matrizes

Use a função SOMARPRODUTO. Por exemplo, você pode calcular a média da pontuação de um aluno usando a função SOMARPRODUTO e dividindo esse resultado pelo número de créditos, conforme mostrado na figura a seguir.

Multiplicar os valores correspondentes em duas matrizes

A fórmula =SOMARPRODUTO(A2:A6;B2:B6)/SOMA(B2:B6) multiplica a nota final obtida para cada classe por seu número de créditos, soma os produtos (61,3), divide essa soma pelo total de créditos (18) e determina a média da pontuação (3,41). Esse tipo de cálculo também é conhecido como média ponderada.

Você também pode usar a função SOMARPRODUTO em operações matemáticas mais avançadas multiplicando várias matrizes.

A função SOMARPRODUTO é fácil de usar com matrizes que têm as mesmas dimensões, mas você também pode usar a função SOMA em um fórmula de matriz se precisar de mais flexibilidade.

Para obter informações mais detalhadas, confira o artigo Função SOMARPRODUTO.

As quatro funções a seguir são normalmente usadas apenas em aplicações matemáticas complexas ou estatísticas avançadas. Portanto, apenas uma breve descrição é fornecida. Para obter mais informações, clique no nome da função para ir diretamente para o tópico de referência correspondente.

  • Função SOMAQUAD: retorna a soma dos quadrados de uma lista de números ou valores em um intervalo. Por exemplo, SOMAQUAD(2,3) retorna 13.

  • Função SOMAX2PY2: adiciona a soma dos quadrados de valores correspondentes em duas matrizes.

  • Função SOMAX2MY2: retorna a soma da diferença dos quadrados dos valores correspondentes em duas matrizes.

  • Função SOMAXMY2: retorna a soma dos quadrados das diferenças dos valores correspondentes em duas matrizes.

Início da página

Casos especiais (soma acumulada, valores exclusivos)

Você pode usar funções de planilha para criar totais que são atualizados automaticamente à medida que você adiciona mais dados a um intervalo ou tabela ou para adicionar apenas os valores exclusivos que são encontrados em um intervalo ou tabela.

Criar uma soma acumulada usando uma função

Use a função SOMA Por exemplo, crie títulos de coluna em uma planilha chamada Depósitos, Retiradas e Saldo.

  1. Na primeira célula na coluna Saldo coluna, insira o saldo inicial.

  2. Na célula diretamente abaixo seu saldo (nesse caso, C3), insira uma fórmula que adiciona o valor da coluna Depósitos na mesma linha e subtrai o valor a partir da coluna Retiradas(=SOMA(C2;A3;-B3).

  3. Arraste esta fórmula para baixo para as novas linhas que você adicionar. No exemplo a seguir, a fórmula é arrastada para a linha 4.

1

2

3

4

A

B

C

Depósitos

Retiradas

Saldo

500

1.000

625

=SOMA(C2;A3;-B3)

1.000

740

=SOMA(C3;A4;-B4)

Você pode usar o saldo como usaria um registro de cheques para ver os valores de itens em células aumentarem ou diminuírem enquanto você digita novos itens e valores ao longo do tempo.

Para obter mais informações, confira o artigo Calcular um saldo.

Início da página

Adicionar os valores exclusivos em um intervalo usando uma fórmula composta

Em uma coluna, insira uma lista de valores que contém duplicatas e, em seguida, use uma combinação das funções SOMA, SE e FREQUÊNCIA para adicionar somente os valores exclusivos que são encontrados nesse intervalo.

Para obter informações detalhadas sobre como executar esse tipo de operação, confira a seção "Adicionar valores exclusivos" no artigo Adicionar números.

Início da página

Incluir valores de outras planilhas ou pastas de trabalho em uma fórmula

Você pode adicionar ou subtrair células ou intervalos de dados de outras planilhas ou pastas de trabalho em uma fórmula, incluindo uma referência a eles. Para fazer referência a uma célula ou intervalo em outra planilha ou pasta de trabalho, use as instruções na tabela a seguir.

Para se referir a:

Insira o seguinte

Exemplos

Uma célula ou intervalo em outra planilha na mesma pasta de trabalho

O nome da planilha seguido de um ponto de exclamação, seguido do nome de intervalo ou referência de célula.

Planilha2!B2:B4
Planilha3!ValoresVendas

Uma célula ou intervalo em outra pasta de trabalho que está aberta no momento

O nome do arquivo da pasta de trabalho entre colchetes ([]) e o nome da planilha seguido de um ponto de exclamação, seguido do nome de intervalo ou referência de célula.

[MinhaPastadeTrabalho.xlsx]Planilha1!A7

Uma célula ou intervalo em outra pasta de trabalho que não está aberta

O caminho completo e o nome do arquivo da pasta de trabalho entre colchetes ([]) e o nome da planilha seguido de um ponto de exclamação, seguido do nome de intervalo ou referência de célula. Se o caminho completo contiver caracteres de espaço, coloque o início do caminho e o final do nome de planilha entre aspas (confira o exemplo).

['C:\Meus Documentos\[MinhaPastadeTrabalho.xlsx]Planilha1'!A2:A5


Início da página

Somar e subtrair valores de data e hora

Você pode usar funções de data e hora e até mesmo uma simples adição ou subtração para calcular o tempo decorrido, estimar as datas de conclusão para projetos e muito mais. A tabela a seguir mostra algumas fórmulas que calculam tempos decorridos e dias. Observe que, se você subtrair uma data ou hora que resulta em um valor negativo, o Excel exibirá os caracteres ### na célula que contém a fórmula.

1

2

3

4

5

A

B

C

Hora de início

Hora de término

Fórmula de tempo decorrido

Descrição (resultado)

11:55:24 AM

2:48:13 PM

=B2-A2

Exibe o tempo decorrido em horas, minutos e segundos. Nesse caso, o Excel exibe o resultado (2:52:49 AM) em um formato "AM" porque a diferença é menor do que 12 horas. Se a diferença fosse de 12 horas ou mais, o Excel exibiria um formato "PM". Se usar o horário de 24 horas, o Excel exibe as horas sem "AM" ou "PM".

Data de início

Data final

Fórmula de dias decorridos

Descrição (resultado)

28/5/2008

03/6/2008

=B5-A5

Exibe os dias decorridos como um número (6).

Trabalhar com valores de data e hora pode produzir resultados inesperados; portanto, continue com cuidado.

Início da página

Exibir cálculos na barra de status do Excel

Para dar uma rápida olhada nos totais de células que são selecionadas em sua planilha, examine a barra de status do Excel (na parte inferior da janela do documento). Na barra de status, o Excel exibe a soma de duas ou mais células selecionadas que contêm dados numéricos. O valor de soma na barra de status é atualizado assim que você seleciona ou cancela a seleção de células.

Barra de status do Excel

Barra de status do Excel

Valor de soma calculada na barra de status do Excel

Quando uma ou mais células estão selecionadas, as informações sobre os dados nessas células são exibidas na barra de status do Excel. Por exemplo, se quatro células da planilha estão selecionadas e contêm os valores 2, 3, uma cadeia de texto (como "nuvem") e 4, todos os valores a seguir podem ser exibidos na barra de status ao mesmo tempo: Média, Contagem, Contagem Numérica, Mín, Máx e Soma. Clique com o botão direito do mouse na barra de status para mostrar ou ocultar algum desses valores ou todos. Esses valores são mostrados na ilustração a seguir.

Barra de status mostrando cálculos e contagens de células selecionadas

Observação   : em versões do Excel anteriores ao Excel 2007, esses mesmos valores podem ser exibidos na barra de status, mas apenas um valor de cada vez.

Início da página

Essas informações foram úteis?

Ótimo! Outros comentários?

Como podemos melhorá-lo?

Obrigado por seus comentários!

×