Introdução ao SharePoint Designer 2010

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Microsoft SharePoint Designer 2010 é uma Web e o programa de design do aplicativo usado para projetar, criar e personalizar sites executados em SharePoint Foundation 2010 e Microsoft SharePoint Server 2010. Com SharePoint Designer 2010, você pode criar páginas da Web de dados sofisticados, criar poderosas soluções habilitados para fluxo de trabalho e a aparência do seu site de design.

Use os links abaixo para saber mais sobre SharePoint Designer 2010 por meio de artigos, vídeos e outros recursos de aprendizado. Use os procedimentos a seguir para saber mais sobre as tarefas básicas que você pode executar SharePoint Designer 2010.

Logotipo Get Started

O que você wan t

Onde a g o

Deseja apenas saber o que mudou?   

Descobrir as novidades desta versão e como aproveitar ao máximo os novos recursos.

Novidades do SharePoint Designer 2010

Procurando menus e comandos da versão 2007?   

Consulte a tabela de comandos de menu e de barra de ferramentas da versão 2007 e saiba mais sobre seus novos locais usando esta pasta de trabalho de mapeamento.

Guias de mapeamento para aplicativos do Microsoft Office

Nunca usou o SharePoint Designer antes?   

Saiba quais SharePoint Designer 2010 é tudo sobre e como aproveitar ao máximo-lo em sua organização.

Introdução ao SharePoint Designer 2010

Procurando treinamento para você e outros integrantes de sua equipe?   

Se tornar mais produtivo nesta versão com treinamento em SharePoint Designer 2010.

Treinamento do Microsoft Office

Tarefas básicas no SharePoint Designer 2010

Abrir e criar sites do SharePoint

Criar listas, bibliotecas e conexões para fontes de dados

Criar modos de exibição e formulários personalizados

Criar fluxos de trabalho personalizados

Projetar páginas, páginas mestras e layouts de página do site

Salvar como modelo

Abrir e criar sites do SharePoint

Em SharePoint Designer 2010, você pode abrir os sites do SharePoint existentes no servidor e iniciar personalizá-los e você pode criar novos sites com base em modelos de site do SharePoint ou sites de novos e vazios que você personalizar do zero.

Abrir sites

Para abrir um site existente, clique na guia Arquivo, escolha Sites e execute um dos seguintes procedimentos:

  • Clique em Abrir Site para procurar sites disponíveis no servidor.

  • Clique em Personalizar Meu Site para abrir e personalizar Meu Site.

  • Em Sites Recentes, selecione um site no qual você trabalhou anteriormente.

Criar sites

Para criar um novo site, clique na guia Arquivo, escolha Sites e execute um dos seguintes procedimentos:

  • Clique em Novo Site em Branco para criar um site do SharePoint vazio, em branco.

  • Clique emAdicionar Subsite ao Meu Site para criar um novo site em Meu Site.

  • Em Modelos de Site, selecione um modelo para criar um novo site com base em um modelo do SharePoint.

Observação : Além de abertura e criação de sites de dentro de SharePoint Designer 2010, você pode abrir um site do SharePoint usando o navegador e abra esse site em SharePoint Designer 2010 usando os links disponíveis no menu Ações do Site, a faixa de opções e outros locais no SharePoint.

Início da Página

Criar listas, bibliotecas e conexões para fontes de dados

Em SharePoint Designer 2010, você pode criar listas e bibliotecas, que normalmente servem como fonte de dados para os sites do SharePoint, e você pode criar conexões de fontes de dados para arquivos XML, bancos de dados externos e serviços Web.

Listas e bibliotecas do SharePoint

Para criar uma lista ou biblioteca do SharePoint, clique em Listas e Bibliotecas no painel Navegação e escolha uma das seguintes opções da guia Listas e Bibliotecas:

  • Clique em Lista Personalizada para criar uma lista em branco do zero.

  • Clique em Lista do SharePoint para criar uma lista com base em um modelo do SharePoint.

  • Clique em Biblioteca de Documentos para criar uma biblioteca com base em um modelo do SharePoint.

  • Clique em Lista Externa para criar uma lista externa com base em um tipo de conteúdo externo. (Tipos de conteúdo externos são explicados a seguir.)

  • Clique em Lista da Planilha para criar uma lista com base em uma planilha importada.

Conexões de fonte de dados

Para criar uma conexão de fonte de dados, clique em Fontes de Dados no painel Navegação e escolha uma das seguintes opções da guia Fontes de Dados.

  • Clique em Fonte de Dados Vinculada para criar uma conexão de dados para várias fontes de dados.

  • Clique em Conexão de Banco de Dados para criar uma conexão de dados com um banco de dados que ofereça suporte ao protocolo OLE DB ou ODBC.

  • Clique em Conexão de Serviço SOAP para criar uma conexão com um serviço da Web XML usando SOAP (Simple Object Access Protocol).

  • Clique em Conexão de Serviço REST para criar uma conexão com um script de servidor usando REST (Representational State Transfer).

  • Clique em Conexão de Arquivo XML para criar uma conexão com um arquivo de origem XML.

Tipos de conteúdo externo

Usando tipos de conteúdo externo, você pode conectar-se a fontes de dados empresariais externas e integrar essas fontes com o site do SharePoint e os aplicativos cliente com suporte. Uma vez criado um tipo de conteúdo externo, você poderá criar listas externas que permitam aos usuários interagir com os dados como se fossem qualquer lista ou biblioteca do SharePoint.

Para criar um tipo de conteúdo externo, execute estas etapas.

  1. Clique em Tipos de Conteúdo Externo no painel Navegação.

  2. Na guia Tipos de Conteúdo Externo, clique em Tipo de Conteúdo Externo e, em seguida, crie operações, campos etc. de tipo de conteúdo externo.

Início da Página

Criar modos de exibição e formulários personalizados

No SharePoint Designer 2010, você pode criar exibições personalizadas e formulários para os seus dados fontes, que realmente se tornam a interface para ler e gravar dados essas fontes de dados.

Modos de exibição

Um modo de exibição é uma exibição personalizável ao vivo de uma fonte de dados que pode ser adicionada a qualquer página do SharePoint. No SharePoint Designer 2010, você pode criar modos de exibição de lista (que usam a Web Part de exibição de lista XSLT) e modos de exibição de dados (que usam a Web Part de formulário de dados). Execute uma das etapas a seguir para criar um modo de exibição de lista ou de dados.

  • No painel Navegação, clique em Listas e Bibliotecas, selecione a lista desejada para a qual criar um modo de exibição e, em seguida, na guia Definições da Lista, clique em Modo de Exibição de Lista.

    Observação : Isso cria um modo de exibição associado à lista ou biblioteca. Como resultado, os usuários verão o modo de exibição e poderão personalizá-lo usando o grupo Gerenciar Modos de Exibição na faixa de opções do SharePoint.

  • No painel Navegação, clique em Páginas do Site, edite a página na qual deseja criar o modo de exibição, clique na guia Inserir, escolha Modo de Exibição de Dados e, em seguida, escolha a lista ou biblioteca do SharePoint que você deseja usar para modo de exibição.

Formulários

Um formulário é uma exibição personalizáveis de uma fonte de dados que você usar para enviar ou gravar de volta para a fonte de dados. No SharePoint Designer 2010, você pode criar formulários de lista e formulários de dados (que usam a Web Part de formulário de dados). Execute uma das etapas a seguir para criar um formulário de lista ou de dados.

  • No painel Navegação, clique em Listas e Bibliotecas, selecione a lista desejada para a qual criar um formulário e, em seguida, na guia Definições da Lista, clique em Formulário de Lista.

  • No painel Navegação, clique em Páginas do Site, edite a página na qual você deseja criar o formulário, clique na guia Inserir, escolha Novo Formulário de Itens, Editar Formulário de Itens ou Exibir Formulário de Itens e selecione a fonte de dados que você deseja usar para o formulário.

Observação : Além de usar as ferramentas de design de formulário em SharePoint Designer 2010, você pode criar e personalizar formulários do SharePoint usando o Microsoft InfoPath 2010.

Início da Página

Criar fluxos de trabalho personalizados

Em SharePoint Designer 2010, você pode gerenciar processos de negócios usando fluxos de trabalho altamente personalizados. Fluxos de trabalho podem ser usados para gerenciar processos de aplicativos, além de processos colaborativos humanos. Você tem várias opções ao criar fluxos de trabalho.

Criar fluxos de trabalho em SharePoint Designer 2010

Ao criar um fluxo de trabalho, você pode criar um com base em uma lista ou biblioteca do SharePoint, um reutilizável que possa ser aplicado a qualquer lista ou biblioteca e um fluxo de trabalho de site que funcione no nível de site.

Para criar esses fluxos de trabalho, clique em Fluxos de trabalho no painel Navegação e, na guia Fluxos de trabalho, execute uma das seguintes etapas:

  • Clique em Fluxo de Trabalho de Lista e escolha a lista à qual você deseja associar o fluxo de trabalho.

  • Clique em Fluxo de Trabalho Reutilizável para criar um fluxo de trabalho reutilizável que possa ser associado a qualquer lista ou biblioteca.

  • Clique em Fluxo de Trabalho de Site para criar um fluxo de trabalho que possa ser aplicado no nível de site.

Uma vez criado o fluxo de trabalho, use o designer para estruturar as condições, as ações e as etapas do fluxo de trabalho. Use o designer de tarefas para gerenciar os eventos associados a cada tarefa.

Fluxos de trabalho de importação do Microsoft Visio 2010

Além de criar fluxos de trabalho em SharePoint Designer 2010, você pode importar um fluxo de trabalho criado em Microsoft Visio 2010 usando o fluxo de trabalho fornecido estênceis e modelos.

Para importar um fluxo de trabalho, clique em Fluxos de trabalho no painel Navegação e, na guia Fluxos de trabalho, execute as seguintes etapas:

  1. Clique em Importar do Visio e navegue no sistema de arquivo ou na biblioteca de documentos do SharePoint em busca do arquivo .vwi (Visio Workflow Interchange).

  2. Escolha a associação do fluxo de trabalho com uma lista ou torne-o reutilizável e clique em Concluir.

  3. Comece a personalizar o fluxo de trabalho no SharePoint Designer.

Início da Página

Projetar páginas, páginas mestras e layouts de página do site

Em SharePoint Designer 2010, você pode criar e personalizar páginas do site, páginas mestras e layouts de página. Enquanto cada uma dessas páginas serve a uma finalidade diferente, a experiência de edição de página é semelhante. Você pode adicionar e remover texto, imagens, links, tabelas, Web Parts, controles de servidor e muito mais. Aplica definições de estilo e folhas de estilo em cascata a suas páginas mestras e layouts de página para alterar a aparência do seu site ou marca-los para corresponder sua identidade corporativa.

Páginas do site

Para criar uma página do site, clique em Páginas do Site no painel Navegação e, na guia Páginas, execute uma das seguintes etapas:

  • Clique em Página de Web Parts para criar uma página que tenha as Web Parts de cabeçalho e corpo e associá-la a uma página mestra do site.

  • Clique em Página e escolha ASPX ou HTML para criar uma página de site vazia, não associada à página mestra do site.

Páginas mestras

  • Clique em Páginas Mestras no painel Navegação e, na guia Páginas Mestras, clique em Página Mestra em Branco.

Layouts de página

  • Clique em Layouts de Página no painel Navegação e, na guia Layouts de Página, clique em Novo Layout de Página e escolha o grupo e o nome do tipo de conteúdo nos quais basear o layout de página.

Observação : Páginas mestras e layouts de página são desabilitados por padrão para todos os usuários, exceto administradores de conjunto de sites. Se você não vir a opção para exibir ou editar páginas mestras ou layouts de página em SharePoint Designer 2010, contate o administrador do site sobre como ativar essas opções.

Início da Página

Salvar como modelo

Ao concluir a personalização do site, você poderá salvar como modelo o site ou partes dele para que outros usuários da sua empresa possam usar o modelo para criar, listas, modos de exibição, fluxos de trabalho, páginas do site, e muito mais.

Você também pode usar o modelo para personalizar ainda mais seu site em outro ambiente ou por outros usuários, como no navegador ou no Microsoft Visual Studio.

Procure a opção Salvar como modelo em SharePoint Designer 2010 aproveitar essa funcionalidade.

Início da Página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Essas informações foram úteis?

Como podemos melhorá-lo?

Como podemos melhorá-lo?

Para proteger sua privacidade, não inclua informações de contato em seus comentários. Avalie nosso política de privacidade.

Obrigado por seus comentários!