Entrar

Introdução a relatórios

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Ao usar um banco de dados, geralmente você usa relatórios para exibir, formatar e resumir dados. Por exemplo, é possível criar um relatório do tipo de lista para exibir os números de telefone de todos os seus contatos ou um relatório resumido com o total das vendas de sua empresa em diferentes regiões e períodos de tempo.

Este artigo fornece uma visão geral dos relatórios no Microsoft Access 2010, além de apresentar recursos de relatórios novos ou alterados. Também explica como: criar um relatório; classificar, agrupar e resumir dados; e visualizar e imprimir um relatório.

Você encontrará é muito mais fácil criar relatórios significativos se seu banco de dados tem uma estrutura de tabela elaborada e relações. Para obter uma introdução ao planejamento e à criação de um banco de dados, consulte o artigo Fundamentos do design de banco de dados.

Neste artigo

Visão Geral

Quais são as novidades

Criar um novo relatório

Adicionar agrupamento, classificação ou totais

Realçar valores usando formatação condicional

Obter uma aparência profissional com Temas

Adicionar imagens

Visualizar e imprimir um relatório

Visão geral

Um relatório é um objeto de banco de dados usado para exibir e resumir dados. Os relatórios permitem distribuir ou arquivar instantâneos dos dados, seja imprimindo, convertendo em arquivos PDF ou XPS, ou exportando para outros formatos de arquivo.

Relatório de funcionários na Visualização de Impressão

Os relatórios podem fornecer detalhes sobre registros individuais, resumos em muitos registros, ou ambos. Você também pode usar relatórios do Access para criar rótulos para mala direta ou outras finalidades.

É possível criar relatórios “não associados” que não exibem dados, mas, para a finalidade deste artigo, vamos supor que um relatório está associado a uma fonte de dados como uma tabela ou consulta.

Relatórios clientes e relatórios da Web

O Access 2010 fornece um novo recurso que permite criar um “banco de dados da Web” publicando um banco de dados do Access em um servidor do SharePoint que esteja executando os Serviços do Access. Quando você cria um banco de dados da Web, os relatórios do Access são renderizados no navegador usando SQL Server Reporting Services. Essa conversão impõe algumas limitações nos recursos que podem ser usados nos relatórios que você deseja renderizar no navegador. Entretanto, se você não estiver preocupado com a renderização de relatórios no navegador, poderá usar o conjunto completo de recursos que o designer de relatórios do Access fornece.

Partes de um relatório

No Access, o design de um relatório é dividido em seções. Em um banco de dados do cliente, você pode exibir o relatório no modo de Design para ver suas seções. No modo de exibição de Layout, as seções não são tão óbvias, mas eles ainda existem e podem ser selecionados, usando a lista suspensa no grupo seleção na guia Formatar. Para criar relatórios úteis, você precisa compreender como funciona a cada seção. Por exemplo, a seção na qual você optar por inserir um controle calculado determina como o Access calcula os resultados. A lista a seguir é um resumo dos tipos de seção e seus usos:

  • Cabeçalho do relatório    Esta seção é impresso apenas uma vez, no início do relatório. Use o cabeçalho do relatório para informações que normalmente apareceriam em uma página de rosto, como um logotipo, um título ou uma data. Quando você coloca um controle calculado que usa a função agregada Soma no cabeçalho do relatório, a soma calculada é para o relatório inteiro. Cabeçalho do relatório é impresso antes do cabeçalho de página.

  • Cabeçalho da página    Esta seção é impressa na parte superior de cada página. Por exemplo, use um cabeçalho de página para repetir o título do relatório em cada página.

  • Cabeçalho de grupo    Esta seção é impressa no início de cada novo grupo de registros. Use o cabeçalho do grupo para imprimir o nome do grupo. Por exemplo, em um relatório agrupado por produto, use o cabeçalho do grupo para imprimir o nome do produto. Quando você coloca um controle calculado que usa a função agregada Soma no cabeçalho do grupo, a soma é para o grupo atual. Você pode ter várias seções de cabeçalho de grupo em um relatório, dependendo de quantos níveis de agrupamento que você adicionou. Para obter mais informações sobre a criação de grupo cabeçalhos e rodapés, consulte a seção Adicionar agrupamento, classificação ou totais.

  • Detalhes    Esta seção é exibida uma vez para cada linha na fonte de registro. Aqui é onde você coloca os controles que compõem o corpo principal do relatório.

  • Rodapé de grupo    Esta seção é impressa no final de cada grupo de registros. Use um rodapé de grupo para imprimir informações de resumo para um grupo. Você pode ter várias seções de rodapé de grupo em um relatório, dependendo de quantos níveis de agrupamento que você adicionou.

  • Rodapé da página    Esta seção é impressa no final de cada página. Use um rodapé de página para os números de página para impressão ou informações por página.

  • Rodapé do relatório    Esta seção é impresso apenas uma vez, no final do relatório. Use o rodapé do relatório para imprimir totais do relatório ou outras informações de resumo para o relatório inteiro.

Observação : No modo Design, o rodapé do relatório aparece abaixo do rodapé da página. No entanto, todos os outros modos de exibição (exibição de Layout, por exemplo, ou quando o relatório é impresso ou visualizado), o rodapé do relatório aparece acima de rodapé da página, logo após a última grupo rodapé ou detalhe linha na página final.

Início do Documento

Novidades

O processo de criação de um relatório no Access 2010 é muito semelhante ao do Access 2007. Entretanto, no Access 2010, há alguns recursos novos que se aplicam a relatórios:

  • Compartilhado a Galeria de imagens    No Access 2010, você pode agora anexar uma imagem a um banco de dados e, em seguida, usar a imagem a vários objetos. Atualizando a imagem única atualiza-lo sempre que ele é usado em todo o banco de dados.

  • Temas do Office    No Access 2010, agora você pode usar padrão temas do Microsoft Office para aplicar com design profissional conjuntos de fontes e cores para todos os seus formulários e relatórios Access ao mesmo tempo.

  • Formatação condicional mais avançada    Access 2010 inclui ferramentas mais eficazes para realçar dados em um relatório. Você pode adicionar até 50 regras de formatação condicional para cada controle ou grupo de controles e nos relatórios de cliente, você pode adicionar barras de dados para comparar dados de registros.

  • Layouts mais flexíveis    No Access 2010, o método de design padrão para relatórios é colocar controles em layouts. Estes ajudam a grades alinhar e dimensionar controles facilmente e necessários para todos os relatórios que deseja renderizar em um navegador. Embora layouts próprios não são novos no Access 2010, existem algumas alterações para as maneiras nas quais você usá-los para mover, alinhar e redimensionar controles. Para obter mais informações, consulte o vídeo de Introdução aos layouts de formulário e relatório.

Início do Documento

Criar um novo relatório

Etapa 1: escolher uma fonte de registro

A fonte de registro de um relatório pode ser uma tabela, uma consulta nomeada ou uma consulta inserida. A fonte de registro precisa conter todas as linhas e colunas de dados que você deseja exibir no relatório.

Para obter mais informações sobre a criação de tabelas ou consultas, consulte os artigos Introdução às tabelas ou Introdução às consultas.

Para obter mais informações sobre como criar e selecionando fontes de registro, consulte o artigo definir a fonte de registro para um relatório.

Etapa 2: escolher uma ferramenta de relatório

As ferramentas de relatório estão localizadas na guia Criar da faixa de opções, no grupo Relatórios. A tabela a seguir descreve sucintamente o que cada ferramenta faz:

Relatórios compatíveis com a Web

Os relatórios criados usando essas ferramentas são compatíveis com o recurso Publicar nos Serviços do Access e serão renderizados em um navegador. Observe que os objetos compatíveis com a Web são indicados pelo globo no ícone do objeto.

Imagem do botão

Ferramenta

Descrição

Imagem do botão

Relatório

Cria um relatório simples e tabular que contém todos os campos na fonte de registro que você selecionou no Painel de Navegação.

Imagem do botão

Relatório em Branco

Abre um relatório em branco no modo Layout e exibe o painel de tarefas Lista de Campos. O Access cria uma consulta de fonte de registro à medida que você arrasta campos da Lista de Campos para o relatório.

Para obter mais informações sobre como publicar para o recurso de serviços do Access, consulte o artigo criar um banco de dados do Access para compartilhar na Web.

Relatórios clientes

Os relatórios criados usando essas ferramentas não são compatíveis com o recurso Publicar nos Serviços do Access. A adição de relatórios clientes a um banco de dados da Web não impedirá o banco de dados de publicar, mas os relatórios clientes não estarão disponíveis no navegador. Entretanto, você poderá usar um relatório cliente quando o banco de dados estiver aberto no Access.

Imagem do botão

Ferramenta

Descrição

Imagem do botão

Relatório

Cria um relatório simples e tabular que contém todos os campos na fonte de registro que você selecionou no Painel de Navegação.

Imagem do botão

Design de Relatório

Abre um relatório em branco no Modo Design, ao qual você pode adicionar apenas os campos e controles desejados.

Imagem do botão

Relatório em Branco

Abre um relatório em branco no Modo de Exibição de Layout e exibe o painel de tarefas Lista de Campos. À medida que você arrasta campos da Lista de Campos para o relatório, o Access cria uma consulta inserida e a armazena na propriedade Fonte de Registro do relatório.

Imagem do botão

Assistente de Relatório

Exibe um assistente com várias etapas, o qual permite especificar campos, níveis de agrupamento/classificação e opções de layout. O assistente cria um relatório com base nas seleções que você faz.

Imagem do botão

Rótulos

Exibe um assistente que permite selecionar tamanhos de rótulo padrão ou personalizado, além de quais campos você deseja exibir e como classificá-los. O assistente cria o relatório de rótulos com base nas seleções que você faz.


Etapa 3: criar o relatório

  1. Clique no botão da ferramenta que deseja usar. Se um assistente for exibido, siga as etapas no assistente e clique em Concluir na última página.

    O Access exibe o relatório em modo Layout.

  2. Formate o relatório até que fique com a aparência desejada:

    • Redimensione os campos e rótulos selecionando-os e arrastando as bordas até que fiquem com o tamanho desejado.

    • Mova um campo selecionando-o (e seu rótulo também, se estiver presente) e arrastando-o para o novo local.

    • Clique com o botão direito do mouse em um campo e use os comandos no menu de atalhos para mesclar ou dividir células, excluir ou selecionar campos e executar outras tarefas de formatação.

      Além disso, é possível usar os recursos descritos nas seguintes seções para tornar seu relatório mais atraente e legível.

Início do Documento

Adicionar agrupamento, classificação ou totais

A maneira mais rápida de adicionar agrupamento, classificação ou totais a um relatório é clicar com o botão direito do mouse no campo ao qual você deseja aplicar o grupo, a classificação ou o total e clicar no comando desejado no menu de atalhos.

Também é possível adicionar agrupamento, classificação ou totais usando o painel Agrupar, Classificar e Total enquanto o relatório está aberto em modo Layout ou modo Design:

  1. Se o painel Agrupar, Classificar e Total ainda não estiver aberto, na guia Design, no grupo Agrupamento e Totais, clique em Agrupar e Classificar.

  2. Clique em Adicionar um grupo ou Adicionar uma classificação e selecione o campo no qual deseja agrupar ou classificar.

  3. Clique em Mais em uma linha de agrupamento ou classificação para definir mais opções e adicionar totais.

Para obter informações mais detalhadas sobre agrupamento, classificação e totais, consulte o artigo criar um relatório agrupado ou resumido.

Início do Documento

Realçar valores usando formatação condicional

O Access 2010 inclui mais ferramentas sofisticadas para realçar dados em um relatório. Você pode adicionar até 50 regras de formatação condicional para cada controle ou grupo de controles e, em relatórios clientes, pode adicionar barras de dados para comparar os dados entre registros.

Para adicionar formatação condicional :

  1. Abra o relatório no modo Layout clicando com o botão direito do mouse no relatório no Painel de Navegação e clicando em Modo Layout.

  2. Selecione todos os controles à qual você deseja aplicar a formatação condicional. Para selecionar vários controles, mantenha pressionada a tecla SHIFT ou CTRL e clique nos controles desejados.

  3. Na guia Formatar, no grupo Formatação de Controle, clique em Formatação Condicional.

    O Access abrirá a caixa de diálogo Gerenciador de Regras de Formatação Condicional.

  4. Na caixa de diálogo Gerenciador de Regras de Formatação Condicional, clique em Nova Regra.

  5. Na caixa de diálogo Nova Regra de Formatação, selecione um valor em Selecionar um tipo de regra:

    • Para criar uma regra que seja avaliada para cada registro individualmente, selecione Verificar valores no registro atual ou usar uma expressão.

    • Para criar uma regra que compara registros entre si usando barras de dados, clique em Comparar com outros registros.

Observação :  A opção Comparar com outros registros não está disponível em bancos de dados da Web.


  1. Em Editar a descrição da regra, especifique a regra que determinará quando a formatação deverá ser aplicada, bem como a formatação que você deseja quando os critérios da regra forem cumpridos.

  2. Clique em OK para voltar para a caixa de diálogo Gerenciador de Regras de Formatação Condicional.

  3. Para criar uma regra adicional para esse controle ou conjunto de controles, repita esse procedimento desde a etapa 4. Senão, clique em OK para fechar a caixa de diálogo.

Para obter mais informações sobre como adicionar formatação condicional a um relatório, consulte a formatação condicional nas relatórios de usode vídeo.

Início do Documento

Obter uma aparência profissional com Temas

Agora é possível aplicar Temas do Office 2010 a um banco de dados do Access, ajudando-o a criar um estilo coerente em todos os seus documentos do Office.

Importante : Se você optar por um Tema, uma fonte ou uma cor do Office, ele(a) será aplicado(a) a todos os formulários e relatórios em seu banco de dados (e não apenas àquele em que você está trabalhando).

  1. Abra um relatório no modo Layout clicando duas vezes no painel de navegação e clicando em Layout Visualizar.

  2. Na guia Design, no grupo temas, selecione o tema, a cor ou a fonte que você deseja:

    Imagem da Faixa de Opções

    • Use a galeria Tema para definir simultaneamente as cores e fontes como um esquema predefinido.

    • Use as galerias Cores ou Fontes para definir as cores ou fontes de maneira independente.


Para obter mais informações sobre como usar temas do Office, consulte o vídeo tornar seus formulários e relatórios Access mais consistente e atraente com temas do Office.

Início do Documento

Adicionar imagens

Tradicionalmente no Access, as imagens são associadas a controles de imagem individuais em formulários ou relatórios. Para alterar uma imagem de uso comum em vários formulários e relatórios, cada controle de imagem tinha de ser editado manualmente. No Access 2010, porém, agora é possível anexar uma imagem a um banco de dados e usá-la em vários objetos. A atualização de uma única imagem é feita em todos os lugares em que ela é usada no banco de dados inteiro. Isso é bastante útil para elementos como logotipos de empresa ou imagens de plano de fundo que são usados em todo o banco de dados.

Adicionar uma imagem

  1. No Painel de Navegação, clique com o botão direito do mouse no relatório ao qual deseja adicionar a imagem e clique em Modo Layout.

  2. Clique no relatório em que deseja adicionar a imagem.

  3. Na guia Design, no grupo Controles, clique em Inserir Imagem.

  4. Siga um destes procedimentos:

    • Usar uma imagem existente    Se a imagem desejada já estiver na galeria, clique nele para adicioná-lo ao relatório.

    • Carregar uma nova imagem    Na parte inferior da galeria, clique em Procurar. Na caixa de diálogo Inserir imagem, navegue até a imagem que você deseja usar e clique em Abrir.

      O Access adicionará a imagem selecionada ao relatório.

Adicionar uma imagem de plano de fundo

Observação :  Imagens de plano de fundo não podem ser adicionadas a relatórios compatíveis com a Web.

  1. No Painel de Navegação, clique com o botão direito do mouse no relatório ao qual deseja adicionar a imagem de plano de fundo e clique em Modo Layout.

  2. Na guia Formatar, no grupo Plano de Fundo, clique em Imagem do Plano de Fundo.

  3. Siga um destes procedimentos:

    • Usar uma imagem existente    Se a imagem desejada já estiver na galeria, clique nele para adicioná-lo ao relatório.

    • Carregar uma nova imagem    Na parte inferior da galeria, clique em Procurar. Na caixa de diálogo Inserir imagem, navegue até a imagem que você deseja usar e clique em Abrir.

      O Access adicionará a imagem selecionada ao relatório.

Início do Documento

Visualizar e imprimir um relatório

Visualizar um relatório

  1. Abra o relatório que deseja visualizar ou apenas selecione-o no Painel de Navegação.

  2. Na guia Arquivo, clique em Imprimir e clique em Visualização de Impressão.

    O Access abrirá o relatório em Visualização de Impressão. Você pode usar os comandos na guia Visualização de Impressão para seguir algum destes procedimentos:

    • Imprimir o relatório;

    • Ajustar o tamanho ou layout de página;

    • Ampliar ou reduzir, ou exibir várias páginas por vez;

    • Atualizar os dados no relatório;

    • Exportar o relatório para outro formato de arquivo.

  3. Para voltar para o espaço de trabalho de banco de dados, na guia Visualização de Impressão, no grupo Fechar Visualização, clique em Fechar Visualização de Impressão.

Imprimir um relatório

Além de imprimir a partir da Visualização de Impressão, você também pode imprimir um relatório sem visualizá-lo:

  1. Abra o relatório que deseja visualizar ou apenas selecione-o no Painel de Navegação.

  2. Na guia Arquivo, clique em Imprimir.

    • Para enviar o relatório diretamente para a impressora padrão sem definir as opções de impressão, clique em Impressão Rápida.

    • Para abrir uma caixa de diálogo e poder selecionar uma impressora, especifique o número de cópias, por exemplo, e clique em Imprimir.

Início do Documento

Try Office 2010 today!

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.



Essas informações foram úteis?

Como podemos melhorá-lo?

Como podemos melhorá-lo?

Para proteger sua privacidade, não inclua informações de contato em seus comentários. Avalie nosso política de privacidade.

Obrigado por seus comentários!