Introdução à segurança do Access 2010

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Este artigo fornece uma visão geral dos recursos de segurança oferecidos pelo Access 2010 e explica como usar as ferramentas disponibilizadas por esse serviço para ajudar a proteger um banco de dados. Esse artigo também vincula para conteúdo mais detalhado sobre diversos recursos de segurança.

Esse artigo não aborda os recursos de segurança do SharePoint, que estarão disponíveis, se você publicar o banco de dados na Web usando os Serviços do Access. Para obter mais informações, confira a seção Ajuda no Microsoft SharePoint Server 2010.

Neste artigo

Novidades sobre a segurança do Access

Usar um banco de dados do Access em um local confiável

Empacotar, assinar e distribuir um banco de dados do Access 2010

Habilitar conteúdo desabilitado ao abrir um banco de dados

Usar uma senha de banco de dados para criptografar um banco de dados do Access

Como funciona a segurança com bancos de dados de versões anteriores do Access abertos no Access 2010

Executar expressões não seguras (Desabilitar a área restrita)

Novidades sobre a segurança do Access

O Access fornece um modelo de segurança aprimorado, que ajuda a simplificar os processos de aplicação de segurança para um banco de dados e de abertura de um banco de dados com segurança habilitada.

Observação : Embora os modelos e as técnicas abordadas nesse artigo melhorem a segurança, a forma mais segura de ajudar a proteger os dados do Access é armazenar as tabelas em um servidor; por exemplo, como um computador executando o Windows SharePoint Services 3.0 ou o Microsoft Office SharePoint Server 2010.

Confira as novidades sobre a segurança do Access:

Novo no 2010

  • Nova tecnologia de criptografia     O Office 2010 oferece uma nova tecnologia de criptografia mais potente do que a tecnologia oferecida no Office 2007.

  • Suporte para produtos de criptografia de terceiros     O Access 2010 permite que você use uma tecnologia de criptografia de terceiros, se assim preferir. Esse artigo não aborda o uso de produtos de terceiros.

Novidades no 2007

  • A capacidade de visualizar dados, mesmo quando não quiser habilitar o conteúdo do banco de dados     Se você definir o nível de segurança como Alto, no Microsoft Office Access 2003, será necessário entrar com um código e confiar em um banco de dados, antes de exibir os dados. Agora você pode exibir dados sem a necessidade de decidir se confia em um banco de dados.

  • Maior facilidade de uso     Se você colocar arquivos de banco de dados (no novo formato de arquivo do Access ou nos formatos de arquivo anteriores) em um local confiável, como uma pasta de arquivo ou um compartilhamento de rede que você determinar como seguro, esses arquivos serão abertos e executados sem exibir mensagens de aviso ou solicitações para habilitar qualquer conteúdo desabilitado. Além disso, se você abrir bancos de dados de versões anteriores do Access, como arquivos .mdb ou .mde do Access 2010, esses bancos de dados forem assinados digitalmente e você optar por confiar no publicador, esses arquivos serão executados sem a necessidade de tomar decisões sobre confiabilidade. No entanto, lembre-se de que o código VBA em um banco de dados assinado só será executado, caso você confie no publicador e se a assinatura digital não se tornar inválida. A assinatura se tornará inválida, se alguém que não seja a pessoa que a assinou a adultere com o conteúdo de um banco de dados.

    Se não tiver certeza sobre a confiabilidade de um certificado, o artigo Como saber se uma assinatura digital é confiável fornece informações gerais sobre como verificar as datas e outros itens em um certificado para garantir sua validade.

  • Central de Confiabilidade     A Central de Confiabilidade é uma caixa de diálogo que fornece um único local para definir e alterar as configurações de segurança do Access. Use a Central de Confiabilidade para criar ou alterar os locais confiáveis e definir as opções de segurança do Access. Essas configurações afetam a forma de comportamento dos bancos de dados novos e existentes, quando são abertos, no caso do Access. A Central de Confiabilidade também é dotada de lógica para avaliar os componentes de um banco de dados e para determinar se ele é seguro para abrir ou se deve desativá-lo, permitindo que você decida ativá-lo.

    Para obter informações gerais sobre o uso da Central de Confiabilidade, confira o artigo Exibir minhas configurações de segurança e privacidade na Central de Confiabilidade.

  • Menos mensagens de aviso     As versões anteriores do Access forçavam você a lidar com uma variedade de mensagens de alerta, como a segurança de macro e o modo de área restrita, somente para citar duas. Por padrão, ao abrir um arquivo .accdb, que ainda não seja confiável, você verá uma única ferramenta chamada Barra de Mensagens.

    Barra de Mensagens

    Se deseja confiar no banco de dados, é possível usar a Barra de Mensagens para habilitar qualquer conteúdo desabilitado do banco de dados: consultas de ação (para adicionar, excluir ou alterar dados), macros, controles ActiveX, expressões (funções que avaliam como um valor único) e código VBA, ao abrir um banco de dados que contém um ou mais desses componentes.

  • Novas maneiras de assinar e distribuir bancos de dados     Nas versões do Access anteriores a 2007, usava-se o Editor do Visual Basic para aplicar um certificado de segurança aos componentes individuais de um banco de dados. Agora, é possível empacotar, assinar e distribuir o banco de dados.

    Ao extrair um banco de dados de um pacote assinado para um local confiável, o banco de dados será aberto sem exibir a Barra de Mensagens. Se extrair um banco de dados de um pacote assinado para um local não confiável, caso você confie no certificado do pacote e a assinatura seja válida, o banco de dados será aberto sem exibir a Barra de Mensagens.

    Observação : Quando empacotar e assinar um banco de dados não confiável ou que contenha uma assinatura digital inválida, será necessário usar a Barra de Mensagens para confiá-lo, cada vez que for aberto, a menos que você o coloque em um local confiável.

  • Um algoritmo potente para criptografia de bancos de dados no formato de arquivo .accdb que usa o recurso de senha de banco de dados     Criptografar um banco de dados codifica os dados nas tabelas e ajuda a impedir a leitura por usuários indesejados.

    Observação : Ao criptografar um banco de dados com uma senha, ele usará o bloqueio em nível de página, independentemente das configurações do aplicativo. Isso pode afetar a disponibilidade dos dados em um ambiente compartilhado.

  • Uma nova subclasse de ações de macro que podem ser executadas, se um banco de dados estiver desabilitado     Essas macros mais seguras também incluem recursos de tratamento de erros. Você também pode inserir macros (mesmo os que contenham as ações desabilitadas pelo Access) diretamente em qualquer formulário, relatório ou propriedade de controle, que funcionaria de forma lógica com um módulo de código VBA ou com uma macro de uma versão anterior do Access.

Por fim, lembre-se das seguintes regras à medida que avançar:

  • Se abrir um banco de dados em um local confiável, todos os componentes serão executados sem a necessidade de tomar decisões de confiança.

  • Ao empacotar, assinar e implantar um banco de dados com um formato de arquivo mais antigo (.mdb ou .mde), todos os componentes serão executados sem a necessidade de tomar decisões de confiança, caso o banco de dados contenha uma assinatura digital de publicador confiável e caso você confie no certificado.

  • Se você assinar e implantar um banco de dados não confiável em um local não confiável, a Central de Confiabilidade o desativará por padrão. Desse modo, será necessário optar por ativar o banco de dados, sempre que o abrir.

O Access e a segurança em nível de usuário

O Access não oferece suporte de segurança em nível de usuário para bancos de dados criados em novos formatos de arquivo (.accdb e .accde). No entanto, se você abrir um banco de dados de uma versão anterior do Access, no Access 2010, e esse banco de dados tiver aplicado a segurança em nível de usuário, essas configurações vão continuar a funcionar.

Importante : As permissões criadas usando o recurso de segurança em nível de usuário não vão proteger o banco de dados contra usuários mal-intencionados e não se aplicam como uma barreira de segurança. É apropriado usar esse recurso para melhorar a usabilidade de um banco de dados para os usuários confiáveis. Para ajudar a proteger seus dados, permita que somente os usuários confiáveis acessem os arquivos do banco de dados ou os arquivos associados à segurança em nível de usuário, usando permissões de sistema de arquivos do Windows.

Ao converter um banco de dados de versões anteriores do Access com a segurança em nível de usuário para os novos formatos de arquivo, O Access excluirá todas as configurações de segurança automaticamente. A partir daí, aplicam-se as regras de segurança para os arquivos do tipo .accdb ou .accde.

Por fim, lembre-se de que, ao abrir os bancos de dados com os novos formatos de arquivo, todos os usuários poderão ver todos os objetos contidos ali.

A arquitetura de segurança do Access

Para compreender a arquitetura de segurança do Access, você deve levar em consideração que um banco de dados não é um arquivo como uma pasta de trabalho do Excel ou como um documento do Word. Em lugar disso, um banco de dados do Access é um conjunto de objetos, tais como tabelas, formulários, macros, consultas, relatórios e assim por diante, que têm uma relação de interdependência para funcionar. Por exemplo, se você criar um formulário de entrada de dados, não é possível inserir ou armazenar dados ali, a menos que você associe (vincule) seus controles em uma tabela.

Vários componentes do Access poderão representar riscos de segurança; portanto, serão desabilitados em um banco de dados não confiável:

  • Consultas ação (para inserir, excluir ou alterar dados)

  • Macros

  • Algumas expressões (funções que retornam um valor único)

  • Código VBA

Para ajudar a melhorar a segurança dos seus dados, o Access e a Central de Confiabilidade executam uma série de verificações de segurança, sempre que você abrir um banco de dados. O processo funciona da seguinte maneira:

  • Ao abrir um arquivo .accdb ou .accde, o Access enviará o local do banco de dados para a Central de Confiabilidade. Se a Central de Confiabilidade determinar que o local é confiável, o banco de dados será executado com total funcionalidade. Ao abri-lo com um formato de arquivo anterior, o Access enviará o local do arquivo e os detalhes sobre a assinatura digital (se houver) à Central de Confiabilidade.

    A Central de Confiabilidade verificará as "evidências" para avaliar a confiabilidade do banco de dados e informar ao Access como abri-lo. O Access desabilita o banco de dados ou abre-o com total funcionalidade.

    Observação : Lembre-se de que as configurações que você ou o administrador do sistema escolher na Central de Confiabilidade vão controlar as decisões de confiança, que ocorrerem quando o Access abrir um banco de dados.

    Para obter mais informações sobre como usar a Central de Confiabilidade, confira a seção Consulte Também.

  • Se a Central de Confiabilidade desabilitar o conteúdo do banco de dados, a Barra de Mensagens será exibida, ao abri-lo.

    Barra de Mensagens

    Para habilitar o conteúdo do banco de dados, clique em Opções e escolha as opções apropriadas na caixa de diálogo exibida. O Access habilitará o conteúdo desabilitado e o banco de dados será reaberto com total funcionalidade. Caso contrário, os componentes desabilitados não funcionarão.

  • Ao abrir um banco de dados criado nos formatos de arquivo anteriores (.mdb ou .mde), e esse banco de dados não for assinado e nem confiável, o Access desabilitará qualquer conteúdo executável, por padrão.

Modo desabilitado

Quando a Central de Confiabilidade avaliar um banco de dados como não confiável, o Access o abrirá no Modo Desabilitado; ou seja, ele desabilitará todo o conteúdo executável, independentemente do formato de arquivo do banco de dados.

No Modo Desabilitado, o Access desabilita os seguintes componentes:

  • Um código VBA e quaisquer referências contidas nele, além de todas as expressões não seguras.

  • Ações não seguras em todas as macros. As “ações não seguras” são quaisquer ações que permitam aos usuários modificar bancos de dados ou obter acesso a recursos de fora dele. No entanto, as ações que o Access desabilitar poderão, eventualmente, ser consideradas "seguras". Por exemplo, se confiar na pessoa que criou o banco de dados, você pode confiar em quaisquer ações de macro não seguras.

  • Vários tipos de consulta:

    • Consultas Ação    Elas adicionam, atualizam e excluem dados.

    • Consultas DDL    As consultas DDL São usadas para criar ou alterar objetos em um banco de dados, como tabelas e procedimentos.

    • Consulta passagem SQL    Essas consultas enviam comandos diretamente a um servidor de banco de dados que suporta a ODBC padrão. As consultas passagem SQL funcionam com as tabelas no servidor, sem envolverem o mecanismo do banco de dados do Access.

  • Controles ActiveX.

Quando um banco de dados for aberto, o Access pode tentar carregar suplementos (programas que ampliam as funcionalidades do Access ou do banco de dados aberto). Também convém executar assistentes que criam objetos no banco de dados aberto. Ao carregar um suplemento ou ao iniciar um assistente, o Access vai passar as evidências à Central de Confiabilidade, que tomará as decisões de confiança adicionais, além de habilitar ou desabilitar os objetos ou as ações. Sempre que a Central de Confiabilidade desabilitar um banco de dados e você discordar dessa decisão, será sempre possível usar a Barra de Mensagens para habilitar o conteúdo. Os suplementos proporcionam exceção a essa regra. Ao marcar a caixa de seleção Exigir que as Extensões de Aplicativo sejam assinadas por um Fornecedor Confiável, na Central de Confiabilidade (no painel Suplementos), o Access solicitará que você habilite o suplemento, mas esse processo não vai implicar a Barra de Mensagens.

Início da página

Usar um banco de dados do Access em um local confiável

Se colocar um banco de dados do Access em um local confiável, todos os códigos VBA, macros e expressões seguras serão executados, ao abri-lo. Não será necessário tomar decisões de confiança quando abrir o banco de dados.

O processo de utilização de um banco de dados do Access em um local confiável envolve as seguintes etapas genéricas:

  1. Usar a Central de Confiabilidade para encontrar ou criar um local confiável.

  2. Salvar, mover ou copiar um banco de dados do Access para o local confiável.

  3. Abrir e usar o banco de dados.

Os conjuntos de etapas a seguir explicam como encontrar ou como criar um local confiável e a adicionar um banco de dados para esse local.

Abrir a Central de Confiabilidade

  1. Na guia Arquivo, clique em Opções.

    A caixa de diálogo Opções do Access será exibida.

  2. Clique em Central de Confiabilidade e em Central de Confiabilidade do Microsoft Office Access, clique em Configurações da Central de Confiabilidade.

  3. Clique em Locais Confiáveis e faça o seguinte:

    • Anote o caminho de um ou mais locais confiáveis.

    • Crie um novo local confiável. Para fazer isso, clique em Adicionar novo local e preencha as opções na caixa de diálogo Locais Confiáveis do Microsoft Office.

Colocar um banco de dados do Access em um local confiável

  • Use sua técnica preferida para mover ou para copiar o arquivo de um banco de dados para um local confiável. Por exemplo, é possível usar o Windows Explorer para copiar ou mover o arquivo, ou você pode abri-lo no Access e salvá-lo no local confiável.

Abrir um banco de dados do Access em um local confiável

  • Use sua técnica preferida para abrir um arquivo. Por exemplo, você pode clicar duas vezes no arquivo do banco de dados no Windows Explorer ou, se estiver executando o Access, clique em Abrir na guia Arquivo para localizar e abrir o arquivo.

Início da página

Empacotar, assinar e distribuir um banco de dados do Access 2010

O Access torna mais fácil e rápido assinar e distribuir um banco de dados. Ao criar um arquivo do tipo .accdb ou .accde, você pode empacotá-lo, aplicar uma assinatura digital ao pacote e distribuir o pacote assinado para outros usuários. A ferramenta Empacotar e Assinar coloca o banco de dados em um arquivo de implantação do Access (.accdc), assina o arquivo e coloca o pacote assinado em um local que você determinar. Outras pessoas poderão extrair o banco de dados do pacote e trabalhar diretamente nele (fora do pacote).

Lembre-se dos seguintes fatos, à medida que prosseguir:

  • Empacotar um banco de dados e assinar o pacote é uma maneira para transmitir confiança. Ao criar um pacote e assinar um banco de dados, a assinatura digital confirmará que ele não será alterado após criá-lo.

  • Após extrair o banco de dados do pacote, não haverá mais uma conexão entre o pacote assinado e o banco de dados extraído.

  • Você pode usar a ferramenta Empacotar e Assinar somente com bancos de dados salvos em formato de arquivo .accde, .accdc ou .accdb. O Access também fornece ferramentas para assinar e distribuir bancos de dados criados em formatos anteriores de arquivos. Será necessário usar a ferramenta de assinatura digital apropriada para o formato de arquivo de banco de dados que você está usando.

  • Você pode adicionar apenas um banco de dados a um pacote.

  • O processo assina digitalmente um pacote que contém o banco de dados inteiro, juntamente com macros e módulos.

  • O processo compacta os arquivos de pacote para ajudar a reduzir os tempos de download.

  • É possível extrair bancos de dados dos arquivos de pacote localizados no servidores do Windows SharePoint Services 3.0.

As etapas nas seções a seguir explicam como criar um arquivo de pacote assinado e como extrair e usar o banco de dados de um arquivo de pacote assinado.

Criar um pacote assinado

  1. Abra o banco de dados que deseja empacotar e assinar.

  2. Na guia Arquivo, clique em Salvar e Publicar e em Avançado, clique em Empacotar e Assinar.

    A caixa de diálogo Selecionar Certificado é exibida.

  3. Selecione um certificado digital e clique em OK.

    A caixa de diálogo Criar Pacote Assinado do Microsoft Office Access será exibida.

  4. Na lista Salvar em, selecione um local para o pacote assinado do banco de dados.

  5. Digite um nome para o pacote assinado na caixa Nome do arquivo e clique em Criar.

    O Access vai criar o arquivo .accdc e coloca-lo no local que você escolher.

Extrair e usar um pacote assinado

  1. Na guia Arquivo, clique em Abrir.

    A caixa de diálogo Abrir será exibida.

  2. Selecione Pacote Assinado do Microsoft Office Access (*.accdc) como o tipo de arquivo.

  3. Use a lista Pesquisar para localizar a pasta que contém o arquivo .accdc, selecione-o e clique em Abrir.

  4. Siga um desses procedimentos:

    • Se optar por confiar no certificado de segurança usado para assinar o pacote de implantação, a caixa de diálogo Extrair Banco de Dados para será exibida. Vá para a etapa seguinte.

    • Se você ainda não escolheu confiar no certificado de segurança, a seguinte mensagem será exibida.

      Mensagem de aviso

      Se você confiar no banco de dados, clique em Abrir. Se você confiar em qualquer certificado desse provedor, clique em Confiar em todo o conteúdo do editor. A caixa de diálogo Extrair Banco de Dados para será exibida.

      Observação : Se você usar um certificado autoassinado para assinar um pacote de banco de dados e clicar em Confiar em todo o conteúdo do editor ao abrir esse pacote, os pacotes assinados usando os referidos certificados serão sempre confiáveis.

  5. Opcionalmente, na lista Salvar em, selecione um local para o banco de dados extraído e digite um nome diferente para ele, na caixa Nome do arquivo.

    Dica : Ao extrair o banco de dados para um local confiável, seu conteúdo será automaticamente habilitado, sempre que abri-lo. Se optar por um local não confiável, parte do conteúdo do banco de dados pode ser desabilitado por padrão.

  6. Clique em OK.

Se não tiver certeza sobre a confiabilidade de um certificado, o artigo Como saber se uma assinatura digital é confiável fornecerá informações gerais sobre como verificar as datas e outros itens em um certificado para garantir sua validade.

Início da página

Habilitar conteúdo desabilitado ao abrir um banco de dados

Por padrão, o Access desabilita todo o conteúdo executável em um banco de dados, a menos que você confie no banco de dados ou que o coloque em um local confiável. Ao abrir um banco de dados, o Access desabilitará o conteúdo e exibirá a Barra de Mensagens.

Barra de Mensagens

Também por padrão, o Access não mais exibirá um conjunto de caixas de diálogo restritas, as quais exigem uma tomada de decisão antes de poder realizar mais alguma coisa ao abrir um banco de dados, tal como no Access 2003. Se preferir esse comportamento, você pode adicionar uma chave do Registro e exibir uma caixa de diálogo restrita mais antiga.

Confiar em um banco de dados

Independentemente de como o Access se comportará ao abrir um banco de dados, se este for proveniente de um fornecedor confiável, você pode optar por habilitar os componentes executáveis no arquivo, isto é, confiar no banco de dados.

  • Na Barra de Mensagens, clique em Habilitar Conteúdo.

Importante : Quando você clicar em Habilitar Conteúdo, o Access habilitará todo o conteúdo desabilitado, inclusive os códigos potencialmente mal-intencionados. Se um código mal-intencionado danificar os dados ou o computador, o Access não pode desfazer esses danos.

Usar a Barra de Mensagens

  • Clique no botão Fechar (X ), no canto superior direito da Barra de Mensagens.

    A Barra de Mensagens será fechada. Ela será exibida novamente, da próxima vez que abrir o banco de dados, a menos que você o mova para um local confiável.

Adicionar a chave do Registro para exibir as caixas de diálogo restritas

Cuidado      A edição incorreta do Registro pode danificar seriamente o sistema operacional e exigir que ele seja reinstalado. A Microsoft não pode garantir que os problemas resultantes da edição incorreta do Registro possam ser resolvidos. Antes de editá-lo, faça um backup de todos os dados valiosos. Para obter as informações mais recentes sobre como usar e proteger o Registro do computador, consulte a Ajuda do Microsoft Windows.

  1. No Microsoft Windows, clique no botão Iniciar e em Executar.

  2. Na caixa Abrir, digite regedit e pressione ENTER.

    O Editor do Registro é iniciado.

  3. Expanda a pasta HKEY_CURRENT_USER e navegue até a seguinte chave do Registro:

    Software\Microsoft\Office\14.0\Access\Segurança

  4. No painel à direita do Editor do Registro, clique com botão direito do mouse na área em branco, posicione em Novo e clique em valor DWORD. Um valor DWORD novo e em branco será exibido.

  5. Digite o seguinte nome para o valor: ModalTrustDecisionOnly.

  6. Clique duas vezes no novo valor.

    A caixa de diálogo Editar Valor DWORD será exibida.

  7. No campo Dados do Valor, altere o valor de 0 para 1 e clique em OK.

  8. Feche o Editor do Registro.

Agora, quando abrir um banco de dados que inclua conteúdo não seguro, é possível visualizar uma série de caixas de diálogo, ao invés de a Barra de Mensagens. Para reverter ao comportamento original, repita essas etapas e altere o valor de 1 para 0.

Início da página

Usar uma senha de banco de dados para criptografar um banco de dados do Access

A ferramenta de criptografia no Access combina e melhora as duas ferramentas mais antigas: as senhas de codificação e de banco de dados. Ao usar uma senha para criptografar um banco de dados, tornará todos os dados ilegíveis por outras ferramentas e exigirá que os usuários insiram uma senha para usá-lo. A criptografia aplicada ao Access 2010 usa um algoritmo mais potente do que o usado nas versões anteriores do Access.

Observação : Se você usar uma senha no Access 2007 para criptografar um banco de dados, convém mudar para a nova tecnologia de criptografia, que oferece mais segurança.

Mudar de um banco de dados criptografado do Access 2007 para a nova tecnologia de criptografia

Para mudar para a nova tecnologia de criptografia, remova a senha do banco de dados atual e adicione-a novamente.

Criptografar usando uma senha de banco de dados

  1. Abra o banco de dados que você deseja criptografar no modo exclusivo.

    Abrir o banco de dados no modo exclusivo

    1. Na guia Arquivo, clique em Abrir.

    2. Na caixa de diálogo Abrir, navegue até o arquivo que deseja abrir e selecione-o.

    3. Clique na seta ao lado do botão Abrir e clique em Abrir Exclusivo.

      Abrindo o arquivo no modo Exclusivo

  2. Na guia Arquivo, clique em Informações e em Criptografar com Senha.

    A caixa de diálogo Definir Senha do Banco de Dados será exibida.

  3. Digite a senha na caixa Senha e digite-a novamente no campo Verificar

    Observações : 

    • Use senhas fortes que combinem letras maiúsculas e minúsculas, números e símbolos. Senhas não combinar esses elementos. Senha forte: Y6dh! et5. Senha fraca: House27. Senhas devem ser 8 ou mais caracteres de comprimento. Uma frase secreta que usa 14 ou mais caracteres é melhor.

    • É fundamental que você se lembre da sua senha. Caso a esqueça, a Microsoft não poderá recuperá-la. Guarde as senhas que anotar por escrito em um lugar seguro, longe das informações que elas ajudam a proteger.

  4. Clique em OK.

Descriptografar e abrir um banco de dados

  1. Abra o banco de dados criptografado, da mesma maneira que normalmente abre qualquer outro banco de dados.

    A caixa de diálogo Senha necessária é exibida.

  2. Digite a senha na caixa Inserir senha do banco de dados e clique em OK.

Remover uma senha

  1. Na guia Arquivo, clique em Informações e em Descriptografar Banco de Dados.

    A caixa de diálogo Desproteger Senha do Banco de Dados é exibida.

  2. Digite a senha na caixa Senha e clique em OK.

Início da página

Como funciona a segurança com bancos de dados de versões anteriores do Access abertos no Access 2010

Ao abrir um banco de dados criado em uma versão anterior do Access, quaisquer recursos de segurança aplicados a esse banco de dados vão continuar a funcionar. Por exemplo, se você aplicar a segurança em nível de usuário a um banco de dados, o recurso funcionará no Access 2010.

Por padrão, o Access abre todos os bancos de dados antigos não confiáveis no modo desabilitado e os mantém nesse estado. É possível optar por ativar qualquer conteúdo desabilitado sempre que abrir o banco de dados mais antigo; ou, ao invés disso, pode aplicar uma assinatura digital usando um certificado de um fornecedor confiável ou, ainda, pode colocar o banco de dados em um local confiável.

Importante : As etapas nessa seção não se aplicam aos bancos de dados que usam um dos novos formatos de arquivo, como o de extensão *.accd.

Para os bancos de dados em formato de arquivo anterior, é possível aplicar uma digital signature aos seus componentes. A assinatura digital confirmará todas as macros, módulos de código e outros componentes executáveis do banco de dados criado pelo signatário, os quais não sejam alterados, a partir do momento em que o banco de dados foi assinado.

Para aplicar uma assinatura ao banco de dados, primeiro é necessário um certificado digital. Se você criar bancos de dados para distribuição comercial, será necessário obter um certificado comercial de uma Autoridade de Certificação (CA). As Autoridades de Certificação fazem verificações de antecedentes para confirmar a reputação das pessoas que criam conteúdos (como bancos de dados).

Para saber mais sobre as Autoridades de Certificação que oferecem serviços para os produtos da Microsoft, confira a seção Consulte Também.

Se quiser usar um banco de dados para cenários pessoais ou para um grupo de trabalho limitado, o Microsoft Office Professional 2007 fornece uma ferramenta para criar um certificado autoassinado. As etapas nas seções a seguir explicam como instalar e usar uma ferramenta chamada SelfCert.exe para criar um certificado autoassinado.

Criar um certificado autoassinado

  1. Localize a pasta que contém os arquivos de programa do Office 2010. A pasta padrão é Unidade:\Arquivos de Programa\Microsoft Office\Office14. Nessa pasta, localize e clique duas vezes em SelfCert.exe.

    A caixa de diálogo Criar Certificado Digital será exibida.

  2. Na caixa O nome do seu certificado, digite um nome para o novo certificado de teste.

  3. Clique duas vezes em OK.

Observação : Se você não vir o comando Certificado Digital para projetos VBA ou se não for possível encontrar o arquivo SelfCert.exe, talvez seja necessário instalar o SelfCert.

Assinar um banco de dados com código

Observação : Lembre-se de que essas etapas se aplicam somente se você utilizar bancos de dados que usam um formato de arquivo anterior, como um arquivo .mdb.

  1. Abra o banco de dados que deseja assinar.

  2. Na guia Ferramentas de Banco de Dados no grupo Macro, clique em Visual Basic para iniciar o Editor do Visual Basic.

    Atalho de teclado  Pressione ALT + F11.

  3. Na janela do Explorador de projeto, selecione o banco de dados ou o projeto do Visual Basic for Applications (VBA) que deseja assinar.

  4. No menu Ferramentas, clique em Assinatura Digital.

    A caixa de diálogo Assinatura Digital será exibida.

  5. Clique em Escolher para selecionar o certificado de teste.

    A caixa de diálogo Selecionar Certificado é exibida.

  6. Selecione o certificado que você deseja aplicar.

    Se seguir as etapas na seção anterior, selecione o certificado que você criar usando o SelfCert.

  7. Clique em OK para fechar a caixa de diálogo Auto Certificar e clique novamente em OK para fechar a caixa de diálogo Assinatura Digital.

Dicas para assinar versões anteriores de bancos de dados

  • Se deseja evitar que determinados usuários modifiquem acidentalmente seu projeto VBA e invalidem sua assinatura, bloqueie o projeto antes de assiná-lo.

    Observação : O bloqueio do projeto VBA não impede que outro usuário substitua uma assinatura digital por outra. Os administradores empresariais deverão assinar novamente os modelos e os suplementos, de modo a controlarem com precisão o que os usuários vão poder executar em seus computadores.

  • Ao assinar digitalmente um projeto VBA, convém obter um carimbo de data/hora para que outras pessoas possam verificar sua assinatura, mesmo após o certificado usado para a assinatura expirar. Consulte o Microsoft Office Online para obter mais informações sobre carimbos de data/hora e segurança de VBA.

Observação : Lembre-se de que essas etapas se aplicam somente se você utilizar bancos de dados com um formato de arquivo anterior no Access 2010.

Instalar o SelfCert.exe

  1. Inicie o CD de Configuração do Office 2010 ou outra mídia a instalação.

  2. Em Configuração, clique em Adicionar ou Remover Recursos e clique em Continuar.

    Caso você trabalhe em um ambiente no qual o Microsoft Office foi instalado em computadores individuais por administradores de TI, e não por CD, siga essas etapas:

    1. No Microsoft Windows, abra o Painel de Controle.

    2. Clique duas vezes em Programas e Recursos.

    3. Selecione Microsoft Office 2010 e clique em Alterar.

      Iniciar configuração

    4. Clique em Adicionar ou Remover Recursos e clique em Continuar.

    5. Continue com as etapas a seguir.

  3. Expanda os nós das opções Microsoft Office e Recursos Compartilhados do Office clicando nos sinais de adição (+) ao lado deles.

  4. Clique em Certificado Digital para projetos VBA.

  5. Clique em Executar a partir do Meu Computador.

  6. Clique em Continuar para instalar o componente.

  7. Clique em Fechar após concluir a instalação e volte ao primeiro conjunto de etapas dessa seção.

Início da página

Executar expressões não seguras (desabilitar a área restrita)

Ao adicionar uma expressão a um banco de dados e, em seguida, confiar nele ou colocá-lo em um local confiável, o Access vai executar essa expressão em um ambiente operacional chamado modo de área restrita. O Access apresenta esse comportamento para bancos de dados criados nele ou em formatos de arquivos anteriores. O Access habilita o modo de área restrita por padrão e esse modo sempre desabilita as expressões não seguras, mesmo após confiar em um banco de dados. Para obter mais informações sobre as expressões desabilitadas pelo modo de área restrita, consulte o artigo da Microsoft Office.comSobre o modo de área restrita do Microsoft Jet Expression Service.

Se você confiar em um banco de dados e deseja executar uma expressão que será desativada pelo modo de área restrita, é possível executar essa expressão alterando uma chave do Registro e desabilitando o modo de área restrita. Você deverá primeiro confiar em um banco de dados para seguir essas etapas.

O desenho a seguir mostra o processo de decisão que você deverá seguir para executar expressões não seguras.

Processo de decisão da área restrita

Cuidado      A edição incorreta do Registro pode danificar seriamente o sistema operacional e exigir que ele seja reinstalado. A Microsoft não pode garantir que os problemas resultantes da edição incorreta do Registro possam ser resolvidos. Antes de editá-lo, faça um backup de todos os dados valiosos. Para obter as informações mais recentes sobre como usar e proteger o Registro do computador, consulte a Ajuda do Microsoft Windows.

Se você não estiver familiarizado com o Registro ou com a alteração de chaves do Registro, entre em contato com alguém mais experiente ou considere converter o banco de dados da versão anterior do Access para o novo formato de arquivo. Além disso, será necessário ter permissões de administrador no computador para alterar os valores do Registro.

Alterar a chave do Registro

Importante : A execução destas etapas permite que as expressões não seguras sejam executadas em todas as instâncias do Access para todos os usuários do computador.

  1. No Microsoft Windows, clique no botão Iniciar e em Executar.

  2. Na caixa Abrir, digite regedit e pressione ENTER.

    O Editor do Registro é iniciado.

  3. Expanda a pasta HKEY_LOCAL_MACHINE e navegue até a seguinte chave do Registro:

    \Software\Microsoft\Office\14.0\Mecanismo de Banco de Dados do Access\Mecanismos

  4. No painel à direita do Editor do Registro, clique duas vezes no valor SandboxMode.

    A caixa de diálogo Editar Valor DWORD será exibida.

  5. No campo Dados do Valor, altere o valor de 3 para 2 e clique em OK.

  6. Feche o Editor do Registro.

Importante    Lembre-se de que, se você não confiar primeiro no banco de dados, o Access desabilitará todas as expressões não seguras, independentemente de alterar essas configurações do Registro.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×