Inserir um objeto em sua planilha do Excel

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Você pode usar o objeto incorporação OLE (vinculação e) para incluir conteúdo de outros programas, como o Word ou Excel.

Vários programas oferecem suporte ao OLE, que é usado para tornar o conteúdo criado em um programa disponível em outro programa. Por exemplo, você pode inserir um documento do Office Word em uma pasta de trabalho do Office Excel. Para ver quais tipos de conteúdo podem ser inseridos, clique em Objeto no grupo Texto da guia Inserir. Somente os programas instalados no seu computador e que ofereçam suporte a objetos OLE são exibidos na caixa Tipo de objeto.

Se você copiar informações entre o Excel ou qualquer programa que ofereça suporte ao OLE, como o Word, copie as informações como um objeto vinculado ou um objeto inserido. As principais diferenças entre objetos vinculados e incorporados são o local onde os dados são armazenados e como o objeto é atualizado depois que você o coloca no arquivo de destino. Os objetos incorporados são armazenados na pasta de trabalho em que são inseridos e não são atualizados. Os objetos vinculados permanecem como arquivos separados e podem ser atualizados.

Objetos vinculados e incorporados em um documento

Objetos vinculados e inseridos em um documento do Office para Windows

1. Um objeto incorporado não tem conexão com o arquivo de origem.

2. Um objeto vinculado está vinculado ao arquivo de origem.

3. O arquivo de origem atualiza o objeto vinculado.

Quando usar objetos vinculados

Se você quiser que as informações no arquivo de destino sejam atualizadas quando os dados no arquivo de origem forem alterados, use objetos vinculados.

Com um objeto vinculado, as informações originais continuam armazenadas no arquivo de origem. O arquivo de destino exibe uma representação das informações vinculadas, mas armazena apenas o local dos dados originais (e o tamanho se o objeto for um objeto gráfico do Excel). O arquivo de origem deve permanecer disponível no computador ou na rede para manter o link com os dados originais.

As informações vinculadas podem ser atualizadas automaticamente se você alterar os dados originais no arquivo de origem. Por exemplo, se você selecionar um parágrafo em um documento do Word e colar o parágrafo como um objeto vinculado em uma pasta de trabalho do Excel, as informações poderão ser atualizadas no Excel se você alterar as informações no documento do Word.

Quando usar objetos incorporados

Se você não deseja atualizar os dados copiados quando ele é alterado no arquivo de origem, use um objeto incorporado. A versão da fonte é incorporada totalmente na pasta de trabalho. Se você copiar as informações como um objeto incorporado, o arquivo de destino precisará de mais espaço do que se você vincular as informações.

Quando um usuário abre o arquivo em outro computador, ele pode exibir o objeto incorporado sem ter acesso aos dados originais. Como um objeto incorporado possui vínculos ao arquivo de origem, o objeto não será atualizado se você alterar os dados originais. Para alterar um objeto incorporado, clique duas vezes no objeto para abri-lo e editá-lo no programa de origem. O programa de origem (ou outro programa capaz de editar o objeto) deve ser instalado no computador.

Alterando a maneira que um objeto OLE é exibido

Você pode exibir um objeto vinculado ou objeto inserido em uma pasta de trabalho exatamente como ele aparece no programa de origem ou como um ícone. Se a pasta de trabalho for exibida online e você não pretende imprimi-la, poderá exibir o objeto como um ícone. Isso minimizará a quantidade de espaço de exibição que o objeto ocupa. Os visualizadores que desejam exibir as informações podem clicar duas vezes no ícone.

Inserir um objeto em uma planilha

  1. Clique dentro da célula da planilha onde você deseja inserir o objeto.

  2. Na guia Inserir, no grupo texto, clique em objeto Ícone de objeto na faixa de opções .
    Inserir Objeto

  3. Na caixa de diálogo objeto , clique na guia Criar do arquivo.

  4. Clique em Procurar e selecione o arquivo que você deseja inserir.

  5. Se você deseja inserir um ícone na planilha, em vez de mostrar o conteúdo do arquivo, marque a caixa de seleção Exibir como ícone . Se você não selecionar todas as caixas de seleção, o Excel mostra a primeira página do arquivo. Em ambos os casos, o arquivo completo é aberta com um clique duplo. Clique em Okey.

    Observação : Depois de adicionar o ícone ou o arquivo, você pode arrastar e solte-o em qualquer lugar na planilha. Você também pode redimensionar o ícone ou o arquivo usando as alças de redimensionamento. Para localizar as alças, clique no arquivo ou o ícone de uma vez.

Inserir um link em um arquivo

Talvez você queira adicionar apenas um link para o objeto em vez de totalmente incorporá-lo. Você pode fazer isso se sua pasta de trabalho e o objeto que você deseja adicionar são armazenados em um site do SharePoint, uma unidade de rede compartilhada ou um local semelhante e se o local dos arquivos permanecerá igual. Isso é útil se o objeto vinculado sofrer alterações porque o link sempre abre o documento mais atualizado.

Observação : Se você mover o arquivo vinculado para outro local, o link não funcionará mais.

  1. Clique dentro da célula da planilha onde você deseja inserir o objeto.

  2. Na guia Inserir, no grupo texto, clique em objeto Ícone de objeto na faixa de opções .
    Inserir Objeto

  3. Clique na guia Criar do arquivo .

  4. Clique em Procurar e selecione o arquivo que você deseja vincular.

  5. Marque a caixa de seleção Vincular ao arquivo e clique em OK.

Criar um novo objeto de dentro do Excel

Você pode criar um objeto inteiramente novo com base em outro programa sem sair de sua pasta de trabalho. Por exemplo, se você quiser adicionar uma explicação mais detalhada em seu gráfico ou tabela, você pode criar um documento inserido, como um arquivo Word ou PowerPoint, em Excel. Você pode definir o objeto a ser exibido para a direita em uma planilha ou adicionar um ícone que abre o arquivo.

Esse objeto inserido é um documento do Word.
  1. Clique dentro da célula da planilha onde você deseja inserir o objeto.

  2. Na guia Inserir, no grupo texto, clique em objeto Ícone de objeto na faixa de opções .
    Inserir Objeto

  3. Na guia Criar Novo, selecione o tipo de objeto que você deseja inserir na lista exibida. Se quiser inserir um ícone na planilha em vez do próprio objeto, marque a caixa de seleção Exibir como ícone.

  4. Clique em OK. Dependendo do tipo de arquivo que estiver sendo inserido, será aberta uma nova janela de programa ou uma janela de edição aparece dentro do Excel.

  5. Crie um novo objeto que você deseja inserir.

    Quando terminar, se o Excel tiver aberto uma nova janela do programa no qual você criou o objeto, você poderá trabalhar diretamente nele.

    Você pode editar o documento do Word inserido diretamente no Excel.

    Quando você terminar seu trabalho na janela, você pode fazer outras tarefas sem salvar o objeto inserido. Quando você fecha a pasta de trabalho seus novos objetos serão salvo automaticamente.

    Observação : Depois de adicionar o objeto, você poderá arrastá-lo e soltá-lo em qualquer lugar na planilha do Excel. Também é possível redimensionar o objeto usando as alças de redimensionamento. Para localizar as alças, clique no objeto uma vez.

Inserir um objeto em uma planilha

  1. Clique dentro da célula da planilha onde você deseja inserir o objeto.

  2. Na guia Inserir, no grupo Texto, clique em Objeto.

    A opção Objeto está na guia Inserir.
  3. Clique na guia Criar do Arquivo.

    A guia "Criar do Arquivo" na caixa de diálogo Objeto.
  4. Clique em Procurar e selecione o arquivo que você deseja inserir.

  5. Se você deseja inserir um ícone na planilha, em vez de mostrar o conteúdo do arquivo, marque a caixa de seleção Exibir como ícone . Se você não selecionar todas as caixas de seleção, o Excel mostra a primeira página do arquivo. Em ambos os casos, o arquivo completo é aberta com um clique duplo. Clique em Okey.

    Observação : Depois de adicionar o ícone ou o arquivo, você pode arrastar e solte-o em qualquer lugar na planilha. Você também pode redimensionar o ícone ou o arquivo usando as alças de redimensionamento. Para localizar as alças, clique no arquivo ou o ícone de uma vez.

Inserir um link em um arquivo

Talvez você queira adicionar apenas um link para o objeto em vez de totalmente incorporá-lo. Você pode fazer isso se sua pasta de trabalho e o objeto que você deseja adicionar são armazenados em um site do SharePoint, uma unidade de rede compartilhada ou um local semelhante e se o local dos arquivos permanecerá igual. Isso é útil se o objeto vinculado sofrer alterações porque o link sempre abre o documento mais atualizado.

Observação : Se você mover o arquivo vinculado para outro local, o link não funcionará mais.

  1. Clique dentro da célula da planilha onde você deseja inserir o objeto.

  2. Na guia Inserir, no grupo Texto, clique em Objeto.

    A opção Objeto está na guia Inserir.
  3. Clique na guia Criar do arquivo .

  4. Clique em Procurar e selecione o arquivo que você deseja vincular.

  5. Marque a caixa de seleção Vincular ao arquivo e clique em OK.

    Na guia "Criar do Arquivo", selecione "Vincular ao arquivo".

Criar um novo objeto de dentro do Excel

Você pode criar um objeto inteiramente novo com base em outro programa sem sair de sua pasta de trabalho. Por exemplo, se você quiser adicionar uma explicação mais detalhada em seu gráfico ou tabela, você pode criar um documento inserido, como um arquivo Word ou PowerPoint, em Excel. Você pode definir o objeto a ser exibido para a direita em uma planilha ou adicionar um ícone que abre o arquivo.

Esse objeto inserido é um documento do Word.
  1. Clique dentro da célula da planilha onde você deseja inserir o objeto.

  2. Na guia Inserir, no grupo Texto, clique em Objeto.

    A opção Objeto está na guia Inserir.
  3. Na guia Criar Novo, selecione o tipo de objeto que você deseja inserir na lista exibida. Se quiser inserir um ícone na planilha em vez do próprio objeto, marque a caixa de seleção Exibir como ícone.

    A guia Criar Novo na caixa de diálogo Objeto.
  4. Clique em OK. Dependendo do tipo de arquivo que estiver sendo inserido, será aberta uma nova janela de programa ou uma janela de edição aparece dentro do Excel.

  5. Crie um novo objeto que você deseja inserir.

    Quando terminar, se o Excel tiver aberto uma nova janela do programa no qual você criou o objeto, você poderá trabalhar diretamente nele.

    Você pode editar o documento do Word inserido diretamente no Excel.

    Quando você terminar seu trabalho na janela, você pode fazer outras tarefas sem salvar o objeto inserido. Quando você fecha a pasta de trabalho seus novos objetos serão salvo automaticamente.

    Observação : Depois de adicionar o objeto, você poderá arrastá-lo e soltá-lo em qualquer lugar na planilha do Excel. Também é possível redimensionar o objeto usando as alças de redimensionamento. Para localizar as alças, clique no objeto uma vez.

Vincular ou incorporar conteúdo de outro programa usando OLE

Você pode vincular ou incorporar todo o conteúdo de outro programa ou parte dele.

Criar um link para o conteúdo de outro programa

  1. Clique na planilha onde você deseja colocar o objeto vinculado.

  2. Na guia Inserir, no grupo Texto, clique em Objeto.

    Imagem da Faixa de Opções do Excel

  3. Clique na guia Criar do Arquivo.

  4. Na caixa Nome do arquivo, digite o nome do arquivo ou clique em Procurar para selecioná-lo em uma lista.

  5. Marque a caixa de seleção Vincular ao arquivo.

  6. Siga um destes procedimentos:

    • Para exibir o conteúdo, desmarque a caixa de seleção Exibir como ícone.

    • Para exibir um ícone, marque a caixa de seleção Exibir como ícone. Opcionalmente, para alterar a imagem padrão do ícone ou o rótulo, clique em Alterar ícone e, em seguida, clique no ícone desejado na lista de ícone ou digite um rótulo na caixa legenda.

    Observação : Você não pode usar o comando Objeto para inserir elementos gráficos e determinados tipos de arquivos. Para inserir um elemento gráfico ou arquivo, na guia Inserir, no grupo Ilustrações, clique em Imagem.

Inserir conteúdo de outro programa

  1. Clique na planilha onde você deseja colocar o objeto inserido.

  2. Na guia Inserir, no grupo Texto, clique em Objeto.

    Imagem da Faixa de Opções do Excel

  3. Se o documento ainda não existir, clique na guia Criar Novo. Na caixa Tipo de objeto, clique no tipo de objeto que você deseja criar.

    Se o documento já existir, clique na guia Criar do Arquivo. Na caixa Nome do arquivo, digite o nome do arquivo ou clique em Procurar para selecionar em uma lista.

  4. Desmarque a caixa de seleção Vincular ao arquivo.

  5. Siga um destes procedimentos:

    • Para exibir o conteúdo, desmarque a caixa de seleção Exibir como ícone.

    • Para exibir um ícone, marque a caixa de seleção Exibir como ícone. Para alterar a imagem padrão do ícone ou o rótulo, clique em Alterar ícone e, em seguida, clique no ícone desejado na lista de ícone ou digite um rótulo na caixa legenda.

Vincular ou incorporar conteúdo parcial de outro programa

  1. Em um programa diferente do Excel, selecione as informações que você deseja copiar como um vinculado ou objeto inserido.

  2. Na guia Início, no grupo Área de Transferência, clique em Copiar.

    imagem da faixa de opções do excel

  3. Alterne para a planilha na qual você deseja colocar as informações e clique no local onde as elas devem ser exibidas.

  4. Na guia Página Inicial, no grupo Área de Transferência, clique na seta abaixo de Colar e clique em Colar Especial.

  5. Siga um destes procedimentos:

    • Para colar as informações como um objeto vinculado, clique em Colar vínculo.

    • Para colar as informações como um objeto incorporado, clique em Colar. Na caixa Como, clique na entrada que apresenta a palavra "objeto". Por exemplo, se você copiou as informações de um documento do Word, clique em Objeto de Documento do Microsoft Word.

Altera a forma como um objeto OLE é exibido

  1. Clique com o botão direito do mouse no ícone ou objeto, aponte para o tipo de objetoObjeto (por exemplo, Objeto de Documento) e clique em Converter.

  2. Siga um destes procedimentos:

    • Para exibir o conteúdo, desmarque a caixa de seleção Exibir como ícone.

    • Para exibir um ícone, marque a caixa de seleção Exibir como ícone. Opcionalmente, você pode alterar a imagem padrão do ícone ou o rótulo. Para fazer isso, clique em Alterar ícone e, em seguida, clique no ícone desejado na lista de ícone ou digite um rótulo na caixa legenda.

Controlar atualizações para objetos vinculados

Você pode definir vínculos para outros programas a serem atualizados da seguinte maneira: automaticamente, quando abre o arquivo de destino; manualmente, quando deseja ver os dados anteriores antes de fazer a atualização com os novos dados do arquivo de origem; ou quando solicita especificamente a atualização, independentemente de a atualização automática ou manual estar ativada.

Definir um vínculo para outro programa a ser atualizado manualmente

  1. Na guia Dados, no grupo Conexões, clique em Editar Vínculos.

    Imagem da Faixa de Opções do Excel

    Observação : O comando Editar Vínculos não estará disponível se o arquivo não contiver vínculos para outros arquivos.

  2. Na lista Fonte, clique no objeto vinculado que você deseja atualizar. Um A na coluna Atualizar significa que o vínculo é automático, e um M na coluna Atualizar significa que o vínculo está definido como atualização Manual.

    Dica : Para selecionar vários objetos vinculados, mantenha pressionada a tecla CTRL e clique em cada objeto vinculado. Para selecionar todos os objetos vinculados, pressione CTRL+A.

  3. Para atualizar um objeto vinculado somente quando você clica em Atualizar Valores, clique em Manual.

Definir um vínculo para outro programa a ser atualizado automaticamente

  1. Na guia Dados, no grupo Conexões, clique em Editar Vínculos.

    Imagem da Faixa de Opções do Excel

    Observação : O comando Editar Vínculos não estará disponível se o arquivo não contiver vínculos para outros arquivos.

  2. Na lista Fonte, clique no objeto vinculado que você deseja atualizar. Um A na coluna Atualizar significa que o vínculo será atualizado automaticamente, e um M na coluna Atualizar significa que o vínculo deve ser atualizado manualmente.

    Dica : Para selecionar vários objetos vinculados, mantenha pressionada a tecla CTRL e clique em cada objeto vinculado. Para selecionar todos os objetos vinculados, pressione CTRL+A.

  3. Clique em OK.

Problema: não consigo atualizar os vínculos automáticos em minha planilha

A opção Automático pode ser substituída pela opção Atualizar vínculos com outros documentos do Excel.

Para garantir que os vínculos automáticos para objetos OLE possam ser atualizados automaticamente:

  1. Clique o Botão Microsoft Office imagem do botão office , clique em Opções do Excel e clique na categoria Avançado.

  2. Em Ao calcular esta pasta de trabalho, verifique se a caixa de seleção Atualizar vínculos com outros documentos está marcada.

Atualizar um vínculo para outro programa agora

  1. Na guia Dados, no grupo Conexões, clique em Editar Vínculos.

    Imagem da Faixa de Opções do Excel

    Observação : O comando Editar Vínculos não estará disponível se o arquivo não contiver informações vinculadas.

  2. Na lista Fonte, clique no objeto vinculado que você deseja atualizar.

    Dica : Para selecionar vários objetos vinculados, mantenha pressionada a tecla CTRL e clique em cada objeto vinculado. Para selecionar todos os objetos vinculados, pressione CTRL+A.

  3. Clique em Atualizar Valores.

Editar o conteúdo de um programa OLE

Enquanto estiver no Excel, você poderá alterar o conteúdo vinculado ou incorporado de outro programa.

Editar um objeto vinculado no programa de origem

  1. Na guia Dados, no grupo Conexões, clique em Editar Vínculos.

    Imagem da Faixa de Opções do Excel

    Observação : O comando Editar Vínculos não estará disponível se o arquivo não contiver informações vinculadas.

  2. Na lista Arquivo de origem, clique na fonte do objeto vinculado e, em seguida, clique em Abrir Fonte.

  3. Faça as alterações desejadas no objeto vinculado.

  4. Saia do programa de origem para retornar ao arquivo de destino.

Editar um objeto incorporado no programa de origem

  1. Clique duas vezes no objeto inserido para abri-lo.

  2. Faça as alterações desejadas no objeto.

  3. Se você estiver editando o objeto no local, no programa aberto, clique em qualquer lugar fora do objeto para retornar ao arquivo de destino.

    Se você editar o objeto incorporado no programa de origem, em uma janela separada, saia desse programa para retornar ao arquivo de destino.

Observação : Clicar duas vezes em determinados objetos incorporados, como clipes de som e vídeo, reproduz o objeto em vez de abrir um programa. Para editar um desses objetos incorporados, clique com o botão direito do mouse no ícone ou objeto, aponte para o tipo de objetoObjeto (por exemplo, Objeto Clipe de Mídia) e clique em Editar.

Editar um objeto incorporado em um programa diferente do programa de origem

  1. Selecione o objeto inserido que você deseja editar.

  2. Clique com o botão direito do mouse no ícone ou objeto, aponte para Objetotipo de objeto (por exemplo, Objeto Documento) e clique em Converter.

  3. Siga um destes procedimentos:

    • Para converter o objeto incorporado para o tipo que você especificar na lista, clique em Converter em.

    • Para abrir o objeto incorporado como o tipo especificado na lista sem alterar o tipo de objeto incorporado, clique em Ativar.

Selecionar um objeto OLE usando o teclado

  1. Pressione CTRL+G para exibir a caixa de diálogo Ir para.

  2. Clique em Especial, selecione Objetos e clique em OK.

  3. Pressione TAB até que o objeto desejado seja selecionado.

  4. Pressione SHIFT+F10.

  5. Aponte para Objeto ou Objeto de Gráfico e clique em Editar.

Problema: quando clico duas vezes em um objeto vinculado ou incorporado, a mensagem "impossível editar" é exibida

Esta mensagem é exibida quando o arquivo de origem ou o programa de origem não pode ser aberto.

Verificar se o programa de origem está disponível     Se o programa de origem não estiver instalado no computador, converta o objeto no formato de arquivo de um programa que esteja instalado.

Verificar se a memória está adequada     Verifique se há memória suficiente para executar o programa de origem. Feche os outros programas para liberar memória, se necessário.

Fechar todas as caixas de diálogo     Se o programa de origem estiver sendo executado, verifique se não há caixas de diálogo abertas nele. Alterne para o programa de origem e feche as caixas de diálogo que estiverem abertas.

Fechar o arquivo de origem     Se o arquivo de origem for um objeto vinculado, verifique se ele não está aberto para outro usuário.

Garantir que o nome do arquivo de origem não foi alterado     Se o arquivo de origem que você deseja editar for um objeto vinculado, verifique se ele tem o mesmo nome que tinha quando você criou o vínculo e se ele não foi movido. Selecione o objeto vinculado e clique no comando Editar Vínculos no grupo Conexões da guia Dados para ver o nome do arquivo de origem. Se o arquivo de origem tiver sido renomeado ou movido, use o botão Alterar Fonte na caixa de diálogo Editar Vínculos para localizar o arquivo de origem e reconectar o vínculo.

Precisa de mais ajuda?

Você pode sempre consultar um especialista na Excel Tech Community, obter suporte na Comunidade de respostas ou sugerir um novo recurso ou melhoria no User Voice do Excel.

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×