Importar ou exportar arquivos de texto (.txt ou .csv)

Importar ou exportar arquivos de texto (.txt ou .csv)

Há duas formas de importar dados de um arquivo de texto no Excel: você pode abri-lo no Excel ou importá-lo como um intervalo de dados externos. Para exportar dados do Excel para um arquivo de texto, use o comando Salvar como e altere o tipo de texto no menu suspenso.

Há dois formatos de arquivo de texto usados com frequência:

  • Arquivos de texto delimitado (.txt), nos quais o caractere TAB (código de caractere ASCII 009) geralmente separa os campos do texto.

  • Arquivos de texto com valores separados por vírgulas (.csv), nos quais o caractere vírgula (,) geralmente separa cada campo de texto.

Você pode alterar o caractere separador que é usado nos dois arquivos de texto, delimitado e .csv. Isto poderá ser necessário para verificar se a operação de importação ou exportação está funcionando da maneira desejada.

Observação : Você pode importar ou exportar até 1.048.576 linhas e 16.384 colunas.

Importar um arquivo de texto abrindo-o no Excel

Você pode abrir um arquivo de texto criado em outro programa como uma pasta de trabalho do Excel usando o comando Abrir. Abrir um arquivo de texto no Excel não altera o formato do arquivo — você pode vê-lo na barra de título do Excel, em que o nome do arquivo mantém a extensão do arquivo de texto (por exemplo, .txt ou .csv).

  1. Acesse Arquivo > Abrir.

    Se estiver usando o Excel 2007, clique no Botão do Microsoft Office imagem do botão office e clique em Abrir.

  2. Selecione Arquivos de Texto na caixa de diálogo Abrir.

  3. Localize e clique duas vezes no arquivo de texto que você deseja abrir.

    • Caso se trate de um arquivo de texto (.txt), o Excel iniciará o Assistente de Importação de Texto. Quando concluir as etapas, clique em Concluir para concluir a operação de importação.

    • Consulte: Importar dados usando o Assistente de Importação de Texto para obter mais informações sobre delimitadores e opções mais avançadas.

    • Se o arquivo for .csv, o Excel o abrirá automaticamente e exibirá os dados em uma nova pasta de trabalho.

      Observação : Ao abrir um arquivo .csv, o Excel usa as configurações atuais de formato de dados padrão para interpretar como importar cada coluna de dados. Para ter mais flexibilidade na conversão de colunas em diferentes formatos de dados, você pode usar o Assistente de Importação de Texto. Por exemplo, o formato de uma coluna de dados no arquivo .csv pode ser MDA, mas o formato de dados padrão do Excel é AMD, ou você deseja converter em texto uma coluna de números que contém zeros à esquerda, para preservar os zeros. Para forçar o Excel a executar o Assistente de Importação de Texto, é possível alterar a extensão do nome do arquivo de .csv para .txt antes de abri-lo ou é possível Importar um arquivo de texto conectando-se e ele.

Você pode importar dados de um arquivo de texto em uma planilha existente como um intervalo de dados externos.

  1. Clique na célula em que você deseja inserir os dados do arquivo de texto.

  2. Na guia Dados, no grupo Obter Dados Externos, clique em De Texto/CSV.

    Opções Obter e Transformar na guia Dados

  3. Localize e clique duas vezes no arquivo de texto que você deseja importar.

    Siga as instruções do Assistente de Importação de Texto. Clique em Ajuda imagem do botão em qualquer página do Assistente de Importação de Texto para obter mais informações sobre como usar o assistente. Quando terminar as etapas do assistente, clique em Concluir para Finalizar a operação de importação.

  4. Na caixa de diálogo Importar Dados, siga estes procedimentos:

    • Outra opção é clicar em Propriedades para definir as opções de atualização, formatação e layout para os dados importados.

    • Em Onde você deseja colocar os dados?, execute um dos seguintes procedimentos:

      • Para retornar os dados ao local selecionado, clique em Planilha existente.

      • Para retornar os dados ao canto superior esquerdo de uma nova planilha, clique em Nova planilha.

  5. Clique em OK.

    O Excel colocará o intervalo de dados externos no local que você especificar.

Se o Excel não converter uma coluna de dados no formato desejado, você poderá converter os dados depois que eles forem importados. Para obter mais informações, consulte os artigos sobre conversão de números armazenados como texto em números e conversão de datas armazenadas como texto em datas.

Você pode converter uma planilha do Excel para um arquivo de texto usando o comando Salvar Como.

  1. Acesse Arquivo > Salvar como.

    Se estiver usando o Excel 2007, clique no Botão do Microsoft Office imagem do botão office e clique em Salvar como.

  2. A caixa de diálogo Salvar como é exibida.

  3. Na caixa Salvar como tipo, escolha o formato de arquivo de texto para a planilha.

    • Por exemplo, clique em Texto (delimitado por tabulação) ou CSV (delimitado por vírgula).

    • Observação : Os formatos diferentes oferecem suporte a conjuntos de recursos diferentes. Para obter mais informações sobre os conjuntos de recursos para os quais os diferentes formatos de arquivo de texto oferecem suporte, consulte Formatação e recursos do Excel que não têm suporte no Excel.

  4. Navegue até o local onde você deseja salvar o novo arquivo de texto e, em seguida, clique em Salvar.

  5. Uma caixa de diálogo é exibida, lembrando-o que somente a planilha atual será salva no novo arquivo. Se você tiver certeza de que a planilha atual é a que você deseja salvar como um arquivo de texto, clique em OK. Você pode salvar outras planilhas como arquivos de texto separados, repetindo este procedimento para cada planilha.

  6. Uma segunda caixa de diálogo é aberta, lembrando-o que a planilha pode conter recursos para os quais os formatos de arquivo de texto não ofereçam suporte. Se você só estiver interessado em salvar os dados da planilha no novo arquivo de texto, clique em Sim. Se você não tiver certeza e quiser saber mais sobre quais recursos do Excel não possuem suporte nos formatos de arquivo de texto, clique em Ajuda para obter mais informações.

Para obter mais informações sobre como salvar arquivos em outros formatos, confira Salvar uma pasta de trabalho em outro formato de arquivo.

Se você usar o Assistente de Importação de Texto para importar um arquivo de texto, poderá alterar o delimitador que é usado para um arquivo de texto delimitado, trocando um caractere TAB por outro caractere na Etapa 2 desse assistente. Nessa etapa, também é possível alterar a forma como delimitadores consecutivos, como aspas consecutivas, são manipulados.

Consulte: Importar dados usando o Assistente de Importação de Texto para obter mais informações sobre delimitadores e opções mais avançadas.

  1. No Microsoft Windows, clique no botão Iniciar e clique em Painel de controle.

  2. Abra a caixa de diálogo para alterar configurações Regionais e de Idioma.

  3. Digite um novo separador na caixa Separador de lista.

  4. Clique em OK duas vezes.

Observação : Depois de alterar o caractere separador de listas no seu computador, todos os programas usarão o novo caractere como o separador de listas. Você poderá retornar ao caractere padrão seguindo o mesmo procedimento.

Precisa de mais ajuda?

Você pode sempre consultar um especialista na Excel Tech Community, obter suporte na Comunidade de respostas ou sugerir um novo recurso ou melhoria no UserVoice do Excel.

Consulte Também

Visão geral de fórmulas no Excel

Como evitar fórmulas quebradas

Encontrar e corrigir erros em fórmulas

Atalhos de teclado e teclas de função do Excel

Funções do Excel (por ordem alfabética)

Funções do Excel (por categorias)

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×