Importar dados do Excel, SQL Server, sites do SharePoint e outras fontes externas

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Rapidamente, você pode importar e exibir dados diretamente em suas formas, usando Microsoft Office Visio Professional 2007. A primeira etapa é para se conectar à fonte de dados e importar dados para o seu desenho. A segunda etapa é vincular os dados importados a formas.

Para obter informações sobre como adicionar dados às formas sem importá-los, consulte Adicionar dados a formas.

Neste artigo

Etapa 1: Importar os dados

Etapa 2: Vincular linhas de dados a formas em seu desenho

Etapa 1: Importar os dados

Nesta primeira etapa, use o Assistente do Seletor de Dados para importar seus dados para a janela Dados Externos.

Os dados que aparece na janela Dados externos são um instantâneo dos seus dados de origem no momento da importação. Você pode atualizar os dados em seu desenho para corresponderem às alterações nos dados de origem. No entanto, é possível atualizar sua fonte de dados, alterando os dados em seu desenho. Consulte Atualizar dados importados.

  1. No menu Dados, clique em Vincular Dados a Formas.

  2. Na primeira página do Assistente do Seletor de Dados, escolha quais dos seguintes tipos de fontes de dados deseja usar:

    • Pasta de trabalho do Microsoft Office Excel

    • Banco de dados do Microsoft Office Access

    • Lista do Microsoft Windows SharePoint Services

    • Banco de dados do Microsoft SQL Server

    • Outra fonte de dados OLEDB ou ODBC

    • Conexão criada anteriormente

  3. Conclua o restante do assistente.

    Observação : Se você escolher, na primeira página do assistente, uma opção que não seja uma pasta de trabalho do Excel, um banco de dados do Access nem uma lista do SharePoint, poderá ser temporariamente desviado para o Assistente de Conexão de Dados durante a conclusão do Assistente do Seletor de Dados.

    Você pode obter ajuda específica para a maioria das páginas do assistente. Para acessar a Ajuda, pressione F1 ou clique no botão Ajuda .

Depois que você clica em Concluir na última página do Assistente para Conexão de Dados, a janela Dados Externos é exibida com os dados importados mostrados em uma grade.

Início da página

Etapa 2: Vincular linhas de dados a formas em seu desenho

Há três maneiras de vincular linhas de dados a formas em seu desenho: você pode vincular linhas a formas existentes de uma só vez, vincular linhas a formas automaticamente ou criar formas para os dados.

Vincular linhas a formas existentes de uma só vez

Esse método é mais adequado para desenhos com relativamente poucas formas.

  • Arraste uma linha da janela Dados Externos para uma forma de seu desenho.

    Os dados são exibidos na forma e um ícone de vínculo é exibido à esquerda da linha na janela Dados Externos.

    arrastar linha para forma

    Observações : 

    • Você pode vincular uma única linha a várias formas, mas não pode vincular várias linhas a uma única forma.

    • Para alterar ou aperfeiçoar a aparência das formas e dos dados, consulte Aperfeiçoar os dados com elementos gráficos de dados.

    • Para exibir a janela Dados Externos, no menu Exibir, clique em Janela Dados Externos.

Vincular linhas automaticamente a formas existentes

Essa abordagem é mais adequada para desenhos existentes com um grande número de formas. Isso só funciona se as formas têm dados já que você pode associar aos dados na fonte de dados.

  1. No menu Dados, clique em Vincular Automaticamente.

  2. Siga as etapas do Assistente de Vinculação Automática.

    Seus dados aparecerão em suas formas. Para alterar ou aprimorar a aparência das formas e dados, consulte aprimorar seus dados com gráficos de dados.

Ajuda específica está disponível para a maioria das páginas do assistente. Para acessar a Ajuda, pressione F1 ou clique no ícone Ajuda.

Criar formas a partir dos dados

Esse método é mais adequado quando o desenho ainda não tem formas e não é necessário usar formas específicas.

  1. Clique em uma forma da janela Formas.

  2. Arraste uma linha ou um conjunto de linhas da janela Dados Externos para um espaço em branco de seu desenho.

    Uma instância da forma em que você clica é exibida para cada linha arrastada para o desenho.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×