Importar dados XML

Se você anteriormente criou um Mapa XML, você pode usá-lo para importar dados XML para células que são mapeadas, mas também há vários métodos e comandos para importar dados XML sem um Mapa XML.

Se você tiver um Mapa XML, faça isso para importar dados XML para células mapeadas:

  1. No Mapa XML, selecione uma das células mapeadas.

  2. Clique em Desenvolvedor > Importar.

    Se você não vir a guia Desenvolvedor, consulte Mostrar a guia Desenvolvedor.

  3. Na caixa de diálogo Importar XML, localize e selecione o arquivo de dados XML (.xml) que deseja importar e clique em Importar.

Outras formas de importar dados XML

Para obter mais informações sobre problemas, consulte Problemas comuns com a importação de dados XML no final deste artigo.

Importar um arquivo de dados XML como uma tabela XML

  1. Clique em Desenvolvedor > Importar.

    Se você não vir a guia Desenvolvedor, consulte Mostrar a guia Desenvolvedor.

  2. Na caixa de diálogo Importar XML, localize e selecione o arquivo de dados XML (.xml) que deseja importar e clique em Importar.

    Se o arquivo de dados XML não se refere a um esquema, o Excel infere o esquema do arquivo de dados XML.

  3. Na caixa de diálogo Importar Dados, execute uma das seguintes ações:

    1. Selecione Tabela XML em planilha existente para importar o conteúdo do arquivo de dados XML para uma tabela XML em sua planilha na localização de célula especificada.

    2. Selecione Tabela XML em nova planilha para importar o conteúdo do arquivo para uma tabela XML em uma nova planilha a partir da célula A1. O esquema do arquivo de dados XML é exibido no painel de tarefas Código-fonte XML.

  4. Se o arquivo de dados XML não se refere a um esquema, o Excel, então, infere o esquema do arquivo de dados XML.

  5. Para controlar o comportamento de dados XML (como ligação de dados, formato e layout), clique em Propriedades, que exibe a caixa de diálogo Propriedades do Mapa XML. Por exemplo, os dados existentes em um intervalo mapeado serão substituídos quando você importar dados por padrão, mas você pode mudar isso.

Importar vários arquivos de dados XML

  1. Selecione uma célula mapeada para importar vários arquivos XML para um único conjunto de células mapeadas.

    Se você quiser importar vários arquivos XML em vários conjuntos de células mapeadas, clique em uma célula em qualquer lugar da planilha que não esteja mapeada.

  2. Clique em Desenvolvedor > Importar.

    Se você não vir a guia Desenvolvedor, consulte Mostrar a guia Desenvolvedor.

  3. Na caixa de diálogo Importar XML, localize e selecione o arquivo de dados XML (.xml) que deseja importar.

    • Se os arquivos forem contíguos, pressione Shift e clique no primeiro e último arquivo na lista. Todos os dados dos arquivos XML serão importados e anexados às células mapeadas.

    • Se os arquivos não forem contíguos, pressione e segure Ctrl e clique em cada arquivo que deseja importar na lista.

  4. Clique em Importar.

    Se você selecionou arquivos que não são contíguos, a caixa de diálogo Importando <nomedoarquivo>.xml é exibida. Selecione o Mapa XML que corresponde ao arquivo de dados XML que você está importando para cada arquivo.

    Para usar um único mapa para todos os arquivos selecionados que ainda não foram importados, selecione Usar este Mapa XML para todos os arquivos selecionados deste esquema .

Importar vários arquivos de dados XML como dados externos

Para importar vários arquivos XML que usam o mesmo espaço para nome, mas esquemas XML diferentes, você pode usar o comando Da importação de Dados XML. O Excel cria um Mapa XML exclusivo para cada arquivo de dados XML que você importa.

Observação : Se você estiver importando vários arquivos XML que não definem um espaço para nome, esses arquivos XML serão tratados como se usassem o mesmo espaço para nome.

  1. Se você estiver usando o Excel com uma assinatura do Office 365, clique em Dados > Obter dados > Do arquivo > Do XML.

    Se você estiver usando o Excel 2016 ou anterior, clique em Dados > De outras fontes > Da importação de Dados XML .

  2. Vá para a unidade, pasta ou local da Internet que possui o arquivo de dados XML (.xml) que deseja importar.

  3. Selecione o arquivo e clique em Abrir.

  4. Na caixa de diálogo Importar Dados, execute uma das seguintes ações:

    • Tabela XML em planilha existente    O conteúdo do arquivo é importado para uma nova tabela XML em uma nova planilha. Se o arquivo de dados XML não se refere a um esquema, o Excel infere o esquema do arquivo de dados XML.

    • Planilha existente    Os dados XML são importados em uma tabela bidimensional com linhas e colunas que mostram marcas XML como cabeçalhos de coluna e dados em linhas abaixo dos cabeçalhos das colunas. O primeiro elemento (o nó raiz) é usado como um título e é exibido na localização da célula especificada. O resto das marcar são ordenados alfabeticamente na segunda linha. Nesse caso, o Excel não inferiu um esquema e você não pode usar um Mapa XML.

    • Nova planilha    O Excel adiciona uma nova planilha à sua pasta de trabalho e coloca automaticamente os dados XML no canto superior esquerdo da nova planilha. Se o arquivo de dados XML não se refere a um esquema, o Excel infere o esquema do arquivo de dados XML.

  5. Para controlar o comportamento de dados XML, como ligação de dados, formato e layout, clique em Propriedades, que exibe a caixa de diálogo Propriedades do Mapa XML. Por exemplo, os dados existentes em um intervalo mapeado são substituídos quando você importa dados por padrão, no entanto, isso pode ser mudado.

Abrir um arquivo de dados XML para importar os dados dele

  1. Clique em Arquivo > Abrir.

    Se você estiver usando o Excel 2007, clique no Botão do Microsoft Office imagem do botão office > Abrir.

  2. Na caixa de diálogo Abrir, clique na unidade, pasta ou local da Internet que contém o arquivo que você deseja abrir.  

  3. Selecione o arquivo e clique em Abrir.

  4. Se a caixa de diálogo Importar XML aparecer, o arquivo que você abriu refere-se a uma ou mais folhas de estilo da Transformação da Linguagem de Folha de Estilo Expansível (XSLT), assim, você poderá clicar em uma das seguintes opções:

    • Abra o arquivo sem aplicar uma folha de estilo    Os dados XML são importados em uma tabela bidimensional com linhas e colunas que mostram marcas XML como cabeçalhos de coluna e dados em linhas abaixo dos cabeçalhos das colunas. O primeiro elemento (o nó raiz) é usado como um título e é exibido na localização da célula especificada. O resto das marcar são ordenados alfabeticamente na segunda linha. Nesse caso, o Excel não inferiu um esquema e você não pode usar um Mapa XML.

    • Abra o arquivo com a seguinte folha de estilo aplicada (selecione uma)    Selecione a folha de estilo que deseja aplicar e, em seguida, clique em OK. Os dados XML são formatados de acordo com a folha de estilos que você selecionou.

      Observação : Os dados XML são abertos como somente leitura no Excel, de modo que você não salve acidentalmente seu arquivo de origem original no formato de arquivo Pasta de Trabalho Habilitada para Macro do Excel (.xlsm). Nesse caso, o Excel não inferiu um esquema e você não pode usar um Mapa XML.

  5. Se a caixa de diálogo Abrir XML aparecer, o arquivo XML não possui nenhuma referência de folha de estilo XSLT. Para abrir o arquivo, clique em uma das seguintes opções:

    • Clique em Como uma tabela XML para criar uma tabela XML em uma nova pasta de trabalho.

      O conteúdo do arquivo é importado para a tabela XML. Se o arquivo de dados XML não se refere a um esquema, o Excel infere o esquema do arquivo de dados XML.

    • Clique em Como uma pasta de trabalho somente leitura.

      Os dados XML são importados em uma tabela bidimensional com linhas e colunas que mostram marcas XML como cabeçalhos de coluna e dados em linhas abaixo dos cabeçalhos das colunas. O primeiro elemento (o nó raiz) é usado como um título e é exibido na localização da célula especificada. O resto das marcar são ordenados alfabeticamente na segunda linha. Nesse caso, o Excel não inferiu um esquema e você não pode usar um Mapa XML.

      Os dados XML são abertos como somente leitura no Excel, de modo que você não salve acidentalmente seu arquivo de origem original no formato de arquivo Pasta de Trabalho Habilitada para Macro do Excel (.xlsm). Nesse caso, o Excel não inferiu um esquema e você não pode usar um Mapa XML.

    • Clique em Usar o painel de tarefas Código-fonte XML.

      O esquema do arquivo de dados XML é exibido no painel de tarefas Código-fonte XML. Você pode então arrastar elementos do esquema para a planilha para mapear esses elementos para a planilha.

      Se o arquivo de dados XML não se refere a um esquema, o Excel infere o esquema do arquivo de dados XML.

Problemas comuns para importar dados XML

O Excel exibe a caixa de diálogo Erro de importação XML quando não pode validar dados de acordo com o Mapa XML. Nesta caixa de diálogo, clique em Detalhes para obter informações adicionais sobre cada erro. A tabela a seguir lista alguns erros comuns de importação:

Erro

O que aconteceu

Falha na validação do esquema

Quando você clicou em Validar dados em esquema para importar e exportar na caixa de diálogo Propriedades do Mapa XML, os dados foram importados, mas não foram validados no Mapa XML especificado.

Alguns dados foram importados como texto

Alguns ou todos os dados que você importou foram convertidos a partir de seu tipo de dados declarado para texto. Para usar esses dados em um cálculo, você precisará converter os dados de texto para números ou datas. Por exemplo, um valor de data convertido em texto não funcionará conforme pretendido na função ANO até você o converta no tipo de dados Data. O Excel converte dados para texto quando:

  • Os dados estão em um formato no qual o Excel não é compatível.

  • Os dados são incompatíveis com a representação interna do Excel do tipo de dados XSD. Para corrigir esse problema, verifique cada declaração de tipo de dados para garantir que seus dados XML sejam válidos de acordo com o esquema XML.

Erro de análise XML

O analisador XML não pode abrir o arquivo XML especificado. Certifique-se de que o arquivo XML não tenha erros de sintaxe e que o XML esteja bem formado.

Não é possível encontrar um Mapa XML que corresponda aos dados

Esse problema pode ocorrer quando você seleciona mais de um arquivo de dados XML para importar e o Excel não consegue encontrar um Mapa XML correspondente para um dos arquivos. Para o arquivo nomeado na barra de título da caixa de diálogo, importe primeiro um esquema apropriado e tente importar o arquivo novamente.

Uma tabela XML não pode ser redimensionada para acomodar dados

Você está tentando adicionar linhas importando ou anexando dados à tabela XML, mas não há espaço para expandir a tabela. Uma tabela XML só pode expandir de cima para baixo. Por exemplo, pode haver um objeto, como uma imagem ou outra tabela, imediatamente abaixo da tabela XML que impede a expansão da tabela XML. Por outro lado, para que a tabela XML se expanda, ela excederá o limite de linha do Excel de 1.048.576. Para corrigir esse problema, reorganize as tabelas e os objetos na planilha para permitir que a tabela XML se expanda de cima para baixo.

O arquivo XML especificado não se refere a um esquema

O arquivo XML que você está tentando abrir não se refere a um esquema XML. Para trabalhar com os dados XML que estão no arquivo, o Excel precisa de um esquema com base no conteúdo do arquivo XML. Se esse esquema for incorreto ou insuficiente, remova-o da sua pasta de trabalho. Em seguida, crie um arquivo de esquema XML e edite o arquivo de dados XML para que ele se refira ao esquema. Para saber mais, veja Mapear elementos XML para células em um Mapa XML.

Observação : Você não pode exportar o esquema inferido do Excel como um arquivo de dados de esquema XML separado (.xsd). Embora existam editores de esquema XML e outros métodos para criar arquivos de esquema XML, você pode não ter acesso conveniente a eles ou saber como usá-los.

Siga estas etapas para remover o esquema que o Excel criou de sua pasta de trabalho:

  1. Clique em Desenvolvedor > Fonte.

    Modo de Exibição de Dados vazio

    Se você não vir a guia Desenvolvedor, consulte Mostrar a guia Desenvolvedor.

  2. No painel de tarefas Código-fonte XML, clique em Mapas XML.

  3. Na caixa de diálogo Mapas XML, clique no mapa XML Excel criado e depois em Excluir.

Importar vários arquivos XML que usam o mesmo espaço para nome, mas esquemas diferentes, não funciona como esperado

Quando você trabalha com vários arquivos de dados XML e esquemas XML, você geralmente cria um Mapa XML para cada esquema, mapeia os elementos desejados e, em seguida, importa cada arquivo de dados XML para o Mapa XML apropriado. Ao usar o comando Importar para abrir vários arquivos XML com o mesmo espaço para nome, você pode usar apenas um esquema XML. Quando você usa esse comando para abrir vários arquivos XML que usam o mesmo espaço para nome, mas esquemas diferentes, você pode obter resultados inesperados. Por exemplo, os dados podem ser substituídos ou os arquivos podem não abrir.

Para importar vários arquivos XML que usam o mesmo espaço para nome, mas esquemas XML diferentes, tente usar o comando Da importação de Dados XML (clique em Dados > De outras fontes). Esse comando permite que múltiplos arquivos XML com o mesmo espaço para nome usem múltiplos esquemas XML. O Excel cria um Mapa XML exclusivo para cada arquivo de dados XML que você deseja importar.

Observação : Se você estiver importando vários arquivos XML que não definem um espaço para nome, esses arquivos XML serão tratados como se usassem o mesmo espaço para nome.

Mostrar a guia Desenvolvedor

Se não vir a guia Desenvolvedor, faça o seguinte para exibi-la:

  • No Excel 2013 e no Excel 2010:

    1. Clique em Arquivo > Opções.

    2. Clique na categoria Personalizar Faixa de Opções.

    3. Em Guia Principais, marque a caixa Desenvolvedor e clique em OK.

  • No Excel 2007:

    1. Clique no Botão do Microsoft Office imagem do botão office > Opções do Excel.

    2. Clique na categoria Popular.

    3. Em Opções principais para o trabalho com o Excel, marque a caixa Mostrar guia Desenvolvedor na Faixa de Opções e clique em OK.

Consulte Também

Visão geral do XML no Excel

Mapear elementos XML para células em um mapa XML

Exportar dados XML

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×